Windows: Geräte-Manager ist leer

win7Kürzlich bin ich durch Forenanfragen auf ein skurriles Problem gestoßen: Benutzer stehen mitunter vor der Situation, dass der Geräte-Manager beim Aufruf nur noch ein leeres Fenster zeigt und keine Geräte mehr auflistet. Nachfolgend der Versuch, einige Reparaturansätze aufzuzeigen.


Werbung

Normalerweise reicht es ja, das Fenster System (z.B. über die Tastenkombination Windows+Pause) aufzurufen und dann in dessen Seitenleiste den Befehl Geräte-Manager anzuwählen. Schon öffnet sich der Geräte-Manager und zeigt die Liste der gefundenen Geräte an.

Geräte-Manager ausgeblendete Geräte 2

Im vorhergehenden Screenshot ist sogar die Darstellung mit ausgeblendeten Geräten zu sehen (siehe). Dumm nur, wenn der Geräte-Manager so gar nichts mehr anzeigen will. Dann bleibt nur noch, die nachfolgenden Punkte abzuprüfen.

Läuft der Plug&Play-Dienst

Eine Ursache, dass keine neue Hardware mehr erkannt und ggf. auch nichts mehr angezeigt wird, kann ein deaktivierter Plug&Play-Dienst sein.

1. Rufen Sie die Diensteverwaltung mit administrativen Rechten auf (z.B. Dienste im Suchfeld des Windows 7-Startmenüs oder der Windows 8-Startseite eingeben und den Treffer Dienste über den Kontextmenübefehl Als Administrator ausführen starten).

2. Suchen Sie in der Liste der Dienste den Eintrag Plug & Play und kontrollieren Sie, ob der Status auf “Gestartet” steht.

3. Falls der Dienst gestoppt ist, wählen Sie den Eintrag per Doppelklick an und stellen den Starttyp auf “Automatisch”. Weiterhin versuchen Sie den Dienst zu starten (siehe [1]).

Standardmäßig ist der Dienst automatisch gestartet und lässt sich auf meinem Windows 7-Testsystem auch nicht starten oder stoppen (die Optionen des Eigenschaftenfensters sind gesperrt). Falls sich der Dienst nicht starten lässt, führen Sie eine Systemdateiprüfung aus (System auf beschädigte Systemdateien prüfen), um beschädigte Dateien auszuschließen.


Werbung – meine Windows 8.0/8.1 Titel –


Zugriffsberechtigungen für Registrierungsschlüssel falsch

Eine andere Ursache für den leeren Geräte-Manager kann eine fehlende Zugriffsberechtigungen auf den Enum-Registrierungsschlüssel sein. Dann kann Windows die Geräte nicht auflisten.

1. In diesem Fall starten Sie den Registrierungs-Editor Regedit.exe mit administrativen Berechtigungen (Aufruf über den Kontextmenübefehl Als Administrator ausführen).

2. Anschließend kontrollieren Sie die Zugriffsberechtigungen in folgendem Schlüssel über den Kontextmenübefehl Berechtigungen.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum

Es muss der Eintrag System vorhanden sein – und bei Anwahl des Eintrags müssen die Berechtigungen Vollzugriff und Lesen für das System gegeben sein. Falls die Berechtigungen fehlen, müssen diese dem System erteilt werden.

Ursache für die verlorenen Zugriffsrechte können Fremdtools oder Treiberinstallationen sein (siehe auch hier). Unter [5] wird ein Fixit-Tool zum Anpassen der Berechtigungen im Schlüssel Enum/Root genannt – keine Ahnung, ob das hilft.

Ähnliche Artikel:
a1: Ausgeblendete Geräte im Geräte-Manager
a2: Geräte-Manager Code 28 – Unbekanntes Gerät
a3: Unbekanntes Gerät ermitteln

b1: Ordner “Geräte und Drucker” bleibt leer
b2: Systemsteuerung/Benutzerverwaltung bleibt leer
b3: Windows-Funktionen bleibt leer

Links:
1: Device Manager is Blank MS-Forendiskussion (Englisch)
2: Diskussion bei sevenforums.com (Englisch)
3: Älterer Beitrag zu Windows XP (Englisch)
4:  Device Manager is Blank 2. MS-Forendiskussion (Englisch)
5: Gerätemanger ist leer MS-Forendiskussion (Deutsch)


Werbung



Dieser Beitrag wurde unter Problemlösung, Windows 7, Windows 8, Windows 8.1, Windows Vista, Windows XP abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

2 Kommentare zu Windows: Geräte-Manager ist leer

  1. Daniel sagt:

    Hallo und Danke für die Tipps,

    leider hat das bei einem Kundenrechner (Windows XP, SP3) nicht geholfen. Der Dienst ist gestartet und auch die Berechtigungen passen. Den Fix („fixccs.exe“ im Abgesicherten Modus ausführen) habe ich getestet, leider ohne Erfolg. Auch in der Registry nach der Zeichenfolge „$%&'()*+“ suchen und bei Fund löschen bringt nichts, weil die Zeichen schon nicht gefunden werden können.

    Gibts hier vielleicht noch weitere Ansatzpunkte?

    Viele Grüße
    Daniel

  2. Daniel sagt:

    Update: Hat sich erledigt. Im englischen Artikel, der am Ende des Artikels verlinkt ist, wird beschrieben wie man die Rechte überschreibt. DAMIT wurde das Problem dann auch gelöst.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.