Windows Installation im AHCI-Mode verweigert

Gelegentlich verweigert das Setup die Installation von Windows auf einem Laufwerk, weil dieses nicht geeignet sei. Grund ist, dass im BIOS der AHCI-Mode für das Laufwerk beim SATA-Controller eingestellt ist.


Werbung

Bei älteren Windows-Versionen (Vista oder Windows 7) und einer am SATA-Port angeschlossenen Festplatte oder SSD als Ziellaufwerk ist die Ursache möglicherweise im Betriebssystem zu suchen (siehe z.B. hier oder hier). In Windows 10 sollte die Installation auf SATA-Laufwerke aber im AHCI-Modus klappen. Verweigert das Setup trotzdem die Installation bei Auswahl des Laufwerks mit der Meldung: Installation nicht möglich, Partition nicht für die Installation geeignet. Dann ist möglicherweise folgende Vorgehensweise die Rettung.

Versuche die Installation im IDE-Modus

Die Gründe für dieses Verhalten sind nicht ganz klar – möglicherweise ist der SATA-Controller oder das BIOS nicht ganz kompatibel. In diesem Fall kann man aber einen Trick zur Installation versuchen.

  • Hierzu ist im BIOS der Controller für das Installationslaufwerk von AHCI auf IDE-Modus umzustellen.
  • Anschließend versucht man die Installation von Windows 10 durchzuführen.

Klappt dieser Ansatz und Windows 10 lässt sich sowohl installieren und auch booten, kann man versuchen, den Betriebsmodus des Installationslaufwerks nachträglich von IDE auf AHCI umzustellen.

Wichtig: Vor dem nächsten Schritt sollte man sicherstellen, dass man einen bootbaren Systemreparaturdatenträger hat, um das System zur Not booten und den Registrierungswert zurück setzen zu können.

SATA-Modus von IDE auf AHCI nachträglich umstellen

Damit Windows im AHCI-Modus bootet, wenn der SATA-Betriebsmodus im BIOS auf AHCI umgestellt wird, ist eine Registrierungsänderung erforderlich.

1. Starten Sie den Registrierungs-Editor regedit.exe über Als Administrator ausführen und bestätigen Sie die Benutzerkontensteuerung.

2. Führen Sie die nachfolgend beschriebene Registrierungsänderungen und dann die weiteren Handlungsanweisungen durch.

Je nach Windows-Version sind verschiedene Werte in der Registrierung zu ändern. Bei Windows 7 ist im Registrierungs-Editor zu folgendem Zweig zu navigieren:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\msahci

AHCI-Eintrag

Im rechten Teil finden sich der DWORD-Wert Start der (von 4) auf 0 zu ändern ist (siehe z.B. hier, hier oder hier).

Ab Windows 8 ist der obige Schlüssel nicht mehr vorhanden. Es gibt aber dann einen weiteren Schlüssel, der die Verwendung des AHCI-Modus regelt. Gemäß diesem Forenbeitrag navigiert man zu folgendem Schlüssel:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\StartOverride


Werbung

AHCI-Mode

Dann ist der Schlüssel von 3 auf 0 umzustellen (vergleiche auch oder hier). Danach sind in allen Varianten folgende Schritte erforderlich.

  • Windows ist im Nachgang zur Registrierungsänderung neu zu starten.
  • Beim Neustart geht man ins BIOS (oder UEFI) und stellen den SATA-Modus von IDE auf AHCI um.

Anschließend testet man, ob Windows mit dem veränderten SATA-Betriebsmodus booten kann. Klappt dies, hat man gewonnen. Andernfalls ist der SATA-Betriebsmodus auf IDE zurück zu stellen, das System mit dem Systemreparaturdatenträger zu booten und im Registrierungs-Editor der Registrierungseintrag auf den vorherigen Wert (meist 3) zurück zu setzen. Dabei ist zu beachten, dass die Registrierungs offline geladen und geändert werden muss. In vielen Fällen ist es einfacher, einfach Windows erneut im IDE-Modus zu installieren.

Ähnliche Artikel:
Wiki
Windows 10: Upgrade-Matrix und Hardwareanforderungen
Windows 10: Netzwerk zeigt Fehler 0x80070035
Windows 10-Fehler: Netzwerkprotokoll fehlt – Teil 1
Windows 10 Fehler “kann nicht auf einem USB-Speicherstick installiert werden”

Windows: Bootfehler 0xC000000F
Windows hängt mit Boot-Fehler 0xC0000225


Werbung



Dieser Beitrag wurde unter Tipps, Windows 10, Windows 7, Windows 8, Windows 8.1 abgelegt und mit , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

9 Kommentare zu Windows Installation im AHCI-Mode verweigert

  1. deo sagt:

    Die Hersteller der Mainboards haben die Voreinstellung des SATA-Controllers geändert. Ich habe ein Mainboard aus 2011, wo der IDE-Modus voreingestellt ist. Man muss ins UEFI gehen und ihn umstellen, während bei meinem anderen Mainboard aus 2014 AHCI voreingestellt ist. Ich rechne damit, dass es immer mehr Mainboards geben wird, wo auch SecureBoot voreingestellt ist und ganz schlecht wird es, wenn die Auswahlmöglichkeit verschwindet. Bei Komplett-PCs ist das mittlerweile keine Seltenheit mehr. Da ist der Trend zur Entmündigung des Benutzers am stärksten.

    • Dieter Schmitz sagt:

      „Entmündigung“

      Der Kunde will es ja!

      Sonst wäre der Protest gegen diesen „Fortschritt“ viel grösser. Zur Bestätigung reicht eine kleine Umfrage im Bekanntenkreis oder ein Blick in den heise online-Bereich: Da wird Windows 10 und all der neue Kram bejubelt.

      Mich wundert, dass sich noch nicht einmal jemand daran stört, dass bei diesem flachen Design Schaltflächen nicht klar erkennbar sind.

      Wie soll das die Produktivität steigern, wenn ich nicht erkenne, wo geklickt werden kann?

      So z.B. bei den Charms rechts in Windows 8.1. Ganz unten sind 5 oder 6 Icons (Tastatur kann fehlen), doch darunter ist eine Schaltfläche, die gar nicht als solche erkennbar ist, da der Text dort auch einfach eine Erläuterung der Icons darüber sein könnte. (Kann leider kein Bild einstellen.)

      • Der Kunde der sich einen Komplett PC Kauft weiß doch gar nicht was er will und für seine Zwecke benötigt.
        Das siehst du doch schon alleine an der Werbung da wird ein PC als Gaming PC geworben mit einer einstigs GeForce GTX 750 Ti Grafikkarte die für gelegentliche 3D-Spiele ausreichen mag aber eben nicht für alle Spiele Taugt.
        Geschweige denn das der Kunde weiß welches Mainboard dort drinnen steckt und welche Erweiterungen per Steckkarte für den PC Möglich sind.
        Also wie soll der Komplett PC Kunde denn auch wissen was für ihn nützlich oder unnütz ist.
        Wer einen Komplett PC Kaufen will wird sich auch sicherlich nicht länger damit beschäftigen als es nötig ist, der ein oder andere wird sich vielleicht später dazu entscheiden beim Nächsten PC vorher mal jemanden danach zu fragen was für seine Zwecke sinnvoll wäre, aber im großen und ganzen ist das den Leuten auch egal.

    • Ingo sagt:

      Warum muss man bei solchen Dingen eigentlich heutzutage gleich immer das ganz große Fass mit „Entmündigung“ aufmachen?

      AHCI ist heute Standard. Ohne AHCI funktionieren bei SSDs sinnvolle Features nicht und man hat einen zumindest messbaren Performance-Verlust. Also ist es doch völlig logisch, dass ausnahmslos jeder (!) Mainboard-Hersteller seit Jahren schon AHCI als Standard-Einstellung verwendet.
      Wo ist denn da bitte die Entmündigung?

      Das letzte System, was kein AHCI von Haus aus kennt, ist XP aus dem Jahr 2001.

      Und da alle seit 2012 aktuellen Windows Versionen SecureBoot beherrschen, wird es auch überhaupt kein Problem sein, wenn die Hersteller von Mainboards im Jahr 2016 entscheiden, SecureBoot standardmäßig zu aktivieren.
      Im Moment muss man auch nicht beführchten, dass diese Wahlmöglichkeit morgen wegfallen wird. Warum sollten die Hersteller diese auch weglassen?

      • deo sagt:

        Alles, was dazu dient, einen PC oder anderes technische Gerät vorzeitig wegzuschmeißen, anstatt sinnvoll aufzurüsten oder gar zu reparieren, wird von den Herstellern versucht. Optimal ist es, wenn der Gesetzgeber das unterstützt.

      • Ingo: Ich interpretiere es so, dass sich die „Entmündigung“ darauf bezieht, dass ich als erfahrener Nutzer diese Modi und Features im UEFI irgendwann im dümmsten Fall nicht mehr abschalten/umstellen kann. Und das sehe ich durchaus als Problem, was auf uns zukommen könnte. In einer idealen Welt hätten wir alle Mainboards mit fehlerfrei implementiertem UEFI, wo alles konfigurierbar ist. Und jetzt finde den Fehler ;-).

  2. rolle sagt:

    eine Frage dazu:
    hier (mit Win7-64) war der Wert „CurrentControlSet\Services\msahci\start“ auf 3, nicht auf 4 nicht 0. Was bedeutet das und warum war das so, default anscheinend doch 4?
    Hab den nat. auf 0 gesetzt, Neustart, keine Probleme aber auch keine Veränderung festgestellt.

  3. Pingback: Anonymous

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.