Netzwerksymbol zeigt Störung (roter Kreis mit X)

Es gibt immer wieder Benutzer unter Windows 7, die mit einem merkwürdigen Effekt konfrontiert sind. Obwohl die Netzwerkunterstützung vorhanden ist, meldet Windows 7 im Netzwerksymbol im Statusbereich der Taskleiste, dass eine Störung vorliegt. Der Beitrag skizziert die Ursachen und Hintergründe.


Anzeige

Was ist angesagt?

In der Einleitung wurde es bereits skizziert, und ich habe nicht schlecht gestaunt, als der Fall bei mir erstmals auftrat: Windows 7 zeigt im Infobereich der Taskleiste das Netzwerksymbol mit einem überlagerten roten Kreis samt weißem X, als Hinweis, dass die Netzwerkverbindung nicht funktioniert.

Netzwerk0

Das Irre an der ganzen Sache ist dabei, dass der Benutzer problemlos auf sein Netzwerk und das Internet zugreifen kann. Der Sachverhalt geistert durch verschiedene Foren.

Wie ist der Effekt zu erklären?

Den technischen Hintergrund für dieses seltsame Verhalten von Windows 7 kann ich mir nur folgendermaßen erklären: Unter Windows 7 lassen sich verschiedene Verbindungen (LAN, WLAN, Einwahlverbindung etc.) einrichten. Bei Windows 7 wurde dabei die Statusanzeige für alle Verbindungen unter einem gemeinsamen Netzwerksymbol zusammengefasst. Die Inflation an Netzwerksymbolen im Infobereich früherer Windows-Versionen gehört damit der Vergangenheit an. Allerdings gibt es ein klitzekleines Problem: Was soll Windows 7 nun machen, wenn mehrere Netzwerkverbindungen eingerichtet sind und es dabei auf einem Adapter zu einer Störung kommt? Die Entwickler haben sich dazu entschlossen, die Stati der diversen Verbindungen über eine logische ODER-Verknüpfung auszuwerten und dann das Ergebnis für die Statusmeldung im Infobereich heranzuziehen. Tritt also bei einem Adapter eine Störung auf, ist dessen Statusbit gesetzt. Die Oder-Verknüpfung mit anderen Adaptern liefert dann das Fehlerbit, welches im Infobereich im Netzwerksymbol signalisiert wird. Da die restlichen Adapter funktionieren, kann also durchaus eine Netzwerkverbindung vorliegen, die auch funktioniert.

Die Ursache ist?


Anzeige

Die Ursache ist damit auch recht schnell geklärt: Irgendwo liegt ein fehlerhafter Netzwerkadapter vor, der keine saubere Verbindung liefert. Windows setzt dann dessen Fehlerstatus entsprechend.

Diesen Effekt konnte ich zufällig bei einem frisch aufgesetzten Windows 7-Testsystem beobachten. Im Rechner war noch eine 10 MBit Netzwerkkarte mit einem RealTec Chip 8029AS eingebaut. Das Teil wurde zwar bereits in Vista nicht mehr richtig unterstützt. Aber ich hatte einen NE2000-Treiger, der sich installieren ließ. Den Ausgang brauchte ich in der heißen Netbook-Testphase, um diverse Geräte mit frisch installiertem Linux an das Internet zu bringen, um WLAN-Treiber einzurichten. Da mein WLAN-Router belegt war, musste halt die alte RealTec-Karte in Verbindung mit einer Netzwerkbrücke als Gateway herhalten. Klappte in Windows Vista gut und auch in Windows 7 RTM ließ sich der Treiber mit Tricks problemlos installieren.

Nach vielen Tests mit diverser Hard- und Software, beschloss ich nach dem Abschluss meines Windows 7 Tricks-Buchprojekts, die Windows 7-Installation auf diesem Rechner neu aufzusetzen. Windows 7 Home Premium 32-Bit war schnell aufgesetzt. Die LAN-Karte des Mainboards funktionierte auch sofort. Die 2. Netzwerkkarte im PCI-Slot wurde erwartungsgemäß nicht erkannt. Also schnell den NE2000.sys-Treiber über die .inf-Datei installiert – und schon meldete Windows 7, dass der Treiber Probleme hätte und nicht richtig funktioniert. Also die Netzwerkkarte im Geräte-Manager deaktiviert und weitere Geräte sowie Software installiert.

Und plötzlich fiel mein Blick auf den Infobereich der Taskleiste, wo das Netzwerksymbol den beschriebenen Fehler anzeigte. Da ich gerade einen Download am Laufen hatte, konnte die Anzeige ja nicht stimmen. Und weil ich kurze Zeit vorher die RealTec-Netzwerkkarte installiert hatte, war mir die Ursache sofort klar. Also schnell mal gescheckt, ob ich den Netzwerkadapter vielleicht doch nicht deaktiviert hatte. Leider ja, der Adapter war auf “deaktiviert” gesetzt – aber der Fehler blieb. Also habe ich den Adapter desinstalliert und auch den Treiber vom System entfernen lassen (der Geräte-Manager bietet eine entsprechende Option einem einem Dialogfeld an, wenn ein Treiber separat installiert wurde). Und siehe da, schon war der Fehler weg.

Ein zweiter Installationstest zeigte mir, dass in meinem Fall die Netzwerkkarte die Ursache war und dass das Deaktivieren der Netzwerkadapter die Fehleranzeige nicht unbedingt beseitigt. In den diversen Foren konnte ich beobachten, dass es in der Regel ebenfalls Netzwerktreiber für LAN-Ausgänge, WLAN-Chips oder BlueTooth-Chips waren, die diese Probleme verursachten. Die Lösung kann also nur darin bestehen, möglichst aktuelle Treiber des Herstellers probehalber zu installieren und zu testen, ob der Fehler weg ist.

Weiterführende Links:
[1] Diskussion im deutschen MS Windows 7-Forum
[2] Diskussion im US MS Windows 7-Forum


Weitere Infos zu Windows 7 finden sich in meinen Windows 7-Tricks-Titeln.

(c) by Günter Born www.borncity.de
The source of smart computer books


Anzeige
Dieser Beitrag wurde unter Netzwerk, Problemlösung, Windows 7 abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.