Audiowiedergabeprobleme, wegen des Diensts "Windows-Audio-Endpunkterstellung"

Manche Anwender haben das Problem, dass die Audiowiedergabe nicht funktioniert. Der Windows Media Player stürzt ab, oder es kommt kein Ton. In einigen Fällen ist der Dienst “Windows-Audio-Endpunkterstellung” an den Problemen beteiligt. Zeit, einen Blick hinter die Kulissen zu werfen.


Anzeige

Fehlerbild 1: Kein Ton bei der Audiowiedergabe

Es gibt Fälle, wo beim Abspielen von Videos und Musik im Windows Media Player kein Ton auf den Lautsprechern ausgegeben wird [8]. Sofern ein fehlender oder defekter Audiotreiber, eine Fehlkonfiguration des Audioausgangs oder ein Hardware-/Verkabelungsproblem ausgeschlossen werden kann, ist die Signalkette zur Wiedergabe gestört.

Fehlerbild 2: Windows Media Player stürzt ab

Das andere Fehlerbild ist kurz und knapp: Der Windows Media Player stürzt beim Versuch einer Audio- oder Videowiedergabe ab [1]. Oder es gibt eine Fehlermeldung, beim Versuch, auf Audio-Komponenten zuzugreifen [10].

Geht man dem Problem nach, stellt sich heraus, dass der Dienst “Windows-Audio-Endpunkterstellung” am Problem beteiligt ist. Deaktiviert man den Dienst, klappt zwar das Abspielen von Video- und Audiomaterial, aber der Ton fehlt. Unter [2] habe ich bei einer Recherche den Fall gefunden, dass der Dienst sogar bei der Audiowiedergabe stoppt.


Werbung

Wozu ist der Dienst “Windows-Audio-Endpunkterstellung” da?

Der Dienst verwaltet die Audiogeräte [6, 7, 11], sprich, er ermittelt die Audiokonfiguration und sorgt dafür, dass Audioausgaben an das gewählte Ausgabegerät (Lautsprecher, Kopfhörer etc.) ausgegeben werden. Zusätzlich stellt der Dienst einen Audioendpunkt bereit, der Audiosignale von der Windows Media Foundation-Filterkette entgegennimmt. Diese Filterkette wird zur Decodierung/Aufbereitung von Audio- und Videosignalen verwendet. Hierzu kommen DSO-Filter, nach landläufiger Ausdrucksweise als Codecs bezeichnet, zum Einsatz (aber dieses Detail interessiert in diesem Zusammenhang nicht).


Anzeige

Falls also ein Benutzer den Dienst deaktiviert oder dieser Dienst abstürzt, kann natürlich kein Ton kommen. Eine fehlerhafte Konfigurierung kann zu allerlei kuriosen Effekten führen. Etwas verwirrend ist dabei auch der berichtete Effekt, dass Systemklänge eventuell doch hörbar sind (mögliche Erklärung: weil diese u. U. direkt an den Audiotreiber geleitet werden).

Diagnose durch Windows 7 ausführen lassen

Unter [9] findet sich eine Anleitung, wie sich Probleme bei der Audioausgabe schrittweise durch Windows 7 diagnostizieren und beheben lassen. Nicht immer wird das aber zum Erfolg führen – speziell, wenn der Dienst zur Windows-Audio-Endpunkterstellung abstürzt. Dann gilt es eine Eigendiagnose auszuführen.

Die Problemursache ist?

Nun stellt sich nur noch die Frage, was die Abstürze des Diensts oder des Windows Media Players verursacht. Eine Möglichkeit besteht darin, dass abhängige Dienste nicht gestartet werden können. Hier gilt es, den Dienst und dessen Abhängigkeiten zu prüfen. Der Dienst ist üblicherweise auf “Automatisch” gestellt. Meist ist dies aber nicht die Ursache für den Absturz bzw. die Fehlfunktion.

Eine weitere Möglichkeit wäre auch ein defekter Audiotreiber, der den Dienst in den Orkus reißt. In diesem Fall dürfte aber auch die Wiedergabe von Systemklängen mit hoher Wahrscheinlichkeit betroffen sein. Unter [3] habe ich bereits den Fall beschrieben, dass ein nicht Standardtreiber die Wiedergabe von DRM-Material deaktiviert und zu einer entsprechenden Fehlermeldung führt.

Konkret ist es so, dass ein Audiotreiber um system effect Audio Processing Objects (sAPO) erweitert werden kann. Diese Objekte sollen digitale Signalverarbeitungs-Effekte in der Audioausgabe ermöglichen. Hierzu kann der Hersteller die sAPO an drei Stellen (pre-mix render, post-mix render, capture) in der Audiodatenverarbeitung einfügen.

Spielt solch eine sAPO-Erweiterung verrückt, hat dies natürlich auch einen Einfluss auf die Audiowiedergabe. Neben der Blockade DRM-geschützten Materials kann auch der Dienst “Windows Audio Endpunkt erstellen” betroffen sein. Falls also das Problem auftritt, prüfen Sie, ob Treibererweiterungen mit sAPO-Erweiterungen, Audials-Treiber, iTunes-Treiber, Napster-Erweiterung etc. installiert sind. Anschließend gehen Sie schrittweise vor, deaktivieren bzw. deinstallieren diese Zusätze und prüfen, ob das Problem gelöst ist.

Unter [1] waren “Treiberverbesserungen” die Ursache für die Abstürze des Windows Media Player und die Beeinflussung des Diensts “Windows-Audio-Endpunkterstellung”. Sollten mir noch weitere Ursachen bekannt werden, trage ich diese hier nach.

Hinweis: Unter [10] wird noch der Fall beschrieben, dass bei Anwahl des Audio-Managers ein Shell-DLL-Fehler auftritt. In diesem Fall war der Dienst “Windows-Audio-Endpunkterstellung” nicht beteiligt – hier half eine Neuinstallation des Audiotreibers.

2. Ursache: Dienst zur Energieverwaltung (Power Service)

Auf eine ganz andere Ursache bin ich gestoßen, als ich im Web nach “service audio endpoint builder” recherchiert habe. Unter [11] findet sich der Hinweis, dass der Dienst “Windows Audio-EndPunkt-Erstellung” von den Diensten “Power” und “Plug&Play” abhängt. Ist Plug&Play als Dienst gekillt, werden die Hardware-Komponenten nicht mehr erkannt (wäre eine Erklärung, warum Anwender mit USB-Headsets gelegentlich Probleme mit der Audiowiedergabe haben – der USB-Treiber wird zwar installiert, kann aber vom Dienst “Windows-Audio-Endpunkterstellung” nicht zugeordnet werden).

Die wirkliche Gefahr schlummert jedoch an einer anderen Stelle: der Optimierungswahn lässt grüßen – manche Anwender deaktivieren den Windows 7-Dienst “Stromversorgung”:

C:\Windows\system32\svchost.exe -k DcomLaunch

Dieser Dienst verwaltet die Energierichtlinie und die Zustellung der Energierichtlinienbenachrichtigung. Und folgerichtig bin ich unter  [12, 14] an genau dieser Stelle fündig geworden. Anwender, die den “Power-Service” deaktivierten, stellten nach einiger Zeit fest, dass die Audioausgabe nicht mehr funktionierte – hatten natürlich die Deaktivierung des Diensts nicht mehr auf dem Radar.

Der Dienst “Windows Audio-EndPunkterstellung” besitzt neben dem Dienst “Plug&Play” noch die zweite Abhängigkeit in Form des “Audio-Diensts”. Falls die obigen Maßnahmen nicht greifen, also auch mal nachsehen, ob dieser Dienst überhaupt gestartet werden kann.

Windows Audio-Endpunkterstellung – Klasse nicht registriert

Meldet Windows 7, dass die Klasse für die “Windows-Audio-Endpunkterstellung” nicht registriert sei [4]? In diesem Fall ist entweder etwas in der Registrierung kaputt oder es sind Systemdateien beschädigt. Geben Sie cmd im Suchfeld des Startmenüs ein, drücken Sie Strg+Shift+Enter und bestätigen Sie die Benutzerkontensteuerung. Danach geben Sie den Befehl sfc /scannow ein und drücken die Eingabetaste.

Liefert die Systemdateiprüfung Fehler und kann diese reparieren? Testen Sie, ob das Problem anschließend behoben ist. Falls Fehler nicht repariert werden können oder das Problem weiter auftaucht, empfiehlt sich eine Inplace-Update-Installation [5].

Windows Audiodienst läuft nicht

Erscheint ein rotes X beim Lautsprechersymbol und es kommt kein Ton. Die erste Maßnahme wäre eine Problembehandlung (über das Kontextmenü des Lautsprechersymbols) auszuführen. In diversen virtuellen Maschinen hatte ich dieses Problem häufiger. Half die Problembehandlung nicht, wurde dies durch automatische Treiberupdates kurz nach der Windows 7-Installation behoben. Gegebenenfalls ist auch eine Systemdateiprüfung gemäß dem vorherigen Abschnitt durchzuführen.

Falls dies alles nicht hilft und Windows 7 meldet “Der Dienst “Multimediaklassenplaner” konnte nicht gestartet werden” bzw. es wird der Fehler 193:0xc1 ausgeworfen, liegt das Problem etwas tiefer. Dann kann der Windows Audiodienst nicht starten. Der Dienst hat zwar keine Abhängigkeiten, wird aber von anderen Diensten verwendet.

Neben einer Überprüfung des Audiotreibers sollte auch die Anmeldung für verschiedene Dienste kontrolliert werden. Über dienste im Suchfeld des Startmenüs eingeben und Strg+Shift+Enter drücken lässt sich der Dienste-Manager aufrufen.

  • Der Dienst Multimediaklassenplaner sollte auf Automatisch stehen und gestartet sein. Auf der Registerkarte Anmelden sollte nur das Optionsfeld Lokales Systemkonto markiert sein.
  • Der Windows Audiodienst sollte ebenfalls gestartet sein und auf dem Starttyp “Automatisch” stehen. Auf der Registerkarte Anmelden ist bei mir das Optionsfeld Dieses Konto markiert. Als Konto ist Lokaler Dienst eingetragen. Das Kennwort bleibt leer (bei mir werden Sternchen angezeigt).

Stehen beim fehlerhaften System andere Einstellungen an, sollten diese gemäß obigen Hinweisen angepasst werden. Nach einem Neustart ist zu prüfen, ob der Audiodienst starten kann. Unter [15, 16, 17, 18] finden sich weitere Hinweise zur Problösung.

WMP-Netzwerkfreigabe: Windows-Suchdienst fehlt

Eine weitere Ursache für einen nicht funktionierenden WMP-Netzwerkfreigabedienst findet sich in diesem MS Answers-Forenbeitrag: Abhängige Dienste (hier der Suchdienst) konnten nicht gestartet werden.

Links
1: Microsoft Foreneintrag
2: Windows Audiodienst stoppt bei Audiowiedergabe (Foreneintrag)
3: Fehler 0xC00D11B1 bei DRM-Titeln im WMP 12
4: Windows Audio-Endpunkterstellung – Klasse nicht registriert
5: Windows 7 Inplace Upgrade (Dr. Windows How-To)
6: Windows Dienste: Windows-Audio-Endpunkterstellung
7: Windows Dienste-Übersicht (Dr. Windows)
8: Audioausgabe ausgefallen
9: Problembehandlung bei Audioausgabe
10: Audio-Problemdiskussion in MS-Foren
11: Wiki-Eintrag Windows Audio EndPoint Builder
12: Diskussion im Windows7-Forum (englisch, mit Problemlösung)
13: RDP-Service AudioEndpoint API Reference (englisch)
14: Microsoft US-Forendiskussion (englisch)
15: Microsoft Forendiskussion
16: Audioservice will not run (englisch)
17: Steps to re-enable audio service (englisch)
18: Windows 8.1/10: Kein Systemsound


 


Anzeige
Dieser Beitrag wurde unter Problemlösung, Video/Foto/Multimedia, Windows 7, Windows Media Player, Windows Vista abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

11 Antworten zu Audiowiedergabeprobleme, wegen des Diensts "Windows-Audio-Endpunkterstellung"


  1. Anzeige
  2. Pingback: Anonymous

  3. jero sagt:

    Vielen Dank, super Hilfe! Die Systemdateiprüfung hat mich gerettet…

  4. Anzeige

  5. Radle sagt:

    Vielen dank, auf den Systemdienst “Power” wäre ich niemals bekommen, zumal in den Beschreibung eine Abhängigkeit nicht Beschrieben wird.

  6. Pingback: Anonymous

  7. Pingback: Beheben Fehler Audio Windows-

  8. Pingback: Papierkorb Sound - Seite 2

  9. Anzeige

  10. R. Rolf sagt:

    Sehr geehrter Herr Born,
    danke für all Ihre Beiträge und Publikationen.
    Bereits 2011 von Ihnen verfasst schein mir doch Ihr damaliger Beitrag den Kern meines Anliegens zu treffen. Audiosystem wird nicht mehr gefunden…… rotes Kreuz am Lautsprechersymbol.
    Dies Thema haben Sie damals erörtert.

    Kürzlich habe ich im Rahmen meiner (voreiligen) Reinigungsbemühungen mittels eines Reg-Cleaners “aufgeräumt” und unter anderem eine vermeintlich unnötige Software gelöscht. Ich meine zu erinnern, dass der Name der Software (Windows 7 – HP Desktop) in etwa “Accu-Energie Manager” o.ä lautete.

    Ich habe viele DInge ausprobiert und auch all Ihre Anregungen durchgespielt.
    Windows-Audio Dienst läßt sich nicht aktivieren
    Windows Audio Endpunkterstellung ist aktiviert
    Multimediaklassenplaner ist aktiviert
    Windows Dienst POwer (Stromversorgung) fehlt —- vermutlich von mir gelöscht.

    Nun finde ich nirgends eine Möglichkeit, die gelöschte Software wieder einzuspielen. Microsoft.de führt mich auch nicht zum Ziel.

    Es wäre sehr nett, wenn Sie mir helfen könnten – danke.

    Ein frohes neues Jahr wünscht Ihnen
    R. Rolf

  11. Bernd Dreyer sagt:

    Skype lässt die Umschaltung von Lautsprecher und Mikrofon zwischen intern und extern zu (leider keine Abbildungen erlaubt). Auf meiner Maschine läuft noch Zoiper. Zoiper lässt ebenfalls die Umschaltung von Lautsprecher und Mikrofon zwischen intern und extern zu (leider keine Abbildungen erlaubt).

    Neuster Stand: Damit ich mit Skype telefonieren kann, muss ich immer zuerst in die Zoiper-Einstellungen und zwischen intern und extern hin- und herschalten. Aber auch dies funktioniert nur sporadisch.

    • Danke für die Ergänzung. Screenshots kannst Du einbinden, indem Du das Bild zu einem Image-Hoster hochlädst und die URL mittels <img src=”URL” > hier einbindest.

      Ich habe die Upload-Funktion für Bilder und Videos nie aktiviert, da mir dann ganz schnell der freie Speicher des Webpakets platzt ;-).

  12. Andre sagt:

    So eine ausführliche Fehlerbeschreibung und Hilfe ist außergewöhnlich.
    Nach langem Suchen bin ich hier gelandet und… es hat geklappt.
    1000 Dank.
    Andre

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.