Systemintegritätsbericht nicht erstellbar

Aktuell bin ich mal wieder in Foren auf ein ziemlich kurioses Problem gestoßen: Anwender können unter Windows 7 keinen Systemintegritätsbericht erstellen und erhalten den Fehlertext “Zeitüberschreitung beim Warten auf den Abschluss des Berichtgenerierungstools.” (bzw. “The wait for the report generation tool to finish has timed out” in englischen Varianten des Betriebssystems). Also mal wieder Zeit, einen Blick auf dieses “Feld” zu werfen und ein paar Sachen aufzudröseln.


Anzeige

Ähm, wie rufe ich den Systemintegritätsbericht auf?

Als ich auf die Fehlerbeschreibung stieß, habe ich natürlich sofort “Systemintegritätsbericht” im Suchfeld des Startmenüs eingegeben. Aber da bekommt man keinen Treffer (irgendwo hatte ich im Hinterkopf auch noch gespeichert, dass ich von Vista auf Windows 7 etwas in der Bezeichnung geändert hatte). Die in den beiden Blog-Artikeln unter [a, b] angesprochenen Funktionen konnten irgendwie nicht gemeint sein.

Etwas näher brachte mich dann die Beschreibung, wie man die Funktion eventuell aufruft. Gehe zur Systemsteuerung und schalte die Anzeige auf “Große Symbole” (im Adressfeld steht dann Systemsteuerung \Alle Systemsteuerungselemente). Nun kann man den Eintrag Leistungsinformationen und –tools anklicken, um zur Seite Bewertung und Verbesserung der Leistung des Computers zu gelangen. In der linken Spalte der Aufgabenleiste wählt man dann den Befehl Weitere Tools und klickt in der Folgeseite auf den Hyperlink Systemintegritätsbericht erstellen.

Tipp: Fixer geht es natürlich, wenn man Leis im Suchfeld des Startmenüs eintippt und dann den Eintrag Leistungsinformationen und Tools anwählt. Oder man gibt perfmon /report im Suchfeld des Startmenüs ein und drückt die Eingabetaste.

Nach Bestätigung der Sicherheitsabfrage der Benutzerkontensteuerung sollte das nachfolgende Fenster sichtbar werden. Das System wird einer Leistungsüberwachung unterzogen und dann sollte nach einer Minute der Bericht erscheinen.

So weit so gut. Nur was ist, wenn der Bericht nicht erstellt wird, sondern die Fehlermeldung “Zeitüberschreitung beim Warten auf den Abschluss des Berichtgenerierungstools.” (bzw. “The wait for the report generation tool to finish has timed out” in englischen Varianten des Betriebssystems [4]) erscheint? Sofern die in den beiden Blog-Artikeln unter [a, b] angesprochenen Funktionen klappen, gilt es, eine weitergehende Diagnose durchzuführen.


Anzeige

Manche Benutzer berichten [1], dass die Berichte generiert werden und unter C:\PerfLogs\System\Diagnostics einsehbar wären. Ob es allerdings ältere Berichte sind, sollte an Hand des Datums evaluiert werden.

O&O-Defrag im Einsatz?

Eine Ursache wird unter [1] genannt: Benutzer, die das Tool O&O Defrag in älteren Versionen (Stand 2009) verwenden, berichten von entsprechenden Problemen [2]. Unter [3] findet sich eine Beschreibung, wie man den betreffenden oodiag.exe-Dienst deaktivieren kann.

Protokolldateien löschen

Wer kein O&O Defrag im Einsatz hat, wird mit obigem Ansatz wohl nicht weiter kommen. Ursache kann auch sein, dass der HTML-Berichtsgenerator die Dateien wegen eines Zugriffskonflikts nicht schreiben kann und dann den Timeout verursacht. Eine Lösung, die häufiger hilft, ist das Löschen der Protokolldateien im Ordner:

C:\PerfLogs\System\Diagnostics

Der Zugriff auf diesen Ordner erfordert allerdings administrative Berechtigungen.

TuneUp im Einsatz

Ich bin im Internet auch auf Informationen gestoßen [8], wo der Einsatz von TuneUp die Erstellung eines Systemintegritätsberichts verhindert hat. Falls dieses Tool im Einsatz ist, sollte in dessen Optionen ein Punkt vorkommt, der sich mit dem Systemintegritätsbericht befasst.

Frag die Ereignisanzeige

Unter [7]  findet sich noch der Hinweis, in der Ereignisanzeige unter Anwendungs.- und Dienstprotokolle –> Microsoft –> Windows nachzuschauen. Dort sollte dann Diagnostics – Performance als Zweig mit dem Eintrag Betriebsbereit zu finden sein. Bei Fehlern dürfte sich dort ein Hinweis auf die Fehlerursache befinden. In meinem System habe ich einige Fehlereinträge gefunden – aber der Bericht wird erstellt

Ereignisanzeige beendet

Unter [7] habe ich den Hinweis gefunden, dass ein Benutzer die Ereignisanzeige geöffnet hatte und der Systemintegritätsbericht scheiterte. Nach dem Schließen der Ereignisanzeige funktionierte die Erstellung des Berichts. Halte ich aber für unwahrscheinlich, da ich hier keine Abhängigkeiten feststellen konnte.

Sind die Dienste verfügbar?

Zur Sicherheit kann noch Dienste im Suchfeld des Startmenüs eingegeben und dann der gleichnamige Befehl über Als Administrator ausführen gestartet werden. Dann sollten folgende Einstellungen überprüft werden:

Diagnosediensthost –> Manuell
Diagnoserichtliniendienst –> Automatisch
Diagnosesystemhost –> Manuell
Leistungsprotokolle und –warnungen –> Manuell

Obwohl ich in diesem Bereich auch keine Fehlfunktion bei der Deaktivierung der Dienste feststellen konnte.

Aufgabenplanung und Registry überprüfen

Unter [9] habe ich noch Hinweise gefunden, Einträge in der Aufgabenplanung bzw. in der Registrierung zu überprüfen. Keine Ahnung, ob dies hilft bzw. sinnvoll ist.

System eventuell beschädigt?

Falls die obigen Hinweise nicht weiter helfen, sollte auch eine Systemdateiprüfung [c] in Betracht gezogen werden. Diese sollte keine beschädigten Dateien melden.

Workaround, falls nix geht

Falls die obigen Maßnahmen nicht weiter führen, kann man versuchen, die Zuverlässigkeitsüberwachung zu werden. Unter [11] findet sich eine Anleitung, wie man diese aufrufen kann.

Ähnliche Artikel:
a: Windows Leistungsüberwachung reparieren
b: Die Zuverlässigkeitsüberwachung streikt
c: System auf beschädigte Systemdateien prüfen

Links:
1: Forendiskussion bei MS Answers
2: O&O Produkte sorgen für Fehler in Systemintegritätsbericht
3: Lösungshinweise für O&O-Problem
4: How to Generate a System Health Report
5: Error When Generating System Health Report
6: Diskussion zu Vista-Integritätsbericht
7: Diskussion bei MS Answers (Englisch)
8: Weitere Diskussion (TuneUp)
9: Diskussion in Sevenforums.com
10: Forendiskussion bei MS Answers (neuer Thread)
11: Forendiskussion MS-Answers (Englisch)


Werbung
Weitere Infos zu Windows 7 finden sich in meinen Windows 7-Titeln


Anzeige


Dieser Beitrag wurde unter Problemlösung, Windows 7, Windows Vista abgelegt und mit , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

2 Antworten zu Systemintegritätsbericht nicht erstellbar


  1. Anzeige
  2. Pingback: Der Befehl "perfmon /report" funktioniert beim 3550er nicht - Notebookforum

  3. Schramm sagt:

    Vielen Dank für Ihren Tipp.Nach Löschen etlicher Protokolldateien im Ordner C:\PerfLogs\System\Diagnostics

    wurde der Systemintegritätsbericht wieder angezeigt.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Hinweis: Bitte beachtet die Regeln zum Kommentieren im Blog (Erstkommentare und Verlinktes landet in der Moderation, gebe ich alle paar Stunden frei, SEO-Posts/SPAM lösche ich rigoros). Kommentare abseits des Themas bitte unter Diskussion.