VMware-Problem “Nicht identifiziertes Netzwerk”

Im heutigen Blog-Beitrag möchte ich auf das VMware-Problem des nicht identifizierten Netzwerks eingehen, welches Nutzer immer wieder plagt. Nachdem ich plötzlich überhaupt kein Netz mehr auf einer Windows 7-Maschine hatte, bin ich der Sache nachgegangen.


Anzeige

Worum geht es eigentlich genau?

Kürzlich stand ich vor dem Problem, dass ich plötzlich kein Netzwerk mehr unter Windows 7 hatte und der Zugriff auf das Internet auch nicht mehr klappte. Im Infobereich der Symbolleiste fand sich nur das Symbol für ein nicht identifiziertes Netzwerk mit dem gelben Dreieck.

Netzwerk4

Zu diesem Problem gibt es den Beitrag Nicht identifiziertes Netzwerk …, der die Hintergründe erklärt – mir aber im konkreten Fall nicht weiter half. Ich hatte gerade den November-Patchday (2014) durchgeführt und einen Tag vorher VMware Workstation 10.0.4 installiert. Irgendwo in dieser Kombination musste der Fehler liegen und als ich die Problembehandlung startet, wurde mir ein fehlender DHCP-Server im VMware-Netzwerk gemeldet.

Ich hatte das Problem in diesem Beitrag angesprochen – und auch meine Lösung skizziert: VMware Workstation deinstallieren, neu booten und VMware Workstation wieder installieren. Im Nachhinein weiß ich, dass die De- und Neuinstallation vermutlich nicht notwendig gewesen wäre, und das Zurücksetzen der Netzwerk-Defaults im Virtual Network Editor gereicht hätte.

VMware virtuelle Netzwerkadapter als Problembär

Aber bei der Recherche bin ich auf ein anderes Problem gestoßen, welches ich im Blog-Beitrag gerne aufgreifen möchte. Sobald man VMware Workstation oder ein anderes VMware-Produkt zur Virtualisierung installiert, bekommt man in der Netzwerkumgebung ein nicht identifiziertes Netzwerk.


Werbung

Verantwortlich sind die beiden virtuellen Netzwerkadapter VMnet1 und VMnet8. Bei Virtualbox ließ sich das Problem immer leicht lösen: Einfach die beiden Netwerksegmente mit einer Netzwerkbrücke vereinen und alles ist gut. Dieser Ansatz klappt bei VMware Workstation-Adaptern aber nicht. Normalerweise kann man das nicht identifizierte Netzwerk ignorieren, da der Netzwerkzugang des Hosts und des Gasts funktioniert.

Die Lösung für das Problem

Wen dieses nicht identifizierte Netzwerk aber stört, kann auf Abhilfe sinnen. Bei meinen Recherchen bin ich auf diesen VMware Knowledgebase-Artikel gestoßen, der die Lösung beschreibt. Man muss die Adapter (virtual NICs) einfach als Endpoint-Geräte festlegen.

1. Hierzu ruft man den Registrierungseditor über Als Administrator ausführen auf und navigiert zum Schlüssel HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\.

2. Dann wechselt man zum Unterschlüssel Class und sucht dort den Unterschlüssel mit dem Wert {4D36E972-E325-11CE-BFC1-08002BE10318}.

3. Im Schlüssel sollt es einen Unterschlüsse oooo geben, der anzuwählen ist. Anschließend fügt man den DWORD-Wert NdisDeviceType ein und setzt diesen auf 1.

Der Schritt ist für die nächsten Unterschlüssel zu wiederholen, bis alle Unterschlüssel entsprechend mit dem DWORD-Wert versehen sind. Dann geht man gemäß den Vorgaben im Artikel oder hier vor und deaktiviert die Netzwerk-Adapter (NICs), um diese im nächsten Schritt wieder zu aktivieren. Nun sollte das nicht identifizierte Netzwerk verschwunden sein.

Ähnliche Artikel:
Nicht identifiziertes Netzwerk …
Windows 7: Netzwerkstandort erzwingen
Windows 7-FixIt für “Netzwerk ist immer öffentlich”
Windows meldet: Netzwerkkabel defekt oder nicht eingesteckt
Windows 8.1: Netzwerkdrucker streikt nach Update
Videotraining: Kleine Windows-Netzwerke
Win-Netzwerkeinstellungen per Konsole ändern
Problem mit Zugriff auf Benutzerordner in Netzwerkfreigabe
Lokales System (Netzwerkeinschränkung) erzeugt hohe CPU-Last
Netzwerkprofile in Windows 8 löschen


Anzeige
Dieser Beitrag wurde unter Netzwerk, Problemlösung, Windows abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

1 Response to VMware-Problem “Nicht identifiziertes Netzwerk”

  1. Thorsten Albrecht sagt:

    Deine Anleitung ist laut der KB-Anleitung von VMware nicht richtig. Zum Einen lautet der neue DWORD-Wert nicht NdisDeviceType, sondern *NdisDeviceType (also mit ‘*’). Und zum Zweiten ist dieser Wert nur bei denjenigen Zweigen (also bei 0000, 0001, etc.) einzusetzen, wo das Feld DriverDesc den Wert “VMware Virtual Ethernet Adapter for VMnet” besitzt. Normalerweise hat man zwei virtuelle VMware-Netzwerkkarten; also betrifft das meistens auch nur zwei Einträge in dem Baum unter {4D36E972-E325-11CE-BFC1-08002BE10318}.

    Bei meiner Installation von VMware Workstation 11 sind übrigens diese Einträge bereits vorhanden (*NdisDeviceType) und auch bereits mit ‘1’ initialisiert, ohne dass ich je etwas geändert hätte. Evtl. ist das also jetzt oder auch schon seit längerem ein Default-Eintrag.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.