Windows-Fehler “Die angeforderte Ressource wird bereits verwendet"

Gelegentlich bekommen Windows-Nutzer beim Kopieren von Dateien oder anderen Operationen die Fehlermeldung “Die angeforderte Ressource wird bereits verwendet” angezeigt. Dann wird die Operation abgewiesen. Im Blog-Beitrag gehe ich dem Problem nach und zeige, was man tun kann.


Anzeige

Die Fehlermeldung kann bei verschiedenen Gelegenheiten erscheinen. So gibt es Fälle, wo das Löschen eines TCP/IP-Druckeranschlusses die Fehlermeldung “Die angeforderte Ressource wird bereits verwendet” (oder “The Requested Resource is in Use”) verursacht. Gelegentlich findet man auch den Fehlercode 0x800700AA dieser Meldung zugeordnet (siehe).

Die angeforderte Ressource wird bereits verwendet

Meist werden aber Nutzer das obige Dialogfeld (habe ich per Script selbst erzeugt) oder etwas ähnliches zu sehen bekommen, wenn Sie auf Dateien von Digitalkameras oder Smartphones zugreifen möchten, die per USB-Kabel am Windows-Rechner angeschlossen sind. Ich selbst habe diesen Fehler sporadisch, wenn ich mein iPad 3 an eine Windows 7 SP1-Maschine anschließe. Der Fehler ist aber auch schon beim Anschluss eines Android-Smartphones aufgetaucht.

Der Fehler besagt lediglich, dass die Ressource (Druckerport, angeschlossenes Gerät) etc. durch ein anderes Programm oder eine Windows-Funktion benutzt wird. Und zwei Funktionen können nicht auf die Ressource gleichzeitig zugreifen. Normalerweise sollten Programme und Windows-Funktionen selbst dafür sorgen, dass eine benutzte Ressource sofort wieder freigegeben wird. Aber Programmfehler verhindern dies mitunter.

Als der Fehler letzte Woche auftauchte, habe ich erneut Ursachenforschung betrieben. Im Internet gibt es zwar viele Seiten (siehe 1, 2, 3, 4, 5, 6, 7), die den Fehler thematisieren – aber Lösungen sucht man vergeblich.

Fehler beim Löschen eines Druckers

Tritt der Fehler beim Löschen eines Druckeranschlusses auf? Bei meiner Suche im Internet bin ich dann sehr schnell auf einen alten Microsoft Answers-Forenthread gestoßen. Dann greift ein Drucker noch auf diesen Anschluss zu und Windows verweigert das Löschen. Hier hilft folgender Trick:

1. Den Registrierungs-Editor mit dem Kontextmenübefehl Als Administrator ausführen starten und die Nachfrage der Benutzerkontensteuerung bestätigen.


Anzeige

2. Anschließend im Registrierungs-Editor die folgenden beiden Schlüssel entfernen und danach Windows ggf. neu starten.

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Monitors\Standard TCP/IP Port\Ports\

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Standard TCP/IP Port\Ports\

Der Fehlercode wird auch in diesem MS-Answers-Forenthread sowie hier thematisiert. Dort gibt es den Vorschlag, den Druckerspooler zu beenden und dann den Port zu löschen.

Fehler beim Zugriff auf Smartphones und Tablets per USB

Kommen wir nun zu dem Fall, der bei den meisten betroffenen Nutzern auftritt und der mich über Jahre sporadisch plagt. Beim Anschluss eines iPad 3 per USB-Schnittstelle lässt sich zwar das Gerät (nach der Freigabe der Zugriffe unter iOS) im Explorer anwählen.

iPad im Explorer

Die gespeicherten Fotos werden auch angezeigt. Aber beim Versuch, Foto- und Video-Dateien vom iPad auf den lokalen Rechner zu kopieren oder zu verschieben, kommt immer mal wieder die gefürchtete Fehlermeldung. Unter Windows 7 SP1 sieht das Dialogfeld so aus.

Windows, Fehler, Ressource verwendet

Ruft man unter Windows die Eigenschaften einer auf dem iPad gespeicherten Datei auf, lässt sich die Registerkarte Ressourcen ansehen.

Der Screenshot zeigt, dass lediglich eine Miniaturansicht als Ressource aufgelistet ist. Lässt den Schluss zu, dass die Bildvorschau des Dateimanagers das Problem verursacht. Im Internet findet man häufig den “Ratschlag” die Vorschau “im rechten Teilfenster zu schließen” (siehe hier). Das geht natürlich im Windows-Explorer unter Windows 7 und höher nicht mehr. Was gehen würde, wäre.

  • Die Anzeige der Miniaturvorschau abschalten, indem man im Explorer die Detailansicht wählt.
  • Das Explorer-Fenster schließen, um die Blockade durch den Vorschauhandler zu beenden.

Beide Ansätze sind aber nur theoretischer Natur. Wenn ich die Anzeigeoptionen im Explorer auf Details stelle, kommt beim Kopieren die gleiche Fehlermeldung. Und ich kann nicht mal zur Anzeige der Vorschau zurück wechseln. Erst nachdem ich das iPad per USB ab- und wieder angestöpselt und die Zugriffe freigegeben habe, werden die Miniaturansichten wieder eingeblendet.

Die zweite Lösung ist noch blöder. Wenn ich die Daten vom iPad (oder einem Android-Handy/-Tablet) kopieren möchte, muss ich den Explorer verwenden. Aber ich habe folgendes getestet:

  • Explorer-Anzeigemodus ändern, um die Vorschau abzuschalten (siehe hier). Blieb bei mir genauso wirkungslos wie den Explorer zu beenden und neu zu starten.
  • Mir kam die Idee, der Navigationsspalte des Explorers das Mobilgerät (iPad, Android-Gerät) per Rechtsklick anzuwählen und im Kontextmenü den Befehl Bilder und Videos importieren zu verwenden.

Der letztgenannte Ansatz endete mit folgendem Fehlerdialog, in dem mir der Ressourcenkonflikt mitgeteilt wurde.

Import-Fehler

Ich habe den Explorer geschlossen, um Vorschauhandler etc. auszuschließen und bin über Wiederholen gegangen. Alleine, der Fehlerdialog verschwand nicht. Scheibenkleister – und der Fehler trat natürlich immer dann auf, wenn ich schnell mal Screenshots oder Fotos von einem iPad oder einem Android-Gerät für einen Blog-Beitrag ziehen wollte …

Dummerweise trat der Fehler auch nur sporadisch auf – dann hatte ich den jeweiligen Lösungsansatz “have you tried to switch off and switch on” schon wieder vergessen. Als der Ansatz zu diesem Blog-Beitrag entstand, wollte ich gerade über diese Apple-Veranstaltung bloggen und dazu einige Screenshots der Präsentation auf den PC ziehen. Nachdem ich eine Lösung (siehe unten) für mein temporäres Problem gefunden hatte, wollte ich ein paar Tage später den Fehler für den Beitrag nachstellen. Aber was ich auch probierte, Windows 7 SP1 ermöglichte mir im Explorer die Dateien vom iPad auf die Festplatte zu kopieren.

Beim Schreiben des Blog-Beitrags gelang es mir den Fehler nach vielen Fehlversuchen doch noch zu provozieren. Ich habe sofort eine Reihe von Maßnahmen probiert, um ggf. eine funktionsfähige Lösung zu haben und diese zu dokumentieren.

  • Das Gerät (iPad, Android-Gerät) neu zu starten, aber das Ergebnis war negativ.
  • Das Gerät mehrfach per USB-Kabel ab- und wieder anstöpseln – auch das hat nie geholfen.
  • Bei einem Android-Smartphone erinnere ich mich, dass die Umstellung des Übertragungsmodus für Bilder von USB-Medium auf PPT- oder MTP-Protokoll unter Android die Ladehemmung auflöste (wird auch hier erwähnt).
  • Und ich hatte mir gemerkt, dass nach einem Neustart von Windows sich das Problem “in Luft auflöste”.

Aber an besagtem Abend wollte ich die Windows 7-Maschine nicht wieder einmal neustarten, nur um auf das iPad zugreifen zu können. Ab- und Anmelden wäre möglicherweise auch gegangen, hätte aber alle Programme beendet. Da der Fehler sporadisch auftauchte habe ich schnell den Prozess Explorer aus den Sysinternals Tools aufgerufen. Aber dort konnte ich nicht wirklich was erkennen. Und dann hatte ich eine Idee.

1. Ich habe den Windows Task-Manager aufgerufen (z.B. Rechtsklick auf die Taskleiste und den Kontextmenübefehl anwählen).

Task-Manager

2. Dann wurde auf der Registerkarte Prozesse den Prozess explorer.exe angewählt und die Schaltfläche Prozess beenden gewählt.

Das bewirkt, dass der Explorer und ggf. ein klemmender Preview-Handler für die Darstellung der Vorschau zwangsweise aus dem Windows-Speicher geworfen wird. Dummerweise haben die Microsoft-Entwickler vor langer Zeit mal beschlossen, dass der Explorer auch der Prozess sein soll, der für die Darstellung des Windows-Desktop samt Taskleiste verantwortlich ist. Durch den Abschuss des Prozesses explorer.exe verschwinden Desktop und Taskleiste.

Task erstellen

3. Also bin ich im Task-Manager zur Registerkarte Anwendungen gewechselt, habe die Schaltfläche Neuer Task gewählt, im Dialogfeld Neuen Task erstellen unter Öffnen den String explorer eingetippt und auf OK geklickt.

Mit dieser Aktion wurde der Explorer als Prozess neu gestartet, Desktop und Taskleiste erschienen wieder. Ich habe dann den Explorer erneut geöffnet, das iPad per USB-Kabel nochmals angestöpselt und konnte nach Freigabe der Zugriffe (wird in iOS abgefragt) vom PC auf den Bilderordner des iPad zugreifen. Kopieren und verschieben lief danach wie am Schnürchen. Mit dem Abschießen des Explorers hatte ich die Belegung der Ressource wohl “aufgelöst”. Ob es der Vorschauhandler war, da bin ich mir nicht mal sicher, denke aber “eher nicht”.

Nachtrag: Gerade hatte ich den Fehler beim Nexus 4. Dort habe ich es einfach mal probiert und den Geräte-Manager aufgerufen. Das Nexus 4 im Zweig Tragbare Geräte per Doppelklick angewählt und auf der Registerkarte Treiber des Eigenschaftenfensters den Treiber kurz deaktiviert und dann wieder aktiviert. Gegebenenfalls muss auf der Registerkarte Allgemein die Schaltfläche Einstellungen ändern angewählt werden, um Administratorrechte anzufordern. Danach ist der Fehler mit der belegten Ressource auch weg. Der Ansatz ist ggf. einfacher als den Explorer zu beenden und neu zu starten. Es führen also mehrere Wege nach Rom.

Und die Ursache ist?

Ich hatte ja den Preview-Handler im Verdacht. Aber egal, was ich später probiert habe (Bild als Vorschau unter Windows öffnen und dann kopieren, Vorschau im Explorer einschalten), der Fehler trat nicht mehr auf.

Ich hatte noch den Verdacht, dass es an einer VMware Workstation-Installation und deren USB-Treibern liegen könnte. Diese hatten mal bei einem iFlash-Drive (USB-Stick mit iPad-Schnittstelle) für mächtig Ärger gesorgt (der Hersteller aus Taiwan musste die Firmware des iFlash-Drive ändern, als ich den Fehler im Rahmen eines Tests aufgedeckt und gemeldet hatte). Aber auch der Start einer virtuellen Maschine änderte nichts an der Tatsache, dass der Fehler nicht mehr auftauchen wollte.

Auch meine Idee, dass es eventuell mit dem Ruhemodus zu tun habe, musste ich verwerfen. Das Kopieren der Dateien klappte nach der Reaktivierung aus dem Ruhemodus problemlos. Erst beim Schreiben dieses Blog-Posts kam ich durch Zufall auf die Idee, das iPad auszuschalten (also iOS herunterzufahren) und das ausgeschaltete Gerät per USB-Kabel mit Windows 7 SP1 zu verbinden. Dann habe ich das iPad angeschaltet, booten lassen, die Freigabe zum Zugriff von einem externen Computer unter iOS zugelassen und dann versucht zu kopieren. Und Bam – der Fehler war plötzlich wieder da.

Ich reime es mir so zusammen, dass Windows bei einem ausgeschalteten Mobilgerät noch eine Geräte-ID beim Anschließen des USB-Kabels abfragen kann. Aber weitergehende Informationen wie die Unterstützung von MTP-Übertragung etc. werden nicht berücksichtigt. Das stünde im Einklang mit meiner Beobachtung, dass Windows 7 SP1 hier beim Einbinden des USB-Treibers eines angeschlossen aber ausgeschalteten Google Nexus 4 scheitert.

Wenn ich mein Nexus 4 einschalte, installiert Windows 7 dann auch erfolgreich seine Treiber. Aber ich gehen davon aus, das Windows beim Konfigurieren der Übertragungsprotokolle scheitert. Die Ressource wird blockiert und nicht wieder freigegeben. Und das kann auch beim späteren Einschalten des Geräts nicht mehr korrigiert werden. Das wäre dann ein Designfehler von Windows – aber ich mag mich irren.

Damit löste sich das Ganze auf: Auch bei Android habe ich oft die Situation, dass die Geräte abgeschaltet sind, aber zum Laden an der USB-Schnittstelle hängen. Dort meldet Windows 7 SP1 mir die Installation eines Treibers. Das endet aber mit einer Fehlermeldung, weil Windows 7 das ausgeschaltete Gerät irgendwie nicht korrekt identifizieren kann und so keine Treiber findet. Beim iPad werden zwar keine Treiber installiert – aber beim Einbinden des ausgeschalteten iPads und dessen anschließendem Hochfahren scheint sich der Ressourcenkonflikt zu ereignen. Und das könnte auch die Erklärung für einen Teil der im Internet berichteten Fälle sein.

Das Ganze ist zwar jetzt eine etwas längere Geschichte geworden. Aber es widerstrebt mir ein kurzes “klicke hier, und drücke da, dann läuft es” hier im Blog rein zu kippen, sondern ich möchte auch darlegen, welche Diagnose- und Lösungsansätze ich verfolgt habe. Vielleicht hilft der Blog-Beitrag anderen Betroffenen aus der Patche bzw. gibt Anregungen, wo man mal nachschauen könnte. Falls etwas geholfen hat, könnt ihr ja einen Kommentar als Rückmeldung hinterlassen.

Nachtrag: Was auch hilft, ist das Abschalten der USB-MTP-Unterstützung im Android-Gerät. Dann wird der MTP-Treiber in Windows getrennt. Danach wieder die USB-MTP-Unterstützung in Android einschalten.

Ergänzung: Treiber neu installieren (Dez. 2018)

Unter Windows 10 Version 1809 bin ich auf das Problem gestoßen, dass die Lösung mit neustarten des Explorers oder aus-/einschalten des MTP-Treibers nicht geholfen hat. Ich habe dann den Geräte-Manager aufgerufen und den Treiber für das Android-Gerät neu installieren lassen. Danach konnte ich die Bilder vom Android-Gerät per Explorer auf das Windows 10-System kopieren.

Ähnliche Artikel:
Windows 8.1 N: Keine PTP- und MTP-Unterstützung
Windows-MTP-Treiber funktioniert nicht
Windows 10 N: Edge PDF-Anzeige funktioniert nicht
Lumia (Windows Phone) USB wird an Windows nicht erkannt
Windows 10 N: Media Feature Pack für Version 1511 verfügbar
Media Feature Pack für Windows 10 N erhältlich
Nexus 4 mit Lollipop wird am PC nicht erkannt
USB-Stick wird als RAW angezeigt – Disk-Doktor II
Windows 10: Fotoimport klappt nicht
Wechselmedien: “Anwendung nicht gefunden”


Anzeige
Dieser Beitrag wurde unter Problemlösung, Windows 10, Windows 7, Windows 8, Windows 8.1, Windows RT, Windows Server, Windows Vista abgelegt und mit , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

9 Antworten zu Windows-Fehler “Die angeforderte Ressource wird bereits verwendet"


  1. Anzeige
  2. Heinz sagt:

    Wir haben das gleiche Problem im Geschäft, beim kopieren von Ordner im Netzwerk. Wenn ich die Ordneransicht auf grosse Symbole ändere, funktioniert es, was aber immer ärgerlich ist. Zuhause benutze ich Linux, ist much better.

  3. Harry sagt:

    @Heinz: Haben die Fehlermeldung in Domänennetzwerken bei diversen Kunden durch Abschalten der Erzeugung der “thumbs.db” gelöst, lässt sich auch via Gruppenrichtlinie regeln

  4. Anzeige

  5. Uwe Billen sagt:

    Hatte dasselbe Problem. Bei mir hatte auf dem Handy der Google Play Dienst die Finger drauf. Kollege Zufall half. Ein Dialog kam hoch, als ich mit dem Handy Samsung S7 ins Internet wollte, um die Datei über We Transfer auf meinen PC zu schicken. Hatte dann die Option, die APP Google PLay Dienste zu schliessen. Prompt erschien auf dem PC (Handy war verbunden) auch die Miniaturansicht und das Kopieren von Handy auf PC ging einwandfrei.

  6. Lukas sagt:

    Aufgrund diesen Fehlers habe ich 3 GB meiner Fotos vernichtet, hab am PC vom internen Speicher meines Smartphones auf die Festplatte auf dem Rechner verschieben wollen und weg waren die Fotos…alle meine Erinnerungen ._.

    • Martin sagt:

      Mit “Verschieben” bin ich immer äußerst vorsichtig. Besser erst kopieren, dann überprüfen, ob der Kopiervorgang erfolgreich war, und erst dann die ursprüngliche Datei löschen. Klar, Dir hilft das auch nicht weiter, aber Du hast mein volles Mitgefühl!

  7. Martin sagt:

    Ich habe mein Samsung S3 an den PC (Win 7) angeschlossen, um ein Ebook auf den PC zu kopieren. Es kam obige Fehlermeldung. Nach Deaktivierung des Smartphone-Treibers über Systemsteuerung-Gerätemanager und umgehender Aktivierung war das Problem behoben. Vielen Dank für den guten Tipp!!!

  8. Mirco sagt:

    Klasse, danke für den Tipp! Hatte auch das Problem in den Einstellungen der Druckereigenschaften.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.