Windows 10: Netzwerkprobleme durch Updates?

Kurze Frage in die Runde: Gibt es seit dem März 2018-Patchday Probleme im Netzwerk unter Windows 10 und haben sich diese möglicherweise die Tage (durch ein Korrekturupdate) aufgelöst? Hier eine kurze Zusammenfassung, um was es geht.


Anzeige

Dass der März 2018-Patchday Probleme im Netzwerk bereitet, hatte ich ja im Blog Beitrag Netzwerkprobleme mit Updates KB4088875 / KB4088878 angesprochen. Das bezieht sich aber auf Windows 7 und überwiegend virtuelle Netzwerkadapter.

Plötzlich Fehler 0x80070035

Die Tage erreichte mich eine Lesermail mit einem Hilferuf im Hinblick auf einen Netzwerkfehler. Der Blog-Leser schrieb:

Ich habe ein Business-Notebook von Acer (Travelmate P645-M mit einem Core i5 aus der 4000er Serie mit Win 10 64 Bit aktuell) und kann mit diesem Notebook nicht mehr auf meine eigenen Freigaben zugreifen. Ich kann zwar auf meinem Notebook unter Netzwerk mein Notebook sehen, aber öffnen kann ich die Freigabe nicht. Mit meinem Desktop-PC (AMD Prozessor mit Win 10 64 Bit aktuell) klappt der Zugriff auf die eigenen Freigaben wunderbar. Bisher habe ich Notebook und PC über die Freigaben synchronisiert, was seit ein paar Tagen nun überhaupt nicht mehr funktioniert.

Der Nutzer gab noch an, dass er folgende Fehlermeldung erhält:

Fehlercode: 0x80070035
Der Netzwerkpfad nicht gefunden.

NetworkErr01

Diese Fehlermeldung (siehe obiger Screenshot) hatte ich im Blog-Beitrag Windows 10: Netzwerk zeigt Fehler 0x80070035 bereits im September 2015 behandelt. Damals war ich unter Windows 10 mit diesem Fehler konfrontiert. Irgendwann hat Microsoft ein Update herausgebracht und ab da war Ruhe.

Merkwürdige Fehlermeldung beim SMB-Client

Der Blog-Leser hatte aber weiter geforscht und schrieb mir, dass in der Ereignisanzeige folgende Fehlermeldung beim SMB-Client zu sehen sei:

Fehler bei der Einrichtung einer Netzwerkverbindung.

Fehler: {Gerät-Zeitüberschreitung}
Das Zeitlimit des angegebenen E/A-Vorgangs auf %hs wurde erreicht, bevor der E/A-Vorgang abgeschlossen wurde.

Servername: ACER-NOTEBOOK
Serveradresse: 192.168.4.2:445
Instanzname: \Device\LanmanRedirector
Verbindungstyp: Wsk

Erläuterung:
Dies weist auf ein Problem mit dem zugrunde liegenden Netzwerk- oder Transportprotokoll (z. B. TCP/IP) und nicht auf ein Problem mit SMB hin. Eine Firewall, die den TCP-Port 445 oder 5445 bei Verwendung eines iWARP-RDMA-Adapters blockiert, kann dieses Problem ebenfalls verursachen.

Der Blog-Leser schrieb mir, dass er dazu im Internet recherchiert und mehrfach die Firewall kontrolliert habe. Die Firewalleinstellungen schienen ok, im Internet gab es keine weiterführenden Hinweise.


Anzeige

Der Blog-Leser hatte wohl auch meinen Blog-Beitrag Windows (Netzwerk-) Fehler 0x800704B3, den ich die Tage publiziert habe, gelesen. Dort löste ein fehlendes SMBv1-Protokoll Probleme beim Zugriff auf die Freigaben aus. Dazu schrieb der Nutzer:

Auch habe ich die Windows-Features überprüft und festgestellt, dass auch SMB aktiv ist. Alle anderen Tipps sind ebenfalls überprüft.

Hat das mit Spectre und Meltdown zu tun? Hast Du noch eine Idee, woran es liegen kann, dass ich nicht auf meine eigenen Freigaben zugreifen kann? Wahrscheinlich hat es mit irgendeiner Sicherheitsrichtlinie zu tun, aber mit welcher?

Ad hoc konnte ich ihm nicht weiter helfen, schlug aber vor in Sachen Firewall/Fremdvirenscanner zu forschen und möglicherweise eine VHD-Parallelinstallation von Windows 10 zum Testen zu verwenden.

Gut, ist ein Einzelfall – mir war im Hinterkopf in Erinnerung, dass ich irgendwo in einem Forum auch von Windows 10-Netzwerkproblemen gelesen habe – ich finde diese Fundstelle aber nicht mehr. Und dann gab es noch den Microsoft Answers-Forenbeitrag vom März 2018 hier und diesen Beitrag aus der Windows FAQ. Im englischen MS Answers-Forum gibt es hier Meldungen von Ende Februar 2018. Auch Microsoft hat hier einen KB-Artikel – aber in leicht anderem Kontext.

Was man tun könnte

Bei einem solchen Fehler gibt es einige Sachen, die man vorsichtshalber als erfahrener Anwender probieren könnte.

  • Neben der Deaktivierung von Antivirus- und Firewall-Software (und bei Fremdprodukten ggf. sogar deren Deinstallation), kann man die oben erwähnten SMB-Einstellungen kontrollieren.
  • Man kann in den Geräte-Manager gehen, die Anzeige verborgener Geräte aktivieren und dann veraltete Netzwerkadapter deinstallieren/löschen (siehe auch den Kommentar hier und den Beitrag hier).
  • Man kann die Netzwerkerkennung für Windows aktivieren und die Protokollbindung in den Eigenschaften des Adapters kontrollieren (siehe auch hier).

Aber das ist alles etwas vage und es können Einzelfälle sein. So eine echte Häufung an Meldungen habe ich aber nicht gefunden.

Aktuelle Lösung: Ein Update hat es gefixt

Bevor ich da mit Blog-Leser Michael O. in die Details gehen konnte, kam aber von ihm ein paar Stunden später eine überraschende Antwort:

das Problem hat sich erledigt. Heute Nachmittag kam ein Update rein, und siehe da, es klappt nun wieder. Ich glaube, dass Microsoft da mit einem vorherigen Update einen Bock geschossen hat, der nun wieder bereinigt wurde.

Das ist für den Blog-Leser natürlich ideal, da Problem behoben. Mich macht das aber immer extrem stutzig, da immer das Gefühl ‘war da was’ mitschwingt. Das war der Punkt, wo ich beschlossen habe, das Thema als Info im Blog einzustellen. Oft gibt es ja bei solchen ungeklärten Fällen eine Bestätigung oder einen Hinweis auf die Ursache. Daher meine Frage an euch Blog-Leser: Ist jemandem so etwas auch aufgefallen?

Vermutung: SMBv1 fehlt

Ergänzender Hinweis: Auch wenn sich der obige Fall beim Blog-Leser durch ein Folgeupdate aufgelöst hat, tippe ich auf eine andere Ursache. In Windows 10 wurde ab Version 1709 die Unterstützung für das SMBv1-Protokoll entfernt (siehe Windows 10: Aus für SMBv1 ab Herbst 2017). Auf bestehenden Installationen bleibt das SMBv1-Protokoll installiert, wird aber nach 14 Tagen ohne Benutzung deinstalliert. Möglicherweise hat ein Update das SMBv1-Protokoll entfernt und ein Korrekturupdate fügte die Unterstützung wieder hinzu (siehe Windows 10: Aus für SMBv1 ab Herbst 2017).

Ähnliche Artikel:
Windows 10 Wiki/FAQ
Windows 10-Fehler: Netzwerkprotokoll fehlt – Teil 1
Windows 10-Fehler: Netzwerkprotokoll fehlt – Teil 2
Windows 10-Fehler: Netzwerkprotokoll fehlt – Teil 3
Netzwerkprobleme mit Updates KB4088875 / KB4088878
Windows (Netzwerk-) Fehler 0x800704B3
Netzwerk-Bug in VirtualBox 5.2.4 unter Linux
Windows 10: Aus für SMBv1 ab Herbst 2017
Windows 10 Version 1803: Netzwerksuche/-umgebung leer


Anzeige
Dieser Beitrag wurde unter Netzwerk, Windows 10 abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

22 Antworten zu Windows 10: Netzwerkprobleme durch Updates?


  1. Anzeige
  2. Volko sagt:

    Auf dem Notebook meiner Frau musste ich unter Windows 10 v1709 nach dem März-Update den Druckertreiber für den per LAN angeschlossenen Drucker neu installieren, da alle Druckaufträge ohne Fehlermeldung plötzlich im Nirvana landeten.
    Paradoxerweise war der Drucker aber noch sichtbar und Statusinformationen konnten angezeigt werden.
    Nur die Druckaufträge verschwanden im Nichts … nach der Neuinstallation des Treibers war das Problem unmittelbar behoben.

    ‘Windows as a surprise” eben!

  3. Simon sagt:

    Ach wie schön, habe die letzten Tage ein ähnliches Phänomen festgestellt. Bei meinem Windows 10 Rechner (Domäne) kann ich über den Explorer keinen Server mehr ohne den FQDN erreichen. (also z.B. \\DCxx)
    Dies ging aber bis zum letzten Patchday wunderbar, was aber noch viel verwunderlicher ist das ein Ping auf den besagten DCxx problemlos möglich ist und auch der FQDN: DCxx.domöne.xxx aufgelöst wird.
    Die Dateifreigabe über FQDN funktioniert auch also mit \\DCxx.domäne.xxx also kann es an keiner Firewall Einstellung liegen.

    Heute Abend dann das Zwangs-Update von Microsoft und nach dem neu Start ein “Bluescreen” oder zumindest hieß es früher mal so. Nach einem weiteren neu Start der der von Windows selbst eingeleitet wurde fuhr der PC normal hoch, jedoch ist das Fehlerbild immer noch das selbe……..

    Jetzige Version 1709 Build-Nummer: 16299.309 ich denke vorher war es .248 bin mir aber nicht ganz sicher.

  4. Anzeige

  5. Ah ja mal sehen ob sich dadurch etwas ändert, ich hing bis eben noch auf der 1709 16299.309 da hat mein Rechner schon wieder was verpasst.

    Das Netzwerk Problem besteht bei mir schon seit dem 2ten oder 3ten Update bei der 1709 Version, hab mir dann händisch Verknüpfungen zu meinen Netzlaufwerken angelegt, beim ersten Zugriff am Morgen taucht noch eine Fehlermeldung auf die ich dann Ignoriere beim Zweiten Versuch klappts dann wie es soll.
    Unterumständen sehe ich dann auch Ordnerfreigaben im Netzwerk aber sobald ich den Explorer wieder Schließe und neu öffne muss ich von neuem Anfangen.

    Mittlerweile hab ich mich daran gewöhnt, finde es auch nicht mehr ganz so Tragisch, aber es bleibt nach wie vor ein Fehler.

    • Thomas Bauer sagt:

      Mein Windows 10 findet selbständig die Diskstation, zeigt diese an und verbindet automatisch mit den eingerichteten Netzwerklaufwerken. Es kam mal eine Abfrage ob im Netzwerk gesucht werden soll. Das hatte ich bejaht.

      • der_Puritaner sagt:

        So ich bin nun auch bei 1709 16299.334 angelangt.

        Die Fest hinzugefügten Netzwerklaufwerke findet Windows ja auch ohne Probleme nach jedem Neustart, jedoch gibt es da noch mehr Ordner im Netzwerk die Freigegeben sind, die will ich nicht alle als Netzwerklaufwerk in den Explorer einbinden.

        Was ich meine ist, wenn ich im Explorer auf dem Windows 10 Rechner den Netzwerk Ordner Öffne sehe ich dort nur meinen Eigenen Rechner, ich hab gerade mal ein Screenshot gemacht was das Problem am wohl am besten veranschaulicht https://abload.de/img/netzwerk_pnomenbyshw.png

        • Thomas Bauer sagt:

          So sieht das bei mir aus.
          Ich frage mich nur warum bei mir die FritzBox mehrmals aufgeführt wird? Hast du da eine Idee?

          http://prntscr.com/ivdlgl
          http://prntscr.com/ivdngr

          • Thomas Bauer sagt:

            Hier habe ich noch etwas gefunden, vielleicht löst das dein Problem:

            http://prntscr.com/ivf1h5

          • der_Puritaner sagt:

            Sei doch froh das du drei Frizboxen im Netzwerk siehst, ich hab meinen Router schon seit gut einem halben Jahr nicht mehr im Netzwerk erblickt ;-)

            Nein Spaß bei Seite, keine Ahnung wieso dein Router gleich dreimal im Netzwerk angezeigt wird.

            Das witzige ist ja, wenn ich mit dem Windows 7 Rechner der hier gleich rechts von mir steht ins Netzwerk gehe werden mir alle Netzwerkrechner inkl. der Freigegebenen Ordner Angezeigt. Im Übrigen sind das alles auch keine alten Krücken, sondern Moderne PCs nebenbei läuft in meinem Netzwerk auch noch ein Windows Server 2012 R2 auch der wird nicht angezeigt.
            Die SMB Freigaben funktionieren jedoch ohne Probleme.

            Heute Morgen kam mir da so eine Idee unter Windows 7 gabs mal so einem Möglichkeit einen PC im Netzwerk zu verstecken und trotzdem auf Datenfreigaben zuzugreifen…

  6. Selinger sagt:

    Mal etwas anderes, aber ich finde es passt auch ganz gut hier rein. Wir haben seit ungefähr 2 Wochen ein großes Problem mit Outlook 2013 und 2016. Mails werden via IMAP schlecht syncronisiert. Dann das immer öfter vorkommende einfrieren von Outlook. Erst nichts bei gedacht. Jetzt betrifft es hier aber weit mehr als nur ein System. Folgen sind leere Mails, fehlende Anhänge. Thunderbird kann es aber. Jetzt aber das ganz komische. Dies ist ausschließlich auf HP Rechnern der Fall. Seitens HP gibt es nur Schulterzucken. Auch hier sehe ich Zusammenhänge mit den Windows Updates der letzten Wochen.

    • wufuc_MaD sagt:

      erinnert mich an epson und die zerlegten nadeldrucker ^^
      vielleicht wollte epson nicht sofort mitspielen..
      was hp angeht, die falls man geldscheine scannt und ausdruckt, naja, leicht zu finden auf yt.. oder das “hp spectre” – die keylogger ständig in den treibern, oder die zerschossenen “drive-guards”, einfach genial!
      one-core

      die outlook “probleme” kann ich bestätigen! die haben totsicher einen guten grund!

  7. Thorsten Leuchert sagt:

    KB4089848 habe ich mir manuell heruntergeladen und installiert.
    Outlook nutze ich nicht.
    Mein Drucker ist ein HP C3180, ich habe bis jetzt in jeder Build (kein Insider) KEINE Probleme gehabt

  8. Horst sagt:

    Bei mir lag es an der WORKGROUP / Arbeitsgruppe.
    Hatte einen neuen PC installiert, kam mit diesem auf meine anderen PCs/Freigaben, aber umgekehrt nicht!? PC-Name wurde nicht gefunden, konnte aber das LW verbinden, nur nicht zugreifen (obige FM).
    Letztendlich lag es an der Arbeitsgruppe. Hatte mal den Standard “Workgroup” geändert.
    Eine Workaround wäre es zu prüfen, ob eine Verbindung über die IP-Adresse geht.
    Das war bei mir immer möglich, nur nicht über den Netbiosnamen.

  9. Anzeige

  10. Horst sagt:

    Da der ping noch nicht ging, habe ich weiter geprüft.
    Als ich den PC statt per WLAN mit LAN-Kabel (wie die anderen PCs) verbunden habe, ging auch das Anpingen per Name?! Lag es am Router?
    Nach Reboot des Routers ging WLAN und LAN!

  11. Lucius sagt:

    Windows 10 läuft in einer virtuellen Umgebung in Ubuntu 18.04
    Samba-Freigaben von Windows sind in Ubuntu sichtbar.
    Samba-Freigaben von Ubuntu, Mint, Debian sind in Windows 10 nicht sichtbar.
    Weder im Explorer unter “Netzwerke” noch bei direkter Eingabe des Rechnernamens / IP-Adresse
    SMB 1 als Server und Client ist in W10 aktiviert, die ganzen übrigen Netzwerkeinstellungen sind kontrolliert. Geht trotzdem nicht. Was für ein blamables Betriebssystem. Alle *nix-Rechner kommunizieren problemlos.
    Für Anregungen und Tipps bin ich dankbar.

  12. Uwe sagt:

    Kann ich bestätigen! Sogar noch schlimmer: Habe gestern ein W10pro April Update neu aufgesetzt. Wollte nebenbei die Updates laufen lassen. In meinen kleinen Netz, auch mit W7 PC kam es fast sofort zu Problemen. So wurde auch das Internet massiv gestört. Sobald ich den W10 runtergefahren habe, war alles wieder OK. Reproduzierbar. Uwe

  13. Andreas sagt:

    Ich habe grade das gefühl verarscht zu werden das trifft 1-zu-1 zu.
    Was mich richtig beunruhigt hat, ist das ich in nem avastupdate vom 16.08.2019 eine malware gefunden hab das problemm besteht zwar schon länger und hat soviel wie ich herausgefunden habe mit einer audiodatei zu tun für die windows schon seit langem kein update mehr rausbringt obwohl der support für windows 7 noch nicht eingestellt ist.
    ich könnte mir vorstellen das wenn man das unter windows 10 im komp. ausführt weiter eine sicherheitslücke bleibt. die wie ich glaube gewollt ist

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.