Update KB971033/KB4480960/KB4480970  bricht Windows 7 Aktivierung (0xc004f200)

win7[English]Neuer Tag, neues Problem: Microsoft hat wohl die Nacht das alte Update KB971033 erneut freigegeben. Wie es ausschaut, ist Windows 7 nach Installation des Updates nicht mehr aktiviert und wird als nicht genuine gemeldet. Ergänzung: Es hängt mit dem Windows 7 Januar 2019 Update KB4480960 /KB4480970 zusammen. Ergänzung 2: Microsoft hat die Hintergründe erläutert – es hat mit den beiden hier genannten Updates nichts zu tun, sondern war Koinzidenz. Ursächlich waren KB971033 und Änderungen an den Aktivierungsservern – siehe Hinweise im Text.


Anzeige

Ich bin gerade bei askwoody.com über das Thema gestolpert, wo es Enterprise-Clients mit Windows 7 getroffen hat.

Update KB971033 für Windows 7

Die Beschreibung für Update KB971033 wurde zuletzt am 17. April 2018 aktualisiert und befasst sich mit dem Thema Windows Activation Technologies für Windows 7. Es gibt dort ein neues Aktivierungs-Update, um sicherzustellen, dass Windows 7 aktiviert werden kann.

Update neu ausgerollt, Aktivierung bricht auf Clients

Woody Leonhard schrieb diese Nacht, dass Microsoft aus unbekannten Gründen das Update KB971033 neu freigegeben habe. Seit dem beschweren sich Admins über nicht mehr aktivierte Windows 7-Clients. Auf reddit gibt es diesen Thread, der die Dramatik beschreibt.

PSA: Windows 7 Genuine Advantage – KB971033. Make sure you don’t have it!

Woke up this morning to find a few thousand Windows 7 VDI machines reporting that Windows 7 wasn’t genuine. After much troubleshooting we found that KB971033 (should not have been installed in a KMS environment in the first place) was installed on these machines. Until today having this KB installed hasn’t been an issue, it appears a change to how Microsoft’s activation servers respond to a standard KMS key being sent to them may be to blame.

Removing the update, deleting the KMS cache and activation data from the PC’s and re-activating against KMS resolved the issue.

Beim Thread-Starter waren morgens (also gestern) ein paar tausend Windows 7 VDI-Maschinen zu finden, die berichteten, dass Windows 7 nicht echt sei. Nach vielen Fehlerbehebungen fanden die Leute heraus, dass KB971033 (hätte überhaupt nicht in einer KMS-Umgebung installiert werden dürfen) auf diesen Maschinen installiert war.

Der Thread-Starter schreibt, dass die Installation dieser KB bisher kein Problem war. Es scheint, dass eine Änderung der Reaktion der Aktivierungsserver von Microsoft auf einen Standard-KMS-Schlüssel, der an sie gesendet wird, schuld sein könnte.

Das Entfernen des Updates, das Löschen des KMS-Cache und der Aktivierungsdaten von den PCs und das Reaktivieren gegen KMS haben das Problem behoben. Ein Nutzer hat folgendes Script zum Fixen gepostet:

wusa /uninstall /kb:971033 /quiet
net stop sppsvc /y
del %windir%\system32\7B296FB0-376B-497e-B012-9C450E1B7327-5P-0.C7483456-A289-439d-8115-601632D005A0 /ah
del %windir%\system32\7B296FB0-376B-497e-B012-9C450E1B7327-5P-1.C7483456-A289-439d-8115-601632D005A0 /ah
del %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform\tokens.dat
del %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform\cache\cache.dat
net start sppsvc
cscript %windir%\system32\slmgr.vbs /ipk 33PXH-7Y6KF-2VJC9-XBBR8-HVTHH
cscript %windir%\system32\slmgr.vbs /ato

Ein weiterer reddit.com-Tread hier thematisiert das ebenfalls. Abschließende Frage: Noch jemand von euch betroffen? Ergänzung: Microsoft hat im KB-Artikel 4480960 und 4480970 (für Win 7) den Fehler bestätigt und untersucht das.

Ergänzung: Die Hintergründe


Werbung

Microsoft hat inzwischen die Hintergründe für den Aktivierungsverlust bei volumenlizenzierten Windows 7-Clients erläutert. Es hat mit den beiden Sicherheitsupdates vom 8. Januar 2019 nichts zu tun, sondern war Koinzidenz. Ursächlich waren ein installiertes KB971033 und Änderungen an den Aktivierungsservern. Ich habe die Details im Blog-Beitrag Microsoft erklärt den Windows 7 KMS-Aktivierungsfehler zusammen gefasst.


Anzeige
Dieser Beitrag wurde unter Update, Windows 7 abgelegt und mit , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

43 Responses to Update KB971033/KB4480960/KB4480970  bricht Windows 7 Aktivierung (0xc004f200)

  1. Anonymous sagt:

    auch
    https://support.microsoft.com/en-us/help/4480960
    “After installing this update, some users are reporting the KMS Activation error, “Not Genuine”, 0xc004f200 on Windows 7 devices.”

  2. Markus K sagt:

    Sehe am WSUS KB971033 nicht => sollte bei uns also keine Probleme machen :)

  3. Werbung

  4. Tony sagt:

    KB4480960 hab ich gleich bei all unsere Systeme auf ignore gesetzt.

    KB971033 scheine ich aber, auf über 200 Server sowie 300+ Workstation (davon ca 30% Win7), nicht zu finden. Wurde der KB zurückgezogen?

  5. Hans Thölen sagt:

    Windows 7 Home Premium SP1 32 Bit.
    KB4480960 am 09.01.2019 installiert. KB971033 hatte ich noch nicht auf
    Windows Update. Auch im Update Catalog ist KB971033 nicht vorhanden.
    Mein Windows 7 ist immer noch aktiviert, also noch keine Probleme.

  6. Andreas Zelle sagt:

    Test auf VM mit Windows 7 64 Pro und KMS Aktivierung. Erst KB4480960 installiert, kein Problem aufgetreten. Dann KB971033 installiert, weiterhin kein Problem.

    • Andreas Zelle sagt:

      Zweiter Test auf einer VM mit Windows 7 32 pro (KMS aktiviert)
      Erst KB971033, kein Problem.
      Dann KB4480960 , weiterhin kein Problem.
      Auch die Zugriffe auf 2008R2 Server shares sind weiterhin problemlos.

      Ich würde den Fehler gerne reproduzieren, irgendwelche Tips?

  7. Bruno Kübli sagt:

    Seit gestern Morgen habe ich in zwei getrennten Netzwerken ähnliche Probleme:
    Von den Workstationen sind die gemapten Laufwerke wohl noch sichtbar, jedoch nicht verbunden. Der Server wird über Namensauflösung angesprochen.

    Der Ping über Namensauflösung verläuft ins Leere. Der Ping über die IP-Adresse ist OK.

    Wenn der Server über Namensauflösung oder über IP-Adresse aufgerufen wird, läuft die Suche ins Leere.

    Habe dasselbe per Script versucht. Namensauflösung läuft ins Leere jedoch die IP-Adresse findet den Server und kann mit USE das Laufwerk wieder mappen.

    Im anderen Netzwerk funktioniert auch dies nicht.

    Könnte da wiederum ein altes bekanntes Problem aufgetaucht sein?

    Nach dem Feststellen des Problems wurden bei beiden Geräten, die als Server arbeiten, gesehen, dass kurz vorher ein Microsoft Update gelaufen ist und die Geräte neu gestartet wurden.

    Was hast du Erlebt? Hat jemand einen Lösungsansatz?

  8. Werbung

  9. Max sagt:

    KB4480960 habe ich auch installiert. Bei mir ist das alte Update KB971033 installiert, wurde aber nicht mehr neu angeboten. Windows 7 ist eine OEM Lizenz und ist noch aktiviert. Könnte sein das es nur KMS Clients betrifft?

  10. Hansi sagt:

    Auch eine Möglichkeit, Windows 7 obsolet zu machen. Ich glaube nicht mehr an Inkompetenz oder Zufall, MS macht das mit Absicht, die Dummuser sollen endlich Windows 10 “umarmen” oder embracen, wie man so schön sagt.

    @Günter, mal ne Frage, gibt es sowas wie ein Update Pack für Windows 7, aber ohne den ganzen Telemetrie- und sonstigen Schrott, also “Security Only”? Ich müsste demnächst mal ein neues Windows 7 installieren, da stehe ich vor der Wahl, mein aktuelles System zu klonen und in eine VM zu packen, oder mich mit dem Treiberchaos (alte/neue Treiber) rumzuärgern.

    Von Hand auf einem neu aufgesetzten Windows-7-System nur die Security Only Updates zu installieren, und den ganzen Telemetrie-Krempel zu verhindern, ist halt schon eine Sisyphos-Aufgabe.

    • Seita sagt:

      So ein Win 7 Security only Image hätte ich auch gerne.

      • mike sagt:

        Wer das mit den Downloadlinks von Bolko nicht versteht, die ISOs sind bei mega.nz gehostet, also mega.nz/link

        • Günter Born sagt:

          Bitte tut mir einen Gefallen und lasst direkte mega.nz-Links hier in den Kommentaren weg. Die kann ich nicht auch noch auf Rechtskonformität prüfen. In der obigen Form ist es ok.

          Ansonsten muss jeder selbst entscheiden, ob er eine ISO für ein OS aus nicht MS-Quellen nutzt – womit ich nicht ausführen will, dass die mit Malware gespickt sind. Aber ich erinnere mich an diverse Win 7 ISOs aus Drittquellen, die vor Jahren recht beliebt waren – und irgendwann gab es die kuriosesten Fehlerbilder, speziell bei Updates, weil irgendwo beim ‘optimieren’ bestimmte Servicing Stack-Geschichten gebrochen waren.

          • Bolko sagt:

            Diese Probleme kenne ich und auch aus diesem Grund mache ich mir diese ISO selber, möglichst sauber und ohne Dritt-Tools. Die Scripte zur Erzeugung und die Inhaltsverzeichnisse der Quelle-Ordner liegen dabei.

          • Janami25 sagt:

            Bolko’s Windows 7 Iso’s laufen jedenfalls bei mir einwandfrei, und ich kann sie nur empfehlen.

            Sie sind natürlich inoffiziell, also Installation auf eigene Gefahr. Er macht das aber schon länger, und die Versionen sind von mal zu mal besser. Aktuell läuft bei mir eine auf einem Z370 Mainboard mit Intel Core i7 8700 problemlos.

            Das nur am Rande, wenn man Win7 noch “zuverlässig” laufen haben will, ohne die Schikanen und die schlimmen “Updates” von MS, die mehr Schaden anrichten, als (angebliche) Sicherheit bringen.

            Danke, Bolko. :)

            Sorry wegen OT und das nur am Rande.

    • Günter Born sagt:

      Zur zweiten Frage bin ich überfragt. Ich habe das nie in Detail verfolgt – weil ich aus der Vergangenheit mitbekommen habe, dass solche ‘vorbereiteten Packs’ irgendwann zu Kollateralschäden führten (mein alter Wahlspruch ‘glaube keiner Statistik, die Du nicht selbst gefälscht hast’ trifft es ganz gut).

      • mike sagt:

        Falls mit “vorbereiteten Packs” die Update-Packs von Winfuture oder Dr. Windows gemeint sind, ich habe zwei Windows 7 Installationen gemacht, eine auf AMD und eine auf Intel Hardware. Nach der Installation das Winfuture Updatepack gestartet und danach Windows-Update gemacht bis keine Updates mehr gefunden wurden. Das war 2014, für die übrigen Computer wurden die Installationen geclont, das Zeug läuft noch heute.

    • F. Meyer sagt:

      Was ist denn mit WSUS Offline Update?
      Damit kannst Du dir schnell ein durchgepatchtes System neu aufsetzen. Windows 7 ISO, idealerweise Windows 7 SP1, vorausgesetzt.

      Hierin kannst Du z.B. auch einstellen, ob Du reine Sicherheitsupdates anstelle Monthly Rollups verwenden möchtest. Und noch so einiges mehr.

  11. Bernard sagt:

    Auf unseren Windows 7 Pro-Rechner ist KB971033 gar nicht installiert.

    Privat nutze ich die KMS Setup Keys, um diverse Windows-Versionen zu installieren und zu testen. Diese Keys sind öffentlich und leicht zu finden.

    Vielleicht ist dies Microsoft ein Dorn im Auge?

    • Manuel sagt:

      Kann ich mir ehrlich gesagt nicht vorstellen.
      Werden von MS ja selbst publiziert.
      https://docs.microsoft.com/en-us/windows-server/get-started/kmsclientkeys

      Diese KMS Keys sagen Windows nur das es einen KMS gibt und das der Key von dort gezogen werden soll.

      lg
      Manu

      • Günter Born sagt:

        Sehe ich auch so. Das Ganze ist recht nebulös – aber entweder erreicht die Genuine-Abfrage wegen der Netzwerkprobleme die KMS-Server nicht mehr – oder es ist irgendwo durch die Patcherei was bzgl. der erkannten Schlüssel kaputt gegangen. Da soll Microsoft ran.

        • Hans Thölen sagt:

          Neustart des PCs. Dann mache ich folgendes :
          Rechtsklick ” Computer ” Linksklick ” Eigenschaften ”
          Es kommt die ” Startseite der Systemsteuerung ”
          Ganz unten : Windows – Aktivierung
          Meldung : Status nicht verfügbar.
          Nach ca. 10 Sekunden die Meldung : Windows ist
          aktiviert. Das ist sehr eigenartig.

  12. derTeichfloh sagt:

    Nein, das ist ganz normal.
    Win braucht eine Weile, um seinen Status zu aktualisieren. Bis zu 10min kann es schon dauern…

    • Hans Thölen sagt:

      Hallo derTeichfloh !
      Danke für die Antwort.
      Jetzt bin ich kolossal beruhigt.
      Gruß Hans Thölen

      • Bernard sagt:

        Hallo Hans,

        das habe ich auch schon beobachtet, dass unmittelbar nach dem Systemstart die Meldung kam, Windows 7 sei nicht aktiviert.

        Nach einiger Zeit, so 5 bis 15 Minuten, war es wieder aktiviert.

        Ist komisch. Aber ich persönlich würde dem ganzen eine halbe Stunde Zeit geben und dann erst wieder kontrollieren.

        Vielleicht vorab einmal “sfc /scannow” laufen lassen?

        • Hans Thölen sagt:

          Hallo Bernard !
          sfc/scannow laufen lassen. Ergebnis :
          Der Windows – Ressourcenschutz hat keine
          Integritätsverletzungen gefunden.
          Dank von Hans

  13. Anonymous sagt:

    Activation failures and “not genuine” notifications around January 8, 2019, on volume-licensed Windows 7 KMS clients

    https://support.microsoft.com/en-us/help/4487266/activation-failures-and-not-genuine-notifications-on-vl-win-7-kms-clie

  14. techee sagt:

    Merkwürdig, dass wir hier diesmal nicht betroffen sind. Alle unsere Clients sind KMS aktiviert und die meisten Windows 7. Es ist bisher verdächtig ruhig. Habe die Updates auch nicht am WSUS zurück gezogen bisher.

  15. Ralf Lindemann sagt:

    Es gibt eine Stellungnahme von Microsoft zur Aktivierungsproblematik – Zitat:

    „Der Zeitpunkt dieses Problems fällt mit der Veröffentlichung der Januar-Updates (KB4480960 und KB4480970) zusammen, die am Dienstag, 8. Januar 2019, veröffentlicht wurden. Diese Ereignisse stehen nicht in Verbindung.

    Das Problem wurde auf den Microsoft-Aktivierungs- und Validierungsservern im Backend behoben. Wenn Sie von diesem Problem betroffen sind, folgen Sie den Anweisungen im Knowledge Base-Hilfeartikel KB4487266.“ (Quelle: support.microsoft.com/de-de/help/4480960/windows-server-2008-kb4480960 / Google Übersetzer)

    • Ralf Lindemann sagt:

      Hallo Günter, ich habe erst im Nachgang gesehen, dass du deinen Artikel um diesen Hinweis bereits ergänzt hast. Sorry. Das ist dann wohl auch Koinzidenz …

  16. Schmidi sagt:

    Hallo Leute,
    in unserer Kunden-Umgebung (ca. 100 Clients) haben wir ebenfalls dieses Problem beobachten können. Mit SLMGR.vbs /ato kam immer der Fehler, dass der Client nicht Aktiviert werden konnte. Ich bin dann die letzten Updates nacheinander durchgegangen:
    Nach dem Entfernen von KB4471318, das mit der Aktivierung anscheinend überhaupt nichts zu tun hat, funktioniert die Aktivierung mittels SLMGR.vbs /ato wieder.

    Das Update KB4471318 wurde mit KB4480970 am 04.01.2019 ersetzt, dass bei uns allerdings noch nicht verteilt worden ist.

Schreibe einen Kommentar zu F. Meyer Antworten abbrechen

Deine E-Mail-Adresse wird nicht veröffentlicht.