Windows 10 V1903: Edge kann keine lokalen DNS-Server

[English]Es gibt Berichte, dass der Microsoft Edge-Browser unter Windows 10 Version 1903 keine Webseiten mehr laden kann, wenn ein lokaler DNS-Server verwendet wird. Das Problem zieht sich seit Juni 2019 durch das Technet-Forum, war man per Workaround zu umgehen, klappt aber wohl nicht mehr.


Anzeige

Keine Ahnung, ob das ein weit verbreitetes Problem ist, auf welches ich durch einen Tweet von @PhantomofMobile aufmerksam wurde.

Das Ganze taucht wohl erstmals im Juni 2019 in diesem Technet Foren-Thread auf, wo ein Nutzer sich beschwert, dass er keine lokalen DNS-Auflösungen mehr verwenden kann.

Windows 10 1903 update stopped allowing Edge to open web sites through local DNS servers.

After updating Windows 10 to 1903 Edge will not load web sites. Other browsers continue to work fine. If I change my DNS settings to 8.8.8.8 and 8.8.4.4 Edge will start to work. I need it to work with my local DNS servers (ex. 10.33.44.2) like it used to. Any help would be appreciated. Thank you in advance.

Sobald er einen lokalen DNS-Server angibt, kann der Edge-Browser keine Webseiten mehr abrufen – die DNS-Auflösung funktioniert nicht mehr. Das Komische ist, dass alternative DNS-Einstellungen wie 8.8.8.8 oder 8.8.4.4 dem Edge-Browser wieder den Webseitenabruf ermöglichen. Ein Nutzer bestätigt das und vermutet, dass es mit dem Network Location Awareness-Protokoll zu tun habe. Weitere Nutzer bestätigen diese Probleme.

Workaround: IP Helper-Dienst deaktivieren

Ein Nutzer mit dem Namen Scoobert beschreibt am 13. August 2019 folgenden Workaround:

I started my computer in “Diagnostic Startup” through msconfig. After a reboot Microsoft Edge opened internal and external websites properly. After digging through what services were disable on Diagnostic Startup, I discovered that for our environment if I disable the IP Helper service Microsoft Edge will work properly. My environment does not use IPv6, so I am safe to disable it. Hope this will help others that are having the same issue.

Da er keine IPv6-Adressen benötigt, hat er den IP Helper-Dienst deaktiviert und konnte auch mit dem Edge-Browser wieder lokale DNS-Server verwenden. Ein zweiter Benutzer bestätigte, dass nach einem Neustart sowohl der Edge-Browser als auch der Windows Store wieder arbeiteten.

Workaround hilft nicht immer

Der neue Technet Forentread hier greift das Thema ebenfalls auf. Dort schreiben Betroffene, dass das Deaktivieren des IP Helper-Diensts das Problem nicht mehr löse. Ein Nutzer gibt an, dass die neue Beta-Version von Edge funktioniere – was aber keine Lösung für Produktivumgebungen ist. Ältere Windows 10-Versionen sind übrigens nicht betroffen. Noch jemand, der das Problem bemerkt hat? Ist eine Lösung bekannt?


Anzeige


Dieser Beitrag wurde unter Edge, Windows 10 abgelegt und mit Edge, Windows 10 verschlagwortet. Setze ein Lesezeichen auf den Permalink.

10 Antworten zu Windows 10 V1903: Edge kann keine lokalen DNS-Server


  1. Anzeige
  2. Dat Bundesferkel sagt:

    Ich kann das Verhalten nicht bestätigen. Es werden ausschließlich(!) redundante, lokale DNS Server in meinen Domänen eingesetzt. Ein Testaufruf mittels Edge und dem Aufruf Deiner Seite verlief ohne jegliches Problem. Selbstverständlich ist die gesamte Infrastruktur IPv6 ready.

    Aber davon ab: Edge ist grottig. Jetzt, wo die Engine eh auf Chrome basiert, hat der Browser eine noch geringere Daseinsberechtigung.

    • Tom sagt:

      Das sehe ich anders. Wenn der Edge ohnehin schon auf Chromium basiert, auch noch alle Chrome Plugins verwenden kann und ohnehin schon mit dem Betriebssystem vorinstalliert ist, aus welchem Grund sollte man sich dann noch den Chrome Browser installieren.

      Hinzu kommt, dass man dank IE Mode auch noch definieren kann, welche Seite mit der alten IE Engine aufgerufen werden sollen, ohne dass in einen anderen Browser gewechselt werden muss. Für Enterprise Umgebungen so gesehen der ideale Browser.

      Muss man sich nur noch zwischen Firefox und Edge Chromium entscheiden.

      • leser2 sagt:

        So ist es.
        Der Edge (IE ist tot) wird durch Chromium sicherer – Stichwort Sandbox.

        Da Microsoft alle Google-Dienste entfernt hat, ist er eben nicht unnötig und es stellt sich dann wirklich nur die Frage ob Firefox oder Chromium-Edge.
        Wenn letzterer noch Firefox Zeug wie First-Party-Isolation + Container hätte, wäre er perfekt.

        Chrome ist einfach nur ein Datenschutz-Disaster

    • 1ST1 sagt:

      Hier kann Edge auch interne Webseiten über deren URL darstellen, kein Problem.

  3. HessischerBub sagt:

    Wer eine Domäne hat, hat doch generell ein lokalen DNS-Server, nämlich den der das AD auflöst eingetragen.

    Muss aber sagen, Edge nutze ich in der Firma nicht, wird da also noch niemand jemals aufgefallen sein, wenn intern.firma.loc nicht die Intranet-Site anzeigt.

  4. Anzeige

  5. Toby sagt:

    Weiß nicht, ob es damit zusammenhängt, aber in der aktuellen Edge-Version kann dieser auch keine URLs mit lokalen IPs mehr aufrufen, während alle anderen Browser das hinbekommen (auch IE).
    Woody schreibt hier im Januar sogar schon nen Artikel darüber:
    https://www.computerworld.com/article/3334778/theres-a-newly-acknowledged-edge-local-ip-networking-bug-in-win10.html

    Wir sprechen hier von einem Computer der im AD aufgehängt ist, DNS ist natürlich aus unserem Firmennetz, sollte aber ja bei nem direkten IP-Aufruf aber gar keine Relevanz haben oder?

  6. John sagt:

    Kann ich bestätigen, in unserem AD mit Windows 10 Enterprise (1903) Clients lädt Edge keinerlei Internet-Websites, nur lokales Intranet.

  7. Andreas sagt:

    -Upgrade clients Win 10 von 1809 auf 1909.
    -Anmeldung an lokaler Domain geht. Netzlaufwerke werden verbunden.
    -Am Client ist IPv6 deaktiviert, feste IPv4 mit zwei lokalen DNS Server = Edge hat keine Verbindung zum Internet, IE geht.
    -nslookup gibt DNS Auflösung vom ersten lokalen DNS Server korrekt zurück.
    -Unter Netzwerkverbindungsdetails werden die fest eingetragenen DNS Server nicht mehr angezigt, aber die WINS Server. Bug in der Anzeige?
    -Umstellung von fester IPv4 auf DHCP (es werden nur interne DNS übermittelt vom DHCP Server) = Edge hat wieder Internetverbindung.
    -Wieder feste IPv4 mit den alten Wertenn eintragen – Edge geht immer noch.
    ——-Neustart des clients – Edge geht wieder mit fester IPv4!!!

    Die “fehlende” DNS Anzeige und keine Edge Internetverbindung ist auch bei externen laptops im home-Netzwerk an FritzBox (StdGateway 192.168.178.1) aufgetreten. Dort konnte ich aber bisher o.g. Verhalten noch nicht testen. Hatte dort aus Verzweiflung den Edge-Chromium installiert. Damit ging es dann auch wieder.

    Das könnte auch an einem feature / bug in den Netzwerkeinstellungen liegen!

    Vielleicht kann das Verhalten jemand bestätigen?

    Frohes remote basteln bei euren Kunden & bleibt Gesund!

    • Andreas sagt:

      Nachtrag. Es hielt leider nicht lange vor. Jetzt auch unter DHCP wieder kein Edge Internet Zugriff möglich.

    • Info sagt:

      Ich betreibe hier einen Laptop(Test-Objekt) mit 1909(Stand 2020-03) auf dem DNSCrypt-Proxy Server(extern) die WAN Provider DNS-Server ersetzen. Nur IPV4, IPV6 in den Verbindungen deaktiviert.

      Solange ich keine alternativen DNS-Server für eine Verbindung vergebe braucht eine unbeeinflusste Verbindung lange bis sie funktionsfähig ist – ca. 30 Sekunden, sehr unschön – Was Windows 10 da alles testet versucht bevor es den Zugriff-Status freigibt… (ist möglicherweise wieder der Defender schuld?)

      Ersetzte ich die Standard DNS-Server(DHCP) der Verbindung erhöht sich die Zeit auf >1 Minute..n. Starte ich z.B. den IE gibt es weitere zeitliche Probleme bei DNS-Anfragen, lange nicht möglich…bis es dann irgendwann problemlos funktioniert.

      Grundsätzlich ist das unter Windows 10 ein unerträgliches Problem das es unter Windows 7 eben nicht gab!

      ————————————————-

      Habe allerdings auch Windows, IPV6 und Tunnel-Techniken vorsätzlich deaktiviert(wie problemlos auf W7 Rechnern)!

      >netsh interface 6to4 show state
      IP6-zu-IP4-Dienststatus: disabled
      Rückgängig b.Dienstende: default

      >netsh interface isatap show state
      ISATAP-Status : disabled

      >netsh interface teredo show state
      Typ : disabled
      Servername : win1901.ipv6.microsoft.com.
      Clientaktual.-intervall : 30 Sekunden
      Clientport : unspecified
      Status : offline
      Fehler : Keiner

      Was mir bisher nach jedem “Patchday” auffiel, werden nach dem ersten Neustart die XBox Server versucht zu verbinden – die verwenden teilweise Teredo-Tunneltechniken – das funktioniert natürlich nicht. Die XBox Task verbleiben aktiv im Taskmanager – obwohl die APPs in den Einstellungen keine Funktion aktiviert haben und auch nicht als Hintergrund-APP definiert wurden. Windows 10 eben – nervt nur.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Hinweis: Bitte beachtet die Regeln zum Kommentieren im Blog (Erstkommentare und Verlinktes landet in der Moderation, gebe ich alle paar Stunden frei, SEO-Posts/SPAM lösche ich rigoros). Kommentare abseits des Themas bitte unter Diskussion.