HPE Proliant DL360 Gen9: Oktober 2020-Update wirft BlueScreen bei Windows Server 2019

[English]Kurze Information von Administratoren von HPE Proliant-Systemen, auf denen Windows Server 2019 (oder Windows Server 2016) läuft. Wirft das System einen Blue-Screen SYSTEM THREAD EXEPTION NOT HANDLED, sobald das Sicherheitsupdate von Oktober 2020 installiert wurde?


Anzeige

Eine Benutzermeldung auf Twitter

Auf Twitter erreichte mich gestern Nachmittag eine Information von Andreas Exner, der in einer Laborumgebung zwei Windows Server 2019-Installation für Testzwecke betreibt.

Blue-Screen SYSTEM THRED EXEPTION NOT HANDLED
(Blue-Screen SYSTEM THRED EXEPTION NOT HANDLED)

Auf beiden Testmaschinen löst das kumulative Update KB4577668  (oder KB4577671, siehe Patchday: Windows 10-Updates (13. Oktober 2020), Andreas hat nicht angegeben, welches Update installiert wurde) einen Blue-Screen SYSTEM THREAD EXEPTION NOT HANDLED aus. Die Windows Server 2019-Installationen laufen auf zwei HPE Proliant DL360 Gen9-Maschinen. Das neueste Service Pack for Proliant (SPP) ist laut Andreas auf den Maschinen installiert. Ich hatte noch auf das Thema HP Sure Click Enterprise und Bromium Secure Platform hingewiesen – was aber bei Servern eher nicht zum Einsatz gelangt. Andreas hat mir darauf noch die folgende Information zukommen lassen:

Hallo Günter, nein nichts von dem [gemeint ist ist Sure Click Enterprise und Bromium Secure Platform ] auf den Maschinen. Diese waren einen Tag vor dem patchday frisch installiert und überstanden jeden Neustart. Nach dem Update liefen die Maschinen bis zum nächsten Neustart. Dann gab es den bluescreen. Ich hatte gestern beide Server neu aufgesetzt und noch kein Update durchgeführt. Neustarts kein Problem. Auch das neue SPP brachte keine Besserung. Nach dem patchen ein Neustart und wieder bluescreen.

An dieser Stelle die Frage: Noch jemand von diesem BlueScreen auf HPE Proliant DL360 Gen9-Maschinen und Windows Server betroffen?

Ursache des Stop-Fehlers eingrenzen

Der Stop-Fehler (BSOD) SYSTEM THREAD EXEPTION NOT HANDLED deutet meist auf ein Problem mit einem Treiber hin. Dazu fallen mir zwei Sachen ein:

  • Die Oktober 2020-Updates für Windows 10 und die Server Pendants erfordern signierte Treiber. Möglicherweise spielt dort etwas mir rein.
  • Es kann sein, dass die Aktualisierung mit dem Oktober 2020-Update einen älteren HP-Treiber(WLAN, Grafikkarte)  auf’s Kreuz legt.

Hier bleibt ggf. nur der Versuch, herauszufinden, an welchem Treiber es liegt. Man könnte in der Ereignisanzeige nachsehen, ob dort noch was vermeldet ist. Zudem besteht die Möglichkeit, die Mini-Dumps mit Tools wie BlueScreenView von Nirsoft auszuwerten. Mit etwas Glück findet sich dort die Quelle des BSOD. Ich hatte vor langer Zeit im Blog-Beitrag Windows BlueScreen-Analyse – Teil 3 skizziert.


Anzeige


Dieser Beitrag wurde unter Störung, Update, Windows 10, Windows Server abgelegt und mit Patchday 10.2020, Problem, Update, Windows Server 2019 verschlagwortet. Setze ein Lesezeichen auf den Permalink.

12 Antworten zu HPE Proliant DL360 Gen9: Oktober 2020-Update wirft BlueScreen bei Windows Server 2019


  1. Anzeige
  2. Blackii sagt:

    Ich hatte gestern ein Lenovo Lifebook Maybe 557 vor mir.
    Das startet immer mit einem Bluescreen SYSTEM THREAD EXEPTION NOT HANDLED. In dem Falle lag es aber an Avira Antivir. Das Programm hatte sich aus irgendwelchen Gründen zerschossen und konnte nicht mehr starten.

    Schreibe das nur, weil der Zeitpunkt sich ähnelt. Das war aber ein Windows 10 1903 mit Sicherheitsupdate von Oktober.

  3. Stephan G sagt:

    Ich nehme auch an, dass es mit veralteten Treibern zu tun hat.
    Sonst wäre das Internet mittlerweile voll mit Meldungen.

    Sicherheitshalber warte ich aber noch ab bis ich irgendwelche Produktivmaschinen patche.

  4. Anzeige

  5. Der JEG sagt:

    Danke für die Hinweise. Ich administriere über 100 HPE Server, davon allerdings nur ein kleiner Teil mit Windows Server.

    Sicher, dass es das Update KB4577671 ist? Das ist doch eigentlich gar nicht für den “normalen” Server 2019 (OS Build 17763.XXXX) welcher auf 1809 basiert vorgesehen.

    Mit BlueScreenView von Nirsoft habe ich keine so guten Erfahrungen. Die Ergebnisse sind teilweise recht ungenau. Ich benutze neuerdings die “WinDbg Preview” App aus dem Microsoft Store. Die ist nicht so kompliziert zu installieren und einzurichten wie der alte WinDbg und liefert ganz brauchbare Ergebnisse.

    • Günter Born sagt:

      Die KB des Update hatte ich auf Grund der Angaben Server 2019 ergänzt- kam nicht vom ursprünglichen Poster. Möglicherweise mein Fehler – hab da was ergänzt.

      Zu BlueScreenView: Es ist ein 50:50-Spiel, ob man den Hinweis auf den beteiligten Treiber bekommt. Optimaler ist WinDbg und ein Full Dump – aber nicht jeder wird sich diese Umgebung einrichten wollen. Ich habe die Store-Version von WinDbg nicht mehr verfolgt – aber zu Beginn war diese buggy bis zum Abwinken.

  6. Andreas sagt:

    Folgende Updates zeigt mir mein Patch Management für die frisch installierten Server an:
    Windows Malicious Software Removal Tool x64 – v5.83 (KB890830)(Win8Win10201220162019)
    2020-10 Cumulative Update for .NET Framework for Windows Server 2019 for x64 (KB4579976)
    2020-10 Cumulative Update for Windows Server 2019 x64 (KB4577668)
    2020-10 Security Update for Adobe Flash Player for Windows Server 2019 x64 (KB4580325)
    2020-10 Servicing Stack Update for Windows Server 2019 x64 (KB4577667)

    Wenn ich nachher Vor Ort bin, werde ich das mal weiter prüfen. Ich kam bisher leider noch nicht dazu.

  7. Michael sagt:

    Hier auf mehreren DL380G9 & G10 mit Server 2019 keinerlei Probleme bisher.
    Aktuelles SPP 2020.9 mit den Treibern die sich im ISO befinden wurde davor eingespielt.
    Eventuell spießt sicht was wenn man manuell oder mit einem Patch-Management abweichende verwendet?

  8. Der JEG sagt:

    Ich habe hier zumindest mal einen BL460c Gen9 mit aktuellem HPE SPP 2020.09.0 und den aktuellen Windows Server 2016 Patches vom Oktober (OS Build 14393.3986). Der Server läuft seit der Neu-Installation gestern nun seit über einem Tag ohne Probleme.

    An einem HPE DL380 Gen9 ist das HPE SPP bereits installiert. Da stehen die Oktober Patches für Server 2019 allerdings noch aus. Wie schnell und oft kommt es denn da zum BSOD?

  9. Anzeige

  10. Andreas sagt:

    Also ich kann das Problem jetzt soweit eingrenzen.
    Das Verhalten mit dem Bluescreen ist auch ohne das Updaten reproduzierbar.
    Es scheint an MPIO und iSCSI zu liegen.
    Sowie ich MPIO und iSCSI aktiviere und die Maschinen neu starte, bekomme ich den BlueScreen.
    Da ich beides immer in einem Abwasch erledigt habe, dachte ich dass es mit dem letzten Update zusammenhängt.
    Also Entwarnung was das einspielen des Cumulative Updates (KB4577668) angeht.
    Aber vielleicht hat ja jemand einen Rat was das eigentliche Problem angeht?

    • Martin Feuerstein sagt:

      Ich hatte zuletzt BSODs/Hard Resets nach Wechsel der Grafikkarte (GTX 1060 zu RTX 2070 Super auf gleichem Board) – hier war das aktivierte ASPM ein Problem. Vielleicht ist das Problem ähnlich gelagert und es hilft, solche “Spielereien” im BIOS zu deaktivieren?

  11. Andreas sagt:

    Noch ein Nachtrag.
    Günter, ich habe jetzt den Dump mit nirsoft angesehen. angeblich ist die vmswitch.sys das Problem. Ja ich habe auch einen SET Switch über 2 Dual 10GB HPE 530SFP+ konfiguriert. Ich bin der Meinung dass erst das installieren von mpio und das aktivieren von MSiSCSI beim nächsten Neustart zum BSOD führt. Ich werde das weiter analysieren.

  12. Wüsten-Nomade sagt:

    D.h. du hast den BSOD jedesmal sofort beim normalen booten, aber nicht beim Safe Mode?

    D.h. du hast einfach “MPIO und iSCSI” beendet/deinstalliert (im safemode) und das Problem war sofort weg?

  13. Andreas sagt:

    Das Problem war folgendes:
    Ich hatte bisher über New-VMSwitch -Name SETvSwitch -NetAdapterName “10G-01-01″,”10G-01-02” -EnableEmbeddedTeaming $true -AllowManagementOS $false eine SET Switch angelegt. jetzt hatte ich aber 2 Dual Adapter. einmal einen 530FLR SFP+ und eine normale 530 SFP+. Vorraussetzung für SET Switch sind gleiche Adapter. Beide haben auch den gleichen Chipsatz aber irgendwie scheint das trotzdem zum Bluescreen geführt zu haben. Ich habe jetzt über New-NetLbfoTeam -Name “SET-Team” -TeamNicName “SET-Team” -TeamMembers “10G-01-01″,”10G-01-02″,”10G-02-01″,”10G-02-02” -TeamingMode SwitchIndependent -LoadBalancingAlgorithm Dynamic -Confirm:$false und dann New-VMSwitch -Name “SETvSwitch” -NetAdapterName “SET-Team” -AllowManagementOS $false konfiguriert und die Probleme mit dem Bluescreen sind weg. Grüße

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Hinweis: Bitte beachtet die Regeln zum Kommentieren im Blog (Erstkommentare und Verlinktes landet in der Moderation, gebe ich alle paar Stunden frei, SEO-Posts/SPAM lösche ich rigoros). Kommentare abseits des Themas bitte unter Diskussion.