Windows 10 V 1511: Vorsicht vor Add-AppxPackage

Wer Windows 10 in der Version 1511 (November Update) einsetzt, sollte sich den PowerShell-Befehle zur Neuregistrierung von Apps verkneifen, da dieser nicht mehr wie erwartet funktioniert. Mir ist ein merkwürdiger Effekt aufgefallen, den ich hier mal dokumentiere.


Werbung



Ich bin nach Installation der Build 10586 der Insider Preview in das Problem gelaufen. Nachdem Cortana nicht mehr sauber funktionierte, habe ich den in folgenden Blog-Beiträgen:

Windows 10: Startmenü Troubleshooting
Windows 10: Store liefert Error 0x80070002
Windows 10: Einstellungen-App stürzt ab – und ein Fix-Tool
Windows 10: Der Fluch des App-Store (Fehler 0x803F7003)

oder hier bei deskmodder.de sowie z.B. in diesem MS Forenbeitrag vom Microsoft-Support genannten PowerShell-Befehl:

$manifest = (Get-AppxPackage Microsoft.WindowsStore).InstallLocation + ‘\AppxManifest.xml’ ; Add-AppxPackage -DisableDevelopmentMode -Register $manifest

ausgeführt. Hätte ich nun besser nicht tun sollen. Ähnlich wie in diesem MS Forenbeitrag erwähnt, bekam ich im PowerShell-Fenster zwar angezeigt, dass der Befehl ausgeführt wird. Aber es gab eine Fehlermeldung, die ähnlich wie im Forenbeitrag dokumentiert aussah.

Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could not be registered.
Merge Failure : error 0x80070003 : Cannot register the Microsoft.WindowsStore_2015.23.23.0_x64__8wekyb3d8bbwe package because there was a merge failure with the following file: C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.23.23.0_neutral_split.scale-125_8wekyb3d8bbwe\resources.pri

Hätte mich jetzt nicht wirklich gekratzt. Aber die böse Überraschung kam beim Öffnen des Startmenüs. Eine Reihe von App-Kacheln zeigten nicht mehr den Titel und das Logo, sondern nur noch den Text @(Microsoft ….) wie in folgendem Screenshot zu sehen.

Offenbar ist da kräftig was schief gegangen. Und ich bin wohl nicht der Einzige, der das bei der Windows 10 Build 10586 (Version 1511) festgestellt hat. Im bereits erwähnten MS Forenbeitrag beklagt sich jemand über den Fehler – und auch hier im Kommentarbereich habe ich diesen Hinweis in die gleiche Richtung gedeutet. In einer Leser-Mail deutet anthropos das gleiche an.

(Ich wagte noch nicht, es abermals auszuprobieren, ohne Sicherung werde ich es sicher nicht wieder probieren; also, ein PowerShell-Befehl führte dazu, dass meine Universal Apps allesamt unbenutzbar wurden und ihre Namen nur noch folgendes Format hatten: @{xxx}, wobei xxx der Name des Ordners ist, worin die Universal App gespeichert ist; der betreffende Befehl lautet:


Werbung

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

Zu diesem Befehl wurde mir auch beim Support-Chat geraten, was zur Folge hatte, dass ich nichts mehr mit den Apps anfangen konnte, und mein Anruf beim Support, der mir ebenso nahegelegt wurde, endete dann dadurch, dass ich nicht mehr den Store zum Probieren öffnen konnte.)

Im Vergleich zu meinen obigen Ansätzen wird der Befehl auf alle Benutzerkonten angewendet – und damit sind alle Apps wohl ruiniert. Also: Finger weg von den PowerShell-Befehlen, bis das Thema geklärt ist. Oder hat jemand andere Erfahrungen gemacht bzw. eine funktionierende Variante gefunden?


Werbung

Dieser Beitrag wurde unter App, Windows 10 abgelegt und mit , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

8 Kommentare zu Windows 10 V 1511: Vorsicht vor Add-AppxPackage

  1. Tim sagt:

    Meine Variante: Finger weg von dem App Geraffel. Sogar das Startmenü als App stört Teilweise unter Vollbildanwendungen, wie Spielen, durch spontanen entzug des Mausfokus.
    Durch ein Classic Menü ersetzt läufts dann wunderbar störungsfrei…

    Was Store und Universal Apps angeht, sitzen derzeit offenbar die falschen Leute bei MS am Ruder. Da wird nur zusammengepfuscht, das wird nix mehr. Ich seh da jedenfalls keine HighLights auftauchen und immer mehr Leute werden davon abgeschreckt, den Kram überhaupt zu nutzen.

    Interessant ist Windows 10 wirklich nur für bisher eine Hand voll Spiele, die da drauf besser laufen. Ansonsten kann man jedem nur raten noch bis Juni (oder wann läuft das gratis Wechsel Angebot aus?) auf seinem alten Vista bis 8.1 zu verweilen. Windows 10 braucht noch einige Brutpflege.

  2. Ralf sagt:

    Das gleiche Problem beim Store. Damit habe ich mir am Montag die Store-App zerstört. (Und nur durch Restore der Sicherung vom Sonntag wieder zum Laufen bekommen.)

  3. anthropos sagt:

    Ich bekenne mich zu den Universal Apps.
    Es wäre nur wünschenswert, dass sie gut gepflegt würden, das begreift auch das System, worin sie werkeln, damit alle Abläufe reibungslos vonstattengehen, was wieder mal nicht der Fall ist.

    Ich schüttle nur den Kopf darüber, wie manche Leute Apps einfach nur nicht mögen, weil es Apps sind, wobei sich rein gar nichts ändert für den Endnutzer, außer dass er nicht so einfach in den Ordnern der Apps herumstochern kann wie bei herkömmlichen Programmen.
    Der ausschlaggebende Vorteil von Apps ist für mich, dass sie keinen Zugriff haben auf das weitere System und auch nicht unter AppData Rückstände hinterlassen und beschränkt sind auf ihren Ordner.
    Zudem lassen sie sich leichter installieren, solange man nicht einen Sammelordner anlegt, wo man (wie ich) die Installationen für herkömmliche Programme speichert, wobei man dann selber die Installationen aktuell halten muss, was bei Apps der Store übernimmt. Dass man immer erst Netz haben muss, um an sie zu kommen, ist ein Übel, was heutzutage allgegenwärtig ist.

  4. Jan sagt:

    Danke für den Beitrag, der mein ebenfalls vorhandenes Problem genau beschreibt.

    Ich selber hatte den PowerShell Befehl angewandt, um das Startmenü wieder zum aufklappen zu bewegen..

    Bin gespannt ob und wann ein Lösungsweg für die Universal Apps kommen :-/

    LG

  5. Pingback: Anonymous

  6. Markus sagt:

    Das gleiche Problem liegt bei mir auch vor. Hat einer von euch dazu eine Lösung?

    Ich verfolge aufmerksam diesen Post, aber leider wird da auch keinem geholfen:

    http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_store/troubleshooting-windows-10-pc-metro-apps-not/29fb735f-1511-442a-a1c7-eb081e7524d9

  7. Ralf sagt:

    Habe alle möglichen Befehle ausgeführt die diesen Fehler beheben sollten.
    Das Ergebnis: NULL, nur viel zeit verschwendet.
    Auch hoch gelobte Freeware kann das Problem nicht lösen.
    Zurücksetzen wird verweigert
    Eine neue installation wird verweigert, mit der Meldung das setup. exe fehlt.
    Obwohl ich das ISO über einen anderen Rechner runtergeladen habe und sich auf anderen Problemlos installieren lässt.
    Da hatte irgendjemand eine Super Idee, nur das sie nicht funktioniert und anscheinend nicht zu korrigieren ist.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.