Outlook 2010: Vorgang wegen Beschränkungen abgebrochen

Anwender haben gelegentlich mit Microsoft Outlook das Problem, dass sich Links in Nachrichten nicht mehr anklicken lassen. Das Programm meldet “Vorgang wurde wegen Beschränkungen auf dem Computer abgebrochen. Bitte wenden Sie sich an Ihren Administrator.”


Anzeige

Ganz schön blöd, wenn der Anwender selbst Administrator ist – oder unter Windows 7 Home Premium werkelt, wo eigentlich keine Gruppenrichtlinien zum Vereinbaren von Softwareeinschränkungen per gpedit.msc unterstützt werden.

Ursache: Kaputte Registrierungseinträge

Der “Fehler” ist bereits aus früheren MS Outlook-Versionen bekannt und hat im Grunde nichts mit MS Outlook zu tun. Ursache ist eine beschädigte Konfiguration der Interneteinstellungen. Der Schlüssel HKEY_Local_Machine\Software\Classes\htmlfile\shell\open\command fehlt oder ist beschädigt bzw. überschrieben. Microsoft hat unter [4] einen Knowledgebase-Artikel veröffentlicht, der auch für Windows 7/Microsoft Outlook 2010 gilt.

Meist tritt der Fehler als Folge der Installation (und Deinstallation) eines zusätzlichen Browsers (z. B. Avant-Browser) auf. Dann wird im Unterschlüssel command der Wert “C:\Program Files (x86)\Internet Explorer\iexplore.exe” –nohome durch den installierten Browser überschrieben. Hintergrund ist, dass dieser Browser sich als Standardbrowser einträgt. Kollateralschaden ist dabei, dass Microsoft Outlook aber auf den Internet Explorer als Client angewiesen ist, da die alternativen Browser i. d. R. nicht die benötigte Funktionalität bereitstellen.

Abhilfe mit wenigen Mausklicks

Die fehlerhaften Registrierungseinstellungen lassen sich von jedem Anwender ohne tiefergehende Kenntnisse unter Windows 7 mit ein paar Mausklicks restaurieren.

  1. Starten Sie den Internet Explorer 8 und wählen Sie in der Symbolleiste die Menüschaltfläche Extras.
  2. Klicken Sie im geöffneten Menü auf den Befehl Internetoptionen.
  3. Klicken Sie auf der Registerkarte Erweitert des Eigenschaftenfensters Internetoptionen auf die Schaltfläche Zurücksetzen.

Mit diesem Schritt werden leider die Einstellungen des Internet Explorer 8 zurückgesetzt (siehe auch Diskussion unter [3]). Nach dem Schließen des Eigenschaftenfenster über die OK-Schaltfläche sollte das Problem nach einem Neustart von Microsoft Outlook aber behoben sein.


Werbung

Ansatz klappt nicht/Interneteinstellungen sollen erhalten bleiben


Anzeige

Falls der obige Ansatz nicht funktioniert oder Sie die Interneteinstellungen erhalten müssen und das Zurücksetzen des IE unbedingt vermeiden möchten, tragen Sie den oben erwähnten Wert:

C:\Program Files (x86)\Internet Explorer\iexplore.exe” –nohome

per Hand in command ein. In [2 bzw. 4] finden Sie bei Bedarf Hinweise, um den beschädigten Registrierungseintrag direkt durch einen Eingriff per Regedit.exe zu reparieren.

Wenn der Schlüssel htmlfile komplett fehlt

Es gibt wohl Fälle, wo Anwendungen den kompletten Schlüssel löschen. In diesem Fall (wenn Sie den Sachverhalt mehrfach verifiziert haben), können Sie die Registrierungseinstellungen importieren.

  • Laden Sie sich die Datei html-file.zip  herunter, speichern Sie diese in einen lokalen Ordner und entpacken das Archiv.
  • Rufen Sie regedit.exe über Als Administrator ausführen mit administrativen Berechtigungen auf.
  • Öffnen Sie das Menü Datei wählen Sie den Befehl Importieren und lassen Sie die Datei html-file.reg importieren.

Spätestens nach dem nächsten Neustart sollte das Problem behoben sein. Unter [4] hat Microsoft noch einen KB-Artikel samt FixIt-Lösung zum Thema bereitgestellt.

Nachtrag: Falls der Import der html-file.reg nichts bringt, empfiehlt sich der Besuch der Webseite unter [7]. Dort werden ebenfalls zwei .reg-Dateien für 32-/64-Bit-Windows zum Reparieren angeboten.

Last Aid: Internet Explorer neu registrieren

Sollte die Installation des Internet Explorer so stark beschädigt sein, dass die obigen Methoden nichts bewirken, empfiehlt sich eine Neuregistrierung der IE-Komponenten. Geben Sie cmd im Suchfeld des Startmenüs ein und drücken Sie die Tastenkombination Alt+Strg+Eingabe. Dies öffnet die Eingabeaufforderung mit administrativen Berechtigungen.

Anschließend verwenden Sie (gemäß [5]) folgende Befehlssequenz zur Neuregistrierung der betroffenen IE-Komponenten:

regsvr32 urlmon.dll
regsvr32 shell32.dll
regsvr32 actxprxy.dll
regsvr32 jscript.dll
regsvr32 vbscript.dll

Danach kann die Eingabeaufforderung geschlossen werden.

Anmerkung: Der Ansatz sollte nicht nur für MS Outlook 2010 sondern auch für andere Mail-Clients funktionieren. Allerdings helfen die obigen Maßnahmen nicht, falls der Mail-Client aus anderen Gründen Probleme mit Links hat. Neben einem zu Windows 7 nicht kompatiblen MS Outlook 2000/2002 (welches wohl generell nicht läuft,, siehe [6]) kann ggf. auch eine Security-Suite den Aufruf der Komponenten bei Anwahl eines Hyperlinks blockieren. Hier empfiehlt sich die versuchsweise Deinstallation der Security-Suite.

Nachtrag: Inzwischen gibt es bei Microsoft einen Supportbeitrag, der die obigen Fixes für diverse Outlook-Versionen beschreibt.

Weiterführende Links:
[1] Microsoft-Foreneintrag
[2] Lösung in MS Outlook FAQ
[3] Diskussion bei Office-Lösungen
[4] Microsoft Knowledge-Base-Artikel
[5] Microsoft-Foreneintrag II
[6] Office-Themen im Blog
[7] Problemlösung von MS-Outlook-Info


Microsoft Office 2010-Titel

(c) by Günter Born www.borncity.de
The source of smart computer books


Anzeige

Dieser Beitrag wurde unter Internet Explorer, Mail, Microsoft Office 2010, Microsoft Office/OpenOffice, Problemlösung abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

18 Antworten zu Outlook 2010: Vorgang wegen Beschränkungen abgebrochen


  1. Anzeige
  2. Volker sagt:

    Vielen Dank, der Artikel war meine Rettung. Als Firefox-Nutzer musste ich allerdings den Internet Explorer kurz als Standard-Browser festlegen. Nur so hat die beschriebene “Abhilfe mit wenigen Mausklicks” funktioniert… Danke!

  3. Gert sagt:

    Nur ein kleiner HInweis als langjähriger Avant Browser Nutzer, bei diesem habe ich den Effekt nicht feststellen können, gerade nochmal verifiziert. Man liest aber in diversen MS-Foren von Chrome und Opera als Verursacher und findet Tipps bzgl. weiterer Schlüssel, die durch diese Browser verstellt sein können. Betrifft damit wohl vor allem solche, die selbst als Mail Client dienen können.

  4. Anzeige

  5. Rainer sagt:

    im Artikel fehlt der Hinweis, dass in “HKEY_CLASSES_ROOT \.html” der Wert “htmlfile” eingetragen sein muss. Gerade der hat mir gefehlt.
    Und der fehlt leider auch im html-file.reg

    Nur der Hinweis zu 4 http://support.microsoft.com/default.aspx?scid=kb%3bde%3b310049&Product=ol10kbGer hat’s dann gebracht.

  6. Günter Born sagt:

    @Rainer: Danke für’s Feedback – ich habe es korrigiert.

  7. Volker Wenning sagt:

    Vielen Dank für diesen Artikel.
    Das hat mir viel Mühe erspart; die grauen Haare habe ich schon.
    Viele Grüße
    Volker

  8. Ulrich sagt:

    Vielen Dank,
    der Artikel hat mir geholfen, die Links zu reparieren. Habe den Microasoft Knowledge Base Artikel (siehe oben Anmerkung 4: http://support.microsoft.com/default.aspx?scid=kb%3bde%3b310049&Product=ol10kbGer) aufgerufen und “Problem automatisch beheben” gewählt (mit Download eines Microsoft Fix-It-Programms). Nach einem Neustart von Windows 7 funktionierte alles wieder wie gewohnt! Super, hätte ich nie alleine hingekriegt, zumal die Hilfefunktion von Microsoft nicht wirklich weiterhilft.
    Übrigens: Ich verwende Windows 7 Ultimate + Office 2010 Professional + Internet Explorer 9

  9. Anzeige

  10. gborn sagt:

    Nachtrag: Unter [1] findet sich ein Diskussionsthread im Microsoft Office-Forum, der ebenfalls auf die Thematik eingeht. Marco Seefeld beschreibt dort einen ähnlichen Ansatz, wobei er eine Reihe an Dateiverknüpfungen reparieren lässt. Vielleicht hilft es weiter, falls die obigen Ansätze nicht hinhauen.

    1: http://answers.microsoft.com/de-de/office/forum/office_2007-outlook/hyperlinks-in-outlook-2007-funktionieren-nicht/fced8433-7c2d-4575-9457-52d418442151

  11. Peter Liebe sagt:

    Hallo,

    ich habe den Hinweis auf diese Seite von meinem Lieferanten von Office 2010 erhalten.
    Bei mir ist das Problem mit Windows 7, Office 2010, 32 bit und Int Explorer 9 aufgetreten nachdem ich Mozilla Firefox deinstalliert hatte.
    Das erste Problem war dass ich Firefox nixht wieder downloaden und installieren konnte. Es kam eine ähnliche Meldung wie im link, ich sollte auswählen ob “die Installation unter dem aktuellen user oder als administrator erfolgen sollte” aber es funktionierte nichts (ich bin der einzige user).
    Der erste Lösungsansatz (Int Expl) zurücksetzen war efolglos.
    Als zweiten Ansatz habe ich Hinweis (4) benutzt und von Windows den “Fix it automatisch” download benutzt.
    Das hat funktioniert.
    Ich hoffe dass meine Kommentare hoílfreich sind für andere mit ähnlichen Problemen.

    Danke und mfg Peter Liebe

  12. Beki sagt:

    Vielen dank an Ulrich, so habe ich mein problem auch gelöst, ist am einfachsten.

  13. Alex sagt:

    Sehr cool. Der FixIt unter 4. hat es gebracht!

    DANKE!

  14. 1210leo sagt:

    Herzlichen Dank an GBorn! FixIt 4 war die Lösung.

  15. USIX sagt:

    Hallo zusammen….
    alles vorbeschriebene hat mir nichts geholfen….
    Aber bei meinem Rechner WIN XP Office 10 half die Neu Installation des IE 8.
    Einfach auf die Homepage von MICROSOFT gehen (seit 27.09.12 gibts ja auch den BUCKfix LÜCKE) und IE 8 neu installieren.
    UND siehe da alles geht wieder…;-D

    Link: http://windows.microsoft.com/de-DE/internet-explorer/downloads/ie-8

    Sprache und Sytem auswählen downloaden und den Rechner arbeiten lassen.

    Bei mir hat es geklappt… ;-D

  16. Pingback: [BLOCKED BY STBV] Link in einer Email funktioniert nicht ?? Outlook 2010 /

  17. Soffi sagt:

    wenn Datei Zuweisungen kaputt gehen, muss man auch nicht gleich unbedingt bei der registry rumschrauben. Bei hat es auch so funktioniert, indem ich die kaputt gegangen Dateizuweisungen so geändert habe: Systemsteuerung -> Standardprogramme-> Dateityp oder Protokoll einem Programm zuordnen

    Dort habe ich dann alle wesentlichen Dateien Internet Explorer zugewiesen. Danach waren auch wieder die Fehlermeldungen weg -> ich hatte Firefox deinstalliert und IE9 als Standard eingestellt dadurch wurden einfach nur Dateizuweisungen kaputt gemacht und einíges war noch Firefox zugewiesen, jedoch musste ich lange danach suchen, da die Fehlermeldungen in Outlook und beim öffnen eines html files nicht wirklich darauf hindeuteten. Jedenfalls hat das einstellen der Dateitypen meine Fehlermeldungen verschwinden lassen und alles funktionsfähig gemacht :D

    Standardmäßig sind folgende Dateien IE 9 zugewiesen:
    .gif
    .htm
    .html
    .mfp
    .mht
    .mhtml
    .partial
    .svg
    .website
    .xevgenxhml
    .xht
    .xhtml
    .xrm-ms
    .xsl

    Protokolle:
    FTP
    HTTP
    HTTPS

    Ich hoffe das kann euch auch weiterhelfen.

  18. Günter Born sagt:

    Danke für die Info.

  19. Pingback: Links in Mails (Outlook 2019) nicht mehr verwendbar

  20. Richard Wolf sagt:

    Im besten Sinne von: (nach Internetzeitaltern gemessen) “Alt, aber gut!”…ach was: Hervorragend!
    Vielen Dank für diese Lösung – ich wäre nie daruf gekommen, dass dies (wohl) im Zusammenhang mit meinen Browsern stehen könnte (kann leider nicht beitragen welcher, da ich turnusmäßig alle gleichzeitig auf den neuesten Stand bringe).

    Damit andere Suchende gerne sehen, dass dies erstklasssige Unterstützung immer noch aktuell ist, lasse ich gerne einen Kommentar hier.

    Besten Dank!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.