WMI-Fehler 0x80041003 mit ID 10

Da ich momentan von einem seltsamen Fehler geplagt werde, stand auch die Inspektion der Ereignisanzeige auf dem Diagnoseplan. Dabei stieß ich auf den WMI-Fehler mit der ID 10 und dem obigen Fehlercode.


Anzeige

In den Details der Ereignisanzeige wurde der Text Ereignisfilter mit Abfrage “SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA “Win32_Processor” AND TargetInstance.LoadPercentage > 99″ konnte im Namespace “//./root/CIMV2” nicht reaktiviert werden auf Grund des Fehlers 0x80041003.

In Englisch lautet der Fehler: Event filter with query “SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA “Win32_Processor” AND TargetInstance.LoadPercentage > 99″ could not be reactivated in namespace “//./root/CIMV2” because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected.

Also blockiert irgend etwas die Abfragen des WMI-Dienstes. Eine kurze Recherche ergab den unter [1] aufgeführten Microsoft KB-Artikel zu Windows Vista mit SP1. Ich arbeite zwar mit Windows 7 SP1, aber die Fehlerursache, ein Zugriffskonflikt auf den WBEM-Store könnte die Ursache sein. Leider lieferte der KB-Artikel keine weiteren Informationen zur Behebung. Erst eine weitere Recherche ergab unter [2] einen brauchbaren Ansatz.

  1. Im Suchfeld cmd eintippen und dann Strg+Shilft+Enter drücken, um die Eingabeaufforderung mit administrativen Rechten zu starten.
  2. Dann den WMI-Dienst mit net stop winmgmt in der Eingabeaufforderung stoppen.
  3. Anschließend habe ich den Windows Explorer aufgerufen und im Pfad C:\Windows\System32\wbem\ den Ordner Repository in Repository-old umbenannt.

Nachdem das System neu gestartet wurde, legt Windows 7 den Ordner samt Inhalt neu an (kann ein paar Sekunden dauern. Anschließend war der WMI-Fehler in der Ereignisanzeige weg (den Restore-Fehler konnte ich damit leider nicht beheben).

Links:
1: Ereignis-ID 10 wird im Anwendungsprotokoll protokolliert
2: Vista SP1: WMI Error 0x80041003 Link ungültig


Anzeige


Dieser Beitrag wurde unter Problemlösung, Tipps, Windows 7 abgelegt und mit Windows 7, WMI-Fehler 0x80041003 verschlagwortet. Setze ein Lesezeichen auf den Permalink.

4 Antworten zu WMI-Fehler 0x80041003 mit ID 10


  1. Anzeige
  2. André sagt:

    der KB Artikel zeigt doch die Lösung? Einfach den VBS code in eine Datei packen und ausführen.

  3. Günter Born sagt:

    @André: Wo Du Recht hast, hast Du Recht. Hab das Teil wohl dreimal überflogen, aber der Lösungszweig war wohl im Browser ausgeblendet. Ergo habe ich die händische Variante mit Erfolg angewandt.

    Aber war eh nur kosmetischer Natur – denn der ursprüngliche Fehler mit dem Task “After Recovery”, der im verlinkten Beitrag beschrieben ist, ist nicht weg zu bekommen. Und ich habe momentan keinen Plan, was mir da einen Streich spielt. Dateien, die gelesen werden und die ich im Explorer nicht sehe. Registrierungsschlüssel, die gelesen werden und die ich im Regedit nicht sehe. So etwas ist mir noch nicht untergekommen.

  4. Anzeige

  5. Pingback: [BLOCKED BY STBV] Win7 Hilfe BSOD zu beseitigen 0x000000c5

  6. Pingback: Grafikkarte: Bluescreen mit NVLDDMKM.SYS - Meldung

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Hinweis: Bitte beachtet die Regeln zum Kommentieren im Blog (Erstkommentare und Verlinktes landet in der Moderation, gebe ich alle paar Stunden frei, SEO-Posts/SPAM lösche ich rigoros). Kommentare abseits des Themas bitte unter Diskussion.