Backup liefert VSS-Fehler 0x807800A1

win7Die in Windows integrierte Backup-Funktion ist ja gelegentlich für Ärger bekannt. In diesem Beitrag möchte ich mal den Fehler 0x807800A1 aufgreifen, der beim Anfertigen einer Systemabbildsicherung auftreten kann.


Anzeige

Den Fehler 807800A1 hatte ich ganz kurz im Beitrag Windows-Backup Fehlerdiagnosen angesprochen. Tritt der Fehler 807800A1 beim Backup auf, kann der Volumenschattenkopiendienst keine Sicherung ausführen (Volume Shadow Copy Service failed). Dann ist zu klären, warum der VSS-Dienst da Probleme hat.

Läuft der Volumenschattenkopiendienst?

Die erste Prüfung in einem solchen Fall wäre zu schauen, ob der VSS-Dienst überhaupt läuft. Ist dieser abgeschaltet, kann Backup natürlich auch nicht auf den Dienst zugreifen.

1. Rufen Sie das Programm Dienste (per Startmenü oder über die Windows 8.1-Startseite) und den Kontextmenübefehl Als Administrator ausführen auf.

VSS-01

2. Suchen Sie den Dienst Volumenschattenkopie und wählen Sie den Eintrag per Doppelklick an.

VSS-02

3. Klicken Sie dann auf die Schaltfläche Starten, und prüfen Sie, ob sich der Dienst ohne Fehler starten lässt.


Anzeige

Standardmäßig steht der Starttyp auf “Manual” und der Dienst ist auch nicht gestartet. Wenn Sie den Dienst starten, sollte dies ohne Fehler durchlaufen. Gibt es bei diesem Startvorgang bereits Fehler, muss die Ursache beseitigt werden.


Werbung – meine Windows 8.1 Titel –

Der VSS-Writer muss laufen – auf Fehler prüfen

Was im Dienstemanager nicht angezeigt wird: Der Microsoft Software Shadow Copy Provider muss gestartet sein. Hier ist mir in diesem Thread die Click2Run-Konfiguration in Microsoft Office Starter 2010, die ein eigenes Laufwerk Q oder R anlegt, als Ursache untergekommen. Da bekommt der VSS-Writer bei der Konstellation unter Umständen Probleme.

Zur Fehlerprüfung kann man eine Eingabeaufforderung über Als Administrator ausführen aufrufen und dann den Befehl

vssadmin list writers

eingeben. Dann werden die jeweiligen Writer samt Fehlerstatus aufgelistet.

VSS-03

Es kommt zu VSS-Timeouts in Windows

Falls Zeitüberschreitungen gemeldet werden kann man noch die Webseite mit KB 826936 aufrufen. Dort bietet Microsoft neben allerlei Hintergrundinformationen einen FixIt an, der Timeout-Probleme beheben kann.

Dual-Boot-Installation schreddert Volumenschattenkopien

In diesem MS Answers-Forenthread bin ich noch auf eine interessante Ursache für den Fehler gestoßen. Die Anwender hatten parallel zu Windows 7 noch Ubuntu auf den Systemen installiert. Dies führte dazu, dass die Volumenschattenkopien beim Booten von Ubuntu gelöscht wurden.

System auf beschädigte Dateien prüfen

Um auszuschließen, dass ein beschädigtes System für den Fehler verantwortlich ist, sollte man auf jeden Fall eine Datenträgerprüfung (in den Eigenschaften der Festplatte auf der Registerkarte Tools aufrufbar) und auch eine Systemdateiprüfung ausführen. Wie eine Systemdateiprüfung gemacht wird, habe ich im Artikel System auf beschädigte Systemdateien prüfen beschrieben.

Systemreserviert-Partition voll

Eine Problemstelle, die man auch im Hinterkopf behalten soll, ist die Partition “Systemreserviert”. Dort muss mindestens 50 MByte frei sein. Hier findet sich ein Artikel, der beschreibt, wie man den freien Speicher überprüft.

Fremdfirewall und Antivirus-Lösungen als Ursache?

Eine mögliche Ursache für Timeouts der VSS-Writer könnten auch Fremd-Virenscanner und Firewalls sein. Es wird daher häufig zur Fehlerdiagnose vorgeschlagen, diese Programme zum Testen zu installieren und Windows ggf. im abgesicherten Modus zu starten.

Weitere Diagnosemöglichkeiten für den VSS-Writer habe ich im Artikel Wiederherstellung bzw. VSS meldet Error 0x81000101 beschrieben. Zudem gibt es bei Microsoft einen Technet-Artikel zu Windows Server Backup-Problemen.

Disk-Reihenfolge und hidden OEM-Partitionen

Nachtrag: Im oben verlinkten diesem MS Answers-Forenthread gibt es weitere Hinweise. Ein zusätzlich installiertes Betriebssystem kann die Bootreihenfolge der Disks ändern und das Problem verursachen. Auch eine zweite eingebaute Disk kann dazu führen, dass ein BIOS-System diese als erste Disk sieht. Während der Boot-Vorgang durch Abfrage aller Festplatten korrekt abläuft, erwartet Backup, dass die Sicherung von Disk 0 erfolgt. Ist Windows auf Disk 1, 2 etc. installiert, wird der obige Fehler vom VSS ausgeworfen.

Zudem wird der Fall beschrieben, dass eine versteckte OEM-Partition auf einer Disk liegt. Zum Anfertigen des Backups muss diese sicht- und beschreibbar sein. Nach dem Backup sind die Parameter der Partition zurück zu setzen.

Ähnliche Artikel:
Die Systemwiederherstellung funktioniert nicht
Wiederherstellung bzw. VSS meldet Error 0x81000101
System auf beschädigte Systemdateien prüfen
Windows-Backup Fehlerdiagnosen
Windows 8.1: Backup-Probleme bei UEFI/GPT-Datenträgern


Anzeige


Dieser Beitrag wurde unter Backup, Problemlösung abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

6 Antworten zu Backup liefert VSS-Fehler 0x807800A1


  1. Anzeige
  2. Pingback: Anonymous

  3. Ween@gmx.de sagt:

    Hallo , der beschriebene Fehler hier ist : ” 0x807800A1″ .
    Unter Vista Ult. SP 2 hatte ich diesen : “0x80780039” .
    Wäre toll , wenn mal jemand die Zahlen aufschlüsseln könnte . :-)
    Da dieses Windows-Problem nun schon fast 10 Jahre besteht ,
    wäre mal eine verständliche , eindeutige Lösung angesagt !
    Sonst bleibt dem User nur die Sicherung mit Fremd-Programmen ,
    wie es bei mir z. Z. der Fall ist . …..Grüße VistExperiment

    • Günter Born sagt:

      Dann hoffen wir, dass sich dieser “jemand” angesprochen fühlt und antwortet ;-). Ansonsten ist das kein Windows-Problem, sondern max ein Backup-Fehler – und häufig durch Fremdkomponenten verursacht. Und es steht jedem frei, auf Fremdprodukte auszuweichen.

  4. Anzeige

  5. Ralf sagt:

    Über dem Hardcopy steht als Befehl vss list writers, im Hardcopy dann aber richtig vssadmin list writers. Vielleicht eine kurze Korrektur wert …

  6. VistExperiment sagt:

    Zitat :
    “häufig durch Fremdkomponenten verursacht”

    ….wüsste nicht , wo da die Fremdkomponente gewesen sein soll ?!
    Für mich ist es ein schwerer Windows-Bug !

  7. Günter Born sagt:

    Möglicherweise liefert der uralte Windows XP KB-Artikel hier noch eine Lösung:

    https://support.microsoft.com/de-de/kb/907574

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Hinweis: Bitte beachtet die Regeln zum Kommentieren im Blog (Erstkommentare und Verlinktes landet in der Moderation, gebe ich alle paar Stunden frei, SEO-Posts/SPAM lösche ich rigoros). Kommentare abseits des Themas bitte unter Diskussion.