Windows 10 Version 1803: Netzwerksuche/-umgebung leer

Heute noch ein kleiner Blog-Beitrag für Nutzer von Windows 10 April Update (V1803), die eine leer Netzwerkumgebung vorfinden und Probleme haben, auf andere Freigaben zuzugreifen.


Anzeige

Dass Microsoft die Heimnetzgruppe aus Windows 10 V1803 entfernt hat, ist im Blogbeitrag Windows 10: Abschied von der Heimnetzgruppe thematisiert. Aber Nutzer von Windows 10 werden beim Umstieg auf das April Update (V1803) durch weiteres Unbill in der Netzwerkumgebung geplagt.

Das Fehlerbild

Ich hatte das Thema im Hinterkopf, bin aber erneut durch diesen Blog-Kommentar von Michael auf das Problem aufmerksam geworden.

Ich schlage mich mit einem kuriosen Problem rum, das mir erst nach der 1803 aufgefallen ist. 2 Maschinen, 1 x Home die Kiste von HP mit nüscht drauf, eine “Workstation” die aber auch bis dahin lief.

Netzwerk leer bis auf Drucker / Fritz, die anderen Maschinen nicht mehr sichtbar.
Gezielt per Name geht,
Net view := Fehler
Systemfehler 1231 aufgetreten.

Die Netzwerkadresse ist nicht erreichbar. Weitere Informationen über die Behebung von Netzwerkproblemen finden Sie in der Windows-Hilfe.
Problembehandlung ergibt natürlich nichts.

Um es kurz zu machen, es gibt keinen Dienst Browser mehr, da war auch früher das Netz leer. Warum der futsch! ist keine Ahnung; LanmanWkst & Server sind intakt und derzeit rolle ich gerade die Sicherungen zurück wann das wohl passiert sein könnte und evtl. warum.
bei den anderen Maschinen gibt es den Dienst aber noch?

Das SMBv1-Problem

Bei Windows 10 V1803 wird das SMBv1-Protokoll nicht mehr standardmäßig installiert. Es gibt von Microsoft den Support-Beitrag SMBv1 ist in Windows 10 Fall Creators Update und Windows Server, Version 1709, nicht standardmäßig installiert, der das Thema näher beschreibt.

  • In Windows 10 Home und Windows 10 Professional ist der SMBv1-Server nach einer Neuinstallation nicht mehr standardmäßig enthalten.
  • In Windows 10 Home und Windows 10 Professional ist der SMBv1-Client nach einer Neuinstallation nach wie vor standardmäßig enthalten. Wenn der SMBv1-Client insgesamt 15 Tage lang (mit Ausnahme von Zeiten, zu denen der Computer ausgeschaltet ist) nicht verwendet wird, wird der Client automatisch deinstalliert.
  • Bei direkten Upgrades von Windows 10 Home und Windows 10 Professional wird SMB1 zunächst nicht automatisch entfernt. Wenn der SMBv1-Client oder -Server insgesamt 15 Tage lang (mit Ausnahme von Zeiten, zu denen der Computer ausgeschaltet ist) nicht verwendet wird, wird er automatisch deinstalliert.
  • Beim automatischen Entfernen von SMB1 nach 15 Tagen handelt es sich um einen einmaligen Vorgang. Wenn ein Administrator SMB1 erneut installiert, wird das Protokoll nicht deinstalliert.

Und im Support-Beitrag findet sich der entscheidende Hinweis: Da der Computersuchdienst auf SMBv1 angewiesen ist, wird der Dienst deinstalliert, wenn der SMBv1-Client oder -Server deinstalliert wird. Dies bedeutet, dass der Explorer-Knoten „Netzwerk“ keine Windows-Computer mehr über die Legacymethode zum Durchsuchen von NetBIOS-Datagrammen anzeigen kann.

Netzwerk-Zugriffsfehler
(Quelle: SuperUser-Forum)

Windows 10 wird in diesem Szenario diverse Fehler wie ‘Der angegebene Netzwerkname ist nicht mehr verfügbar.’ etc. anzeigen. Den in obigem Screenshot gezeigten Fehler beim Zugriff auf eine Freigabe hatte ich im Blog-Beitrag Windows 10: Netzwerk zeigt Fehler 0x80070035 schon mal behandelt.

Eine Lösung für das Problem

Bei superuser.com gibt es den Forenbeitrag Did Windows 10 April Update break network discovery and Samba support?, wo jemand das obige Fehlerbild ebenfalls beschreibt. Er kann nicht mehr auf NAS-Freigaben zugreifen. Die Ursache würde ich im deinstallierten SMBv1-Protokoll suchen.


Werbung

Der erste Impuls wäre, das SMBv1-Protokoll wieder zu installieren, um das Problem auszumerzen. Aus Sicherheitsgründen sollte man aber darauf verzichten. Es muss einen anderen Weg geben, um die Funktion des Netzwerkbrowsers wieder zu reaktivieren. Und im superuser.com Forenbeitrag kam dann der Ratschlag, das WS-DISCOVERY-Protokoll zur Suche zu aktivieren.

  • Find the Function Discovery Provider Host and Function Discovery Resource Publicationservices and set their startup types to Automatic (Delayed Start).
  • The next time you start network browsing, follow the prompts to enable Network discovery.

Microsoft erklärt das Ganze in deutscher Sprache in diesem Support-Beitrag. Führen Sie auf den Windows-basierten Computern, auf denen SMBv1 nicht mehr verwendet wird, die folgenden Schritte aus:

Funktionssuchanbieter-Host

1. Starten Sie die Dienste „Funktionssuchanbieter-Host“ und „Funktionssuche-Ressourcenveröffentlichung“, und legen Sie für sie die Option Automatisch (Verzögerter Start) fest.

Starttyp Dienst

2. Wenn Sie den Explorer-Knoten „Netzwerk“ öffnen und zum Aktivieren der Netzwerkerkennung aufgefordert werden, aktivieren Sie diese Option.

Alle Windows-Geräte in diesem Subnetz, die über diese Einstellungen verfügen, werden jetzt in „Netzwerk“ angezeigt und können durchsucht werden. Dabei wird das WS-Suchprotokoll verwendet. Vielleicht behebt dies das Problem, dass die Netzwerksuche nichts mehr findet.

Ähnliche Artikel
Windows 10: Netzwerk zeigt Fehler 0x80070035
Windows (Netzwerk-) Fehler 0x800704B3
Windows 10: Netzwerkprobleme durch Updates?
Windows 10: Netzlaufwerke unvollständig verbundenen
Windows 10: Kein Zugriff auf Freigaben
SMBv1-Abschaltung bei Windows 10 Enterprise ab 9.6.2017
Windows 10: Aus für SMBv1 ab Herbst 2017
Windows 10: Scanner macht Probleme nach Update


Anzeige

Dieser Beitrag wurde unter Netzwerk, Windows 10 abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

18 Kommentare zu Windows 10 Version 1803: Netzwerksuche/-umgebung leer

  1. Paul Brusewitz sagt:

    > Der erste Impuls wäre, das SMBv1-Protokoll wieder zu installieren,
    > um das Problem auszumerzen. Aus Sicherheitsgründen sollte man
    > aber darauf verzichten.

    Was reißt man denn da für Sicherheitslücken auf, wenn das nur im privaten Netzwerk läuft?

    MfG P.B.

    • Ralph sagt:

      https://www.borncity.com/blog/2017/05/14/wannacry-neue-versionen-und-mehr-neuigkeiten/

      Du kannst natürlich auf solche Absicherungen verzichten, wenn Dein privates Netz an keiner Stelle Zugang zum öffentlichen Netz hat und an allen Rechnern die Nutzung von externen Medien (CD, DVD, USB-Sticks, externe Festplatten, Speicherkarten, Floppy Disks) wirksam unterbunden wird.

      Sollte Dein privates Netzwerk allerdings an irgendeiner Stelle ans öffentliche Netz angeschlossen sein, solltest Du ausreichend Sozialkompetenz beweisen, indem Du alles tust, was verhindert, dass irgendeine Maschine in Deinem privaten Netzwerk zur Virenschleuder am öffentlichen Netz wird.

  2. OlliD@IRQ8 sagt:

    Ganz neu ist das Problem nun nicht: https://www.drwindows.de/windows-10-desktop/99148-windows-10-th2-findet-keine-netzwerk-computer-6.html#post1005738
    Konsequent wäre, SMBv1 nicht zu verwenden, was aufgrund des Hardwarezoos’s nicht so einfach gelingt (https://blogs.technet.microsoft.com/filecab/2017/06/01/smb1-product-clearinghouse/), da viele SOHO-Produkte auf SMBv1 setzen. Aus die Maus für alle NAS, FRITZ!Boxen, Speedport, TV, MFP mit “Scan to folder/share” und “Print to share” usw., die SMB2 nicht unterstützen.
    Aber: Ab SMBv2 gibt es wieder andere Probleme… siehe hier: https://newyear2006.wordpress.com/2015/08/10/

  3. Tom sagt:

    Bei mir gehen seit dem grossen update gestern die Lautsprecher nicht mehr. Hat jemand eine Ahnung, an was das liegen könnte? Die Treiber sind aktuell.

  4. Exi sagt:

    Danke für den Tipp!
    Ich besitze ein NAS des gleichen Herstellers, habe aber auf meinen privaten Rechnern aufgrund dieses sich abzeichnenden Problems noch auf das Windows-Update verzichtet.
    Schöne Grüße

  5. Werbung

  6. Phil sagt:

    Wir haben ebenfalls Probleme mit der neuen Version 1803. Windows auf Client installiert, alle bisherigen Updates installiert. Das Beitreten in eine Domäne ist nicht mehr möglich. Mit der Version 1709 klappt es ohne Probleme. Als DC wird Windows Server 2012 R2 eingesetzt. Ich habe bereits im Technet Forum nach einer Lösung gesucht. Ohne Erfolg.

  7. Sieht ein bisschen besser aus, alle Windows 10 PCs werden nun wieder im Netzwerk angezeigt mit dem Windows Server 2012 gibts immer ein paar Start Schwierigkeiten, bis auf die beiden Windows 7 PCs, ich schätze mal da will uns jemand zum Upgrade überreden, wenn Windows 10 keine so großen Probleme mit Seriellen Schnittstellen hätte würde ich es ja fast tun.

  8. Janami25 sagt:

    Bei mir hilft absolut gar nichts. Synology NAS (DS918+ und DS916+ mit DSM 6.1.6 Update 1) im Netzwerkumgebung funktioniert nur, wenn SMBv1 in Windows 10 mit aktiviert wird. Jedenfalls mit der Windows 10 1803.

    Sicherheit hin oder her, wenn es nicht funktioniert, nützt mir das sicherste System auch nichts mehr. So läuft es jedenfalls (wieder). Funktionsanbieter (beide Dienste in Windows) musste ich trotz allem auf “Automatik” stellen, sonst ging da auch nichts.

    Woran es liegt, weiss ich nicht genau, ob an Synology oder Windows (oder beiden), ich habe tagelang Foren durchgeackert, und alles mögliche durchprobiert, um ohne SMBv1 auszukommen, aber es ging nicht.

    Jetzt läuft alles wieder einwandfrei, samt sämtlichen Freigaben. Also, bleibt es erstmal so.

    • Thomas Bauer sagt:

      Hast du beim Synology NAS ein anderes SMB Protokoll eingestellt. Ist einfach.
      Unter Dateidienste/SMB Dienst aktivieren/Erweiterte Einstellungen. Dort kann man SMB einstellen.

      • Andres Müller sagt:

        Bei mir funktionierte mit Win 10Pro 1803 quasi über Nacht auf mehreren Servern (ein Synology und zwei WD Mycloud) kein Dateizugriff mehr. Es wurde zwar mit z.B. \\Synology der Server gefunden und das Hauptverzeichnis geöffnet, es wurden aber keinerlei darin befindliche Verzeichnisse mehr angezeigt.

        Alle Server sind konfiguriert um mit SMB 1 – SMB 3 Protokoll zu arbeiten.
        Unter Netzwerke wurden einige Geräte angezeigt, andere jedoch nicht. Von 8 Geräten wurden nur 4 angezeigt, der Rest konnte aber mit \\DeviceX geöffnet werden, aber eben ohne jeglichen Inhalte.

        Machte mich rasend, habe dann dank @Born diesen Artikel gefunden, nachdem ich bereits Einiges ausprobiert hatte.

        Es stellte sich heraus dass sich SMB1 über Nacht deinstalliert hatte, jedoch ohne jegliche Benachrichtigung darüber und offenbar über einen Kniff vor meinen Augen verborgen. Der Kiff bestand darin das Microsoft unter “Windows Feature aktivieren oder deaktivieren” ein aktiviertes SMB 1.0 anzeigte (schwarzes Rechteck neben Unterstützung für die SMB 1.0 CIFS Datei -Freigabe, jedoch wenn man dann den hierarchischen Baum öffnete war weder unter Client noch unter Server der Haken gesetzt.

        Ich war also schon mehrfach daran vorbei gesaust mit meinen Augen, weil ich nicht bemerkte dass SMB 1.0 trotz dem durch Microsoft angezeigten schwarzen Rechteckes (= Teilaktivierung [hatte den Client aktiviert]) eben beide SMB 1.0 deaktiviert = ohne gesetzen Haken neben Server und Client war.

        Nachdem ich jetzt die SMB 1.0 reaktiviert habe werden nun entgegen dem Zustand vorher jetzt ALLE Netzwerkgeräte angezeigt , nicht wie vorher einige Geräte weniger. Und wenn ich jetzt den Synology öffne sind die Verzeichnisse wieder da und werden angezeigt.

        ABER! – jetzt werden mir alle Server Geräte wie der Synology DOPPELT angezeigt unter Netzlaufwerke, ausser die Microsoft Computer. Und zwar mit dem genau gleichen Namen. Wenn man auf einen Namen klickt werden die Dateiverzeichnisse angezeigt, beim anderen Namen öffnet sich das Hauptverzeichnis mit einem “NFS” – Verzeichnis darin. Daneben im Explorer werden ebenfalls für jeden Server zwei identische Gerätenamen angezeigt. Aber im Verzeichnisbaum finde ich dann bei einem Gerät das NFS Verzeichnis angezeigt und ein weiteres Dateiverzeichnis von den 13 möglichen Verzeichnissen in diesem Gerät.

        Der Explorer ist jetzt somit nicht mehr richtig zu benutzen, wegen doppelten exakt identischen Gerätenamen mit je verschiedenen Dateiverzeichnissen darin. Wenn man ein Gerät geöffnet hat und in der Hierarchie oben auf Zurück klickt, so ist das erste der identischen Geräte jetzt immer vorselektiert, auch wenn man vom zweiten identisch bezeichneten Geräte her kommt, wo zum Beispiel nur das NFS Verzeichnis drin angezeigt wird.

        Microsoft aktiviert oder deaktiviert Dienste ohne jegliche Mitteilung. Wenn man das bemerkt und den Dienst wieder aktivert, dann kann es wie bei mir ein fehlerhaftes Anzeigeverhalten geben.
        Die SMB 3 Sachen konnte ich nicht aktivieren, wie bei Janami25 funktioniert nichts ausser SMB 1.0 – und zwar bei verschiedenen Produkten wie Synology und zwei verschiedenen Western Digital Produkten. Ohne 1.0 wird bei keinem Geräte etwas im Hauptverzeichnis angezeigt.

        • Andres Müller sagt:

          Habe eine Lösung für doppelt angezeigte Netzwerkgeräte gefunden. Allerdings eine Lösung mit Abstrichen.

          SMB (1.0) und die NFS- Dateidienste sind bei mir nicht mehr gleichzeitig aktivierbar!

          Ich habe “Windows 10 Pro 64bit” Version 1803 (Stand 5 Juni)

          Wenn bei aktivem”SMB” der “NFS” -Dienst in den Windows Features deaktiviert wird, dann gibt es keine doppelten Gerätenamen mehr.

          Aber man hat dann auch keinen Zugriff auf Unix Geräte mehr die für NFS konfiguriert sind.

          Deaktiviert man anstelle “NFS” den SMB -Dienst, dann werden die Geräte auch nicht doppelt angezeigt, aber dann erhält man nur noch über Verzeichnisse Zugriff bei denen NFS eingeschaltet ist. Zudem werden Umlaute im Datei/Ordnernamen wie ö ä ü bei mir unter NFS zerstückelt im Windows -Explorer angezeigt.

  9. Markus T. sagt:

    Trotz des neuen Windows Updates KB4284848 welches das Problem angeblich lösen soll, ist der Fehler bei mir immer noch präsent. Falls man irgendwie einschränken möchte oder jemand Gemeinsamkeiten erkennt:
    Asus Z370 Strix F Gaming mit Intel I219-V, Windows 10 1803 frisch (kein Upgrade)

    Zum Thema Synology NAS: SMB Protokoll v2 min und v3 max (Dateidienste SMB) zusammen mit der aktivierten Funktion WS-Discovery (Dateidienste erweitert) lassen zumindest das NAS bei mir problemlos trotz dieses Bugs laufen und es wieder im Netzwerk erscheinen

  10. Gordon Wagner sagt:

    Habe das gleiche Problem mit Windows 10 1803 aktuellstes Patches aus 2018/08 und mit folgendem zur Lösung gebracht…

    Erst war das System nicht zu sehen, dann stand da das keine Ordner-Inhalte vorhanden waren.

    Was wurde gemacht:

    – hosts Datei in Windows 10 angepasst und IP ergänzt um NAS IP + Name
    – Dienste für SMBv1 reaktiviert bei Windows 10

    – Am DSM die Funktion für SMB-Dienst aktiviert und: Opportunistic Locking aktiviert + SMB 2 Lease aktiviert + Mehrere Verbindung von der selben IP deaktiviert eingeschaltet…
    – Verschlüsselung auf “automatisch” gestellt
    – Min. SMBv2 und Large MTU sowie Max. SMBv3
    – SSDP sowie WS-Discovery aktiviert
    – Unter Firewall am DSM eine Ausnahme für das IP-Netz/Subnetz erstellt und alles zugelassen

    Einmal alles durchstarten.

    Nun läuft alles wie zuvor!!! 2 Stunden meines Lebens mal wieder umsonst vergeudet!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.