Windows 10: Netzwerkbug, Fix soll später kommen

[English]Mit den Januar 2019-Updates hat sich in allen unterstützten Windows 10-Versionen ein Netzwerkfehler eingeschlichen. Ein Patch zur Korrektur des Problems ist für den Februar 2019 zu erwarten. Hier einige Informationen, was Sachstand ist.


Anzeige

Das Fehlerbild: Edge macht Probleme, DHCP-Probleme

Ich gestehe, diese Fehler sind etwas an mir vorbei gegangen, weil die ursprüngliche Meldung eine exotische Kombination ist (Windows 10 und Microsoft Edge). Daher habe ich auch nicht aufgemerkt, als ich diesen Kommentar zu meinem heise.de-Artikel Windows 7: Updates KB4480970 und KB4480960 verursachen Netzwerkprobleme gelesen habe. Der Benutzer schrieb:

Nicht nur 7 auch windows10

Nach der Installation der Sicherheitsupdates 2019-01 (KB4480116) konnte der Telekom Router (Speedport 925) nicht mehr aufgerufen werden. Nach der Deinstallation ließ sich der Speedport-Router wie üblich problemlos aufrufen.

Im Forenthread kam dann schnell der Hinweis auf DHCP-Probleme nach dem Windows 10-Update (trifft wohl auch Windows Server 2016). Hier die Diskussion aus einem zweiten Thread.

wie schon vor über einem Jahr (1709), als sie (besonders) bei Atheon Chipsätzen das Problem hatten, dass der Client die per DHCP ausgelieferten Daten nicht verarbeiten konnten, scheint das jetzt bei Intel-Chipsätzen (wiederum WiFi) zu passieren.

Vergibt man die IP fest, geht es, per DHCP landet man bei 169.254.*.*

Ein zweiter Nutzer ergänzte dann:

Genau das gleiche habe ich heute morgen nach dem Einschalten auch erlebt, direkt vorher wurden die Updates von gestern fertig eingespielt. Hatte aber erstmal nicht die Updates im Verdacht, sondern unseren DHCP-Server. Nach ipconfig /release und /renew war das Netz aber wieder da.

Allerdings ist das ein normaler PC mit Intel I217-LM onboard-LAN…

Ich hatte es kurz auf ‘musst Du dir merken und verfolgen’ gesetzt, aber dann geriet das Thema wegen anderer Turbulenzen aus dem Fokus. Dann gab es gestern einen Kurzhinweis, dass KB4480116 Probleme bereitet – und dann fiel hier der Groschen.

Fast alle Windows 10-Versionen betroffen?

Zum 17. Januar 2019 hat Microsoft dann die KB-Artikel, die die Updates für Windows 10 vom 8. Januar 2019 beschreiben aktualisiert. Es betrifft folgende Updates:

  • Windows 10 V1809 und Server 2019: KB4480116 vom 8. Januar 2019
  • Windows 10 V1803: KB4480966 vom 8. Januar 2019 und KB4480976 vom 15. Januar 2019
  • Windows 10 V1709: KB4480978 vom 8. Januar 2019 und KB4480967 vom 15. Januar 2019
  • Windows 10 V1703: KB4480973 vom 8. Januar 2019 und KB4480959 vom 15. Januar 2019
  • Windows 10 V1607 und Server 2016: KB4480961 vom 8. Januar 2019;

Beim Update KB4480977 für Windows 10 V1607 und Server 2016 vom 17. Januar 2019 ist der Bug nicht mehr aufgeführt. Auch beim Update KB4480116 vom 8. Januar 2019  für Windows 10 V1507 finde ich keinen Hinweis. Ob es lediglich ein Dokumentationsmangel ist oder der Fehler dort nicht auftritt oder gefixt ist, kann ich noch nicht sagen.

Die Fehlerbeschreibung Microsofts

In den betreffenden KB-Artikel findet sich (wohl seit dem 17. Januar 2019) die folgende Ergänzung im ‘known issues’-Abschnitt.

After installing KB4480116, some users report that they cannot load a webpage in Microsoft Edge using a local IP address. Browsing fails or the webpage may become unresponsive.


Werbung

Die oben genannte KB-Nummer stammt aus dem Beitrag für Windows 10 V1809 und ändert sich, je nach Windows 10-Version. Die Aussage Microsoft: Nach der Installation des Updates berichten einzelne Nutzer, dass sie im Microsoft keine lokalen Webseiten von einer lokalen IP-Adresse laden können. Der Abruf geht schief und die Seite reagiert nicht mehr. Also genau das Szenario, welches der Benutzer im heise.de-Forum beim Zugriff auf die Router-Seiten beschrieben hatte.

Ein Workaround

In diesen Kommentar zu meinem heise.de-Artikel wurden einige Ansätze genannt – habe ich aber nicht probiert. Microsoft schlägt folgende Schritte vor, um die lokale Seite in die Liste der Vertrauenswürdigen Webseiten aufzunehmen.

1. Die Systemsteuerung öffnen (in der Taskleiste nach dem Begriff suchen und dann den Treffer anklicken) und dann die Internetoptionen anwählen.

Internetoptionen - Sicherheit

2. Auf der Registerkarte Sicherheit das Symbol für Vertrauenswürdige wählen und im Anschluss auf die Schaltfläche Sites klicken.

Vertrauenswürdige Sites

3. Im Dialogfeld Vertrauenswürdige Sites die Markierung des Kontrollkästchens Für Sites dieser Zone ist eine Serverüberprüfung (https:) erforderlich löschen.

4. Dann die URL der lokalen Webseite (z.B. http://192.168.0.1) im Feld Diese Website zur Zone hinzufügen eintragen und mittels der Hinzufügen-Schaltfläche in die Liste aufnehmen.

5. Dann die Markierung des Kontrollkästchens Für Sites dieser Zone ist eine Serverüberprüfung (https:) erforderlich wieder setzen.

Im Anschluss sind das Dialogfeld und das Eigenschaftenfenster zu schließen und dann der Microsoft Edge neu zu starten. Jetzt sollte sich wieder auf die lokalen Webseiten (wie z.B. der Router) zugreifen lassen. Microsoft arbeitet an einer Lösung und will diese mit einem der kommenden Updates bereitstellen. Irgend jemand betroffen?

Ergänzung: Noch ein Workaround über die hosts-Datei

Auf askwoody.com (die ich auf das Problem hingewiesen habe) hat sich ein Nutzer gemeldet. Bei ihm hat es geholfen, in der hosts Datei im Verzeichnis

%windir%\system32\drivers\etc

um entsprechende Einträge wie:

192.168.1.1   myrouter

zu ergänzen. Dann sollen sich die lokalen Webseiten ebenfalls aufrufen lassen.

Ähnliche Artikel:
Patchday: Updates für Windows 7/8.1/Server 8. Jan. 2019
Patchday Windows 10-Updates (8. Januar 2019)
Netzwerkprobleme mit KB4480970 (Monthly Rollup)/KB4480960
Fix für das Windows 7-Netzwerkproblem mit Update KB4480970/KB4480960
Januar 2019-Patchday Probleme und Nachlese
Probleme mit den Microcode-Updates vom 10.1.2019?


Anzeige

Dieser Beitrag wurde unter Netzwerk, Update, Windows 10 abgelegt und mit , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

9 Responses to Windows 10: Netzwerkbug, Fix soll später kommen

  1. Martin Feuerstein sagt:

    Mir erschließt sich gerade nicht, was eine Zonenzuordnung in den Einstellungen für Internet Explorer/Edge mit dem Zuweisen einer IP-Adresse per DHCP zu tun hat. Sind das evt. zwei verschiedene Probleme?

  2. Herr IngoW sagt:

    Bei “WinFuture” gibt es einen Artikel mit Workaround:

    ->Start ->Windows-System ->Systemsteuerung aufrufen
    ->In der Systemsteuerung “Internetoptionen” aufrufen
    ->Wählen Sie auf der Registerkarte “Sicherheit” das Symbol “Vertrauenswürdige Sites”.
    ->Wählen Sie die Schaltfläche “Sites”.
    ->Deaktivieren Sie das Kontrollkästchen für “Serververifizierung erforderlich” (https:) für alle Standorte in dieser Zone.
    ->Geben Sie im Feld “Diese Website zur Zone hinzufügen” die lokale IP-Adresse ein, die nicht geladen werden konnte, z.B. http://192.168.0.1.
    ->Wählen Sie die Schaltfläche “Hinzufügen”.
    ->Aktivieren Sie das Kontrollkästchen “Serververifizierung erforderlich” (https:) für alle Standorte in dieser Zone. (Dieses muste bei mir nicht gemacht werden)
    ->Wählen Sie die Schaltfläche Schließen.
    ->Wählen Sie die Schaltfläche OK.
    ->Starten Sie Microsoft Edge neu.
    (Zitiert von Artikel: https://winfuture.de/news,106984.html)

    • Günter Born sagt:

      Möglicherweise Parallelposting? Die Schritte hatte ich oben im 2. Durchlauf (bevor der Kommentar kam) mit Screenshots nachgetragen. Hab es in 2 Hälften veröffentlicht, weil der Artikel raus sollte.

      • Herr IngoW sagt:

        Oh war ich wohl zu schnell am frühen Morgen.
        Als ich diesen Beitrag gelesen habe war der Workaround noch nicht da.
        Einen schönen Tag noch Herr Born, hier kommt endlich mal die Sonne raus.

  3. Brezner sagt:

    Vielen Dank für die Zusammenfassung.
    Ihre Website und Artikel sind immer das beste, feinste, Destillat der ganzen Tagesmeldungen der IT.

  4. P. K. sagt:

    Hallo, ich habe hie noch eine Lösung für Probleme mit der Fritzbox und Edge gefunden: https://www.windows-10-forum.com/threads/microsoft-edge-kein-zugriff-mehr-auf-fritzbox.98182/#post-180138

    Müsste derselbe Bug sein, oder?

  5. Werbung

  6. Martin Feuerstein sagt:

    Konnte das Problem gerade im Edge nachvollziehen – die Oberfläche der Fritz!Box lässt sich weder per IP noch per fritz.box aufrufen. Im IE kein Problem.

    Es wird aber noch verrückter:
    – lokaler Webserver mit lokaler Domain des Domaincontrollers (Endung .lan): funktioniert
    – lokaler Webserver mit externem Domainnamen (Endung .de) auf lokale IP-Adresse aufgelöst: funktioniert
    – lokaler Webserver per lokaler IP-Adresse: Fehler
    – Fritz!Box bekommt einen Namen auf Endung der lokalen Domain (fritz.box.domain.lan): funktioniert (wenn auch Fehlerseite)
    – Zugriff auf einen Webserver aus privatem Adressraum (172.16.x.x) vom PC (192.168.x.x) mit Edge: funktioniert
    – Zugriff auf einen Webserver im Internet per IP-Adresse: funktioniert

    Zusammengefasst:
    – auf Server unterhalb der Top-Level-Domain des DC kann zugegriffen werden (kann mit .lan ein Spezialfall sein)
    – auf bekannte Top-Level-Domain mit externer IP-Adresse kann zugegriffen werden
    – auf bekannte TLD mit lokaler IP kann zugegriffen werden
    – auf UNbekannte TLD mit lokaler IP kann NICHT zugegriffen werden
    – auf eine IP-Adresse in einem privaten Adressraum kann zugegriffen werden, sofern der Adressraum des Ziels vom Adressraum des PCs abweicht
    – auf externe IP-Adressen kann zugegriffen werden

    Hätte ja fast auf einen DNS-over-HTTPS-Fehlschlag getippt, aber… das passt nicht dazu, dass ein interner Webserver per lokalem “öffentlichen Domainnamen” angesprochen werden kann und dass die lokale Domain noch unter ihrem Namen ansprechbar ist. Und passt so gar nicht zu dem Fehler, Webserver im eigenen Netz nicht per IP-Adresse ansprechen zu können.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.