Juni-Update KB4503276 blockt PXE-Boot bei SCCM DPs

[English]Kleine Warnung für Administratoren, die Windows Server 2012 zum Deployment per SCCM verwenden. Das Juni 2019-Update KB4503276 verursacht Ärger, weil es das PXE-Booten (WDS) unterbindet. Microsoft hat inzwischen das Problem bestätigt.


Anzeige

Update KB4503276 für Windows Server 2012 R2

Update KB4503276 ist das Juni 2019-Rollup Update für Windows 8.1 und Windows Server 2012 R2, welches am 11. Juni 2019 freigegeben wurde. Microsoft gibt im KB-Artikel zum Update sogar an, dass ein Problem im Pre-Boot eXecution Environment (PXE) behoben wurde. Zitat aus dem KB-Artikel:

Behebt das Problem, dass die Pre-Boot eXecution Environment (PXE) ein Gerät auf einem Windows-Bereitstellungsdienste-Server (Windows Deployment Services, WDS), für den die variable Fenstererweiterung konfiguriert ist, nicht starten kann. Dies kann dazu führen, dass beim Herunterladen des Images die Verbindung zum WDS-Server vorzeitig getrennt wird. Clients oder Geräte, die die variable Fenstererweiterung nicht verwenden, sind von diesem Problem nicht betroffen.

Gleichzeitig werden im KB-Artikel noch einige bekannte Probleme genannt, aber PXE-Boot-Probleme sind da nicht aufgeführt.

Eine Warnung auf Twitter

Ich selbst habe auf diesem Gebiet keine Aktien, aber mir ist die Tage auf Twitter diese Meldung unter die Augen gekommen.

Johan Arwidmark warnt davor, Update KB4503276 vom 11. Juni 2019 an Deployment Points (DPs) von SCCM zu verteilen. Mit hoher Wahrscheinlichkeit gehe bei diesem Vorgang der PXE-Boot (für den Windows Deployment Service, WSD) kaputt. Falls das Ganze passiert, seit das schwer zu debuggen, weil es intermittierend auftritt. Auf reddit.com gibt es diesen Thread vom 1. Juli 2019, der das Thema ebenfalls aufgreift. Zitat:

After June’s CU applied to our DPs we have intermittent problems with PXE boot again. Looking at KB4503276 I can see that the old issue with variable window extension from the March CU is supposed to be solved.

I tried to set that value back to 0 since that was the recommended workaround in previous months and it appeared to initially solve the problem. But now we see about half of the PXE boots failing with the same error code as in March. All google results point to the registry value.

We have uninstalled the patch on one DP and are waiting for confirmation from other IT staff if PXE boot is working again or not.

We’ve also opened a ticket with MS about this but we’ve gotten nowhere so far. Does anyone else have these problems again after the June CU?

Das Problem wird von weiteren Lesern dort bestätigt. Doof ist, dass selbst die Deinstallation des Updates das Problem nicht mehr löst. Ein Nutzer hat einen Fix gepostet, wo er die Option “Enable a PXE responder without Windows Deployment Services” setzt. Weitere Informationen sind dem reddit-Thread zu entnehmen.

Microsoft bestätigt das Problem

Ich hatte den Beitrag hier schon als Konserve geschrieben, als ich nochmals auf Twitter meine Benachrichtigungen geprüft habe. Und da trudelte mir nachfolgender Tweet unter die Augen.


Werbung

Microsoft hat zum 11. Juli 2019 den KB-Artikel 4512816 mit dem Titel ‘Devices that start up using Preboot Execution Environment (PXE) images from Windows Deployment Services or System Center Configuration Manager may fail to start with error “0xc0000001″’ veröffentlicht. Das Problem betrifft faktisch alle Windows-Server-Versionen, die noch im Support sind. Details entnehmt ihr dem KB-Artikel, wo auch ein Workaround besprochen ist.

Gut, ist jetzt nicht mein Betätigungsfeld – ich gehe aber mal davon aus, dass die Betroffenen mit der Warnung und den Informationen etwas anfangen können. Wisst ihr also Bescheid.


Anzeige
Dieser Beitrag wurde unter Tipps, Windows Server abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.