Hyper-V 2nd Gen: Betriebssystem lässt sich nicht installieren

[Englisch]In Hyper-V lassen sich in Generation 2 VMs eventuell keine Gast-Betriebssysteme installieren. Der Installationsvorgang endet mit einer 'PXE Network boot using IPv4 …'-Meldung.


Anzeige

Das Fehlerbild

Ich bin zufällig die Tage in diesem administrator.de-Post auf die entsprechende Fehlerbeschreibung gestoßen:

Setup VM W2016 startet nicht in Hyper-V 2016

sitze gerade über meinem neuen Server und versuche, die VM auf den Host zu prügeln. Jetzt wollte ich eine W2016-VM (als Generation 2 über eine ISO) installieren … sah kurz die Aufforderung, eine beliebige Taste zum setup über das "optische Laufwerk" zu drücken … und dann bin ich ständig in einen black screen mit "PXE Network boot using IPv4 ( ESC to cancel). Performing DHCP Negotiation …." gefallen.

Es schaut so aus, als ob die Aufforderung, eine Taste zu drücken, nicht an die virtuelle Maschine weiter gereicht wird. Dann bootet diese nicht von der gemounteten ISO-Datei und versucht einen PXE Netzwerk-Boot, der natürlich fehlt schlägt.

PXE Network Boot
(Quelle: scomandothergeekystuff.com)

Sucht man im Internet nach dieser Fehlermeldung, erhält man gleich mehrere Treffer. Der Technet-Forenthread hier diskutiert das Problem – und auch dieser Blog-Beitrag befasst sich mit dem Thema. Der obige Screenshot stammt aus diesem Blog-Beitrag.

Lösungsvorschläge für das Problem

In diesen Blog-Beitrag findet sich der Hinweis, in den Einstellungen für Sicherheit die Secure Boot-Option auf "Microsoft UEFI Certificate Authority" zu stellen oder den Secure Boot abzuschalten.

Hyper-V Secure Boot
(Quelle: scomandothergeekystuff.com)

Der obige Screenshot stammt ebenfalls aus dem Beitrag von scomandothergeekystuff.com, bezieht sich dort aber auf Ubuntu. Auf WindowsPro findet sich dieser Artikel, der sich ebenfalls mit dem Thema befasst. Dort gibt es den Hinweis, das Ganze auf Gen 1 VMs zu konvertieren – was aber eher nicht zielführend ist. Auch in diesem Beitrag befasst sich jemand mit der Konfiguration der VM, zielt aber auf einen Legacy Network Adapter für das Netzwerk.

Auf administrator.de hat ein Betroffener eine gänzlich andere Lösung gefunden – er stellt lediglich sicher, dass die Tastatureingaben des Hosts an die VM und den Gast weitergeleitet werden. Dazu schreibt er:


Anzeige

Einige Vorschläge im Netz gefunden (secure start abwählen, ISO-Datei verschieben) … haben nix gebracht. Zielführender Hinweis: In den Einstellungen des HOST unter Benutzer die Tastatur für die Verwendung mit dem "physischen" Computer konfigurieren …

Vielleicht hilft es ja dem einen oder anderen Betroffenen aus der Patsche.

Ergänzende Hinweise

Nach Veröffentlichung dieses Artikels hat sich Blog-Leser Karl per Twitter gemeldet und folgenden Tweet als Antwort gepostet:

Ähnliche Artikel:
Risiko für Hyper-V durch RDP-Schwachstelle
Kostenlose Version von Hyper-V Server 2019
Windows 10 V1903: IP-Zuteilungs-Bug in Hyper-V-Switch
Hyper-V VM Shutdown-Problem in Windows Server 2019
Windows 10/Server 2016: Hyper-V-Problem durch Update KB4480977 bestätigt
Tipp: Hyper-V VMs mit einem GUI-Tool entfernen


Cookies blockieren entzieht uns die Finanzierung: Cookie-Einstellungen

Anzeige


Dieser Beitrag wurde unter Problemlösung, Virtualisierung, Windows abgelegt und mit Hyper-V, Problem, Windows verschlagwortet. Setze ein Lesezeichen auf den Permalink.

5 Antworten zu Hyper-V 2nd Gen: Betriebssystem lässt sich nicht installieren

  1. oli sagt:

    Ich habe schon länger 2x Windows Server 2019 als Gen2 mit aktiviertem Secureboot problemlos laufen. Unter "Firmware" (=Bootoptionen) ist bei mir die Netzwerkkarte ganz unten und die EFI-Bootdatei steht ganz oben. Wer natürlich Networkboot braucht, für den ist das keine Lösung, aber alle anderen sollten einfach das mal probieren.

    • Alitai sagt:

      Also bei mir jetzt es so, dass ich einfach warte bis die ISO gebootet wird. CPU läuft in der Zeit etwa bei 24%. Nach 1-2 Minuten geht's dann automatisch weiter.

  2. Michael sagt:

    Das Problem kenne ich auch, aber bei mir hilft ein ziemlich simpler Workaround. Einfach vor dem ersten Start der VM im Hyper-V Manager bei der Netzwerkkarte "Nicht verbunden" wählen, und man kommt über diese Hürde weg. Danach kann man die Netzwerkkarte wieder aktivieren.

  3. Thomas D. sagt:

    Moin Moin,

    Ich habe den Fehler auch jedesmal wenn ich eine VM aufsetze.
    Ich gehe immer rein in das Fenster und mache dann einen Neustart.
    Anschließend drücke Ich dann die any key taste und überwinde das Szenario.

    HyperV ist gut, aber gegenüber VMWare, das Ich auf der anderen Kiste benutze, sind ein paar kleinere Macken vorhanden.
    Unterm Strich muss ich aber an Pros das Fazit ziehen (VMWare 14 und HyperV 2019/W1803:)
    – HyperV kann mehr Maschinen mit akzeptabler Performance gleichzeitig laufen lassen
    – in VMWare kann Ich einer Maschine ohne Probleme mehr Performance zuweisen.
    – Übergaben von VM´s ist in VMWare nicht so problematisch über OVF.

    Einiges an Vorteilen die VMWare hat hat auch VirtualBox.
    Allerdings muss man bei VB auch Lizenzen zahlen als Unternehmen..

    So long
    Tom

  4. Michael Schreiber sagt:

    bei mir ging es erst auch nicht (server 2022) aber wenn nach Taste drücken gefragt wird, schickt man über das Menü Aktion der virtuellen Maschine Str-Alt-Entf
    dann bootet die maschine von dem ISO

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Hinweis: Bitte beachtet die Regeln zum Kommentieren im Blog (Erstkommentare und Verlinktes landet in der Moderation, gebe ich alle paar Stunden frei, SEO-Posts/SPAM lösche ich rigoros). Kommentare abseits des Themas bitte unter Diskussion.