Windows 10 V1903 zeigt plötzlich generische USB-Laufwerke

[English]Ein Bug in Windows 10 verunsichert momentan (seit dem Wochenende vom 9. November 2019) Nutzer, die USB-Speichermedien verwenden. Statt eines USB-Laufwerks wird nun im Explorer das Symbol für ein generisches Gerät angezeigt. Hier einige Informationen zum Problem.


Anzeige

Ich bin über diesen Kommentar im Diskussionsbereich des Blogs auf das Problem aufmerksam geworden (danke an Benutzer John Doe für den Hinweis).

Das Fehlerbild

Ich habe das Ganze auf zwei Systemen mit Windows 10 Version 1903 mit USB-Sticks getestet und eine interessante Beobachtung gemacht. Als ich einen USB-Stick in ein System eingesteckt habe, wurde mir dieser korrekt mit einer Bezeichnung und einem Symbol für ein Laufwerk im Explorer angezeigt.

Explorer mit USB-Laufwerken und generischem Symbol

In obigem Screenshot ist dies das Laufwerk G: mit der Bezeichnung antiXlive. Was aber schon auffällt: Das USB-Laufwerk D: wird mit einem generischen Symbol in Form eines stilisierten Computers angezeigt. Das Laufwerk hatte auf der Maschine kein Medium eingelegt, wird also ausgeblendet dargestellt. Ich habe dann den USB-Stick an einer zweiten Testmaschine angesteckt und den Explorer geöffnet. Dort wurde der USB-Stick bereits mit einem generischen Laufwerksymbol angezeigt.

Dann bin ich mit einem zweiten USB-Stick zum ersten Testsystem mit Windows 10 Version 1903 zurück und habe diesen eingesteckt. Zuerst wurde noch ein korrektes Symbol eingeblendet. Aber nach einigen Sekunden kam dann plötzlich das generische Laufwerksymbol mit einem stilisierten Computer. Also USB-Stick ausgeworfen und den USB-Stick, der ‘eben noch korrekt angezeigt wurde’ eingesteckt. Aber dieser wurde jetzt ebenfalls mit einem generischen Laufwerksymbol im Explorer dargestellt. In obigem Screenshot ist es das Laufwerk D: mit der Bezeichnung antiXlive.

Irgend etwas ist also mit der USB-Laufwerkerkennung passiert und Windows 10 V1903 blendet ein fehlerhaftes Gerätesymbol ein.


Anzeige

Geräte-Manager

Ich habe mir im Geräte-Manager die betreffenden Zweige anzeigen lassen. Der USB-Stick wird korrekt als SanDisk Cruzer Edge USB-Device angezeigt und im Zweig USB-Controller kann ich auch nichts auffälliges entdecken.

Mehrere Fundstellen im Web

Blog-Leser John Doe hat ja in seinem Kommentar auf mehrere Treffer im Microsoft Answers-Forum hingewiesen (hier, hier und hier). Eine deutschsprachige Meldung gibt es hier. Allen Benutzern ist gemeinsam, dass plötzlich das falsche (generische) Gerätesymbol im Explorer angezeigt wird. Ein Benutzer schreibt:

My USB drives shows either as a generic device or a non-specified device

As the title stated, all of my USB drives shows with a “generic device icon” in windows explorer, and when im about to remove my device it shows as “remove “device””, when I plug the device it shows the normal drive icon for a split seccond and then changes to a generic icon, which it doesnt affect the performance of my drives, but makes me suspect that something is wrong on my computer while detecting my usb devices.

I’ve attached some screenshots of this so you can understand me a little bit more

Cheers (I apologize if you have a hard time reading the screenshots because my pc is in spanish)

PS: Most of my usb drives are made by kingston and it normally shows as “Data Traveler x.0”

Ein MVP-Kollege schlägt im Thread ein Rollback der Treiber vor (was geholfen zu haben scheint). Greg Carmack gibt in diesem Thread eine Erklärung, was möglicherweise die Ursache sein könnte (siehe folgenden Text).

Geänderte Richtlinie oder schlicht ein Bug?

Der Hinweis von Greg Carmack zielt darauf ab, dass Microsoft im April 2019 seine Richtlinien zur Behandlung von Wechselmedien (USB-Speicher) geändert hat. Von Microsoft gibt es diesen Supportbeitrag zum Thema und ich hatte im Blog-Beitrag Windows 10 V1809: Richtlinie für USB-Medien geändert über diese Änderung berichtet. In diesem Blog-Beitrag gibt es eine Anleitung, wie man das Ganze wieder auf das vorherige Verhalten umstellt. Das Einfachste wäre also, diese Richtlinienänderung zurückzunehmen (obwohl ich skeptisch war, denn diese Änderung exiistert ja seit April 2019).

Das habe ich dann versuchsweise gemacht, den USB-Stick abgekoppelt und wieder angesteckt. In der Tat erschien kurz danach das korrekte Laufwerkssymbol für den USB-Stick im Explorer. Dachte schon, das Problem ist behoben. Als ich dann diese Zeilen eingetippt hatte und und auf der Testmaschine nachschaute, war aber wieder das generische Symbol in der Anzeige. Mir ist es nicht gelungen, die Änderung des Icons zu verhindern.

Welches Update verantwortlich ist, weiß ich nicht – möglicherweise das zum 8. Oktober 2019 ausgerollte kumulative Update KB4517389 (siehe Patchday Windows 10-Updates (8. Oktober 2019)). Oder kennt jemand von euch einen anderen Grund bzw. Fix für das USB-Anzeigeproblem? Oder hat jemand den Bug auch unter älteren Windows 10-Builds beobachtet?

Ich werde es jetzt mal in Englisch zusammen klopfen und versuchen, an die Entwickler zu melden.

Scheint ein Server-seitiges Problem

Ergänzung: Es sieht so aus, als ob das Ganze serverseitig über die Bereitstellung der Metadaten für erkannte Geräte falsch eingeordnet ist. Darauf weist ein nachfolgender Kommentar hin. Zudem scheinen auch Windows 7 und Windows 8.1 sowie ältere Windows 10-Build betroffen. Das würde die These, dass keine korrekten Metadaten von den MS-Servern geliefert werden, stützen. Allerdings habe ich keine Option gefunden, dies auf meinen Testsystemen zu verhindern. Es bleibt m.M.n. nur abwarten, ob Microsoft den Fehler behebt.

Ähnliche Artikel:
Windows 10 V1809: USB Type-C Shutdown-Bug bestätigt
Windows 10 V1903: Upgrade-Blocker externe USB-Speicher
Windows 10: Nicht genügend USB Controllerressourcen
Windows 10 V1809: Richtlinie für USB-Medien geändert
Windows 10: NetBIOS-Bug bei USB-Netzwerkadaptern


Anzeige
Dieser Beitrag wurde unter Windows 10 abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

46 Antworten zu Windows 10 V1903 zeigt plötzlich generische USB-Laufwerke


  1. Anzeige
  2. ubie sagt:

    Ist dieses denn jetzt relevant oder wichtig?
    Bei meinem WIN 10 Version 1903 auf einem HP-Läppi werden auch angezeigt
    Festplatte (c:) ; DVD-Laufwerk (D:), eine eingesteckte SD-Card als SDHC (E:) sowie wenn ich einen USB-Stick anschließe USB (F:).
    Gehe ich auf Eigenschaften, werden die konkreten Bauteile namentlich benannt, z.B. USB Sharkon usw.

    • Sherlock sagt:

      > Ist dieses denn jetzt relevant oder wichtig?

      Welches Icon für ein USB-Laufwerk angezeigt wird, hat in etwa die Relevanz von “Sack Reis in China”, sofern das Laufwerk korrekt funktioniert. Ohne diesen Artikel hätte ich die Veränderung wohl nie bemerkt. Für manche Leute scheint ein verändertes Icon allerdings existenzbedrohend zu sein. Da werden dann Stunden investiert, um das alte Icon zu restaurieren. Seit den letzten Updates hat der neue Chromium-Edge übrigens auch ein anderes Icon erhalten….

  3. Roland Moser sagt:

    Das Problem ist auf meinen beiden Win 10 1809 PCs auch vorhanden. Wie lange schon, weiss ich allerdings nicht, es ist mir erst jetzt aufgefallen.

  4. Anzeige

  5. Harald.L sagt:

    Es ist kein Win10-Problem, mein Win8.1 macht das seit kurzem genauso. Ich kopiere mal rein was ich im Winboard-Forum dazu geschrieben habe:

    https://www.winboard.org/threads/ploetzlich-neues-icon.265695/#post-1453879

    So, ich habe jetzt einen Verdacht zur Ursache des Icons: Da dürfte ein Onlinedienst von Microsoft dran schuld sein. Heute in der Arbeit, erster Arbeitstag nach Urlaub habe ich meinen USB-Stick am Firmen-PC (Win10) angesteckt. Er bekam das alte Laufwerks-Icon. Eine Stunde später fiel mir dann auf daß er jetzt das neue, generische Icon hat ohne daß was gemacht wurde. Links im Laufwerksbaum war noch das alte Icon, rechts unter “Dieser PC” das geänderte am Stick. Nach Schließen und Neustart des Explorers war auch links das geänderte. Der Stick war die ganze Zeit angesteckt. Unter “Geräte und Drucker” erscheint der Stick jetzt in einer eigenen Rubrik “Nicht angegeben” für unbekannte Gerätetypen mit Name einfach nur “Device”. In Eigenschaften/Hardware sehe ich dann die Typenbezeichnung und den Volumenamen.

    Grund dürfte sein wie man in der klassischen Systemsteuerung unter “Geräte und Drucker” sieht, daß manche Geräte besondere Icons bekommen. Installiere ich z.B. unseren großen Büro-Kopierer als Drucker hat er zuerst ein simples allgemeines Drucker-Icon. Nach einiger Zeit, die Installation ist längst beendet, manchmal erst am nächsten Tag bekommt er dann ein aufwendiges Icon das den Kopierer mit seinen Fächern usw. korrekt zeigt. Genauso bei meiner Logitech-Maus usw. Diese Sonder-Icons sind nicht beim Treiber-Setup dabei sondern dazu holt sich der Gerätemanager für die verschiedenen Geräte von einem Microsoft-Dienst online passende Icons.

    Die Einstellung dafür ist in Systemsteuerung – System – Erweiterte Systemeinstellungen – Register “Hardware” – Geräteinstallationseinstellungen. Die Einstellung ” … benutzerdefinierte Symbole automatisch herunterladen” ist standardmäßig aktiviert.

    Und anscheinend liefert dieser Online-Dienst derzeit für USB/SD-Medien kein oder kein brauchbares Ergebnis so daß eben das neutrale Symbol und die Kategorie “nicht angegeben” verwendet wird. Darum betrifft es auch mein Win8.1 (und wohl auch Win7) und wenn jemand sagt an USB2 stimmt das Icon dann einfach mal stecken lassen und warten, ich vermute nach einiger Zeit ändert sich auch da das Icon. Wenn das Gerät schon mal dran war kommt das Icon vermutlich erstmal aus dem Cache, wird dann aber irgendwann online kaputt-aktualisiert.

    • Ralf S. sagt:

      Danke für diesen Hinweis! Ich kann das für Win 7/Home Premium/64 Bit fast identisch bestätigen! Dachte schon, dass ich selbst irgendeinen Murks verzapft habe… Das “Phänomen” ist bei mir auch vor einigen Tagen plötzlich aufgetreten. Unter “Hardware sicher entfernen” in der Taskleiste wird allerdings bei mir zusätzlich zur Bezeichnung “Device” dann als Unterpunkt die richtige Laufwerksbezeichnung, als auch der richtige Name des USB-Geräts angezeigt. Unter “Geräte und Drucker” dann nur “Device” und unter “Computer/(Arbeitsplatz)” dann wieder alles korrekt…!

    • Roland Moser sagt:

      Ich habe das Problem an USB 2.0 und 3.0.

  6. NichtWichtig sagt:

    Ich nutze ab und an NirSofers Tool “USBDeview64.exe”. Damit lösche ich nicht mehr relevante USB-Infos aus der Datenbank und bin deshalb noch nicht auf dieses o.g. Problem gestoßen.

    Zumindest gibt es auf meinen System solche Phänomene nicht.

  7. Bernard sagt:

    Off-topic:

    Wie kann ich bei FAT32-formatierten USB-Sticks die Laufwerksbezeichnung mit Gross- UND Kleinschreibung hinbekommen?

    Neugekaufte Sticks zeigen die Laufwerksbezeichnung noch richtig an, doch nach einer Umbennung sind nur noch Grossbuchstaben zu sehen.

  8. Bernard sagt:

    Wie kann man den Download derartiger Symbole verhindern, falls man dies in der Vergangenheit erlaub hat?

    Wäre das eine Lösung.

  9. Anzeige

  10. Andreas Hofer sagt:

    Ich zitiere Harald L.:

    “Die Einstellung dafür ist in Systemsteuerung – System – Erweiterte Systemeinstellungen – Register “Hardware” – Geräteinstallationseinstellungen. Die Einstellung ” … benutzerdefinierte Symbole automatisch herunterladen” ist standardmäßig aktiviert.”
    Dort kann man das auch abstellen.

    Ich erinnere mich, daß ich das unter Windows 8.1 (oder schon Windows 7?) sehr früh abgestellt habe. Erst fand ich es toll, daß die Bilder viel genauer auf die Geräte passen. Aber dann hat es mich genervt, weil es eben immer wieder Probleme gab.

    • Günter Born sagt:

      Ich hatte das probiert, hat bei meinem Testsystem nichts gebracht.

      • Roland Moser sagt:

        Nützt bei mir auch nichts.
        Als IT-Laie sieht es für mich so aus, dass die Symbole jetzt auf dem PC sind. D.h. dass ein Ausschalten der Funktion nichts mehr bringt. Man müsste die Symbole manuell wechseln.

      • Harald.L sagt:

        An meinem Rechner, wo schon mal das falsche Icon auftauchte hat es auch nichts gebracht, auch nicht eine Systemrichtlinie (*) zu ändern und zu rebooten.

        Aber gerade vorher getestet: Am Rechner meiner Frau wo bestimmt ein halbes Jahr kein USB- oder SD-Medium angesteckt war habe ich die Einstellung geändert (und zusätzlich mit GPEDIT die entsprechende Richtlinie (*) aktiviert) und dann rebootet.

        Nach einem Reboot habe ich dann einen USB-Stick am Rechner meiner Frau angesteckt und der behielt dort das richtige Icon dauerhaft. Der gleiche USB-Stick hatte vorher an meinem Rechner ganz kurz das richtige Icon um dann, trotz der deaktivierten Einstellung zum falschen zu wechseln. Anscheinend, wenn ein Rechner einmal online das falsche Icon geladen hat wird das irgendwo lokal abgespeichert und dann trotzdem weiter verwendet. Nur auf Rechnern die seit Beginn des Problems keine USB/SD ansteckten und sich die falsche Info noch nicht online gezogen haben scheint das zu helfen.

        Jetzt müsste nur jemand wissen wo Windows diese Info speichert.

        (*) GPEDIT.MSC: Computerkonfiguration – Administrative Einstellungen – System – Geräteinstallation – Abrufen von Gerätemetadaten aus dem Internet verhindern -> Aktiviert

  11. Frank sagt:

    Bei 1909 wird es auch fehlerhaft angezeigt.

  12. Hrey sagt:

    Moin

    Auch exFAT formatierte Laufwerke (SD Karte)zeigen das seltsame verhalten.
    Wenn die Karte ausgeworfen werden soll,ist der Name “Device”,darunter
    dann die Bezeichnung der Karte(SDXC)und der Laufwerksbuchstabe.
    Alles sehr ominös.

    Hery

  13. Andreas B. sagt:

    Bei mir trat das gleiche Problem am Wochenende auf, aber mit wesentlich schlimmeren Auswirkungen als nur mit einem neuen Icon:

    Mitten beim Schreibvorgang wurde der (3.0er) USB-Stick (am 3.0er Port) nach jahrelanger Fehlerfreiheit plötzlich als “schreibgeschützt”(!) und mit diesem merkwürdigen “PC”-Icon angezeigt. Einige (gerade geschriebenen) Dateien und Ordner hatten danach nur noch kryptische Namen.

    (Ich ziehe einen USB-Stick niemals einfach so schnell ab, immer nur sicher per Klick auf “Gerät entfernen” !)

    Später hatten sogar sämtliche Dateien auf dem Stick nur noch kryptische Namen.
    Beim (Neu-)Einstecken in den Rechner (auch in einen anderen) meint Windows, der Stick hätte ein “Problem”, aber der angebotene Reparaturversuch scheiterte. Nicht mal neu formatieren lässt sich der Stick (mit diversen Tools versucht)… immer die gleiche Fehlermeldung, der Stick sei schreibgeschützt – oder “E/A-Fehler”.
    Alle Lösungsansätze aus dem Web (Reg-keys “WriteProtect=0″ setzen, DISKPART->”clean”, etc.) bringen leider nichts…

    Beim Scannen per HDTune werden dagegen keine kaputten “Sektoren” (Zellen) angezeigt, auch der Benchmark läuft wie gewohnt durch. Es lassen sich aber keine normalen Dateien/Ordner mehr lesen oder schreiben. Neuformatieren mit FAT32, exFat oder NTFS geht gar nicht… Noch nicht mal umbenennen lässt sich der Stick. (Er hatte auch einen kryptischen Namen bekommen.)

    “checkdisk a: /f /r” meint, der Stick hätte zuwenig Platz zum Speichern der Wiederherstellungsdaten… und ein Problem mit “querverlinkten Dateien”.

    Dachte zuerst, der Stick hat eben eine Hardware-Macke und kann weg, aber jetzt lese ich, dass anscheinend viele seit letzter Woche solche Probleme mit USB-Sticks unter Win10 haben… Nur wenige Stunden vorher hatte ich noch ein größeres Windows-Update (Patch) installiert. Vlt. liegt es daran ?

    Bin eher pessimistisch, dass das MS durch einen weiteren Patch wieder hinbiegen kann. Mein Stick (Medion Nano-Stick mit 32GB -> Intenso inside ??) ist wahrscheinlich für immer zerschrotet worden… :-(

    Hat noch jemand solche GAU-Erfahrungen gemacht ?

    • Andreas B. sagt:

      p.s.
      Ich bekomme im Event-Viewer seit dem Wochenende viele Fehler zu den “Metadaten”, was mich hierhin führte:

      https://social.technet.microsoft.com/Forums/en-US/4ffda40e-bc70-4a49-9423-cba3fdc7ec0d/devicemetadataserviceurl-httpgomicrosoftcomfwlinklinkid252669ampclcid0x409?forum=win10itprosetup

      Kann es sein, dass der Rechner bzw. der angesteckte USB-Stick vom MS-Server falsche Metadaten automatisch zugewiesen bekam, die ihn jetzt nur noch als “schreibgeschütztes Gerät” ausweisen ?

      • Manfred sagt:

        Ich würde versuchen, den Stick mit diskpart wieder herzustellen. Das sollte funktionieren, wenn die Datenträgerverwaltung es nicht mehr hinbekommt:

        VORSICHT bei Punkt 4!!

        1. Cmd-Fenster als Admin
        2. diskpart
        3. list disk
        4. Laufwerksnummer des Stick ablesen
        5. select disk x (x=LW Nummer des Stick)
        6. clean
        7. create partition primary
        8. active (nur notwendig, falls man vom Stick booten will)
        9. format fs=fat32 quick

    • Ismail sagt:

      Um alle möglichen Fehlerquellen auszuschließen würde ich Windows ohne Netzwerk/Internet neu installieren. Alternativ kann man von der DVD booten und dort im Installieren-Menü (Partitionen löschen und neu anlegen Fenster) den USB-Stick formatieren.

      • Ismail sagt:

        >>Mein Stick (Medion Nano-Stick mit 32GB -> Intenso inside ??) ist wahrscheinlich für immer zerschrotet worden… :-(

        Minitool oder Windows-interne Diskmanagement probiert?

        >> oder “E/A-Fehler”.

        Da nützt nur der Abgesicherter Modus

      • Andreas B. sagt:

        Internes Diskmanagement, Mini-Tool, Macrium Reflect, Paragon, administrative CMD-shell… alles vergeblich ausprobiert. :-(
        Obwohl die eigentlich schon ziemlich low-level arbeiten. Werde nochmal einen Bootstick der Tools ausprobieren…

        Zeitaufwendiges Neuinstallieren ist keine Option für mich, wenn es nur einen einzigen USB-Stick von mir betrifft, der nicht mehr beschreibbar ist.
        (Das Icon allein ist nur ein kleines optisches Problem bei all meinen USB-Sticks, mit dem ich bis zum nächsten Patch von MS gut leben könnte…)

        Ich hatte auf dem Stick zum Glück nur Backup-Dateien (Kopien) drauf, die noch auf dem Rechner sind. Also wenigstens kein Datenverlust.

        Ich will jedoch den Stick wieder zum Leben erwecken, weil es mich ärgert, dass er vlt. nicht von selbst sondern durch Windows “kaputt” gemacht oder blockiert wurde (was hoffentlich noch reparabel ist).

        Ich habe genau diesen Stick baugleich noch ein zweites Mal: Der 2. zickt nicht so herum, sondern zeigt “nur” das neue Icon (auf 2 Rechnern ausprobiert).

        Also wenn der Stick nicht tatsächlich zufällig auch einen HW-Fehler hat, dann ist das Problem evtl. dadurch entstanden, dass genau beim “Umstellen” des Sticks auf “generic device” ich zeitgleich viele Dateien darauf kopiert habe – die dann unleserlich darauf gelandet sind. (Mehr zufälliges Pech könnte man nicht haben.)

        Habe wenig Hoffnung, dass das MS noch zum aktuellen Patchday (oder überhaupt) gerade biegen kann.

    • TorstenJ sagt:

      Kannst du den Stick nicht an einem anderen PC testen? Bei dem Fehlerbild würde ich aber mit 99,9%iger Sicherheit auf einen Hardwaredefekt schließen.

      • Andreas B. sagt:

        Bei einem anderem PC zeigt er das gleiche Fehlerbild, also merkwürdiges Icon, kryptische Ordner- und Dateinamen, und kein Lese-/Schreibzugriff.
        Allerdings ist dort auch Win10-1903 installiert, d.h. auch dort zieht sich Windows automatisch die Metadaten+Icons von MS (weil ich es auf beiden PCs so eingestellt hatte).

        Was ich dazu sagen muss:
        Ich hatte die letzten Monate immer wieder mal Fehler im Eventviewer bzgl. der Webadresse, von der sich Windows die Metadaten zieht. Die ist in der Registry hinterlegt, aber leitet Anfragen immer um. Daher hatte ich den Pfad in der Registry direkt auf den Ziel-Webpfad (der MS-Server) umgeändert.
        … Vlt. hat MS da etwas an der Umleitung geändert, aber einige User verwendeten immer noch den (evtl. veralteten) “Direkt”-Link – und zogen sich dadurch evtl. veraltete Metadaten rein !?

        (Das wäre jetzt eine Vermutung zum Icon-Problem, nicht unbedingt eine Erklärung meiner ernsteren Stick-Probleme…)

    • Andreas B. SH sagt:

      Lieber Namensvetter:

      “… zuwenig Platz zum Speichern der Wiederherstellungsdaten …”
      bei der Datenträgerüberprüfung, das sieht für mich so aus, als ob hier der Hase im Pfeffer liegt. – Auf einem Stick, der nur zur Datensicherung dient, ist die Windows-Wiederherstellungs-Überwachung doch Nonsense.
      Weiß jetzt nicht, aber ich glaube, dies kann man unter den Wiederherstellungsoptionen (“Diesen Datenträger überwachen”) abstellen. Dort kann man, wenn ich mich recht erinnere, auch die Größe, die für die Wiederherstellung reserviert wird, festlegen; so man denn will. – Das ganze Gerümpel, das Windows dafür erzeugt, ist natürlich “hidden” usw. – Das angerichtete Elend müsste aber mit Knoppix sichtbar zu machen sein.

      Abgestürzte riesengroße Kopieraktion (!) via Windows-Explorer, das ist nach meinen schlechten Erfahrungen sowieso der Wiederherstellungspunkte-Killer par excellence unter Windows.

      Ich hatte hier schon öfters den “Totalcommander” von Ghisler als besseren Dateimanager empfohlen. (Es gibt auch andere.) Damit kann man sehr gut arbeiten. (Für Dateisicherungen ist bspw. “asymmetrisch synchronisieren” vom linken zum dem Stick im rechten Fenster ganz easy. – Als gebranntes Kind starte ich dafür erst den TC, beende den Windows-Explorer per Taskmanager, führe die Kopieraktion mit dem Totalcommander durch und hole mir danach den Taskmanager per Strg+Shift+Esc, starte dort dann unter Datei/Neuer Task “explorer” den Windows-Explorer neu.

      PS: So, weil Du meinen bisherigen User-Namen gekapert hast, muss ich mich halt jetzt wohl umbenennen. Oder bist Du etwa auch aus SH? ;-)

      • Andreas B. (aus NDS) sagt:

        Auf dem Stick war keine Windows-Wiederherstellungsüberwachung aktiv. Den Stick habe ich immer nur zum manuellen stupiden (Backup-)Kopieren von einzelnen Ordnern/Dateien benutzt – und zwar mit dem jahrelang bewährten Total-Commander (bei dem trotzdem das Problem auftrat…glaube aber nicht, dass er Schuld daran ist).

        Die noch aussagefähigsten Fehlermeldungen mit “nicht genug Platz” und “querverbundenen Dateien” stammten von “chkdsk x: /f /r”
        Alle anderen Tools inkl. Diskpart gaben nur solche knappen Fehlermeldungen aus: “Datenträger ist schreibgeschützt” oder “E/A-Fehler”.

        Werde bei Gelegenheit mal eine Reparatur auf “Boot-Ebene” versuchen… (denn auf low-level-Ebene lässt er sich ja noch beschreiben z.B. per HDTune-Benchmark, nur das Dateisystem oder die Partitionsverwaltung scheint eine Macke zu haben).
        …Das Löschen des lokalen Metadaten-Caches probier ich auch noch, auch wenn das bei Günter Born bisher nichts brachte.

        p.s. Bin Andreas B. aus NDS… ;-)

        • Andreas B. SH sagt:

          Ach so, dann ist die Meldung “… zuwenig Platz zum Speichern der Wiederherstellungsdaten …” mal wieder eine Falschübersetzung ins Deutsche und heißt: “… zuwenig Platz zum Speichern der wiederherzustellenden Dateien …”, bzw. in Wirklichkeit schlicht: “kann auf dem Datenträger nichts schreiben”. – Schade! Alles auf Anfang, wäre ja auch zu schön gewesen, wenn’s so einfach wäre.

  14. wufuc_MaD sagt:

    eine autorun.inf auf dem stick erstellen mit dem inhalt:

    icon = flash.ico

    und ein passendes icon mit korrektem namen und bildchen auf dem stick platzieren!?

    in weiser voraussicht hab ich genau das vor 10 tagen mit meinem schreibgeschützten stick unter linux getan. zu testen ob sich das als workaround eignet muss ich “betroffenen” überlassen.

    mfg

    • Bernard sagt:

      Muss die Datei autorun.inf in dem Fall nicht wie folgt lauten?

      [autorun]
      icon=flash.ico

    • Günter Born sagt:

      Ich denke, dass mit dem Autorun wird nicht funktionieren. Ich hatte einen USB-Stick, der genau so ein spezielles Icon aufwies, welches in der autorun.inf definiert ist. Kurz nachdem der Stick eingestöpselt wurde, wechselte das Symbol zum generischen Icon und das war es dann. Windows 10 ignoriert das Symbol in der autorun.inf.

      • wufuc_MaD sagt:

        ok.

        mein stick hat einen hardware-schreibschutz den ich nicht mehr unter windows entfernen werde. hab diesbezüglich genug negative erfahrungen gemacht (ein kaputter mit gelöstem schutz dank 1809.september, schlechte formatierung meines mp3-players..)

        ps: habe mir angewöhnt den dienst zur erkennung tragbarer geräte (wpdbusenum) zu deaktivieren.

        tut man dies werden einem stick folgende treiber zugewiesen:
        disk.sys
        ehstorclass.sys
        fltsrv.sys
        partmgr.sys

        tut mans nicht:
        wpdfs.dll
        wpdupfltr.sys
        wudfrd.sys

        vielleicht “hilft” das weiter. doch ich denke bezüglich usb wird eh noch einiges kommen..

        gruß!

  15. Ismail sagt:

    Die Metadaten dürften hier liegen:
    %LOCALAPPDATA%\Microsoft\Device Metadata\dmrccache

  16. Nobody sagt:

    Die Ursache scheint tatsächlich an einer Aktion zu liegen, die Microsoft erst in den letzten Tagen gestartet hat. Ich habe die Firma seit langem weitgehend ausgesperrt und mit meinem Windows 7 keine hier genannten Probleme.

  17. Bediener 1 sagt:

    Auf “Heise” gibt es ja einen Artikel, wie das F.. ermittelt: Es werden allen Sticks im “Supermarkt” ge…. (poisoned).
    Wie das genau geht… .?

  18. Harald.L sagt:

    Ein erster Erfolg (hier unter Win8.1): Dank des Tipps von @Ismail habe ich die Metadaten gefunden, allerdings bei Win8.1 unter C:\ProgramData\Microsoft\Windows\DeviceMetadataCache\dmrccache\en-us\, hier in einem Ordner f4e323bf-0f31-42b6-9ad6-5d5382d3fa83, wollte den komplett verschieben was nicht ging. Habe dann den Inhalt dieses Ordners in einen neuen Ordner auf dem Desktop verschoben (den Ordner also leer hinterlassen) und auch im übergeordneten C:\ProgramData\Microsoft\Windows\DeviceMetadataCache die dmrc.idx auf den Desktop verschoben.

    Nach dieser Aktion ohne Reboot davor (aber bei deaktivierter Option daß bei Geräteinstallation benutzerdefinierte Symbole geladen werden, siehe weiter oben) einen USB-Stick angesteckt der in den letzten Wochen nicht dran war und hurra, der behält sein richtiges Icon. Ein Stick den ich gestern probierte der bleibt beim kaputten Icon, der muß wohl mit einem Tool wie USBDEVVIEW von Nirsoft o.ä. komplett entfernt werden, teste ich noch. Die verschobene dmrc.idx wurde übrigens nach dem Anstecken des neuen Sticks neu erzeugt, die im dmrccache verbliebenen Symbole für Drucker, Logitech-Maus aus den anderen Ordnern usw. bleiben erhalten.

    Im verschobenen Ordner findet man eine PackageInfo.xml mit einer langen Liste von Hardware-IDs und im Unterordner DeviceInformation das ominöse Icon. Ich vermute in die ID-Liste ist irgendwas reingerutscht was da nicht hingehört. Ganz unten trägt die Liste die Info LastModifiedDate 2012-05-31, ja ja genau, die Dateien sind bei mir alle vom 07.11.2019.

  19. Anonymous sagt:

    Es könnte seltsam sein, weil es von einer Übersetzungs-App übersetzt wird.

    In meiner Umgebung habe ich mich offenbar erholt

    C: \ProgrammData \Microsoft \Windows \DeviceMetadataCache
    in
    dmrccache
    dmrc.idx
    Löschen von zwei
    (Entfernen Sie alle Dateien im DeviceMetadataCache)
    Neustart
    USB-Flash
    Bedienfeld > Geräte und Drucker > USB-Flash
    Entfernen
    Neustart
    Normalerweise

    Es ist nicht klar, welche weiteren Auswirkungen dies haben könnte

  20. Andreas Hofer sagt:

    Bei der Installation ist die Anzeige von Gerätesymbolen aus dem Internet zunächst deaktiviert. Zumindest ist das bei der Einzelplatzinstallation von Windows 8.1 und Windows 10 so. Ich belasse es am liebsten dabei.

    Microfoft verführt einen jedoch, diese Funktion zu aktivieren: Wenn man “Geräte und Drucker” in der Systemsteuerung aufruft, sieht man im oberen Bereich eine gelb hinterlegte Texteinblendung, die darauf hinweist, daß man gerätespezifische Symbole aus dem Internet herunter laden kann. Hat man das einmal gemacht, gibt es an dieser Stelle kein Zurück!

    Der Weg zurück ist vermutlich über die Gruppenrichtlinien möglich, auf jeden Fall über die Registry:

    ———————————————————————————
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Device Metadata]
    “PreventDeviceMetadataFromNetwork”=dword:00000001
    ———————————————————————————

    Abgelegt werden die Symbole unter Windows 8.1 sowie 10 hier:
    C:\ProgramData\Microsoft\Windows\DeviceMetadataCache

    Wenn man den Download der Symbole wieder deaktiviert, bleiben die heruntergeladenen Symbole erhalten.

    Zunächst finden sich unter
    C:\ProgramData\Microsoft\Windows\DeviceMetadataCache
    nur eine Datei dmrc.idx und ein Ordner “dmrccache” mit leerem Unterordner “downloads”.
    Sobald man Symbole heruntergeladen hat, füllt sich der Ordner und die dmrc.idx-Datei wird verändert.

    Weiter habe ich das nicht untersucht. Bei einem Test in einer VM war aber gerade auch das Standardsymbol für meinen Drucker verschwunden, und es wurde statt dessen das Symbol für ein leeres Dokument angezeigt, nachdem ich C:\ProgramData\Microsoft\Windows\DeviceMetadataCache komplett gelöscht hatte. Den gleichen Effekt hatte es, wenn ich nur die dmrc.idx-Datei gelöscht habe. Auch den kompletten Ordner mit den ursprünglichen Inhalten wieder herzustellen, half nicht. Da muß man also ggf. Vorsicht walten lassen…

  21. Harald.L sagt:

    Wurde inzwischen wohl serverseitig bei MS korrigiert, hilft aber nicht wenn man bereits betroffen ist. Habe folgendes erfolgreich an 3 Rechnern (2x Win10, 1x Win8.1) getestet:
    – Kein USB-Stick oder SD-Karte angesteckt, alles entfernt
    – Von mit gesetzte Richtlinie wieder zurückgestellt mit GPEDIT.MSC: Computerkonfiguration – Administrative Einstellungen – System – Geräteinstallation – Abrufen von Gerätemetadaten aus dem Internet verhindern -> Nicht konfiguriert
    – Von mir gesperrtes Nachladen von Icons usw. wieder erlaubt: Systemsteuerung – System – Erweiterte Systemeinstellungen – Register “Hardware” – Geräteinstallationseinstellungen.
    – Unter C:\ProgramData\Microsoft\Windows\DeviceMetadataCache die dmrc.idx gelöscht
    – Unter C:\ProgramData\Microsoft\Windows\DeviceMetadataCache\dmrccache\en-us\ nur den Ordner f4e323bf-0f31-42b6-9ad6-5d5382d3fa83 gelöscht, alles andere belassen
    – Gerätemanager geöffnet, Ansicht – Ausgeblendete Geräte anzeigen -> aktiviert
    – Im Gerätemanager unter “Laufwerke”, “Speichervolumes” und “USB-Controller” alle als grau erkennbaren nicht vorhandenen Geräte mit rechter Maustaste deinstalliert
    – den PC neu gestartet (ggf. nicht mal nötig)

    Jetzt werden alle USB-Sticks die am gleichen Rechner vorher Probleme machten wieder korrekt angezeigt. Auch in der Systemsteuerung – Geräte und Drucker stehen sie jetzt wieder unter “Geräte” statt “Nicht angegeben”. Und das bleibt auch so, die falschen Metadaten werden nicht mehr online nachgeladen obwohl ich es wieder erlaubt habe.

    Da muß ich jetzt bei jedem betroffenen Rechner mit der Prozedur halt durch, vielen Dank MS! Nur wer vom ca. 7.11. bis jetzt keinen USB-Stick, keine SD-Karte angesteckt hat der blieb verschont.

    • Günter Born sagt:

      Dank dir für die Ergänzung.

    • Info sagt:

      > “– Im Gerätemanager unter “Laufwerke”, “Speichervolumes” …(………)… mit rechter Maustaste deinstalliert.”

      ???
      Also von den Speichrvolumes(auch den Ausgegrauten) würde ich unter Win7 lieber die Finger lassen. Aus eigener Erfahrung, aus frühen Zeiten, kann einem das die Windows Funktion komplett zerlegen.

    • Andreas B. sagt:

      Vielen Dank, das hat bei mir sofort geholfen, dass zumindest das Icon-Problem gelöst wurde, selbst bei meinem defekten USB-Stick.

      Der wurde danach sogar kurz wieder als beschreibbar angezeigt, aber sämtliche Reparaturversuche schlugen danach wieder mit “E/A-Fehler” etc. fehl, und seitdem wird der Stick wieder als schreibgeschützt angezeigt (evtl. ein Selbstschutzmechanismus von Windows ?)
      Zumindest eine RAW-Partition mit (falscher) Partitions-ID (für FAT16 statt für FAT23 oder NTFS) wird mir jetzt angezeigt, aber löschen kann ich sie immer noch nicht.

      Werde den Stick versuchsweise an dem Rechner reparieren, an dem das Problem ursprünglich plötzlich am letzten Wochenende auftrat (hab irgendwo gelesen, dass die Rücknahme des automatischen Schreibschutzes nur dort wieder möglich sei)…De Hoffnung stirbt zuletzt, auch wenn das bisher schon ein riesiger vergeblicher Aufwand war – umso ärgerlicher, falls MS daran die Schuld trägt.

      Aber vlt. hatte ich auch nur Pech mit einem unabhängigen Hardwareversagen – will MS jetzt nicht falsch beschuldigen. (Aber die zeitliche Nähe war schon sehr auffällig, weil bis dahin jahrelang alles fehlerfrei mit dem Stick funktionierte.)

  22. Ismail sagt:

    @Andreas
    Wegen dem Usb-Stick, ähnliches ist mir vor ca. 10 Tagen auch passiert. Auch das Problem mit dem Schreiben, E/A usw… da haben Tools wie Minitool mir auch nicht genützt. Soweit ich mich noch erinnern kann, habe ich mein Stick im Windows-Installationsmenü mit diskpart neu eingerichtet.

    PS: Auf dem Installationsmenü gelangt mit Shift+F10 ins Command, also quasi Offline ohne jegliches Zugriff auf Usb-Stick.

  23. Bediener 1 sagt:

    Auf einem Asus Rechner ist das neue Symbol für den Rechner ein Schlupf Wodka Quader. Problematischer als die Symbole ist, in meinen Augen, dass es wieder Probleme mit den Protokollen gab (Zuverlässigkeitsverlauf etc.).
    USB Probleme in der letzten Zeit…
    Vor und nach Patchday…
    Beim Einstecken eines USB Sticks über HUB an einem Rechner mit MSI Mainboard:
    Endloses Fensteröffnen und im Zuverlässigkeitsverlauf Hardwaredefekt. Wird wohl
    ein Zufall gewesen sein, weil die EDV Qualität insgesamt auch im Hardwarebereich
    schwer nachgelassen hat!
    Bei USB Stick Problemen vielleicht mal mit einem Hex Editor schreibgeschützt öffnen.
    Manchmal ist es ein mechanisches Problem (kalte Lötstelle) der Kontroller ist ab-
    geraucht, oder der Speicher selber (meist nur Ausschuss oder B-Wareaus der SSD Produktion). Wenn die Daten wirklich wichtig sind, hilft nur ein professioneller Datenretter.

  24. Bediener 1 sagt:

    Frei nach Dan Br…, “The lost symbol” finde ich es schon merkwürdig, dass parallel am Zuverlässigkeitsverlauf herumgebastelt wurde: Alte Problemberichte lassen sich zwar noch aufrufen, aber in einer andern Konstellation zusammen mit den “Treibergeschichten”. Dass der Umbau unabhängig von den Patchdays erfolgte…???
    Seltsam !!!???
    Der “trusted installer” darf und kann alles. Auch mit “Verzögerung”.
    Logische Zeitb.m..n ???
    Gab`s bei einer bestimmten Serie von Cosair SSD`s auch!!!
    Auf Grund eines Firmware Fehlers war ab einem bestimmten Datum alles weg!
    A brave new World!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.