Windows 10 V2004: NCSI zeigt ‘Kein Internet’, obwohl online

[English]Windows 10 Benutzer stehen vor dem Problem, dass der Statusbereich der Taskleiste eine fehlende Internetverbindung signalisiert, das System aber trotzdem online ist. Der Fehler tritt auch im Windows 10 Mai 2020 Update (Version 2004) auf. Das verursacht bei verschiedenen Programmen Probleme.


Anzeige

Rückblick: Windows 10 Bug verhindert Internetzugang

Bereits im März 2020 hatte ich im Blog-Beitrag Windows 10: Bug verhindert (meist VPN) Internetzugang über Probleme mit dem Internetzugang berichtet. Ein Bug verhinderte, dass die Systeme einen korrekten Status der Internetverbindung ermitteln können.

Windows 10: Internet connection indicator shows issues(Quelle: Technet)

Das Netzwerksymbol im Benachrichtigungsbereich der Taskleiste kann im Network Connectivity Status Indicator (NCSI) einen eingeschränkten oder keinen Internetverbindungsstatus anzeigen. Laut diesem Artikel bei Bleeping Computer soll das Problem durch Updates wieKB4554364 behoben werden.

Windows 10 Version 2004 zeigt ebenfalls kein Internet

Der obige Beitrag bezog sich auf ältere Windows 10-Versionen. Inzwischen haben viele Nutzer ja das Windows 10 Mai 2020 Update (Version 2004) installiert. Und dort gibt es wohl ähnliche Probleme. Auf der Webseite administrator.de habe ich bei der Recherche zum Blog-Beitrag diesen Eintrag gefunden.

Windows 10 Build 2004 – Keine Internetverbindung wird angezeigt

wir haben gerade mit der Vorbereitung eines neuen Windows 10 Images begonnen. Als Basis dafür dient der Build 2004.

So weit sieht es schon mal ganz gut aus (Anpassungen).

Was mich jedoch etwas wuschig macht. Es wird immer angezeigt, dass kein Internetzugriff vorhanden ist. Internetzugriff ist natürlich doch da (Proxy). Da das mit unserem jetzigen Images auf Basis Build 1803/1809 einwandfrei funktioniert hat, gehe ich mal davon aus, das MS am Verfahren etwas geändert hat (NCSI).

Weiß Jemand, welche Änderungen MS gemacht seit dem Build 1809 hat, um den Internetzugriff von Windows 10 zu prüfen?

Gibt noch einen Benutzer, der das Problem für Windows 10 Version 2004 bestätigt. Blog-Leser Stefan hat sich nun mit diesem Kommentar gemeldet:

Hallo Herr Born,
zu dem Thema NCSI gibt es auch mit Windows 10 2004 ein Problem: der NCSI zeigt ‘kein Internet’, obwohl das Browsen funktioniert. Effekte sind u.a. Probleme mit Office 365/Outlook/OneDrive, aber nicht mit Teams. Mein Kunde hat das Verhalten scheinbar nur auf Rechnern, die LAN- und WLAN-Ausrüstung haben, und die VPN-/Proxy-Clients benutzen (noch nicht ganz geklärt).

Stefan schreibt dazu, dass Microsoft dazu bereits Tickets offen habe. Zudem gibt es im Technet einen Eintrag:

NCSI taskbar icon may report “no internet” on Windows 10 2004 devices that DO have internet access

Customers are reporting “no internet” access in the Network Connectivity Status Indicator (NCSI) on Windows 10 2004 devices on devices that in fact can ping internet resources or browse web sites with internet browsers.

Current situation:

Microsoft has known about this issue but haven’t resolved it yet.
It is being investigated by Microsoft currently.

Dort findet sich also die Bestätigung, dass Microsoft das Problem kennt, aber noch nicht behoben hat. Stefan fragt in seinem Kommentar, ob jemand schon Erfahrung mit dem Problem gemacht habe?


Anzeige

Dieser Beitrag wurde unter Internet, Windows 10 abgelegt und mit Internet, Problem, Windows 10 2004 verschlagwortet. Setze ein Lesezeichen auf den Permalink.

17 Antworten zu Windows 10 V2004: NCSI zeigt ‘Kein Internet’, obwohl online


  1. Anzeige
  2. Info sagt:

    Es ist ein anhaltendes Problem das “Thema NCSI” und zeigt wieder einmal die Katastrophe W10 auf – wie kann man ein Betriebssystem funktionell, allgemein, nur so ruinieren!

    Ich verwende seit 6 Monaten auf “einem” Gerät mit W10 1909 nur eine mobile Internet-Verbindung – externer USB-Stick.

    – In der gesamten Zeit habe ich diese fehlerhaften NCSI Anzeigen. Es hat aber auch vorab funktionelle Einschränkungen während des Verbindungsaufbau. Es “dauert bis zu einer Minute” bis beispielsweise vom System auf der untersten Ebene ein Ping auf eine bekannte WAN/IP/DNS Adresse möglich ist.

    – Eine weitere, bis zwei Minuten dauert es bis DNS Anfragen zugelassen werden und sonstiger http/https Datentransfer möglich ist. Danach eben auch die fehlerhaften NCSI Anzeigen. Dabei ist es egal ob Provider DNS oder ein Anderer.

    – NUR WENN EINE “MODEM DFÜ-VERBINDUNG”(RAS – nicht NDIS!) über das mobile Gerät aufgebaut wird, zeigt NCSI eine korrekte Verbindung an. Die Verzögerungen im Netzzugriff ist aber auch vorhanden! (Zudem geht das Herstellen der DFÜ-Verbindung ja nur noch über die Einstellungen/… Oberfläche und “nicht mehr” direkt über Tray oder Netzwerkverbindungen, oh nein… – des weiteren, das auf Modem-Basis keine automatische Wiederverbindung erlaubt ist!!!)

    Microsoft sollte das ganze mal intensiv überdenken – die Katastrophe liegt vermutlich auch bei den folgenden Komponenten und deren Zusammenspiel. Der Aufwand führt möglicherweise zu Timing-Problemen des Ganzen.

    – Gerätemanager/Softwäregeräte…
    – Task “svchost.exe -k Networkservice -p -s Dnscache”
    (zeitweise 50% CPU Last über Minute/n)
    – Defender Schutztechniken/Defender Firewall
    – Einstellungen/…/Datennutzung – Erfassung der aktiven WAN Verbindung
    – Die Task Priorisierungs-Technik oder wie es auch immer tönt…

    Zudem ist zu beachten das Windows zwar Lokal ipv6 verwenden kann – es aber WAN-Verbindungstechnisch, auch jetzt, möglicherweise nicht möglich ist/sein soll!

    Hoffnungslos…

  3. 1ST1 sagt:

    Da ist schon viel länger der Wurm drin, ich mag das aber nicht so unbedingt rein auf Win 10 (as a service) zurückführen, sondern laste das auch mangelndem Support durch die WLAN-Chipsatzherstellern an. Nicht nur dass das Netzwerksymbol den falschen Status anzeigt, sondern dass es auch z.B. nicht auf einen Klick reagiert, um die Verbindung zu prüfen oder herzustellen. Sind mehrere bekannte Accesspoints in der Nähe, verwendet das Ding öfters nicht den zuletzt verwendeten oder den stärksten, sondern irgendeinen schwächeren. Ich behelfe mir dann so, dass ich in die Adaptereigenschaften gehe, die WLAN-Karte deaktiviere und wieder aktiviere, und dann schwupps gehts wieder. Daher vermute ich ein Problem im Zusammenspiel zwischen dem Betriebssystem mit bestimmten WLAN-Chipsätzen bzw. deren Treibern, bei mir ist es ein RaLink RT3290, für den es schon eine Weile keine neueren Treiber mehr gibt, der neueste wurde von Win 10 selbst ausgeliefert und ist von 2017. Für RaLink Hardware fühlt sich halt keiner mehr verantwortlich, gehört zu MediaTek, dort ist der neueste Treiber von 2015. Hier habe ich diverse Leidensgenossen: https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/limited-wifi-connectivity-on-ralink-rt3290-driver/044c5f00-894a-4766-8f1d-1461c0465628?auth=1 Bei mir wurde es etwas besser, nachdem ich das HP-Notebook geöffnet habe, und eine zweite WLAN-Antenne, ursprünglich war nur eine für ANT+ im Displaydeckel verlegt, jetzt ist auch eine für ANT- rund um die Tastatur verlegt, aber ganz weg sind die Probleme nicht. Eigentlich wollte ich mal eine WLAN-Karte mit Intel-Chip einbauen, damit weigert sich das HP-Notebook aber zu booten, es ist per BIOS auf die Ralink-Karte “verdongelt”.

    • Info sagt:

      Diverse Treiber werden “nur noch” über Windows(W10) ausgeliefert – vor allem für zeitgemäße “Geräte/Rechner”. Soweit hat Microsoft große Hersteller inzwischen wohl überzeugt. Die Hersteller pflegen ihre Support-Seiten nicht mehr – dort sind meist nur frühe Treiberkollektionen der Markteinführung des Gerätes vorhanden, die eine Funktion garantieren sollen, aber alles andere als aktuell sind.

      Ob das nun positiv/negativ ist lasse ich mal offen. Der lästige Kunde hat eben keine Wahl mehr was oder wann installiert wird sowie einen möglichen Verlust des Funktionsumfang. Entspricht eben W10 (as a service) und das geht weiter.

      Ändert aber nichts daran, Microsoft bekommt grundlegende Funktionen kaum noch geregelt oder deaktiviert sie vorsätzlich. Um die Funktion Ihrer aktuellen chaotischen “Einstellungen Oberfläche” zu gewährleisten – und das ist der “einzige Task” der hier regelmäßig verendet. Wenn er minimiert im Tray, wieder über “Click” geöffnet wird(egal welche Priorität/Grafik-Priorität).

  4. Anzeige

  5. Mark Heitbrink sagt:

    Ich schalte die aktiven Tests der Netzwerkverbindung immer ab. Seit 2004 erkennt die NLA aber wesentlich später, das es Internet gibt. Hat es jemand schon mit einem alternativen Host statt msftconnecttest.com versucht?

    Ich probier’s Mal aus …

    • Mark Heitbrink sagt:

      GPO umgestellt auf “Aktive Tests zugelassen” und über Administrative Vorlagen\Netzwerk\Netzwerkverbindungs-Statusanzeige einen eigenen Host hinterlegt, der zur Prüfung dient.
      NCSI reagiert jetzt wieder direkt auf Änderungen. Verhalten ist wie gewünscht.

  6. Eberhard Scherb sagt:

    Bei mir (2004, 19041.264) hat es geholfen, HKLM\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing auf 1 zu stellen.

  7. Alexander Meckelein sagt:

    Ich stelle mal die heretische Frage, wozu benötige ich überhaupt so einen Indikator?
    Oder spezieller, warum verlassen sich Softwarehersteller überhaupt auf diese Information?

    Habe ich eine Software die Offline laufen soll, benötige ich die Info nicht.

    Habe ich eine Software die auf Online Services zurück greift, prüfe ich doch besser selber ob die von mir benötigten Services erreichbar sind. Hierdurch kann ich auch aussagekräftigere Fehlermeldungen an den Anwender abschicken.

    Auch hilft mir diese Info nicht bei der Problembehebung. Wenn der Indikator nicht in der Lage ist eine Verbindung zu msftconnecttest.com aufzubauen, kann dies viele Ursachen haben. Angefangen von DNS Problemen, dann bin ich aber nach wie vor Online, bis hin zu das die Telekom Backbone Anbindung mal wieder überlastet ist und Pakete droppt.

    Auch sind mir schon einige Fälle unter gekommen, in dennen der Indikator fehlerhaft Online angezeigt hat, warum auch immer.

    Übertrieben gesagt, erinnert mich der Indikator immer daran, dass MS in der Lage ist zu protokolieren wann ich meinen PC ein- bzw. ausgeschaltet habe.

    just my two cents

    • Mark Heitbrink sagt:

      Wozu der Indikator? Damit dein Mobildevice keine Internet Verbindung aufbaut, wenn du es nicht möchtest. Keine Verbindung, kein Trafficversuch.

      Stichwort: One Device, Volumenverträge wtc

  8. Alitai sagt:

    Es geht auch über gpo’s:

    Computer Configuration\Computer Configuration\Administrative Templates\System\Internet Communication Management

    Turn off Windows Network Connectivity Status active tests

    und

    Computer Configuration\Policies\Administrative Templates\Network\Network Connectivity Status Indicator

  9. Anzeige

  10. Dat Bundesferkel sagt:

    Joa, hab das Ding auch gerade mal wieder bei mir in der Systray. Hatte leider vergessen mein Smartphone vom USB Kabel abzuziehen, als ich den PC aus S3 geweckt habe.
    Das Symbol bleibt jetzt so lange unten bestehen, bis ich den PC einmal neu starten werde – ohne angeschlossenes Smartphone.

    Bei meinem “Normalgebrauch” egal, alles funktioniert. Windows Update? WSUS lokal. … aber die üblichen Apps aus dem Microsoft Store funktionieren nicht mehr: Wetter, Netflix etc. pp – weil… NCIS sagt, hier gibbet kein Internet, also kann es auch keines geben. Völlig egal, ob der Benutzer gerade munter auf seinem Eyefinity im WehWehWeh unterwegs ist.

  11. Auchmawat sagt:

    Hier: –> https://www.ghacks.net/2020/07/19/windows-10-version-2004-may-show-no-internet-even-though-there-is-internet-access/

    Der letzte Beitrag hat funktioniert:

    After reading

    https://docs.microsoft.com/en-us/windows/privacy/manage-connections-from-windows-operating-system-components-to-microsoft-services#bkmk-ncsi

    about the NCSI, I just changed in the registry the following configuration to point the old MS servers:

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\NlaSvc\Parameters\Internet]

    “ActiveDnsProbeContent”=”88.221.52.97”
    “ActiveDnsProbeHost”=”www.msftncsi.com”
    “ActiveWebProbeContent”=”Microsoft NCSI”
    “ActiveWebProbeHost”=”www.msftncsi.com”
    “ActiveWebProbePath”=”ncsi.txt”
    “EnableActiveProbing”=dword:00000001

    And voilà, working again :)

  12. Herr K. aus L. sagt:

    @ Auchmawat

    Vielen Dank für die Angabe Deiner Registry-Einträge
    Die 1:1 -Übernahme Deiner Einträge scheinen nach einem Neustart mein gleichartiges Problem gelöst zu haben.. :-)

  13. von Wartburg sagt:

    @ Auchmawat

    Danke! Bei mir haben die Registry-Einträge ebenfalls geholfen. Der Parameter “EnableActiveProbing” war bei mir bereits auf 1 und konnte somit nicht die Lösung sein. Das Einstellen aller Einträge hat geholfen!

  14. Wipe sagt:

    @alitai:

    “Computer Configuration\Policies\Administrative Templates\Network\Network Connectivity Status Indicator”

    Was muss ich da wo eingeben oder verändedrn?

  15. Andre S. sagt:

    Microsoft hat am Dienstag das KB4579311 veröffentlicht, welcher bei uns das Problem Fall gelöst hat. Also falls ein Betroffener das liest, schaut mal nach, ob der Patch bei euch installiert ist.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Hinweis: Bitte beachtet die Regeln zum Kommentieren im Blog (Erstkommentare und Verlinktes landet in der Moderation, gebe ich alle paar Stunden frei, SEO-Posts/SPAM lösche ich rigoros). Kommentare abseits des Themas bitte unter Diskussion.