Windows 10 20H2: Upgrade löscht Administratorkonto

Mir ist eine Benutzermeldung zugegangen, dass ein Windows 10 Version 20H2 bei der Upgrade-Installation das einzige Administratorkonto verloren habe. Ich stelle den Vorfall mal hier im Blog ein, um herauszufinden, ob es weitere Betroffene gibt. Ähnliche Fälle gab es schon mit älteren Windows 10-Upgrades.


Anzeige

Der Vorfall ist mir über Facebook in einer privaten Mitteilung von Markus P. zugegangen. Er ist in einem Systemhaus aktiv, das Problem trat bei einem Kundensystem auf. Zum Fehlerbild schreibt Markus folgendes:

[…] wir haben gestern auf einem Laptop das Update auf 20H2 installiert. Nach einem Neustart (ohne Fehlermeldung – es sah alles gut aus) war der bisherige Benutzer "admin" verschwunden. Neu angelegt war ein Benutzer "administrator". Alle Benutzerdaten von admin sind verschwunden (auch in windows.old). Das Update lässt sich nicht rückgängig machen da der automatisch neu angelegte Administrator erst entfernt werden soll. Dies geht aber nicht da er der einzig aktive Windows-Benutzer ist. Wir haben wegen einem Windows-Update nicht extra ein Backup erstellt. Somit haben wir jetzt einen Kunden mit einem langen Gesicht. Falls wir nicht die Einzigen mit diesem Problem sind wäre ich natürlich für einen Tipp dankbar.

Ein solcher Fall ist mir bisher nicht unter die Augen gekommen und auch bei einer Suche habe ich nichts gefunden. Aber bei dieser Konstellation fallen mir einige Sachen ein.

  • Ich hatte mir mal gemerkt, dass man tunlichst kein Administratorkonto mit dem Namen 'Admin' verwenden solle, weil es immer wieder Schwierigkeiten gibt. Das Problem ist, dass 'Admin' in 'Administrator' vorkommt, was ja der Name des Build-In-Administratorkonto ist. Ein Konto mit dem Namen 'Administrator' lässt sich daher nicht anlegen. Immer wenn eine Windows-Funktion den Kontennamen nicht vollständig abprüft, kommt es dann zu einem Konflikt. Möglicherweise ist dies eine Ursache für die obige Beobachtung.
  • Wird ein Administratorkonto gelöscht (geht in der Benutzerverwaltung aber nicht), aktiviert Windows beim nächsten Boot-Vorgang das Build-In-Benutzerkonto Administrator . Normalerweise sollte man sich dort anmelden und weitere Benutzerkonten anlegen können.

Dass die Benutzerdateien verschwunden sind und sich auch nicht im Ordner windows.old befinden, ist doof, aber im Grunde nicht neu. Die Fälle sind schon mal vorgekommen. Jemand, der dieses Verhalten schon mal beobachtet hat?

Ähnliche Artikel:
Vom Windows-Administratorkonto ausgesperrt – Teil I
Vom Windows-Administratorkonto ausgesperrt – Teil II
Kardinalfehler beim Einrichten von Benutzerkonten
Windows 10 V1809: Upgrade deaktiviert 'Administrator'-Konto
Administratorrechte durch Umstufung zum Gastkonto verloren
Windows 10: Administratorrechte verloren …


Cookies blockieren entzieht uns die Finanzierung: Cookie-Einstellungen

Anzeige


Dieser Beitrag wurde unter Update, Windows 10 abgelegt und mit Problem, Update, Windows 10 20H2 verschlagwortet. Setze ein Lesezeichen auf den Permalink.

12 Antworten zu Windows 10 20H2: Upgrade löscht Administratorkonto

  1. Dabbelju sagt:

    Zwar löschte das letzte Update nicht das Adminkonto, doch einer meiner Rechner ist seitdem platt. Zu allem Überfluss auch noch der an dem Bild- und Videobearbeitung stattfindet. Kein Programm ist bereit zu starten. Es wird jedesmal ein Dateifehler angezeigt. Selbst nachdem das Backup aufgespielt war und erneutem Updateversuch, gleiches Szenario. Nach dem 3. Versuch abgebrochen.
    Nach vielen Jahren problemlosen updates, das erste Mal, dass ein update von Win 10 mir ein System zerschossen hat. Es ist also eine Neuinstallation nötig.

  2. Chris sagt:

    Das Adminpasswort lässt sich zurücksetzen, sowohl über reine Windows Bordmittel, als auch mit der Hilfe von Tools:

    Mit Bordmittel: (hab ich selber noch nicht getestet)
    https://www.passcope.com/de/how-to-reset-windows-10-administrator-password-using-command-prompt/

    Mit LSMC Tool: (Funktioniert aus eigener Testerfahrung)
    https://www.rmtechcentral.com/lsmc/

    Keine Dauerlösung, wer will schon nach jedem Update das AdminPW reseten, aber zumindestens bekommt der Kunde so wieder Zugriff auf sein Gerät.

    Für alles weitere müsste man zur Analyse mal in die Upgrade Log Dateien gucken.

  3. Hans sagt:

    Das Benutzerprofil befindet sich nur in NT 4.0 im Systemordner, ab Windows 2000 gibt es einen extra Stammordner dafür. Wenn so ein Benutzer gelöscht wird und scheinbar wird dann so ein Benutzer restlos entsorgt, dh sein Benutzerordner wird dann eben auch gelöscht.

    Deswegen kann sich auch nicht da etwas irgendwo im Windows.old an Benutzerdaten finden, ausser jemand hat da dort drinnen etwas explizit reingeschrieben.

  4. Mecki sagt:

    Das Problem hatte ich auch. Das Problem ist aber erst aufgefallen als der PC aus der Domäne genommen wurde und ich mich dann nicht mehr mit dem Admin anmelden konnte.
    Wurde dann mit dem utilman.exe / cmd.exe Trick umgangen. War aber erst mal nervig.
    Nun kenne ich auch den Grund dafür.

    • Henry Barson sagt:

      Das funktioniert spätestens seit den 18xxer Versionen von Windows 10 nicht mehr, es sei denn man hat wissentlich und auch willentlich entsprechende Sicherheitsvorkehrungen und -funktionen deaktiviert, was man tunlichst vermeiden sollte.

      • Thomas D sagt:

        Moin
        Inwiefern?
        Ich bin durch Tests schon mit nach 18xx Versionen den Utilman change zu machen gezwungen gewesen.

        Funktionierte.
        Nur direkt danach, ja. Dann wurde dies vom Defender entsprechend entfernt.
        Aber DAS ist ja auch völlig korrekt.
        Das andere funktioniert dann nicht wenn man verschlüsselt hat.
        Oder aus Performancegründen die utilman entfernt hat wie Ich bei Tests mit
        https://flings.vmware.com/vmware-os-optimization-tool
        Feststellen musste :-)
        Ein gutes aber gefährliches Tool.
        Es zeigt schnell wie verwoben in Windows alles ist wenn man etwas damit deaktiviert und anderes nicht mehr so funktioniert wie gedacht ;-)

        Mein Senf
        Thomas

  5. Ärgere das Böse! sagt:

    Das hatte ich scbon mehrere Male, aber nur mit einem Benutzer-Konto. So wie ich es sehe, tritt das Problem beim ersten Konto auf, bei dem man sich nach dem Update einloggt.
    Das sollte helfen, bzw. hilft bei mir: Ins Konto einloggen, wieder ausloggen, wieder einloggen und dann sollte das Konto wieder da sein. Mit einem Admin-Konto hatte ich das Problem noch nie, da ich mich immer mit dem Benutzer-Konto anmelde.
    Wenn Du noch nichts rumgebastelst hast, könnte es helfen.

  6. L. v. A. sagt:

    @Günter:

    >> … dass man tunlichst kein Administratorkonto mit dem Namen ‚Admin' verwenden solle… <<

    Könnte es helfen, den User "Admin" vor dem Upgrade umzubenennen? Der Ordner wird dabei allerdings nicht umbenannt, nur der Kontoname.

  7. Fabian Kütbach sagt:

    Guten Tag,

    weiß jemand, ob das Problem mittlerweile von Microsoft gefixt wurde?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Hinweis: Bitte beachtet die Regeln zum Kommentieren im Blog (Erstkommentare und Verlinktes landet in der Moderation, gebe ich alle paar Stunden frei, SEO-Posts/SPAM lösche ich rigoros). Kommentare abseits des Themas bitte unter Diskussion.