Windows 8.1: Backup-Probleme bei UEFI/GPT-Datenträgern

Bei Windows 8 und Windows 8.1 gibt es ja noch die Möglichkeit, eine Systemabbildsicherung mit Bordmitteln durchzuführen. Klappt hier in meiner BIOS-Umgebung auch. Allerdings hat es den Anschein, als ob Anwender  in UEFI-/GPT-Umgebungen in böse Probleme laufen. Im Sinne “Versuch, ein paar lose Fäden zusammen zu knüpfen”, schiebe ich hier mal einige Infos zusammen.


Werbung

Systemabbildsicherung in Windows 8.1

Auch in Windows 8.1 hat Microsoft nochmals die in Windows 7 bereits vorhandene Funktion zum Erstellen eines Systemabbilds auf externe Datenträger eingebaut.

  1. Lassen Sie in der Systemsteuerung nach Dateiversionsverlauf suchen und wählen Sie diese Funktion an (obiger Screenshot).
  2. Dann lässt sich in der linken unteren Ecke des Fensters der Befehl Systemabbildsicherung anwählen (folgender Screenshot).

Nach Anwahl des Befehls erscheint das nachfolgend gezeigte Dialogfeld zum Anfertigen  einer  Systemabbildsicherung auf DVD oder auf einer separaten Festplatte (bei Windows 8.1 Pro wird auch eine Sicherung auf Netzwerkfreigaben angeboten).

So weit so gut. Ich habe die Funktion in meinen virtuellen Maschinen mit Windows 8.1 und an einem (BIOS-basierenden) WeTab Tablet PC getestet – funktioniert wie erwartet. Und in der Linkliste am Artikelende gibt es Verweise auf Beiträge, wo ich das unter Windows 8 auch nutze.

Die Backup-Funktion von Windows gilt vielen Nutzern als etwas unzuverlässig. Zu häufig gibt es Fehlerabbrüche – im Anhang gibt es einen länglichen Artikel mit Troubleshooting-Tipps [a1]. In meinem Windows 8.1-Basiswerk beschreibe ich daher die Backup-Funktion auch nicht – obwohl ich die durchaus nutze.

Ein Problem auf UEFI-Systemen mit GPT-Datenträgern?

Normalerweise könnte ich jetzt zur Tagesordnung übergehen und gut ist. Allerdings bin ich im Microsoft Answers-Forum zu Windows 8.1 auf diesen Thread gestoßen, in dem mehrere Anwender übereinstimmend berichten, dass die Backup-Funktion bei ihnen scheitert. Die Systemabbildsicherung bricht mit der Meldung “Nicht genügend Speicherplatz vorhanden.” und dem Fehlercode 0x80780119 ab.

Und in einem zweiten Forenthread (siehe auch) hat Communitymoderator-Kollege Sven Mähl noch ein paar Screenshots gepostet. Hier ist seine Liste der zu sichernden Partitionen.

Bild

Es werden sowohl die EFI-Partition und die Wiederherstellungspartition (Systemreserviert) als auch die Windows-Partition zur Sicherung markiert. Beim Ausführen der Sicherung bricht diese dann mit folgendem Fehler ab.

Bild

Mich erinnerte dies an den unter [a4] beschriebenen Fall. Allerdings gibt es da ein kleines Problem bei der Evaluierung: Die Leute, bei denen dies auftritt, arbeiten mit UEFI-Systemen, wobei für das 64-Bit-Windows eine GPT-Partitionierung auf dem Datenträger verwendet wird. An dieser Stelle beginnen die “Pferde buchstäblich vor der Apotheke zu kotzen”, wie mein erster Cheffe vor 34 Jahren zu sagen pflegte.

Eine Vermutung – aber keine Möglichkeit zur Verifizierung

Ich habe es im Artikel Win 8-Datenträgerverwaltung: Falle bei GPT-Systemdisks thematisiert – in der Windows-Datenträgerverwaltung ist der Zugriff auf GTP-Disks nicht vollständig implementiert. Damit erlebt man als Benutzer bei einer GPT-Disk in der Datenträgerverwaltung einige unangenehme Überraschungen (hier ein Screenshot aus einer virtuellen Maschine mit erzwungener EFI-Umgebung und GPT-Partitionierung).

  • Die Datenträgerverwaltung unterschlägt generell die 128 MByte MSR-Partition in der Anzeige (bei Datenträger 0 findet sich in obigem Screenshot nix).
  • Die Partitionsbelegung der beiden Systemdisks (300 MB Wiederherstellungspartition, 99 MByte FAT32 EFI-Systempartition) wird im oberen Teilfenster fälschlich mit 100 % angegebenen. Das ist definitiv falsch – man hat also keine Möglichkeit, die belegte Kapazität festzustellen.
  • Im Kontextmenü der Partitionen (Rechtsklick auf die Partition) fehlen bei System-Partitionen die unter MBR-Datenträgern üblichen Befehle, um einen Laufwerksbuchstaben zuzuordnen.

Man kann also nicht viel im Hinblick auf eine Diagnose tun – hier habe ich zwar noch einen Kniff beschrieben – aber der Zugriff ist ohne Fremdtools problematisch. Was ginge: Versuchsweise die Wiederherstellungspartition auf 500 MByte vergrößern (was aber für Windows 8.1 geeignete Fremdtools als Partition Manager erfordert). Mangels UEFI-Hardware und auch wegen fehlender Zeit kann ich hier wenig testen.


Werbung – meine Windows 8.1 Titel –

Workaround: BIOS-Compatiblitätsmodus

Im verlinkten Forenthread gibt es ja den Hinweis, das UEFI-Board in den Legacy-BIOS-Mode umzustellen – so dass das Backup nach einer Neuinstallation auf einer MBR-Disk funktioniert. Ist aber nicht befriedigend – und so habe ich eine Recherche bezüglich des Problems durchgeführt.

Bring Licht hinein: Möglicherweise die Erklärung

Dabei bin ich auf diesen Beitrag gestoßen, der etwas Licht ins Dunkel bringen kann. Der betreffende Anwender verwendet dort zwar wbadmin zur Systemabbildsicherung. Aber es gibt dort folgenden Hinweis:

Ein Microsoft Support-Engineer hat dem betreffenden Anwender wohl bestätigt, dass wbadmin nicht auf UEFI-Systemen mit Windows 8.1 funktioniert. Grund ist, dass der verwendete Volumenschattenkopiendienst – Volume Shadow Service (VSS) – keine Schattenkopien der FAT32 EFI Partition anfertigen kann. Volumenschattenkopien sind nur auf NTFS-Datenträgern möglich.

Und damit fällt ein wichtiges Puzzleteil an die richtige Stelle. Auch die Windows Systemabbildsicherung setzt auf dem VSS-Dienst auf und versucht alle Systempartitionen zu sichern. Da aber keine Schattenkopien von FAT32-Partitionen möglich sind, die EFI-Partition aber gesichert werden soll, dürfte dies das Problem für den Abbruch des Backups sein.

Im oben verlinkten Beitrag wurde der Tipp gegeben, eine administrative Eingabeaufforderung über Als Administrator ausführen aufzurufen und dort den folgenden Befehl auszuführen:


Werbung

wbAdmin start backup -backupTarget:E: -include:C:

Hier wird das Laufwerk C: auf das Ziellaufwerk E: gesichert, wobei der Parameter –allCritical weggelassen wird. Dann sichert wbadmin keine Partition “Systemreserviert” und auch keine EFI-Partition. Man erhält die Warnung, dass die Sicherung nicht zur Wiederherstellung des Systems per Recovery verwendet werden kann (weil die “Systemreserviert” etc.) fehlt. Aber man hat eine Sicherung der Windows-Partition und kann diese ggf. in einer gebooteten Windows PE-Umgebung zurücklesen (hilft, solange die “Systemreserviert”- und EFI-Partitionen in Ordnung sind).

Unterm Strich: Es schaut so aus, als ob es in der Windows 8.1-Backup-Funktionen einen dicken Bug beim Sichern von UEFI-/GPT-Systemen gibt. Und da die Systemabbildsicherung für zukünftige Windows-Versionen abgekündigt ist, bin ich mir auch unsicher, ob Microsoft da noch was fixt oder ändert.

An dieser Stelle seid ihr gefragt. Wenn ihr eine solche Systemumgebung habt, könnt ihr meine Informationen bzw. Theorie prüfen und ggf. hier in Kommentaren die Vermutung bestätigen oder widerlegen.

Erste Rückmeldungen zum Thema

Ein Kommentar ist mir direkt von einem Betroffenen per E-Mail zugegangen, da er den Artikel vorab lesen durfte. Hier die Rückmeldung.

“der Artikel ist sehr gut geschrieben, die Problematik wird im Kern getroffen. Über den wbadmin Befehl lässt sich das System problemlos sichern. Ob es sich problemlos zurücksichern lässt, habe ich noch nicht ausprobiert.”

Im Forenthread [3] gibt es bereits einen Nachtrag, dass sich das mit wbadmin gesicherte Abbild nicht zurücklesen ließe. Hier ist es wichtig, dass das Zurücklesen ebenfalls mit wbadmin erfolgt – da die Windows PE-Funktionen ja ein vollständiges Systemabbild mit Wiederherstellungspartition und EFI-Partition erwarten (was aber per wbadmin nicht gesichert wurde).

Nachtrag: Zielverzeichnis löschen, VSS vergrößern

Über die Trackbacks bin ich auf diesen Beitrag gestoßen, wo das Löschen des Sicherungsordners und möglicherweise das Vergrößern des VSS Abhilfe brachte.

Ähnliche Artikel:
a1: Windows-Backup Fehlerdiagnosen
a2: Windows-Backup: Befehlszeilenoptionen
a3: SystemProfile: Backup-Fehler 0×80070002
a4: Windows 7 Backup-Error 0×81000019
a5: Backup-Lösungen für Windows 8
a6: Behält Windows 8.1 RTM doch die Backup-Funktion?
a7: GPT-FAQ: Wissen zu GPT-Datenträgern
a8: Win 8-Datenträgerverwaltung: Falle bei GPT-Systemdisks

Windows 8/8.1 Diagnose- und Troubleshooting-Artikel
i: Windows 8.1 Upgrade-Troubleshooting FAQ – Teil 1
ii: Windows 8.1 Upgrade-Troubleshooting FAQ – Teil 2

iii: Windows 8 Upgrade-Troubleshooting FAQ – Teil 2
iv: Windows 8 Upgrade-Troubleshooting FAQ – Teil 3

v: Windows 8.1: Upgrade als ESD-Version doch möglich
vi: Windows 8.1: So funktioniert das Upgrade von Windows 8 – I
vii: Windows 8.1: So funktioniert das Upgrade von Windows 8 – II
viii: Windows 8.1: Wo ist das Store-Upgrade gespeichert?
ix: Windows 8.1: Media Center-Upgrade Tricks (auch MSDN-Versionen)
x: Windows 8.1 ISO-Upgrade-Trick & weitere News…

Links:
1: Sicherung in Windows 8.1 gesperrt
2: Systemabbilderstellung bricht ab MS-Answers-Diskussion 1
3: Systemabbildsicherung bricht ab MS-Answers-Diskussion 2
4: Sicherungseinstellungen prüfen (MS-Answers-Diskussion)
5: Weitere MS-Answersdiskussion zu Wiederherstellungsimage


Werbung



Dieser Beitrag wurde unter Backup, Windows 8.1 abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

34 Kommentare zu Windows 8.1: Backup-Probleme bei UEFI/GPT-Datenträgern

  1. Stephan Krause sagt:

    Genauso ging es mir vor zwei Wochen auch. Nach dem Umstieg von 8 nach 8.1 konnte ich das System , was in einer UEFI – Umgebung läuft, nicht sichern, die Screenshots oben im Beitrag kenne ich nur zu gut. Wirklich gute Alternativen hab ich nicht gefunden, zerstörten mir letztlich meine Installation.
    Ich hatte noch eine Sicherung von der vorherigen 8 – Installation, die ich aber nicht zurück spielen wollte , um nicht nochmal das ganze Download – Prozedere durchzumachen. Also machte ich einen Clean – Install.
    Danach funktionierte die Sicherung tadellos, sie ließ sich problemlos erstellen und auch zurückspielen.
    Für mich ist also eher der Unterschied da, ob der Umstieg von DVD oder Download vollzogen wurde……

    • Günter Born sagt:

      @Stephan: Danke für den Kommentar – interessante Beobachtung. Würde eher gegen einen Bug beim Sichern der EFI-Partition und für eine zugemüllte Wiederherstellungspartition sprechen.

  2. Johann sagt:

    Hallo alle zusammen,

    ich habe das gleiche Problem bei einem nagelneuen Surface Pro 2 mit Win8.1 Pro erlebt. Der „zu wenig Speicherplatz“-Fehler bei der Abbildsicherung bezieht sich aber meines Erachtens auf zu kleine Systempartitionen bei bestimmter Formatierung (siehe Hinweis bei http://technet.microsoft.com/de-de/library/hh824839.aspx). Der Volumenschattenkopierdienst braucht wohl etwas mehr Platz, um sich auf den Systempartitionen „breit machen“ zu können, bevor das Image auf das Sicherungslaufwerk geschrieben wird. Ich habe die WinRE-tools partition auf 500 MB und die EFI-Systempartition auf 260 MB vergrößert, und voila, die Systemabbildsicherung klappt und stellte auch mit dem USB-Wiederherstellungslaufwerk alles wieder ordnungsgemäß her.

    Gruß Johann

  3. Emanuel sagt:

    Ich habe ebenfalls eine UEFI/GPT-Installation von Windows 8.1 (Neuinstallation) und bei mir läuft die Sicherung einwandfrei. Eine Wiederherstellung habe ich unter 8.1 bisher noch nie ausprobiert.
    Unter Windows 8 hingegen habe ich beides schon getestet und sowohl eine Sicherung wie auch eine Wiederherstellung mit Bordmitteln funktionierte auch bei meiner UEFI/GPT-Installation einwandfrei.

  4. Werbung

  5. Pegasus sagt:

    Das zeigt ja mal wieder deutlich die völlige Unbrauchbarkeit dieser Windows-Sicherung.
    Schon immer war die Wahrscheinlichkeit groß, dass man im Notfall damit im Regen steht. Unzählige Beiträge in den Foren bestätigen dies ja schon lange.
    Man nimmt einfach einen brauchbaren Imager und gut ist. Zudem ist die EFI-Partition im Notfall ja auch einfach mit der Windows-Reparatur neu erstellbar. Man muss sie also nicht unbedingt mitsichern.

  6. dietlmann sagt:

    Ich verwende zwar kein UEFI, kenne diese Fehlermeldung beim Sichern aber noch aus Windows 7-Zeiten. Sie trat bei Windows 7 auch ohne UEFI auf, wenn die System-Reserviert-Partition nicht genug freien Speicherplatz hatte. Bei einer 100 MB-Partition trat der Fehler auf, wenn weniger als 30 MB frei waren. MS „bereinigt“ die Partition zwar immer wieder, aber irgendwann hat’s aus mir unbekannten Gründen nicht mehr gereicht. Nachdem ich die Partition vergrößert hatte, war immer genügend Speicherplatz frei und das Problem ist bei zahlreichen Sicherungen und Wiederherstellungen unter Win 7 und 8 nicht mehr aufgetreten.

    • Günter Born sagt:

      @dietlmann: Danke für das Feedback – das ist der Fehler, den ich im Artikel auch adressiert habe (verursacht wurde er gerne durch Dritthersteller Defragmenter etc.). Ob es bei Windows 8.1 zutrifft, ist noch unklar.

  7. Pegasus sagt:

    Besser, man legt diese Minipartition niemals an, denn sie verursacht viel zu oft noch andere Fehler, die man ohne sie nicht hätte. In Win 7 ist es z.B. so, dass man bei Anwendung von Bitlocker durch sie die Wiederherstellungsumgebung verliert. Das ist Murks. Wenn Bitlocker diese Partition nicht vorfindet, passiert das nicht.

  8. Werbung

  9. Günter Born sagt:

    Nachtrag zum Problem

    Was sich zwischenzeitlich herauskristallisiert, ist der Umstand, dass die Systemabbildsicherung bei einer Windows 8.1 Neuinstallation funktioniert, aber bei einem Upgrade von Windows 8 auf Windows 8.1 gibt es Probleme.

    Da ich momentan etwas mehr in Kontakt mit den Leuten von deskmodder.de stehe, habe ich mal auf die Schnelle deren Forum überflogen. Und dabei bin ich in diesem Thread auf eine Erklärung gestoßen, die logisch klingt.

    Die standardmäßig mit mit 350 MByte Größe angelegte Systempartition (Systemreserviert) wird beim Windows 8.1-Upgrade bis auf eine verbleibende Kapazität von 5% (sind 18 MByte) gefüllt. Der Volumenschattenkopiendienst (VSS) braucht dummerweise aber 50 MByte freien Speicher, um eine Sicherung eines Systemabbilds anzufertigen.

    Damit ist klar, dass es an dieser Stelle knallen muss. Die 50 MByte-Grenze sind im Technet-Artikel Troubleshoot VSS issues … genannt. Hinweise auf einen zu kleinen Speicher in der Systempartition und Workarounds finden sich inital in diesem US MS-Answers-Forenbeitrag und in diesem US MS-Answers-Forenbeitrag. Und in diesem Blog-Beitrag hat noch jemand einen Ansatz beschrieben, um aus der Nummer herauszukommen. Er löscht die betroffenen Partitionen in diskpart und baut sie neu auf.

    In diesem MS Answers-Forenthread gibt es allerdings die Rückmeldung, dass die bei GPT-Systemen automatisch angelegte 300 MByte Systempartition generell zu klein ist – egal ob Upgrade oder Clean Install. Bei Deaktiviertem UEFI (Legacy BIOS-Mode) werden 350 MByte beim Clean Install reserviert und es funktioniert. Auch dort kommt der Verweis auf den oben verlinkten Forenthread, die Systempartition mittels externer Partitiontools auf 400 MByte zu vergrößern. Dann funktioniere die Systemabbildsicherung.

    Tipp zum VSS-Debug-Tracing

    Beim Recherchieren für diesen Artikel bin ich noch auf diesen Forenthread gestoßen, wo Benutzer DK2000 noch einen Registrierungshack beschreibt, um einen Debug-Trace von der Arbeit des VSS-Diensts zu erzwingen. Könnte bei entsprechenden Problemen ganz hilfreich sein.

  10. Pingback: Anonymous

  11. Dirk sagt:

    Habe das Problem nach einer Upgrade Installation von 8 -> 8.1 sowie einer Clean Installation von 8.1 auf SSD am UEFI-Board gehabt. Beides mal war die Wiederherstellungspartition 300MB groß und mit 288MB belegt. Also weniger wie 50MB frei. Dateiversionsverlauf und WHS2011 Client-Sicherung schlugen fehl. Mittels Paragon 12 habe ich die SSD auf eine Festplatte geklont und anschließend wieder zurück auf die SSD und dabei die Partitionsgrößen so angepasst, dass die Wiederherstellung 350MB groß war. Danach liefen auch die Sicherungen wieder. Microsoft bekleckert sich nicht gerade mit Ruhm in Bezug auf Backup. Das war unter Windows 7 noch viel besser, wenn man von der 2TB Backupgrenze mal absieht.

  12. Wolfgang sagt:

    Fazit des ganzen, Günter, mit Windows Bordmitteln, sie taugen wenig. Ich
    habe das ganze (Win 8.1 UEFI/BIOS) mit Paragon Free hin bekommen. Hat
    mit allen 4 Laufwerken geklappt und selbst getestet.

    Normalerweise braucht man nur (C) BOOT (Win 8.1) zurück zu spielen. Sollte
    aber eins von den Dreien beschädigt sein, kann man auch diese zurück
    spielen. Voraussetzung natürlich, dass man sie beim Image schreiben mit
    einbezogen hat.
    http://bit.ly/ILyOkk

    Gruss,
    Wolfgang

  13. Sebastian sagt:

    Hatte das Problem auch und konnte es recht einfach lösen indem ich die Wiederherstellungspartition mit dem „Mini Tool Partition Wizard“ gelöscht habe.

    Für alle die auf die Wiederherstellungspartiton verzichten können ist das der einfachste Weg.

  14. Günter Born sagt:

    Nachtrag: In diesem MS Answers-Forenbeitrag finden sich noch einige Screenshots und Hinweise rund um UEFI/GPT-Partitionen und Backup.

  15. Bernhard Malota sagt:

    Wie geht es mit :
    Clonezilla (ISO-Image) (64 Bit) bei CHIP angeboten?
    Hoffentlich wird MiSo bald eine Reparatur selbst tun.

    • Günter Born sagt:

      @Bernhard: Danke für die Rückmeldung. Mit Dritthersteller-Backup-Lösungen ging es schon immer. Die setzen i.d.R. nicht auf dem Volumenschattenkopien-Dienst (VSS) auf, der von den Bordfunktionen verwendet wird.

  16. Bernhard Malota sagt:

    Danke für die Antwort.
    Habe von Clonezilla mal das ISO und das ZIP-File heruntergeladen.
    Ferner die PDF-Anleitung.
    Wird eine weile dauern..
    – – – – – – –
    Habe in der Verwaltung die Paritionen angesehen.
    400MB Fehlerfreie Wiederherstellungspartition,
    300MB Fehlerfrei (EFI-Systempartition)
    Acer (C:) 681,85GB NTFS Fehlerfrei(Startpartition,Auslagerungsdatei,Abstrurzabblild,Primäre Partition)
    350MB Fehlerfrei(Wiederherstellungspartition)
    15,64 GB Fehlerfrei (Wiederherstellungspartition)
    …letztere geht sicher und gut bei der Erstellung eines Wiederherstellungslaufwerkes auf einen USB3-Stick…schon erwähnt.
    Der PC wurde mit Win( gekauft und dann vom Händler auf Win 8.1 und Office2013
    aufgebessert.
    Meine Internetverbindung ist dazu zu schwach. – tiefste Provinz.
    – – – – –
    Noch eine Frage:
    Bei der „Laufwerke optiemieren“../ Defragmentierung -Ansicht
    erscheinen 4 Positionen.
    Acer(C:)
    Push Button Reset
    Recovery und:
    \\? \Volume(e4769559-929d-4c7a-aaf4-0d3d2b55e428)\
    Diese Bezeichnung ist mir unverständlich,
    und nicht zu defragmentieren.
    Optimierung erforderlich (35% fagmentiert)
    Alle versuche scheitern, letztere zu defrag..
    Auch mit einem Defraggler und boot defrag und Neustart.
    Ist hier auch ein BUG?
    Die Volumes sind nach den anderen blogs zu klein.
    Also patch von MS erforderlich.
    Aber diese seltsame Laufwerksbezeichnung ist mir unbekannt.
    Habe ein MS-Konto, aber speichere nichts in irgend einer CLOUD.. oder ähnlichem.
    Habe auch alle Speicherungsmöglichkeiten im Web ausgeschaltet. – hoffentlich-
    —–
    Noch etwas.
    Wie kann ich Schirmbildfotos posten.??
    Die HTML-Tags verstehe ich leider auch nicht.
    Wo Erklärung??

    • Günter Born sagt:

      Bernhard: Ich lese immer nur Bug …

      Auch mit einem Defraggler und boot defrag und Neustart.

      Lasse doch die Finger von diesen unseeligen Tools – und bedanke dich bei denen, denn die sind möglicherweise die Ursache, dass das Backup nicht mehr funktioniert. Siehe Defragmentieren unter Windows 7 – Teil 2.

      Die Angabe \\? \Volume(e4769559-929d-4c7a-aaf4-0d3d2b55e428)\ ist die Bezeichnung für den Mount-Point für deine Partition, wobei die Partitions GUID angegeben wurde. Anhand dieser Angabe kann Windows oder das Recovery auf die Partition zugreifen. Da gibt es keine Notwendigkeit, manuell drauf zuzugreifen.

      Ansonsten: Ich helfe immer gerne, wenn ich ad-hoc eine Antwort weiß – aber das ist hier halt kein Forum, wo man seine Probleme einstellen kann. „Schirmfotos posten“ ist eher ungerne gesehen. Da müssten die Bildgrößen zum Blog-Layout passen (640 Pixel max. Breite) und zu einem Image-Hoster hochgeladen werden. Dann lässt sich ein Screenshot über <img src=“url …“/> hier einfügen. Aber wie gesagt, ich kann und will keinen individuellen Support für ein vergurktes System leisten – das Thema ist in Foren besser aufgehoben.

  17. Anguel sagt:

    Da hat sich Microsoft wieder mal was geleistet. Ich teste gerade Windows Server 2012 R2 Essentials (basiert auf Win 8.1). Es wird damit geworben, dass dieser Small-Business-Server Komplettbackups aller Client PCs ziehen und wiederherstellen kann. Nun klappen die Backups bei Win 8.1 GPT/UEFI Client-PCs aber bei der Wiederherstellung ermöglicht der Assistent nur die Wiederherstellung des C: Volumens. Andere EFI / Wiederherstellungs-Partitionen scheint der Server nicht richtig erkennen oder wiederherstellen zu können. Überhaupt scheint es bei Microsoft keine Qualitätssicherung zu geben. Es wird mit den Daten der Kunden gespielt. Es werden Backup-Lösungen geliefert, die nicht einmal oberflächlich getestet wurden. Grob fahrlässig nenne ich sowas…

    • Günter Born sagt:

      UEFI schein ein Problem – da stimmen weder die Kapazitätsangaben in der Datenträgerverwaltung noch lässt sich dort drauf zugreifen. Ist unschön und Zugriff auf NAS ist auch nicht gut abgedeckt (ich habe eben einen Blog-Beitrag zum Backup-Fehler 0x807800C5 auf Vorrat in den Blog einlaufen lassen). Aber die Backup-Funktion ist m.W. eh abgekündigt. Wird also spannend, zu erfahren, was Windows 9 diesbezüglich so bringen wird.

  18. Anguel sagt:

    Abgekündigen statt nutzbar machen – sehr gut.
    Meine Notlösung momentan ist die folgende:
    Nur C: sichern. Bei Komplettausfall der Platte Windows komplett neu installieren und dann nur C: wiederherstellen. Kann ich davon ausgehen, dass sich die Spezial-Partitionen nach der Installation nicht mehr ändern, solange man explizit keine Änderungen daran vornimmt oder täusche ich mich da?

    • Günter Born sagt:

      Ich hätte spontan gesagt, dass sich die Spezialpartionen normalerweise nicht ändern. Ausnahmen sind i.d.R. die Installation von Service Packs oder größeren Updates (Hintergrund: Dann wird meist auch die in den Wiederherstellungspartitionen abgelegte Windows RE aktualisiert).

  19. Anguel sagt:

    Interessant, danke für die Info. Hätte jetzt auch nicht gedacht, dass da nach der Erstinstallation nochmal etwas hineingeschrieben wird…

  20. Anguel sagt:

    Hier noch etwas vielleicht Interessantes: Habe gestern mehrere Backup-Programme durchgetestet: Storagecraft Shadowprotect 5, Paragon Backup & Recovery 14 Home und Acronis True Image 2014.
    Mein PC ist ein Dell OptiPlex 9020 mit einer Samsung 840 Pro SSD (512 GB). UEFI und Secureboot hatte ich aktiviert. Installiert hatte ich Windows 8.1 Pro auf der zuvor mit gelöschten SSD sauber und mit Standardoptionen von der beiliegenden Dell OEM DVD so dass ich wahrscheinlich die von Win 8.1 vorgegebenen üblichen UEFI/GPT Partitionen habe und der Rest ist dann C:.
    Nun habe ich bemerkt, dass sowohl Shadowprotect als auch Paragon zwar ein Erstbackup aller Partitionen schaffen aber dann Probleme mit der darauffolgenden inkrementellen Sicherung der speziellen Partitionen bekommen und bei diesen abbrechen. Acronis scheint alles bei den Inkrements probelmlos zu machen, habe allerdings noch kein Restore getestet.
    Windows Server 2012 R2 Essentials scheint den Client PC wie bereits oben beschrieben problemlos zu sichern, nur bei der Wiederherstellung bietet er mir nicht an, die speziellen Partitionen wiederherzustellen sonden nur C: …

    Anguel

    • Günter Born sagt:

      @anguel: Danke für das Feedback – Wenn Du von einer OEM-Setup-DVD installierst, bekommst Du die Standardpartitionen automatisch auf einer leeren Festplatte/SDD angelegt. Bzgl. des mehrfachen Backups: So detailliert habe ich mir die Geschichte nicht angeschaut. Aktuell habe diese Artikelfolge im Blog, wo ich auf UEFI-Hardware eine Systemabbildsicherung fahre. Ich lasse gleich mal ein zweites Backup laufen, um zu sehen, was da passiert.

  21. Edelbastler sagt:

    ..noch eine Merkwürdigkeit, die die Größenproblematik der Wiederherstellungspartition in neuem Licht erscheinen lassen könnte: Installiert man Windows 8.1 ein zweitesmal als planmäßiges Dualbootsystem auf einer zweiten Festplatte, funktioniert die Abbildsicherung zumindest für das zweite OS – obwohl die Wiederherstellungspartition gleich groß geblieben ist.

  22. Stefan sagt:

    ich hatte das Problem auch beim Sicher von Gen2 VMs (Windows Server 2012 R2)
    Lösung:
    Die EFI Partition manuell anlegen.
    Im Win Setup bei der HD Auswahl shift-F10 drücken

    dann schreiben:
    Diskpart
    Select disk 0
    Create part prim size=300
    Create part efi size=300

    Dann auf dem freien Platz der HD Windows installieren, die erstellten Partitionen werden für das System hergenommen.

    Das Windowsbackup funktioniert dann, aus der EFI Partition werden 296 (!) MB an Daten gesichert.

    Infos aus diesem TechNet Artikel:

    http://technet.microsoft.com/en-us/library/hh825686.aspx

    lg
    Stefan

  23. Clemens Krause sagt:

    Oh weh danke für die ganzen Infos versuch das schon seit einem halben Tag. Gut da hätte ich noch lange rumspielen können…

  24. Daniel sagt:

    Seers^^,

    vielen dank für die infos, hat mir sehr weitergeholfen
    und gut geschrieben, sehr gut verständlich wenn ma a weng ahnung hat

    mfg daniel

  25. Moh sagt:

    Ich hatte die gleichen Probleme. Kam die gleiche Fehlermeldung als ich die Sicherung startete.

    Mit dem Befehl im Dos-Fenster als Administrator bekam ich auch den Fehler , dass die Sicherung fehlgeschlagen hat.

    Daraufhin habe ich im Windows 8.1 die Partition fuer die Sicherung nochmal NTFS formatiert und alles funktionierte korrekt.

    Verstehe nicht, die Partition war korrekt formatiert, lesen und schrieben war moeglich aber die Sicherung brachte immer Fehler.

    viele gruesse
    Moh

  26. Pingback: Windows 8.1 Backup mit WBADMIN bricht mit Fehler “Auf das bereitgestellte Sicherungsvolume konnte nicht zugegriffen werden” ab, bzw. Fehlercode 0x807800C5 | Das nie endende Chaos!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.