Windows 8/8.1: DVD-Laufwerke verschwunden

Verschiedene Benutzer, die sich Windows 8/8.1 Consumer Preview auf’s System ziehen, beklagen sich über verschwundene CD-, DVD- und BD-Laufwerke. Ist kein prinzipielles Problem, auf meinen Systemen sind die optischen Laufwerke vorhanden. Nachdem sich das Problem aber in den Foren häufte, habe ich mal eine Lösung skizziert.


Werbung



Upper-/Lower-Filtereinträge stören/Code 19 wird angezeigt

Das Windows durchaus schon bei der Installation Probleme mit einem optischen Laufwerk haben kann, hatte ich bereits hier für Windows 7 skizziert. Auch das Problem der plötzlich verschwundenen Laufwerke war schon Thema eines Blog-Beitrags. Ich empfehle auf jeden Fall, diese Geschichte mit den Upper-/Lower-Filtereinträgen vorsorglich zu überprüfen und als Ursache auszuschließen. Dies gilt auch, falls der Fehlercode 19 im Geräte-Manager für das optische Laufwerk angezeigt wird.

Wenn das Fehlerbild nicht zutrifft

Das obige Fehlerbild, dass Upper- und Lower-Filter durch Fremdsoftware (Brennprogramme etc.) verändert wurden, trifft bei Windows 8 (bzw. auch bei Windows 8.1) aber oft nicht als Ursache für das verschwundene Laufwerk zu – speziell, wenn das Laufwerk sofort nach der Betriebssysteminstallation verschwunden ist.

Bereits in Windows 8 Consumer Preview ergab sich folgendes Fehlerbild: Die Betroffenen können Windows 8 (gilt auch für Windows 8.1) installieren, stellen aber nach dem Neustart des Systems fest, dass die Laufwerke nicht im Ordnerfenster auftauchen. Das Problem wird hier im Microsoft Answers-Forum thematisiert. Als Communitymoderator hatte ich es zur Kenntnis genommen. Da der Fehler bei mir nicht auftrat, konnte ich zunächst aber wenig tun – bin dann aber doch noch auf Lösungen gestoßen.

Fehlender Registrierungseintrag bei ATAPI-Laufwerken

Durch Zufall kam mir aber in meinem Google+ Stream zeitnah ein Verweis auf diesen Forenbeitrag unter die Augen. Dort wurde auf einen fehlenden EnumDevice1-Eintrag im Services\atapi Teil der Registrierung hingewiesen. Der Artikel enthält zwar noch einen kleinen Fehler (auf Grund der Formatierung im Forum), war aber die Lösung. Als ich den Ansatz im Microsoft Answers Forum postete, kam gleich die Rückmeldung von mehreren Betroffenen, dass es die Lösung für verschwundene DVD-Laufwerke sei.

  1. Also unter einem Administratorkonto anmelden, dann die Tastenkombination Windows+R drücken und regedit im Dialogfeld Ausführen eingeben.
  2. Sobald die Benutzerkontenabfrage bestätigt und der Registrierungs-Editor gestartet ist, navigiert man zum unten angegebenen Schlüssel und trägt den benötigten Wert nach.

Der Schlüssel in der Registrierung lautet:

HKEY_LOCAL_Machine\System\CurrentControlSet\Services
\atapi\Controller0

Im rechten Teil des Registrierungs-Editors ist dann der DWORD-Wert EnumDevice1 einzutragen und auf 1 zu setzen. Im oben verlinkten Forenbeitrag wurde ein alternativer Befehl angegeben:

reg.exe
add “HKLM\System\CurrentControlSet\Services\atapi\Controller0”
/f /v EnumDevice1 /t REG_DWORD /d 0x00000001

Kann natürlich auch verwendet werden. Hierzu ist das Fenster der Eingabeaufforderung über Als Administrator ausführen zu öffnen und der Befehl einzugeben.

Nach einem Neustart sollten die Laufwerke wieder auftauchen. Und zwischenzeitlich ist mir auch klar, warum das Problem auf meinen Testsystemen nicht auftrat: Die nutzen keine ATAPI-Schnittstelle – ergo ist der Schlüssel hier auch nicht in der Registrierung vorhanden. Bei Verwendung von SATA-Laufwerken gebe ich nachfolgend einige Hinweise gegeben.


Werbung

Wenn zwei ATAPI DVD-Laufwerke verbaut sind

Bei manchen Anwendern sind zwei optische Laufwerke vorhanden, von denen nur eines erkannt wird. Ich bin durch Zufall auf den Link [o1] gestoßen, der einen entsprechenden Registry-Eintrag:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
Services\atapi\Controller0

beschreibt, den man kontrollieren sollte. Der DWORD-Wert EnumDevice1 soll auf 1 gesetzt werden. Während [o1] behauptet, dass man bei zwei optischen ATAPI-Laufwerken den DWORD-Wert EnumDevice1 auf 2 setzen soll, scheint das aber nicht ganz zu stimmen. Im Forenthread [o2] finden sich ein paar ergänzende Hinweise, die ich in [o3, o4] bestätigt fand.

Für das zweite optische ATAPI-Laufwerk ist der DWORD-Wert EnumDevice2 im obigen Schlüssel einzutragen und auf 2 zu setzen.

Nachtrag: Geht mit Sinn und Verstand an das Thema heran

Die obigen Hinweise samt Registrierungseingriff sind nur dann hilfreich und sinnvoll, wenn ihr ein ATAPI-Laufwerk besitzt. Möglicherweise ist dann auch der Upper- und LowerFilter durch Fremdsoftware am verschwundenen Laufwerk beteiligt (siehe meine obigen Ausführungen und die Linkliste am Artikelende).

Moderne Notebooks kommen aber häufig mit einem SATA-Laufwerk daher. Dann bleibt der obige Registrierungseintrag ohne Funktion. Schaut euch die folgenden Ausführen von mir an. Da gibt es z.B. den Kommentarnachtrag vom 29. Oktober zu Toshiba-Geräten. Auf den Toshiba-Geräten müssen z.B. Dienste deaktiviert und ggf. Programme deinstalliert werden.

Links:
o1: No DVD Drive Listed in Windows 8
o2: Windows 8 blendet Laufwerk aus (MS Answers-Diskussion)
o3: In windows 8 consumer preview DVD drive is not recognized
o4: Installed Windows 8 Release Preview Now My DVD Drive Is Missing

Ähnliche Artikel:
1: CD-/DVD-Treiber bei Windows 7-Installation nicht gefunden
2: CD-/DVD-Laufwerk verschwunden


Werbung

Dieser Beitrag wurde unter Windows 8, Windows 8.1 abgelegt und mit , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

59 Kommentare zu Windows 8/8.1: DVD-Laufwerke verschwunden

  1. Günter Born sagt:

    Nachtrag: Bei WinTotal.de gibt es noch einen schönen Beitrag, der zeigt, wie man die Upper- und Lower-Filter in der Registrierung überprüft und löscht.

    Wichtig: Auch Virenscanner bzw. deren Filtertreiber können Ursache sein

    Ich möchte in diesem Zusammenhang auf diesen MS Forenthread verweisen, wo ein Sophos CD-Rom Device Control Filter Driver die Ursache für ein verschwundenes Laufwerk war.

    FixIt-Lösungen von Microsoft

    Bei Microsoft gibt es zudem sogenannte FixIt-Tools, die häufige Fehler bei CD/DVD-Laufwerksproblemen beheben sollen. Hier die Links:

    Eine CD oder DVD lesen bzw. brennen funktioniert mit Ihrem Laufwerk nicht
    Das CD- oder DVD-Laufwerk wird von Windows oder anderen Programmen nicht erkannt.

    Die Meldung:

    HP CDDVDW SN-208BB Stopped working Code (19)

    Device SCSI\CdRom&Ven_hp&Prod_CDDVDW_SN-208BB\4&bc34cf3&0&050000 had a problem starting.

    Driver Name: cdrom.inf
    Class GUID: {4D36E965-E325-11CE-BFC1-08002BE10318}
    Service: cdrom
    Lower Filters:
    Upper Filters:
    Problem: 0x13
    Status: 0x0

    ist im Grunde weiter oben mit dem Thema Upper-/LowerFilter adressiert. Hier aber noch je ein Link auf ein Mirosoft- und ein HP-Forum, welches das Thema ebenfalls adressiert:

    http://h30434.www3.hp.com/t5/Notebook-Hardware/CD-DVD-Drive-Stopped-Working-Windows-8/td-p/2348061
    http://technet.microsoft.com/en-us/library/cc772156(v=ws.10).aspx

    Achtung: Windows 10, bitte beachten

    Die obigen Hinweise können auch unter Windows 10 helfen. Aber der Vollständigkeit halber, weil die Leute nur rumprobieren und die Technik sich weiter entwickelt hat: Ich habe den Artikel auf Windows 10 umgestrickt und erkläre, wann was gilt. Daher unbedingt folgendes lesen: Windows 10: DVD-Laufwerk fehlt nach dem Upgrade

  2. Gerhard sagt:

    Dieses Problem trat schon bei Windows Vista auf – unverständlich warum das jetzt wieder passiert…

    • Günter Born sagt:

      Gerhard, danke für die Info – kannte ich noch nicht. Offenbar hat’s jemand aus dieser Zeit ausgegraben. Jedenfalls sind die Leute wieder glücklich, wenn die Laufwerke erneut auftauchen.

  3. Pingback: [BLOCKED BY STBV] Windows 8: Wo sind die CD/DVD-Laufwerke? - Hardware und Treiber (Windows 8)

  4. Michael sagt:

    Hallo Günter, habe deine Lösung weiterempfohlen. [1]
    Scheint ein ziemlich weit verbreitetes Problem zu sein.
    Vielen Dank

    Link[1]: http: // windows-hilfe-forum.de/f62/windows-8-wo-sind-die-cd-dvd-laufwerke-6272/

  5. Klaus sagt:

    Hallo Günter

    Ich habe die Eingabeaufforderung mit (Als Administrator ausführen) geöffnet.
    Anschließend habe ich den mit der Maus kopierten Befehl

    reg.exe
    add “HKLM\System\CurrentControlSet\Services\atapi\Controller0”
    /f /v EnumDevice1 /t REG_DWORD /d 0×00000001

    aus Deiner Beschreibung eingefügt, und mit Enter Bestätigt.
    Danach kommt folgende Fehlermeldung.

    http://img5.fotos-hochladen.net/uploads/eingabeauffordep3y8fomzbl.jpg

    Wenn ich jedoch den Befehl von Deiner verlinkten Webseite unter (diesen Forenbeitrag) nehme, funtioniert es.

    http://img5.fotos-hochladen.net/uploads/eingabeauffordeq9a0348fn6.jpg

    Worin liegt hier der Unterschied?
    Die Befehle scheinen beide die gleichen zu sein.

    MfG Klaus

    • Günter Born sagt:

      @Klaus: Die Erklärung ist recht einfach – in meinem Beitrag ist ein Zwangs-Zeilenumbruch (durch die Blog-Software) hinter reg.exe, der bei der Eingabe natürlich berücksichtigt werden muss (nicht einfach alles sklavisch abtippen, was da steht, oder per Cut&Paste übernehmen, sondern verstehen, worum es geht).

      Genau das kommt auch in deinen Screenshots raus. Der nicht funktionierende Ansatz gibt add.exe mit drücken der Eingabetaste ein – Du bekommst einen Fehler und landest auf der Eingabeaufforderung. Das wurde natürlich ignoriert und fleißig die nächsten Befehle übernommen – musste natürlich schief gehen, das der Befehlsprozessor von cmd keinen add-Befehl kennt.

      Du hättest den Befehl aus der Zwischenablage in ein Editorfenster übernehmen und um die Zeilenumbrüche bereinigen müssen – dann erneut in die Zwischenablage kopieren und im Fenster der Eingabeaufforderung einfügen.

      Im übrigen hat die erste Eingabeaufforderung keine administrativen Berechtigungen – vergleiche mal die Titelzeile und den angezeigten Pfad im Prompt – nur so am Rande ;-).

      HTH

  6. Günter Born sagt:

    Nachtrag: Toshiba Notebooks

    Bei Toshiba Notebooks gibt es wohl Probleme mit dem DVD-Laufwerk. Die obigen Tricks helfen nicht (ist wohl ein SATA-Laufwerk). Hier zwei Links aus den Toshiba Foren mit Lösungen.

    1: http://forums.toshiba.com/t5/Windows-8-Knowledge-Base/CD-DVD-drive-is-missing-after-upgrading-to-Windows-8/ta-p/342038
    2: http://forums.computers.toshiba-europe.com/forums/thread.jspa?threadID=68222

    Update: Toshiba Disc Creator als Problembär

    Gemäß diesem Foreneintrag von Heinz M. scheint es bei Toshiba-Notebooks ein Disc Creator-Tool (anfertigen von Recovery Disks, Musik etc. brennen) zu geben. Dieses Tool über die Systemsteuerung (Programmen entfernen) deinstallieren – neu booten – und eventuell freuen.

    Update: habe jetzt auch bei Toshiba eine FAQ gefunden, die das bestätigt. Hab’s mal gefettet, weil es sonst doch wieder keiner liest …

    … und weil viele Nutzer da einen Zoo an installierten Utilities haben, schließt ihr Kollateralschäden durch diesen Software-Zoo aus, indem ihr einen Diagnosestart nach meinem Artikel Problemdiagnose mit msconfig durchführt. Dann sollte sich schnell zeigen, ob das Laufwerk tut oder nicht.

  7. Wimi sagt:

    Vielen Dank, Günter!
    Du hast mir viel Zeit bei der Problemsuche erspart :). Bei meinem Toshiba Satellite Notebook hat der Trick mit der Regestry in der Tat nicht geholfen, da Eintrag nicht vorhanden (aus bereits erwähnten Gründen).

    Deinstallation der Programme und des Treibers hat das Problem gelöst, Laufwerk wird nun angezeigt und arbeitet korrekt.

    mfg

  8. ar1969 sagt:

    “Der Schlüssel in der Registrierung lautet:

    HKEY_LOCAL_Machine\System\CurrentControlSet\Services
    \atapi\Controller0”

    Bei mir fehlt der Eintrag “Controller0” in der Registrierung, dafür “StartOverride”
    (Toshiba C670-1DC)

    Danke schon mal im Vorraus

  9. nightfeeling sagt:

    Vielen Dank für den Artikel, habe den Eintrag gleich selbst erstellt und nach Neustart ist das Laufwerk da.
    Hatte mir am Montag Windows 8 64 bit gekauft und konnte es nicht verstehen das das Laufwerk plötzlich weg ist. Hatte eine Neuinstallation gemacht und das Problem verfolgt.
    Bei der Installation von Windows 8 ist das optische Laufwerk noch vorhanden, aber sobald man einen Neustart ausführt weil Windows 8 Updates runterläd und danach einen Neustart verlangt kommt man nicht drum rum und dann ist das optische Laufwerk verschwunden.
    Mein Mainboard nutzt noch den IDE Modus trots SATA Anschlüsse und das wird wohl nicht mehr richtig unterstützt. Denke das Microsoft eventuell ein Update Rausbringt 🙂

  10. Günter Born sagt:

    @nightfeeling: Danke für die positive Rückmeldung. Üblicherweise werde ich ja in den Foren angegiftet, wenn der IDE-Controller-Tipp nicht hinhaut …

  11. Norbert Weber sagt:

    Vielen Dank.
    Bei mir hat es sofort geholfen.
    Nagelneues Windows 8 Upgrade und so ein Fehler:(
    Ohne Internet und solchen fleißigen Schreibern wie du wäre MS verloren.
    Und ich auch;)
    Norbert

  12. Markus L sagt:

    Habe das gleiche Problem mit einem LG DVD Brenner (S-ATA)

    Nach dem Neustart des Rechners ist das Laufwerk weg.
    Der Schlüssel: HKEY_LOCAL_Machine\System\CurrentControlSet\Services
    \atapi\Controller0″

    funktioniert nicht, da bei mir ebenfalls der Eintrag “Controller0″ in der Registrierung fehlt.

    Win 8 (64 Bit)

  13. Thomas sagt:

    Vielen dank für den Tipp, hat geholfen 😉

  14. georg sagt:

    Danke, aber bei mir ist nach dem Neustart das Laufwerk immer noch nicht da. Wenn ich aber das System mit eingelegter Windows8-Installations-DVD starte (ohne dann aber von der DVD zu starten) erscheint das Laufwerk wieder. Beim Start ohne DVD ist das Laufwerk verschwunden.

  15. Steffen T sagt:

    @ Markus L.

    gabs da jetzt schon ne Lösung ???

  16. Günter Born sagt:

    @Steffen: Du hast den Unterschied ATAPI-/SATA-Laufwerk berücksichtigt? Kann ein Fremddienst oder der Upper-/LowerFilter-Eintrag das Problem verursachen?

    Was man testen kann

    Bootet das System von der Setup-DVD, geht bis zum zweiten Fenster des Installationsassistenten, drückt die Tastenkombination Shift+F10.

    Jetzt sollte das Fenster der Eingabeaufforderung erscheinen. Tippt dort Notepad ein und drückt die Eingabetaste.

    Dann kann man auf “Datei/Öffnen” gehen (seht auch mal meinen Artikel hier, Abschnitt zu Windows PE samt dem Screenhot des Editors). Ist das Laufwerk vorhanden (hab’s selbst nicht getestet)? Zudem gibt es immer noch den Tipp aus dem obigen Artikel, einen Diagnoseneustart mittels msconfig zu versuchen.

    Hoffe, es hilft euch weiter.

  17. Martin R sagt:

    Ähnliches Problem hier.
    Bin mir nicht sicher, ob seit Win8-Installation das Laufwerk überhaupt je funktionierte (wurde allerdings von DVD installiert).
    Der Registry-Hack hat nicht geholfen.
    Aber msconfig, restart als “Diagnosesystemstart” => DVD-Laufwerk ist wieder da, dann wieder normaler Systemstart => DVD-Laufwerk ist immer noch da. Ja was … keine Ahnung was dran Schuld war, scheint jetzt aber zu funktionieren.

  18. Petros45 sagt:

    @Günter Born @Martin R
    Bei mir existiert der Eintrag “Controler0” ebenfalls nicht. (2Laufwerke)
    Der Versuch “msconfig – restart als Diagnosesystemstart” hat zum größten Desaster geführt: Die Diagnose hat ein fehlendes Laufwerk erkannt , konnte den Fehler aber nicht beseitigen, nach Neustart konnte WIN8 nicht mehr starten, Reparatur und Rücksetzung auf Wiederherstellungspunkt war nicht möglich, von den angebotenen Möglichkeiten funktionierte nur der Start von anderem Betriebssystem, dieses hat mit Chkdsk Fehler gefunden und repariert- damit war WIN8 hin – Formatierung der Partition und Neuinstallation unumgänglich!
    Möglicherweise habe ich SATA-Laufwerke – muss ich jetzt mal kontrollieren.

  19. Günter Born sagt:

    @Petros45: Danke für die Rückmeldung. Aber ich bin mir ziemlich sicher, dass ein Diagnosestart mittels abgeschalteter nicht MS-Dienste KEIN Windows beschädigt. Keine Ahnung, welche Diagnose Du das fährst – aber beschädigte Dateien deuten doch darauf hin, dass da was ziemlich im Argen liegt.

    Da Du Dualboot implizit erwähnst – kleiner Tipp: Konfiguriere deine Virenscanner auf den Alt-Windows-Systemen so, dass diese die Windows 8-Partition nicht anfassen. Veraltete Scanner oder Signaturen führen dazu, dass die Windows 8-Systemdateien löschen oder in Quarantäne schicken.

  20. Petros45 sagt:

    @Günter Born vom 09.Jan.2013 09:49
    Mir ist klar, dass nicht die Diagnose die WIN8-Installation unrettbar beschädigt hat sondern die nachfolgende „Reparatur“ durch ChkDsk von WIN7. Fakt ist aber, dass ich aus der Diagnose und den nachfolgenden Vorschlägen nur durch die Wahl des anderen BS herauskam.

    Inzwischen hatte ich den Versuch unternommen, mittels

    reg.exe add “HKLM\System\CurrentControlSet\Services\atapi\Controller0″ /f /v EnumDevice1 /t REG_DWORD /d 0×00000001

    (zwei Einträge für 2 Laufwerke) einzufügen. Nach einigem Kamp mit der Syntax habe ich auch die zusätzlichen Einträge in die Registry hinbekommen, hat aber keinen Erfolg gezeigt.

    Dann habe ich den Eintrag von Topcon-2 vom 15.Nov2012 in der Micrsoft.com gefunden:

    Topcon-2 geantwortet am November 15, 2012
    Antwort auf Beitrag von KrisRob am Oktober 31, 2012
    Hallo,
    unter \atapi muss neben “Enum” noch ein 2.Unterschlüssel mit dem Namen “Controller0” angelegt werden (“Neuer Schlüssel#1” einfach umbenennen), dann in den gerade neu angelegten Unterschlüssel “Controller0” per rechter MT einen neuen “DWORD-Wert (32-Bit)” eintragen und die Bezeichnung ändern in “EnumDevice1”.

    In “EnumDevice1” noch den voreingestellten Wert “0” in “1” ändern und den Computer neu starten.

    Unter “HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/services/atapi/” befinden sich jetzt die Einträge “Enum” und “Controller0”, unter “Controller0” steht “Standard” und “EnumDevice1” vom Typ “REG_DWORD” mit dem HEX-Wert “0x00000001 (1)”

    Das BD-Laufwerk ist wieder “da” und wird auch in der Datenträgerverwaltung automatisch mit einem LW-Buchstaben versehen.

    Gutes Gelingen und viel Spaß !

    Hurra – das hat zum Erfolg geführt – beide Laufwerke sind da und funktionieren. Ich hoffe, das bleibt auch so wenn ich AVG-Virenscanner installiert habe.

    Vielen Dank an Günter Born, Topcon-2 und alle die in den Foren und Blogs mitgewirkt haben!

    Ein Gedanke noch, warum diese Fehler –zumindest zum Teil – auftreten könnten: Ich habe zwar SATA Laufwerke (LG) und ´-Platten + eine IDE-Platte – doch kann ich mich dunkel erinnern, dass es zum. Anfang von SATA die Diskussion gab, ob es sich lohne, SATA-Geräte wirklich als SATA zu installieren. Das wurde in der Diskussion verneint, ich habe dann meine Devices auch mit IDE-Emulation laufen lassen — möglicherweise fehlte deshalb der Eintrag „Controller0“ mit dem Unterschlüssel. Allerdings unter XP und WIN7 gab es keine Schwierigkeiten. Auch ist mir ein Rätsel, wieso der Brenner erkannt wurde?

    Zum Schluss nochmals vielen Dank
    Petros

    • Günter Born sagt:

      @Petros: Danke für den Hinweis, hilft vielleicht anderen Blog-Lesern. Da ich den Fehler bisher nicht hatte, kann ich da wenig testen.

    • Marisol sagt:

      Auch bei mir trat das Problem auf, hab verschiedenes versucht, aber auch bei mir gabs den Schlüssel “Controller0” nicht.
      Die Lösung hier hat endlich geklappt und jetzt funktioniert alles. Vielen herzlichen Dank! 🙂

  21. Thomas Minar sagt:

    Das ist die richtige Lösung:

    reg.exe add HKLM\System\CurrentControlSet\Services\atapi\Controller0 /f /v EnumDevice1 /t REG_DWORD /d 0×00000001

    Diesen Eintrag kopieren-mit der Maus unten-links in die Ecke und mit Rechtsklick auf “Eingabeaufforderung (Administrator)” wandern.
    Anklicken und mit “ja” bestätigen.
    Mit Rechtsklick den kopierten Registereintrag beim blinkenden Cursor einfügen und Entertaste drücken.
    Neustart …. Enjoy !!!

  22. Thomas Minar sagt:

    Der “Fehlerteufel” im Leitartikel lag in den Anführungszeichen für den Eintrag in die Registerdatenbank… die dürfen nicht sein.
    Der Fehler hat sich von der Microsoft-Supportseite aus ungehindert fast alle Foren und Hilfeseiten verbreitet.

    • Günter Born sagt:

      Die Anführungszeichen um den Schlüssel könnten hier entfallen, da kein Leerzeichen im Ausdruck vorkommt – schaden aber auch nicht. Grundsätzlich sollte man die Anführungszeichen immer verwenden.

      Deinen 3. Post mit dem Link zu einer .reg-Datei – ich möchte alle Leser darauf verweisen, die betreffenden Einträge direkt im Registrierungs-Editor vorzunehmen.

      Hintergrund: Es gibt mir zu viele Leute, die auf alles Doppelklicken, was nicht bei Drei auf den Bäumen ist. Der Artikel ist so angelegt, dass man seine Hirnzellen anstrengen soll – wenn kein ATAPI-Laufwerk sondern ein SATA-Anschluss verwendet wird, nützt der Import der reg-Datei nämlich gar nichts. Zudem nützt der Doppelklick nichts, wenn der Import von einem Standardkonto vorgenommen wird, da dann die Schreibberechtigungen für HKLM fehlen.

      Danke aber für den Kommentar.

  23. Thomas Minar sagt:

    …. noch ‘ne Möglichkeit :

    Ich habe die benötigte reg – Datei zum herunterladen bereitgestellt.
    Keine Sorge, die Datei ist sauber.
    Anklicken … ausführen … Neustart …. fertig !!

    http://home.arcor.de/tminar

  24. peter sagt:

    hallo,
    habe das gleich Problem wie alle anderen.
    Nur ist bei mir der Ablauf im reg.-Editor folgender:
    HKEY_LOCAL_MACHINE\SYSTEM\CurentControlSet\Services\atapi\
    danach erscheint Enum und nicht Control

    wo liegt hier der Fehler?

  25. Günter Born sagt:

    Kein Fehler – ich schätze, dass Du kein ATAPI-CD-/DVD-Laufwerk, sondern ein SATA-Laufwerk hast. Kann das zutreffen?

    Falls doch ein ATAPI-Laufwerk vorliegt, ergänzt Du den fehlenden Schlüssel und den DWORD-Wert.

  26. Thomas Minar sagt:

    Alles ist soweit richtig kommentiert.
    Die angebotene .reg-Datei stammt von einem Administratorkonto und funktioniert (habe es getestet) sowohl bei IDE.- als auch bei SATA-Laufwerken. Ich hatte bislang nur die Möglichkeit auch die Kombination 1xIDE mit 1xSATA zu testen. Erfolgreich. Mir fehlte bislang die Möglichkeit zu testen, ob bei der Kombination 2xIDE oder 2xSATA weitere Schlüssel für ein zweites Laufwerk am selben Controller nötig sind.

  27. Alexander Ulbrich sagt:

    Wenn ich die o.a. Syntax eingebe erhalte ich die Fehlermeldung:
    FEHLER: Ungültige Syntax. Geben sie e. gültigen Wert für ‘/d’ ein.

  28. Alexander Ulbrich sagt:

    … gültigen numerischen Wert …

  29. Günter Born sagt:

    @Alexander: Ok, die Fehlermeldung besagt lediglich, dass Du wohl keinen gültigen numerischen Ausdruck für 0x00000001 verwendet hast oder das Leerzeichen zwischen /d und dem Wert fehlt. Ich würde dir aber eh empfehlen, den Registrierungseintrag manuell im Registrierungs-Editor einzutragen und auch sicherzustellen, dass Du wirklich ein ATAPI-Laufwerk und kein SATA-Laufwerk hast.

    HTH

  30. Diddmaster sagt:

    Dankeschöööön hier war es das Toshiba Recovery Create Programm, nach dessen Löschung war war alles supi mit dem Matshita BD MLT uj240es

  31. Thomas Minar sagt:

    Lassen wir die Katze aus dem Sack !!
    Für die Verifizierung von Treibern erhebt Microsoft Lizenzgebühren. Reichlich.
    Wir erinnern uns:
    Es gab/gibt Steckplatinen, mit denen es möglich ist entweder IDE-Geräte an einem SATA-Steckplatz oder SATA-Geräte an einem IDE-Steckplatz zu betreiben.
    Nun wird bei Preiswert-Geräten ein Trick angewandt.
    Durch gezielte Modifikation wird ein ATAPI-Gerät SATA-fähig gemacht.
    Anders als bei den Vorgängern merkt Windows8 das.
    Diese Unpäßlichkeit wird aber nicht automatisch korrigiert, sondern der Verbraucher bleibt im Regen stehen.
    Der geringere Datentransfer fällt dem normalen User nicht auf, da Daten aufgrund von Typ und Größe ohnehin unterschiedlich schnell transportierbar sind.
    Bestenfalls kann eine Vergleichsmessung mit gleichen Datensätzen Aufschluß bringen.
    Aber wer kann das schon ?

  32. Peter sagt:

    Bei mir läuft’s leider immer noch nicht. Unter atapi habe ich jetzt den Ordner “Controller0” (mit den richtigen Einträgen) und “StartOverride” (mit dem Eintrag “0”, “REG_DWORD” und 0x00000003 (3). Kann (muss?) ich das löschen?.

  33. Günter Born sagt:

    @Peter: Ich kann dir nicht genau sagen, ob das gelöscht werden muss. Aber wenn Du unsicher bist, warum benennst Du die Schlüssel bzw. Werte nicht einfach um – einfach ein _ vor den Namen setzen – dann wird der nicht berücksichtigt. Dann siehst Du sehr fix, ob es was bringt. Ich kann hier nix testen, da ich weder den Fehler noch die ATAPI-Laufwerke habe – und auf meinen Uraltrechnern Windows 8 für einen Test aufzusetzen, ist mir ein wenig zu aufwändig. Muss mal bei Gelegenheit schauen, ob mein Notebook noch einen Atapi-Controlller für das DVD-Laufwerk aufweist.

  34. Peter sagt:

    Hallo Günter, danke für die Info. Funktioniert leider auch nicht. Ich verstehe, dass du da nicht viel machen kannst. Die Website von Thomas ist ja super. Habe alles ausprobiert. leider ohne Erfolg. Was mich nur stutzig macht, ist der zweite Ordner unter “atapi”, der bei ihm “Enum” heißt (bei mir wie gesagt “StartOverride”). Das ist meine (letzte?) Hoffnung, dass der Eintrag fehlt. Leider ist der bei seinem Screenshot nicht geöffnet, so dass ich nicht sehen kann, was da drin steht. Vielleicht guckt er hier noch mal vorbei? Könnte es ansonsten an Nero liegen? Habe kürzlich die 9er-Version installiert (da funktionierte das Laufwerk noch), die entgegen der Auskunft von Nero auch unter Win8 läuft. Gebrannt habe ich natürlich noch nichts (s.o)! Rechner und Laufwerk sind brandneu.

    • Günter Born sagt:

      @Peter: Habe kürzlich die 9er-Version installiert (da funktionierte das Laufwerk noch),… Nichts für ungut – aber die Info hättest Du sofort raus rücken sollen. Ich schrieb ja im Blog, geht mit gesundem Menschenverstand an das Thema ran. Der Blog-Beitrag ist alleine aus dem Umstand entstanden, dass Windows 8 Pro-Upgrader sofort nach dem Upgrade kein DVD-Laufwerk mehr vorfanden.

      Wenn Du Nero installiert hast, und vorher das Laufwerk noch funktionierte, würde ich mir das Thema “Upper- und Lower-Filters” vornehmen – ist der wohl wahrscheinlichere Problembär. Das Thema ist im Blog-Beitrag auf den betreffenden Artikel von mir verlinkt.

      PS: Nero würde mir nicht einmal gegen Geld und gute Worte auf ein Windows 8-System kommen. Da ist zu vieles, was schief läuft – und dann noch eine alte Version – der Rat wäre: Mache ein Auffrischen von Windows 8 (dann sind zwar alle Programme weg, aber Du kannst halbwegs sicher sein, dass auch Nero verschwunden ist). Dann testen, ob das DVD-Laufwerk vorhanden ist.

      Ja -> dann hast Du den Problembär vermutlich gefangen – lasse dann den Mist vom System und das Laufwerk wird weiter tun
      Nein -> versuche eine Neuinstallation und schaue, ob das DVD-Laufwerk dann vorhanden ist, falls nein, baust Du den Registrierungseintrag wie hier beschrieben ein.

      PS: Ansonsten gibt es ja auch noch das Thema Fremdvirenscanner – ist hier im Blog auch thematisiert, dass deren Filtertreiber z.B. MTU-Treiber stilllegen können. Ggf. auch in diese Richtung bohren.

  35. Peter sagt:

    Hallo Günter, nochmals vielen Dank für deine Unterstützung. Hatte zwischenzeitlich die Lowers und Uppers deaktiviert, dann Neustart: Es funktioniert. der Recorder ist wieder da! Sogar Nero funktioniert. Werde ich aber trotzdem rausschmeißen. Dein Blog ist ein Segen!!!
    PS: Mein Menschenverstand ist wohl einigermaßen in Ordnung, aber beim Computer hapert’s eben mächtig! Frage: Was könnte Nero ersetzen?

    • Günter Born sagt:

      @Peter: Danke für die Rückmeldung – und schön, dass es geklappt hat. War kein “krummer Hund” den ich mit dem gesunden Menschenverstand vorwerfen wollte. Aber ich werde von Leuten, die ein SATA-Laufwerk haben, in den Microsoft-Foren angepflaumt, dass mein Tipp nicht hülfe.

      Zum generellen Thema Nero ein paar Hintergrundinformationen. Um keine Missverständnisse aufkommen zu lassen: Ich habe nichts gegen Nero – vor Jahren habe ich Insider-Bücher drüber geschrieben und fand das Paket schon mal richtig gut. Leider habe ich damals auch die Interna kennen gelernt – und die Tools kommen aus verschiedenen Quellen. Verursachen daher oft vielfältige Kollateralschäden. Spätestens seit Vista brauchte man Nero nicht mehr wirklich. Ich habe es seit dem nicht mehr eingesetzt.

      – Daten-CDs/DVDs lassen sich mit Windows-Bordmitteln brennen
      – Musik-CDs brennt man ggf. mit dem Windows Media Player
      – Zur Wiedergabe von DVD-Video verwende ich den VLC-Player portable
      – Zum Videoschnitt nehme ich den Windows Live Movie Maker (Windows Essentials 2012)
      – Zum DVD-Authoring kann man den DVD-Writer verwenden.

      Und es gibt noch Freeware-Tools wie Deep-Burner und CDBurner XP. Hier mal eine kleine Link-Liste an Blog-Artikeln rund um das Thema Multimedia unter Windows 8:

      DVD-Video-Wiedergabe unter Windows 8
      Windows 8-Media Center-Ersatz: Media Portal – I
      Windows 8: Ersatz für den Windows DVD-Maker I

      Hilft vielleicht weiter …

  36. Peter sagt:

    Hilft weiter. Danke dir noch mal!

  37. Mai Doan sagt:

    Sehr geehte Herr Günter,
    ich habe viele Bücher von Ihnen gelesen.dafür brauchen Sie bestimmt sehr viele Zeit.Haben Sie noch Zeit für Ihr Familie ?
    vielen Dank für Ihr Hinweis. Ich benutze ein Toschiba Notebuch, nach Upgrade von Windows 7 zu Windows 8 Pro war DVD-Laufwerk verschwunden. (DVD-Laufwerk im Bios noch vorhanden).Nach vielen Hinweis versuche ich zu lösen, leider klappt das nicht.Problem liegt am meisten an ein Brennprogramm. Ich dachte auch an Toshiba Disc Creator, aber war Zweifel daran. in ein PC-werkstatt sagt mann zu mir, es wäre ca. 10 € für Lösung,(für 10€ ist für mich billig). Ich versuche aber weiter selbst zu lösen erst heute finde ich Ihr Hinweis, und Problem ist gelöscht . nochmal vielen Dank.

    Mai Doan

  38. Jule sagt:

    Guten Tag,
    ich habe dasselbe Problem mit den verschwundenen Laufwerken (hier ein USB-Stick) in Windows 8 (kein Upgrade, vorinstalliert gekauft), die Änderungen in der Registrierung habe ich versucht. Leider steht bei mir bei dem angegebenen Schlüssel nicht Class DVD/CD, sondern “Wert nicht festgelegt”.
    Auch die Upper und lower levels sehe ich nicht.
    So langsam weiß ich nicht mehr was ich tun soll. Alles Updates gemacht.. gibt es denn bei Windows keinen, der sich kümmert? (beim Support erhielt ich im Netz die Auskunft bei dem verwendeten Produktkey sei dieser kostenpflichtig)

  39. Rudolf E. sagt:

    Tausend Dank für Ihre sehr hilfreichen Tipps in Sachen DVD- Laufwerk und Windows 8.
    Das ist schon eine Unverschämtheit von Microsoft, daß plötzlich das DVD -Laufwerk nicht mehr ansprechbar ist.
    Um so besser, daß es Menschen wie Sie gibt, die hilfreich mit ihrem KnowHow zu Stelle sind !
    Also nochmals vielen Dank, hat prima geklappt !

    Gruß R. E.

  40. jakob sagt:

    okay also bei mir ist das laufwerk auch verschwunden und ich habe mir grad (weitgehendst) alle kommentare durchgelesen, da der oben angegebene weg bei mir nicht funktioniert hat. Ich weiß nicht ob ich ein SATA oder ATAPI laufwerk habe und kann dies auch grade nicht mit der cd o. ä. nachschauen. kann mir nochmal jemand den unterschied erklären, weil ich eigentlich alles ausprobiert habe, was hier (auch in den kommentaren) steht (nach bestem wissen und gewissen). was müsste ich tun wenn ich ein SATA laufwerk hätte?

    ps: habe ein lenovo notebook und keine ahnung falls das hilft^^

    • Günter Born sagt:

      @Jakob: Wird schwierig. SATA-Laufwerke erkennst Du am 9-poligen-Stecker. Ansonsten habe ich das zusammen getragen, was mir bekannt ist. Notfalls bei Lenovo nachfragen, ob da irgend eine Software bekannt ist, die das Laufwerk blockiert.

      Quelle: Wikipedia

  41. Camen Rico sagt:

    Hallo Günther

    Hoffe auf deine Hilfe.
    Seit dem Update von Windows 8 auf Windows 8.1 funktioniert die Store-App nicht mehr.
    Ich erhalte nachfolgende Meldung:
    “Wir konnten keine Verbindung mit dem Store herstellen. Möglicherweise ist ein Serverfehler oder eine Zeitüberschreitung der Netzwerkverbindung aufgetreten. Warten Sie bitte einige Minuten und Versuchen Sie es nochmal. (0xc800227)”
    Internet, e-Mail etc. laufen einwandfrei!
    Danke und Gruss aus der Schweiz

    • Günter Born sagt:

      Ich habe da leichte Zweifel, dass die Fehlernummer 0xc800227 wirklich stimmt. Die Fehlercodes müssen 8 stellig hinter dem x sein – und Windows zeigt die acht Stellen i.d.R. auch an. Ansonsten:

      1. Diese Fehlerprüfung ausführen: Windows 8: Komponentenstore reparieren
      2. Welcher Fremdvirenscanner bzw. welche Internet Security Suite ist installiert? Klappt es, wenn diese deinstalliert und dann ein Removal-Bereinigungstools des Herstellers ausgeführt wird?

      Ansonsten einfach auch mal den folgenden Artikel durchlesen.

      Windows 8-Store- und App-Download-Troubleshooting FAQ

      und ggf. auch mal prüfen, ob dieses Fixit hilft. Ansonsten bleibt nur ein Zurücksetzen auf Windows 8 und dann ein erneutes Upgrade auf Windows 8.1 übrig.

  42. olaf sagt:

    Hallo, auch bei mir war das Dvd-Ram matsushita verschwunden,ich bekam einen
    Rechner eines Bekannten in die Hände,der wohl lustig alles installierte,was die zeitungen so hergeben… Nach sehr langen Versuchen mit Registry ,Forenlesen usw,usw
    (siehe oben) las ich etwas über Nero und stellte fest, dass auf dem rechner ein
    paket von nero (Grösse: 1,14 gigabyte(!!)) installiert war und noch ein contentpack
    (Grösse 999megabyte (!!)). Diese Werte machten mich doch etwas stutzig…
    Eine einfache Deinstallation aller Nero-pakete brachten ohne Neustart das Laufwerk
    wieder ! Ich bin sehr froh und danke an das tolle Forum. Olaf

    • Günter Born sagt:

      @Olaf: Herzlichen Dank für dein Feedback. Ich habe zwar früher mal Insider-Bücher (Nero – geheime Tricks) zu Nero 6 und Nero 7 geschrieben. Aber seit Nero unter Windows Vista zu allerlei Kollateralschäden führte, ist das Paket hier vielen Jahren passé (und wird auch faktisch nicht mehr gebraucht). Von daher hatte ich es gar nicht mehr auf dem Radar. Dein Feedback hilft mir ggf. aber bei weiteren Anfragen weiter.

  43. Peter ORTNER sagt:

    Fehlerbehandlung bei Windows 8.1 wenn das DVD-CD Laufwerk fehlt:
    Systemsteuerung starten, dann auf System und dort Geräte Manager gehen.
    Jetzt bei IDE ATA/CD-ROM-Controller alle Einträge entfernen. Wenn Sie aufgefordert werden dass System neu zu starten nicht neu starten sondern weiter die Einträge löschen bis keine Einträge mehr vorhanden sind.
    Erst wenn der letzte Eintrag gelöscht wurde einen Neustart durchführen.

    Dann sollte das DVD-CD Laufwerk wieder zur Verfügung stehen.
    Bei mir hat es geklappt und ich hoffe ich konnte jemanden bei dem Problem helfen.

  44. Pingback: Beheben Dvd-laufwerk Fehler Windows 8

  45. Ralph sagt:

    Hallo zusammen.

    Das hier genannte Problem hatte ich heute nach der dem Upgrade von Windows 7 Ultimate auf Windows 10 Pro in Zusammenhang mit einem LG BD/HD DVD Super Multi RW SATA Laufwerk (Modell GCC-H20L).

    Folgende Lösung aus diesem Beitrag hat auch unter Windows 10 Pro den Fehler behoben:

    CMD als Administrator starten

    Eingabe des Befehls:
    reg.exe add „HKLM\System\CurrentControlSet\Services\atapi\Controller0“ /f /v EnumDevice1 /t REG_DWORD /d 0x00000001

    Nach einem Neustart des Computers war das Laufwerk im Windows Explorer wieder vorhanden und funktioniert normal.

    Vielen Dank für diesen Beitrag. Ohne Hilfestellungen wie diese würden viele Normalo-Windows Nutzer – wie auch ich selbst – oft verzweifelt und Ratlos dastehen. 😉

    Viele Grüße
    Ralph

  46. matthias sagt:

    Hat bei einem Sony Vaio VGC-JS1E nach Upgrade auf Windows10 tadellos geholfen, hier wird ein Pioneer DVD-RW (DVR TD08 ATA Device) verwendet und der fehlende Controller0 Eintrag hatte die Anzeige im Gerätemanger + Funktionieren verhindert.
    Zudem wurden die LowerFilters und UpperFilters gelöscht wie angegeben.

    Prima Hilfe. Danke.
    Matthias

  47. ronald sagt:

    If you don’t find CD or DVD drive on your Windows 7 computer then you can take help of “Playing and Burning CDs, DVDs, and Blu-ray Discs troubleshooter” to resolve the issue.
    1. Click Start button
    2. On search box, type Troubleshooting. Open the result.
    3. On left click “View All”.
    4. Click “Playing and Burning CDs, DVDs, and Blu-ray Discs”.
    If this method doesn’t work, it might be possible that the problem exists inside your computer’s hardware. You can make use of “Hardware and Devices troubleshooter”. It checks all the hardware issues and confirms that your CD/DVD drive is installed correctly or not.
    1. Again click on “Start” button.
    2. On search box, type Troubleshooting. Open the result.
    3. Under “Hardware and Sound” setting, click “Configure a device”. If prompted for confirmation click “Yes”.
    4. Now reboot your computer and check for drive by clicking on Start button and then “Computer”. If the drive is listed then your problem is solved.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.