Windows 10 20H2: Installation von Update KB4598242 erzeugt BSOD

[English]Frage in die Runde der Nutzer von Windows 10 20H2: Gibt es bei euch einen BSOD bei der Installation von Update KB4598242 samt Rollback? Ein Blog-Leser ist mit einer entsprechenden Beobachtung an mich herangetreten, wobei aber eine spezielle Umgebung mit Windows 10 20H2 Enterprise samt Credential Guard, Device Guard und Hyper-Visor Code Integration sowie der Einsatz des Driver Verifier zum Tragen kommt.


Anzeige

Blog-Leser Martin E. ist über meinen Artikel Windows 10: Bug ermöglicht BSOD durch Pfadeingabe im Browser gestolpert und dann an mich herangetreten, weil er auf ein merkwürdiges Fehlerbild gestoßen ist. Ich stelle es einfach mal hier im Blog ein, vielleicht hat ja ein weiterer Administrator im Windows 10 20H2 Enterprise-Umfeld etwas ähnliches beobachtet. Im Internet findet sich bisher dazu (noch) nichts.

Die Fehlerbeschreibung

Martin betreibt eine Umgebung mit Windows 10 20H2 Enterprise als Administrator und versucht das kumulative Sicherheitsupdate KB4598242 vom 12. Januar 2021 in dieser Umgebung zu installieren. Dabei bekommt er aber entweder einen BlueScreen (BSOD) oder das Betriebssystem macht die Update-Installation rückgängig. Das Ganze lässt sich bei Martin reproduzieren.

Was ist die Ursache?

Dazu schreibt Martin, dass beim Aktivieren des Credential Guard, Device Guard und Hyper-Visor Code Integration ein PowerShell-Script (von Microsoft, siehe unten) verwendet wird. Dieses PS1-Script startet den Driver Verifier “verifier“ (C:\Windows\System32\verifier.exe) mit der Option, die „Codeintegrität“ zu überwachen.

  • Ist das PS1-Script aktiv und die Installation des Update KB4598242 wird angestoßen, macht Windows 10 20H2 die Installation rückgängig.
  • Startet man den verifier.exe mit den Parametern aus dem Script dagegen nachdem der Januar Patch installiert ist, löst dies einen BSOD aus, ohne dass die Maschine wieder zurückkommt.

Zum zweiten Punkt gibt Martin noch eine Erklärung: Der Driver Verifier verifier.exe wird standardmäßig „persistent“ für jeden Boot aktiviert. Die Maschine kommt also nicht mehr aus der BSOD-Schleife. Martin gibt an, dass er das System nur wiederbeleben kann, indem er in die Reparaturumgebung mit Windows RE bootet, dort in die Eingabeaufforderung geht und den Befehl:

verifier.exe /reset

verwendet. Das sei natürlich in Unternehmensumgebungen ein Ding der Unmöglichkeit, schreibt er.

Beim Driver Verifier kenne ich es noch aus Windows 7-Zeiten, dass die Maschine nach dessen Einsatz nur noch mit BlueScreens reagierte. Daher vermeide ich den Einsatz dieses Programms.

Hinweise zum PowerShell-Script

Das oben erwähnte PowerShell-Script zum Aufruf von verifier.exe besitzt die Version 3.7.2 und lässt sich bei Microsoft im Beitrag Windows Defender Device Guard and Windows Defender Credential Guard hardware readiness tool abrufen. Martin schreibt dazu, dass aber „nur“ die Version 3.6 des PowerShell-Scripts direkt herunterladbar sei.

Beide Scripte 3.7.2 und 3.6 unterscheiden sich, laut Martin, aber nicht in Bezug auf den verifier. Im Script wird zuallererst folgendes gemacht:


Anzeige

LogAndConsole „Enabling Driver verifier“

verifier.exe /flags 0x02000000 /all /log.code_integrity

Wenn man den Januar Patch aktiv hat und das dann ausführt, so schreibt Martin, endet dies in einem BSOD mit „Bad Pool Caller“, aber ohne Bugnummer. Es gibt auch keinen Dump im Ordner C:\Windows, wie es normalerweise bei Stopp-Fehlern der Fall sein sollte. Ergo lässt sich auch keine Ursachenforschung per Debugger betreiben.

Abschließende Bemerkungen

Martin schreibt dazu: Mit dem Dezember Patch von Windows 10 20H2 ging noch alles ohne Probleme. Da Windows 10 20H2 Enterprise keinen separaten UEFI Patch hat wie Windows 10 Version 1909 etc., geht Martin davon aus, dass dessen Änderungen direkt in KB4598242 integriert sind und diesen BlueScreen auslösen. Abschließend schreibt Martin:

Credential Guard etc. funktionieren laut Systeminformation auch, wenn der verifier nichts macht….

Kannst es ja mal checken (auch mit Deinen guten Kontakten). Testsystem muss aber UEFI sein, Secure Boot und TPM 2.0 haben. Ich habe jetzt das PS1 so angepasst, dass der verifier gar nicht mehr aktiviert wird. Dann klappt alles mit dem Januar Patch und den W10 Sicherheitsfunktionen – so wie bis Dezember 2020.

Hier wird es schwierig, ich habe keine Maschine, bei der ich das so testen könnte. Martin hat mir in einer Nachfolgemail noch zwei Hinweise gegeben: Der BSOD kommt bei ihm auch in einer Hyper-V VM, wo er gar keinen nicht Microsoft-Treiber installiert hat. Nach einem manuellen Aufruf des Befehls verifier /flags muss die VM neu starten. Dann kommt aber beim Booten der BlueScreen (BSOD), und zwar direkt nachdem das BIOS an Windows 10 übergibt. Martin schreibt zudem: Wir haben nur Dell und Hyper-V als „Hardware“. Daher gebe ich die Beobachtung an die Blog-Leserschaft weiter. Ist es Einzelfall, oder kann noch jemand das bestätigen?

PS: Zu Martins Vermutung -> ‚die guten Kontakte‘ sind bzw. waren hier schlicht nicht existent. Hab meine Aktivitäten als Microsoft Answers Community-Moderator seit zwei Jahren eingefroren (macht für mich von der Qualität der Arbeit keinen Sinn mehr). Den Insider MVP haben wir auch gerade geschlachtet (war aber bezüglich der oben erwähnten guten ‚Kontakte‘ für mich persönlich sowieso eine Null-Nummer, fast alles outgesourced, und der Rest in meinen Augen Traumtänzer). Ziel der Insider MVPs sollte expressis verbis ja sein, die ‚frohe Botschaft wie great Windows 10 sei‘ in der Community zu verkünden. In der Schaumschläger-Truppe war ich erkennbar fehl am Platz (lasse mich ungerne instrumentalisieren).


Cookies blockieren entzieht uns die Finanzierung: Cookie-Einstellungen

Anzeige


Dieser Beitrag wurde unter Windows 10 veröffentlicht. Setze ein Lesezeichen auf den Permalink.

22 Antworten zu Windows 10 20H2: Installation von Update KB4598242 erzeugt BSOD

  1. Martin Feuerstein sagt:

    „Credential Guard, Device Guard und Hyper-Visor Code Integration“ hab ich nicht, aber noch läuft der HO-PC trotz 2021/01-Updates (auf Arbeit werden die Updates erst später freigegeben). UEFI und SecureBoot sind aktiv, TPM-Status/Version müsste ich mal prüfen.

    @Günter: Das KB dürfte wohl eher aus 2021 sein. Der Jahreswechsel nervt aber auch jedes Jahr wieder ;-)

    • Günter Born sagt:

      @Martin: Danke für den Hinweis auf 2020 – ich weiß, ich bin ein ewig Gestriger – ist aber vom Datum korrigiert ;-)

      Ansonsten stellt es sich für mich so dar, dass der verifier nur bei dem obigen Szenario mit Credential Guard & Co. aufgerufen wird.

  2. fre4kyC0de sagt:

    Es scheint tatsächlich mit den Januar-Updates ein Treiber-Problem zu geben.
    Nach Installation des 2021-01 Patches freezt bei mir der Bootvorgang kurz nach Initialisierung des Grafiktreibers. Bootlog und so sind leider nicht verfügbar. Es half nur ein Rollback.
    Ein Test mit frischem Setup (selbe Hardware (Z390-Board, i7 9700k, 32GB RAM, diverse HDDs und optische Laufwerke [SATA], NVIDIA GTX1650) nur eine leere HDD verwendet) zeigte das selbe Bild (Treiber sind Audio-Treiber von Realtek, Intel Chipsatz-Treiber + Intel ME + Intel Optane, Ethernet-Treiber von Realtek, Grafiktreiber von Intel und NVIDIA, Treiber für einen PCIe-SATA-Controller von ASMedia; alle auf neustem Stand laut Hersteller-Seiten). Optane war im Test-Stetup aktiviert sowie Anwendungen mit Kernel-Treiber installiert (VirtualBox, Sandboxie und AV), im gesamten Test-Setup keine Internetverbindung.
    Das Problem wurde bei mir sowohl im Test-Setup als auch im Produktivsystem durch Deaktivierung von Optane und Entfernen von Sandboxie gelöst (sprich: Zurückfahren auf Minimalkonfiguration); da ich den Rechner aktuell dringend brauche und es zu dem Zeitpunkt schon 3:15 Uhr in der Nacht war, wollte ich nicht mehr nachvollziehen, was von beidem es war.

    • Anonymous sagt:

      Mein persönlicher Tipp:

      Mal wieder der Rapid Storage Treiber von Intel. Der hat mir auch schon graue Haare bereitet. Ich hatte mit dem Rapid Storage Treiber schon auf meiner privaten Hyper-V Spielwiese mit Windows Server 2012R2 eklige Probleme. Bei mir sind die Hosts immer mal wieder eingefrohren. Blöderweise konnte das auch nach erst vier Monaten passieren. Die Diagnose hat mich daher fast ein Jahr gekostet. Ich wusste nur schnell das es die Hardware selber nicht war :)
      In der Arbeit hat sich dieser Treiber auch schon als Upgrade Blockade erwiesen, Dell aktiviert sinnloserweise oft standardmäßig den Raid Modus und dann braucht man den Treiber. Ich bin dazu übergegangen wo immer möglich den Raid Modus zu deaktieren und den Standard SATA oder NVME Treiber von Microsoft zu verwenden. Wenn man weiß wie geht das auch sehr schnell und ohne Risiko :D

      Scheint aber in diesem Fall wohl nicht der einzige Treiber zu sein der Probleme bereitet, anderen Falls sollte es in einer VM nicht zu Problemen kommen.

  3. Ärgere das Böse! sagt:

    win 10 pro 64 bit 20H2, nicht verbastelt, läuft wie vorher ohne Probleme.

  4. 1ST1 sagt:

    Bei uns sind hunderte 2004 und ein gutes Test-Dutzend 20H2 „unterwegs“, Enterprise, Credential/Device-Guard, TPM, Bitlocker, UEFI, pipapoh, alles -bis auf wenige Ausnahmen- Dell. Ich kann im WSUS bisher nur einen PC sehen, bei dem KB4598242 fehlgeschlagen ist, der hat automatisch ein Rollback gemacht, läuft aber ansonsten. Den will sich ein Kollege näher ansehen, ich gebe ihm den Artikel hier mal zum prüfen. Wegen Homeoffice mit Remotezugriff, wichtigen Terminen (kann jetzt gerade nicht rebooten…) usw sind allerdings noch rund 1/3 nicht upgedatetd. Naja, mal sehen, ob sich da noch was tut, ob der Fehler nochmal auftritt.

    Wieviele PCs betrifft das denn in der Ausgangsnachricht?

  5. Norbert Holtkamp sagt:

    Hi,
    ich hatte ja im anderen Thread über den 01-2021, der leider als Anonym gepostet wurde, von diversen Problemen berichtet …
    Seit dem habe ich den Update deinstalliert, noch einmal installiert, wieder deinstalliert und dann noch einmal installiert … die Probleme wurden immer weniger und sind jetzt weg oder ich bemerke sie nicht mehr. Zwischendurch, aber nicht bei Installation oder Deinstallation, gab es auch mal einen BlueScreen.
    Gruß Nobby

  6. Triceratops sagt:

    Das Updates bei Windows 10 hin und wieder BSOD verursachen, ist ja bei Windows 10 normal (Quasi.: It’s not a bug, it’s a Feature). Sollte einen bei Windows 10 nicht wundern, wenn Updates probleme machen.

    • 1ST1 sagt:

      Genau die gleiche Aussage konnte man vor Jahren über Windows 8.x, 7, Vista, XP, 2000, NT4, … lesen und im Nachhinein schaut man trotzdem nostalgisch verklärt auf diese jeweilige Version. Früher war schon immer alles besser.

      • Zocker sagt:

        Nein, das war früher nicht der Fall. Bei XP noch am ehesten, aber spätestens ab Vista war es wesentlich besser als heute. Vorausgesetzt man hatte auch Treiber, die für das OS waren. Du verwechselst das vielleicht mit Win9x.

  7. Sebastian sagt:

    Hallo zusammen,

    heute wurde dieses Update bei uns auf zwei Rechnern (Domäne) installiert, bei dem danach das Problem auftrat, dass nach ca. 10 Minuten Laufzeit keine Internetseite mehr aufgerufen werden konnte. Ebenso konnte sich Outlook nicht mehr mit dem Exchange Online verbinden.
    Namensauflösung und Ping ins Web weiterhin möglich. Auch Teamviewerverbindungen waren möglich. Nach Deinstallation von KB4598242 ist das Problem anscheinend weg.

  8. micha45 sagt:

    Wenn man dieses kumulative Update (KB4598242) manuell installiert, muss man vorher zwingend das dazugehörige Servicing Stuck Update (KB4598481) aufspielen.
    Ansonsten kommt es zu Fehlern oder Systemabstürzen.

    Mittlerweile sollte das eigentlich allgemein bekannt sein.

  9. Wil Ballerstedt sagt:

    Auch bei mir alles klaglos. Allerdings läuft auf meinem Lap kaum was. MSO, ein paar Bildprogramme (schon lange nicht mehr genutzt) und ein wenig Audio (Audacity, Tracktion und zwei Apps). Nun gut. Nun wisst ihr’s (❁´◡`❁).

  10. Günter Born sagt:

    Auf Facebook gab es folgende Rückmeldung:

    Ja bei uns sind am Kassensystem die Comport Treiber rausgeflogen. Konnte allerdings durch einen alternativen Treiber wieder korrigiert werden. Windows hat den alten Treiber für nicht mehr gültig erklärt.

  11. Wolfgang sagt:

    Hallo zusammen,
    hier mal ein W10Home PC der ein Problem mit dem KB4598242 hat.
    Nach Download und Installation bootet PC, installiert dann bis 7% und macht dann ein rollback. Update bringt Error 0x80070003. Deaktivieren Update Service und löschen der Installationsdateien bringt keinen Erdolg. sfc und die diversen dism’s bringen keine Fehler, alles erfolgreich und trotz dem immer wieder das selbe Fehlerbild.
    Hat da jemand eine Idee?
    Hatte unter anderm versucht von der Home auf Pro Upgrade durchzuführen. Endet dann aber auch immer mit rollback.
    Alle Lizenzen original von MS!
    4 weitere PCs in meinem Netzwerk brachten keine Probleme, weder beim Update noch beim Upgrade

    • Günter Born sagt:

      Werte die CBS.log aus, vielleicht findet sich dort eine Information.

      • Wolfgang sagt:

        vielen Dank für die schnelle Reaktion. Werde mich damit auseinander setzen. Alle Zeilen beginnen mit Info, nicht Error. Wäre gut zu wissen worauf ich im Besonderen achten muss.

        • Günter Born sagt:

          Schau, ob irgendwo ein Warnung oder ein Error steht – es muss ja der von dir angegebene Fehlercode irgendwo auftauchen. Ggf. im Editor nach suchen.

          • Wolfgang sagt:

            Ich finde folgende Einträge nach dem ersten Auftreten des Codes:
            2021-01-26 19:13:39, Info CBS Session status queried: Current Phase: 1, Last SuccessfulState: Startup, Completed: 1, Status: 0x80070003
            2021-01-26 19:14:10, Info CBS Session: 30864399_188464785 initialized by client WindowsUpdateAgent, external staging directory: (null), external registry directory: (null)
            2021-01-26 19:14:10, Info CBS InternalOpenPackage failed for Package_for_KB3025096~31bf3856ad364e35~amd64~~6.4.1.0 [HRESULT = 0x800f0805 – CBS_E_INVALID_PACKAGE]
            2021-01-26 19:14:10, Info CBS Failed to internally open package. [HRESULT = 0x800f0805 – CBS_E_INVALID_PACKAGE]
            2021-01-26 19:14:10, Info CBS Failed to create open package. [HRESULT = 0x800f0805 – CBS_E_INVALID_PACKAGE]
            2021-01-26 19:14:10, Info CBS Failed to OpenPackage using worker session [HRESULT = 0x800f0805]
            2021-01-26 19:14:10, Info CBS Session: 30864399_188621015 initialized by client WindowsUpdateAgent, external staging directory: (null), external registry directory: (null)
            2021-01-26 19:14:10, Info CBS InternalOpenPackage failed for Package_for_KB3025096~31bf3856ad364e35~x86~~6.4.1.0 [HRESULT = 0x800f0805 – CBS_E_INVALID_PACKAGE]
            2021-01-26 19:14:10, Info CBS Failed to internally open package. [HRESULT = 0x800f0805 – CBS_E_INVALID_PACKAGE]
            2021-01-26 19:14:10, Info CBS Failed to create open package. [HRESULT = 0x800f0805 – CBS_E_INVALID_PACKAGE]
            2021-01-26 19:14:10, Info CBS Failed to OpenPackage using worker session [HRESULT = 0x800f0805]
            2021-01-26 19:14:16, Info CBS WU creates the package, AppID:MoUpdateOrchestrator, UpdateID:{BBDCFCC3-7595-4B9D-8730-B561F942F70A}, revision: 200

            Hilft das weiter?

            Habe mal versucht das KB3025096 zu installieren, welches erwähnt wird, das läuft aber auf Fehler
            Eigenständiges Windows Update-Installationsprogramm……..

          • Günter Born sagt:

            Kippe mal CBS_E_INVALID_PACKAGE in die Suchfunktion des Blogs. Es gibt einige Treffer – vielleicht hilft einer weiter. Ansonsten im Internet nach dem Begriff suchen.

          • Wolfgang sagt:

            Bin mit Deiner Empfehlung nicht weiter gekommen.

            Habe in der CBS.log allerdings folgenden Eintrag gefunden, der mich stutzig macht:
            CBS Failed to extract file TOC.xml from cabinet \\?\C:\WINDOWS\SoftwareDistribution\Download\e2b6710f9e24cf153fcf0c6b0dccb036\Windows10.0-KB4598242-x64.cab [HRESULT = 0x80070002 – ERROR_FILE_NOT_FOUND]
            Die Datei kann ich auch durch manuelles sucen in den Cab-Dateien nicht finden.
            Ich frag mich warum das bei meinen anderen Geräten mit der Installation funktioniert hat, wenn die TOS.xml garnicht drin ist????

  12. Markus sagt:

    Hi,
    habe das gleiche Problem auf einem Medionlaptop mit Win10home 20h2.
    Zuerst kamen bei jedem Reboot es Updates immer BSoDm welche ich nur mit viel Arbeit und Reboots wieder hinbekommen habe (STOP…ndis.sys)
    Spätere Versuche (nach Deaktivierung nicht von mir genutzter Netzwerktreiber) haben zwar keinen sichtbaren BSoD mehr gebracht, aber da während des Bootens plötzlich noch mal das Bios durchlaufen wurde und dann die Installation rückgängig gemacht wurde, tippe ich auf ähnliche Treiberprobleme wie auch im ersten Kommentar beschrieben.
    Habe auch schon diverse Sachen, die auch hier beschrieben wurden, getestet ohne Erfolg.
    Heute auch mal das vor 2 Tagen erschienene Nachfolgeupdate KB4601319.
    Leider mit gleichem negativen Ergebnis.
    Gibt es schon eine Lösung?
    Kann auch noch gerne weitere Daten liefern, falls das helfen würde.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Hinweis: Bitte beachtet die Regeln zum Kommentieren im Blog (Erstkommentare und Verlinktes landet in der Moderation, gebe ich alle paar Stunden frei, SEO-Posts/SPAM lösche ich rigoros). Kommentare abseits des Themas bitte unter Diskussion.