Windows 10: Neues zum “keine gültige IP-Konfiguration”-Bug

Aktuell kämpfen weltweit ja eine Reihe Windows 10-Systeme bzw. deren Benutzer mit einem “gekappten Internet”. Ich konnte den Fehler auf einer Testmaschine reproduzieren. Hier ein paar ergänzende Informationen – der Beitrag geht stückweise online. Nachtrag: Der Beitrag ist aus meiner Sicht jetzt (vorerst) fertig.


Anzeige

Im Blog hatte ich vor zwei Tagen über das Update KB3201845 für Windows 10 Version 1607 berichtet (KB3201845 hebt Windows 10 Version 1607 auf Build 14393.479–kappt Internetzugang?). Es gab Vermutungen (auch meinerseits) und Problemlösungen (die wirken). Und es gab heftige Diskussionen, auch zu obigem Blog-Beitrag. Die Geschichte geht zwischenzeitlich durch das Internet.

Das gekappte Internet hat nichts mit Update KB3201845 zu tun!

Das ist die Erkenntnis, die sich sich aus den Kommentaren und Forendiskussionen ergab. Ich konnte es nicht verifizieren – mein VMs mit Windows 10 hatten keine Version 1607 oder Insider Previews – genau wie das normale Testsystem. Jetzt trat der Fall auf einer Windows 10 Version 1607-Maschine, die ich lange nicht gebootet hatte, auf. Es handelt sich um das in diesem Blog-Beitrag Sony Vaio PCG-6L2M auf Windows 10 aktualisieren – Teil 1 beschriebene Notebook. Benutze ich gelegentlich für Tests (speziell im Miracast-/Streaming-Bereich). Da war seit Monaten kein Update mehr installiert worden, war wohl im September 2016 zum letzten Mal in Betrieb, aber beim Start heute war das Internet plötzlich weg.

Das Fehlerbild auf meiner Maschine

Nach der Anmeldung am Benutzerkonto schien zuerst alles in Ordnung. Ich konnte sogar die Update-Seite in der Einstellungen-App aufrufen und diese zeigte mir gefundene Updates an, deren Download auch als “begonnen” in einer Fortschrittsanzeige ausgewiesen wurde. Nur blieb der Fortschrittsbalken bei 0% stehen (was nichts außergewöhnliches ist).

Kein Internetzugriff

Nach einiger Zeit erschien dann das berühmte gelbe Dreieck mit dem Ausrufezeichen im WLAN-Symbol und die QuickInfo meldete “Netzwerkidentifizierung – Kein Internetzugriff” (siehe obiger Screenshot).

Wi-Fi-Netzwerke

Nach dem Anklicken des Netzwerksymbols wurde das Netzwerk zwar mit seiner SSID aufgeführt (siehe obiger Screenshot). Aber es gab kein Internet.

Prämissen, die ich nun ausschließen kann


Anzeige

Wie bereits eingangs beschrieben, gab es im Rahmen der Diskussionen im Internet Vermutungen. Für mich kann ich nun folgendes definitiv ausschließen:

Updateverlauf

  • Es liegt nicht an einem der in den letzten Wochen ausgerollten Updates. Das Update KB3201845 für Windows 10 Version 1607, welches als Auslöser vermutet wurde, lässt sich definitiv ausschließen. Auch die in der Insider Release Preview vorab freigegebene Fassung oder das kumulative Update für November scheidet aus.  Der obige Screenshot zeigt, dass die Maschine im September wohl das letzte kumulative Update KB3176938 bekommen hat.
  • Ein kaputter Netzwerktreiber kann gemäß den obigen Screenshots ausgeschlossen werden, da die Maschine über WLAN mit der FRITZ!Box das Wi-Fi-Netzwerk gefunden hat und kommunizieren konnte. Auch WLANs der Nachbarschaft wurden angezeigt.
  • Ein ständig laufender Router schließe ich ebenfalls aus. Der WLAN-Router ist nachts aus Sicherheitsgründen ausgeschaltet. Möglicherweise spielt der Ruhezustand eine Rolle – normalerweise fahre ich die Maschinen regulär herunter – aber in der Ereignisanzeige konnte ich bei der Auswertung sehen, dass das System aus dem Ruhezustand aktiviert wurde.

Was die Sache noch komplizierter macht: Es tritt wohl nur bei Windows 10 Version 1607 (Anniversary Update) auf. Mein VMs und Testmaschinen sind aber auf anderen Builds (entweder RTM, V 1511 oder Insider Preview).

Einfach mal die Netzwerkdiagnose befragt

Im Grunde ist ja alles im Blog-Beitrag KB3201845 hebt Windows 10 Version 1607 auf Build 14393.479–kappt Internetzugang? behandelt. Die Geeks wissen sich also zu helfen. Wenn ich aber einen Fehler schon mal habe, versuche ich das Ganze ein wenig zu dokumentieren und zu untersuchen – u.a. für normale Anwender, die über Google ggf. hierhin kommen, und für reguläre Blog-Leser, die vielleicht noch eine Idee haben, die mir nicht gekommen ist. Tritt unter Windows ein Netzwerkfehler auf, ist es eigentlich sinnvoll, die Netzwerkdiagnose ausführen zu lassen. Mache ich eigentlich in der Regel so.

Problembehandlung Netzwerk aufrufen

Es reicht ein Rechtklick auf das LAN-/WLAN-Symbol und dann Problembehandlung im Kontextmenü anzuwählen. Schon beginnt die Problembehandlung mit der Netzwerkdiagnose.

Problembehandlung Netzwerk

Und kurz darauf kam der Hinweis der Problembehandlung, dass der Netzwerkadapter zurückgesetzt werde.

Problembehandlung Netzwerk

Nachdem die Problembehandlung abgeschlossen wurde, kam die nachfolgend gezeigte Meldung, dass das Problem nicht behoben sei und das “WLAN” über keine gültige IP-Konfiguration verfüge.

Netzwerkdiagnose - Ergebnisse

Das ist also die bereits im Internet ausgiebig diskutierte Fehlerquelle. Über den Hyperlink Ausführliche Informationen anzeigen kann man sich weitere Ergebnisse anzeigen. Hier mal kommentarlos die betreffenden Screenshots.

Netzwerkdiagnose - Ergebnisse - Details 1

Zusammenfassend lässt sich feststellen, dass die Problembehandlung den Fehler der ungültigen IP-Konfiguration (zumindest auf meinem System) nicht lösen konnte. Die Hinweise in den Details des Assistenten sind auch wenig zielführend – den Router zurücksetzen wird nicht helfen.

Und noch eine Erkenntnis habe ich gewonnen. Man kann sich die Erkennungsdetails über einen Hyperlink im Internet Explorer anzeigen lassen. Im konkreten Fall führte dies aber nicht weiter, da der IE wohl etwas aus dem Internet brauchte, dies aber nicht abrufen konnte. Jedenfalls wurde mir eine leere Seite mit einem x in der linken oberen Ecke (Platzhalter für nicht darstellbar Objekte) angezeigt.

Weitere Diagnosen

Ich habe dann noch versucht, einige weitere Informationen zu sammeln. Ich konnte die Ergebnisse der Netzwerkdiagnose in den Dialogfeldern des Assistenten abrufen. Hier ein Auszug:

Ergebnis der Diagnose: Problem ermittelt

Fehlerursache:
Dieser Computer wechselt kontinuierlich zwischen zwei oder mehr Drahtlosroutern oder Zugriffspunkten.

Detaillierte Fehlerursache:
Übermäßige Serverspeicherung (zwischen Zugriffspunkten, innerhalb eines Profils oder in einem bevorzugten Netzwerk).

Allerdings ist diese Information meiner Ansicht nach nicht korrekt, denn ich konnte über den WLAN-Router auf eine Netzwerkfreigabe eines zweiten Rechners zugreifen.

Die Ergebnisse der Abfrage der IP-Adressen ist in obigem Screenshot zu sehen. Es ist ein DHCP-Bezug aktiviert, es gibt eine IPv4-Adresse aber diese passt nicht zu meinen IPv4-Adressen im Netzwerk.

Also die in diesem heise.de-Artikel Situation, dass die IP-Adresse nicht vom DHCP-Server bezogen werden kann und daher per APIPA festgelegt wird.

Ich habe an dieser Stelle nicht weiter geforscht, sondern mit dem Zurücksetzen von winsock begonnen (siehe unten). Ein nachträglicher Blick in die Ereignisanzeige ergab für mich einige Merkwürdigkeiten.

  • Es wird mir die aktive Systemzeit zum 11.12.2016 mit 86966356 Sekunden angezeigt – und dann findet sich ein “chronologisch” älterer Eintrag mit Datum 29.2016 im Ereignisprotokoll (wurde vom Zeitstempel nach dem Event vom 11.12.2016 eingeordnet – hatte ich so auch noch nicht gesehen), der informiert, dass das System aus dem Energiesparmodus neu gestartet wurde.
  • Dann gibt es den Hinweis, dass die Systemzeit am 11.12.2016 auf das aktuelle Datum geändert wurde (vermutlich über die Hardware-Uhr). Und dann folgt irgendwann (um 07:33:21) die Information, dass ich die Maschine aus dem Ruhemodus gestartet habe (ich habe meine ursprüngliche Prämisse, dass die Maschine per Schnellstart bootete, verwerfen müssen).
  • Ab 07:33:28 ist “die Hölle los”, es werden laut Ereignisanzeige jede Menge Dienste (Plattformdienst für verbundene Medien, COM+ Ereignissystem, Funktionssuchanbieter Host, Windows-Dienst für Schriftartencache, Windows-Lizenzmanager-Dienst, Netzwerklistendienst, Netzwerkspeicher-Schnittstellendienst, Diagnosehost, WinHTTP-Web Proxy Auto-Discovery-Dienst) beendet.
  • Ein paar Informationen-Events später findet sich die Warnung, dass es eine Zeitüberschreitung bei der Namensauflösung für einen Microsoft-Server gegeben hat, nachdem der DNS-Server nicht geantwortet hat.

Das muss der Zeitpunkt gewesen sein, zu dem mir die verminderte Konnektivität mit dem gelben Ausrufezeichen angezeigt wurde. Die Ereignisanzeige meldet zwar noch, dass der Update-Client mit dem Herunterladen eines Updates begonnen habe. Aber gleich darauf wird ein Fehler gemeldet, dass Korrekturmaßnahmen nach dem Beenden des “Netzwerkspeicher-Schnittstellendienst” fehlgeschlagen seien (siehe folgender Screenshot).

Es ist also beim Aufwachen aus dem Ruhezustand etwas gravierendes passiert, so dass die Dienste beendet wurden. In der Ereignisanzeige finde ich danach die Protokolleinträge der Problembehandlung. Dort gibt es den Hinweis, dass der Rechner mit einer lokalen IP-Adresse versehen wurde und möglicherweise nicht auf das Internet zugegriffen werden kann.

Ohne jetzt scharf nachzudenken, wage ich die Prämisse, dass der Bezug einer IP-Adresse über den DHCP-Server der FRITZ!Box wegen der sterbenden Dienste scheiterte (mag mich aber täuschen).

Mein Versuch zum Beheben

Ich habe eine administrative Eingabeaufforderung geöffnet (Windows+X und den Befehl Eingabeaufforderung (Administrator) anwählen) und die Befehle:

netsh winsock reset
netsh int ip reset

eingegeben. Im Fenster der Eingabeaufforderung wurde ich dann zum Neustarten des Computers aufgefordert.

IP-Reset

Ab diesen Zeitpunkt wurde es etwas schwierig – Netzwerkzugriffe waren aus einer Anwendung noch möglich (ich habe Screenshots im Netzwerk speichern können), aber im Explorer konnte ich nicht mehr auf Freigaben zugreifen, da die Netzwerkerkennung nicht eingeschaltet werden konnte. Der Versuch, die Ereignisanzeige zu öffnen, führte dazu, dass Windows 10 so gut wie überhaupt nicht mehr bedienbar war. Ich habe daher das System per Power-Taste herunter gefahren, neu eingeschaltet und nach der Benutzeranmeldung einen sauberen Neustart eingeleitet (Umschalttaste gedrückt halten und im Menü Ein/Aus den Befehl Neu starten gewählt). Damit gelangte ich in Windows PE und habe die Option zum Herunterfahren von Windows gewählt. Nach dem nächsten Start war das Problem behoben.

Nach den Microsoft-Hinweisen wäre nur ein einfacher Neustart erforderlich gewesen – ohne meine Eingaben in der Eingabeaufforderung. Dies als Hinweis für normale Nutzer, die hier landen: Windows 10 Version 1607 neu starten und gut ist – hoffentlich …

Was Microsoft rät

Parallel habe ich (auf einem zweiten Rechner) im Internet nach “keine gültige IP-Konfiguration” gesucht und auf einer Microsoft-Seite zu diesem Problem folgenden Hinweis gefunden.

Dort wird also ein Neustart von Windows vorgeschlagen, wobei der saubere Neustart nicht gefordert wird (war aber auch meine Anmerkung weiter oben). Im Blog-Beitrag KB3201845 hebt Windows 10 Version 1607 auf Build 14393.479–kappt Internetzugang? sind weitere Ansätze genannt – u.a. den Schnellstart abzuschalten (ist wohl nicht erforderlich).

Abschließende Bemerkungen

Am Ende des Tages weiß ich immer noch nicht, was im Detail zu diesem Fehler geführt hat. Updates der letzten 8 Wochen schließe ich auf Grund der oben skizzierten Problematik aus. Das Thema “nicht erneuerter DHCP-Lease” könnte zutreffen – aber die vielen Ereignisse über beendete Dienste geben mir doch arg zu denken. Aber es mag Zufall sein.

Die in Kommentaren hier und hier adressierte fehlenden Recherche nehme ich zur Kenntnis. Hätte ich mich, wie früher, täglich mehrfach im MS Answers-Forum herumgetrieben, wäre mir der Thread über das DHCP-Problem auch unter die Augen gekommen (ist seit meinem Unfall, und aus diversen anderen Gründen, nach wie vor nicht mehr drin). Hätte ich Google mit den richtigen Suchbegriffen befragt (bei der MS Answers-Suchfunktion habe ich das Fragen aufgegeben), hätte mir der Browser die Beiträge wohl auch ausgespuckt (und die Update-Theorie wäre nicht aufgekommen). Hätte, hätte, Fahrradkette – wusste schon Peer Steinbrück. War nicht und hinterher ist man immer schlauer …

Zum Rest schweige ich mal besser. Aber ich sage es mal so: Hier läuft Windows 7 als Produktivsystem – und wir diskutieren eh über einen Fehler, der theoretisch niemals vorkommen kann. Denn die Leute nutzen ja das beste Windows aller Zeiten, und das wird durch Windows-as-a-service täglich besser. Zudem lese ich auch immer, dass die hier im Blog beschriebenen Probleme bei den Windows 10 Nutzern sowieso nie auftreten. Also wieder ein Sack Reis in China, der umgefallen ist. Oder ein Fehler, der genau so wahrscheinlich ist wie der Umstand, dass mich morgen ein schwarzes Loch verschlingt Zwinkerndes Smiley.

Aber egal, ich habe die obigen Infos, quasi aus akademischem Interesse, zusammen getragen, mache jetzt aber einen Haken dran. Vielleicht wird irgendwann bekannt, was genau mit Windows 10 Version 1607 passiert ist und was der Auslöser für das DHCP-Problem war – wenn wir bis dahin nicht in das schwarze Loch gefallen oder vom umfallenden Sack Reis erschlagen worden sind.

Nachträge: Bei heise.de gibt es ja den Artikel Windows-10-Computer vom LAN und Internet abgeschnitten mit recht vielen Diskussionsbeiträgen. Wenn man die Troll-Kommentare herausfiltert, bleiben einige Zusatzinformationen übrig. Hier beschreibt ein Nutzer ein Problem mit der Intel I217-V-Schnittstelle, welches ein ähnliches Fehlerbild ergab und durch ein Treiber-Update behoben werden konnte. Ein zweiter Hinweis enthält dieser Post als Ergänzung zu einem Kommentar von mir mit Verweis auf diesen Blog-Beitrag. Dort gibt der Benutzer an, dass bei angelaufenem Lease das Fehlerbild bei seinen Rechnern häufiger auftaucht. Dass das Neustarten des DHCP-Client-Diensts helfen soll, hatte ich schon irgendwo gelesen.   Spannend fand ich auch diesen Post mit einem Registrierungs-Eintrag (hab da aber nichts getestet und die Erklärung sind momentan für mich auch “ferne Galaxie”).  Und hier bemängelt jemand ein kaputtes DHCPv6 – während in diesem Kommentar ein ganzes Bündel an Ungereimtheiten thematisiert wird.

Microsoft patcht mit KB3206632

Microsoft hat mit Update KB3206632 auch das Problem adressiert und hofft, dass der Fehler behoben ist. Hat mir Gelegenheit gegeben, auf der betroffenen Maschine nachzusehen. Ich habe dazu noch einen Blog-Beitrag Nachbetrachtung: KB3206632 und der “Keine IP”-Fix – weitere Erkenntnisse nachgeschoben.

Ähnliche Artikel:
KB3201845 hebt Windows 10 Version 1607 auf Build 14393.479–kappt Internetzugang?

Windows 10-Fehler: Netzwerkprotokoll fehlt – Teil 1
Windows 10-Fehler: Netzwerkprotokoll fehlt – Teil 2
Windows 10-Fehler: Netzwerkprotokoll fehlt – Teil 3

Windows 10 Anniversary Update macht Webcam unbrauchbar
Windows 10 Anniversary Update: System friert ein
Windows 10 Version 1607: Externe USB-Festplatte nicht erkannt
Anmeldung fehlt bei Windows 10 Version 1607


Anzeige
Dieser Beitrag wurde unter Problemlösung, Windows 10 abgelegt und mit , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

57 Antworten zu Windows 10: Neues zum “keine gültige IP-Konfiguration”-Bug


  1. Anzeige
  2. Jo sagt:

    Gratulation – sehr gute Erklärung und Zusammenfassung!
    Jetzt sprechen die Fakten und man kann ohne Vorurteile, Gerüchte und Weitersagen die Ursache ermitteln (aber MS muss schon kräftig mithelfen).

  3. Nils sagt:

    Leider hat sich mittlerweile durch die Berichterstattung schon überall die Meinung festgesetzt, dass es ausschließlich am KB3201845 liegt.

    Das soll jetzt wirklich kein Vorwurf an den Blog hier oder an Günter Born sein. Aber es ist eben leider so, dass viele selbst ernannte Tech-Blogs nicht mehr selber recherchieren sondern nur noch voneinander abschreiben. Der Günter versucht ja wenigstens im Nachhinein Licht ins Dunkle zu bringen, was lobenswert ist.

    Aber viel zu oft setzt irgendeine Seite Vermutungen oder Behauptungen ins Netzt und alle andere übernehmen das dann ohne selber die Hintergründe zu überprüfen.

  4. Anzeige

  5. OlliD@IRQ8 sagt:

    Hallo Günter,

    den Fehler “Zugriff verweigert” bei “netsh int ip reset” gibt es schon “ewig” (fehlerhafte ACL in der Registry).

    So funktioniert es für die WiFi-Verbindung per Batch-File sauber (SetACL.exe wird hierfür über den Downloadlink benötigt):

    REM Reset_WiFi_Limited.cmd
    REM SetACL – Automate Permissions and Manage ACLs • Helge Klein
    REM https://helgeklein.com/setacl/

    PUSHD “%~dp0”
    IF EXIST NsiReg.txt DEL /F NsiReg.txt
    IF EXIST Reset_WiFi_Limited.log DEL /F Reset_WiFi_Limited.log
    FOR /F “tokens=1-6 delims=\” %%a IN (‘%windir%\System32\reg.exe QUERY HKLM\SYSTEM\CurrentControlSet\Control\Nsi’) DO (
    %windir%\System32\reg.exe QUERY HKLM\%%b\%%c\%%d\%%e\%%f\26 2>NUL
    IF NOT ERRORLEVEL 1 ECHO HKEY_LOCAL_MACHINE\%%b\%%c\%%d\%%e\%%f\26 >> NsiReg.txt
    )
    FOR /F “tokens=1” %%a IN (NsiReg.txt) DO SetACL.exe -on %%a -ot reg -actn ace -ace “n:Jeder;p:full” >> Reset_WiFi_Limited.log
    %windir%\System32\ipconfig.exe /flushdns >> Reset_WiFi_Limited.log
    %windir%\System32\netsh.exe interface ip reset >> Reset_WiFi_Limited.log
    %windir%\System32\shutdown.exe /r /t 30 /f

    EXIT

  6. Christian sagt:

    Vielen Dank für die umfangreichen Infos, die hier wieder zusammengestellt
    wurden. Schande über mein Haupt, dann ist Windows 10 ja doch “Great!”?
    Aber warum möchte ich dieses “Beste Windows aller Zeiten” dann immer
    noch nicht? Hmm….

    Nun ja, heut gibt’s wenigstens Reis zum Nachtessen. Der Sack wird nämlich
    somit wieder etwas kleiner und kann nicht mehr so leicht umfallen…

    Einen guten Wochenstart an alle!
    Christian

  7. Jo sagt:

    Klarstellung:
    Sollte mein Hinweis zur Sachlichkeit und zu Fakten als persönliche Kritik an Günter Born verstanden werden, so VERNEINE ich es hiermit ausdrücklich. Es war in keinster Weise persönlich gemeint.
    Es waren immer die Schnellschüsse gemeint.
    Zudem erwartet niemand am selben oder nächsten Tag eine sofortige Lösung aber mit einer solch präzisen Analyse ist die Fehlersuche um einiges einfacher.
    So eine tolle Recherche in dieser Ausführlichkeit sucht Ihresgleichen und so manche Abschreiber und Nachplapper er werden sich an der Nase nehmen müssen.

    Nochmals DANKE – die „small code company“ wird’s schon richten ;-)

  8. Luccabrasi sagt:

    Vielen Dank für die aussagekräftig Recherche und machen sie bitte weiter so.

  9. Anzeige

  10. Thürk Maschke sagt:

    “Aber warum möchte ich dieses „Beste Windows aller Zeiten“ dann immer
    noch nicht? Hmm….”

    @Christian:

    Wahrscheinlich, weil “Satya Nadella” und das „Beste Windows aller Zeiten“ nach wie vor ein Oximoron bilden;-)
    Deshalb spare ich mir auch die “Asche auf’s Haupt” und rudere keinen Millimeter zurück. “Windows 10” und “seine Anhänger” werden weiter in lodernder Hassliebe unglücklich glücklich verkettet bleiben.
    Die “WorldWideWindows-Welt” erscheint mir inzwischen als eine einzige Kette “Oximoronen”(Oxymora;-)

    “Borncity.com” und “Erstklassiger IT-Blog”,
    passen hingegen wie die “Die Faust auf’s Auge”.

    Danke, lieber Günter Born, für die vielen “Blauen Veilchen”;)

    Allen einen schönen Abend:-)

  11. Janami25 sagt:

    Ich habe mal einen Test mit dem Update gemacht, weil ich auf meinem Testrechner unmittelbar nach der Installation des 14393.479 Updates das Problem mit der Internetverbindung hatte.

    Ich habe folgendes gemacht : Zuerst eine 2 Wochen altes, funktionierendes Backup von Windows 10 wiederhergestellt. Dann, Wlan Verbindung zum Internet getrennt bzw. zu meinem Router. Am Wlan Adapter auf Dynamischer IP belassen.

    Offline habe ich das Update nun durchgeführt, also ohne eine aktive Verbindung zum Router.
    Und nach Installation des Updates hatte ich trotzdem das Problem, das die Netzwerk Einstellungen im WLAN Adapter komplett durcheinander waren, so das eine Verbindung nicht mehr möglich war.

    Da muss mir mal langsam einer erklären, das es nicht an dem Update liegt…

    Wenn vor dem Update im Adapter bzw den IP4 Konfiguration alles super aussieht,dann das Update Offline gemacht wird, und nach dem Update funktioniert es nicht mehr, liegt es für mich bestimmt nicht an der Hardware oder dem Router… ;)

    Vielleicht kann das ja ein zweiter mal gegen testen…

  12. Nils sagt:

    Eben in der Fima mal an zwei Testrechner (1x Win10 x86, 1x Win10 x64) versucht.
    Beide Rechner hatten das Update noch nicht, da im WSUS noch nicht freigegeben. Nach der maneullen Installation läuft alles noch ohne Probleme, auch nach zwei Neustarts der Rechner.

  13. Janami25 sagt:

    Okay, danke. Dann bin ich auch langsam überfragt.. ;)

  14. Sven Fischer sagt:

    Scheinbar gibt es vom KB3201845 eine neue Version. Ich habe heute morgen bei meinem Netbook mit Win10 / 32Bit, das manuelle Update ausglöst. Dabei kam eine neue Version des besagten Patches.

    Meine beiden Notebooks, Asus Netbook und Lenovo T410, waren / sind auch von dem Problem betroffen. Den Schnellstart hatte ich bei dem Upgrade auf Win10 als erstes deaktiviert. Die Netzwerkprobleme waren / sind unabhängig vom WLAN / LAN, oder DHCP, statischer IP.

    Bei meinem “Arbeitssystem” mit Win7 sind derartige Probleme, seit der Installation nie aufgetreten. Hoffentlich setzt MS, Win10 mit den ständigen Problemem, nicht ganz und gar in den Sand.

    Grüße

  15. Gerd sagt:

    KB3201845: Erfolgreich installiert am 10.12.2016.
    Der betroffene Rechner (ein Acer Aspire 5742G) stellt weiterhin problemlos eine WLAN-Verbindung her, auch der Internetzugriff funktioniert (eben getestet mit http://www.heise.de und auch http://www.borncity.com).

    Was habe ich falsch gemacht?

  16. Kim O. Fee sagt:

    12. Dezember 2016 um 11:08
    Sven Fischer sagt:
    Scheinbar gibt es vom KB3201845 eine neue Version. Ich habe heute morgen bei meinem Netbook mit Win10 / 32Bit, das manuelle Update ausglöst. Dabei kam eine neue Version des besagten Patches.

    Dann müsste es auch von der 64-Bit-Version eine “neue Version” geben, was jedoch nicht der Fall ist – Download via http://www.catalog.update.microsoft.com/Search.aspx?q=KB3201845 vom 8.12.2016 und vom 13.12.2016: jeweils völlig identische “windows10.0-kb3201845-x64_95e1e765344e1388fee3f7c0c143499e0b617d9f.msu” mit jeweils 983 459 725 Byte bzw. MD5 = 4907ba05a108c4bb3225aefc390ac3c9

  17. ubdu sagt:

    Vielen Dank für die ausführliche Beschreibung – geholfen hat tatsächlich der ganz einfache Tipp “Neustart”.

  18. Jo sagt:

    Im neuesten KB3206632 gibt es folgenden Fix:

    Es wurde ein Dienstabsturz in CDPSVC festgestellt, der in einigen Situationen dazu führen könnte, dass die Maschine keine IP-Adresse erwerben kann.

    Dieser Dienst (Connected Devices Platform Service (CDPSvc) ist erst ab der Version 1607 auf Automatik gestellt (in 1511 disabled).
    Vielleicht hat diese Schwachstelle jetzt zugeschlagen.

  19. Fred sagt:

    Kam mit 1 Notebook auch nicht ins Internet, gleiche Fehler wie hier beschrieben. Gleiches Problem an sowohl Lan und WLAN, nachdem mein Rechner allen in ein Domain sind und auch DHCP vom Windows Server bekommen ist mein Fritz!Box hier kein teil des problems.

    Bemerkenswert is allerdings das die IP addresse ein PIPA ist, aber der DNS server welcher auf uber DHCP erhalten werden stimmten mit der DHCP ausgabe.

    Letzter update war von september 2016, am DHCP server das protocol angesehen und kein eintrage vom Notebook. Es hat bei mir letzendlich gereicht um der DHCP dienst neu zu starten und hatte dan wieder ein IP-Address vom server und im DHCP server protocol ein eintrag.

    Es hat meiner ansicht nichts mit der KB3201845 zu tun, aber nachdem der neu start der DHCP Dienst das Problem behoben hat vermutte ich ein Problem in der DHCP Client dienst von Windows.

  20. Thomas F. sagt:

    In Zusammenhang mit den Updates bei:

    v1511 KB3198586
    und
    v1607 KB3206632/3201845

    habe ich an einer Reihe von Windows 10 pro Clients folgendes Phänomen:

    Beim Starten einer *.exe über ein Netzwerkshare verabschiedet sich Windows 10
    mit einem BOSD FLTMGR.SYS System Service Exception

    Alle Clients liefen vor diesen Updates problemlos.

  21. Thomas F. sagt:

    Daran dachte ich auch.

    Jedoch sind die Clients mit unterschiedlichen Scannern ausgerüstet, wie z.B. gdata und Avira.

    Allen gemein ist, dass die Probleme erst nach den beschriebenen Updates auftraten.

    Hab jetzt einen Client (v1511) folgendermaßen “behandelt”:
    Deinstallation von KB3198586
    Neustart
    Starten einer exe via Netzwerkshare
    Weiterhin BOSD mit FLTMGR.SYS System Service Exception
    Deinstallation / Neuinstallation des Netzwerktreibers (In dem Fall Intel 219-V)
    (Es macht keinen Unterschied ob DHCP oder fixe IP)
    Reboot
    >> Geht

    Zurücksetzen des Netzwerkstacks etc. half nicht.

    Insgesamt trifft es Clients mit vollkommen unterschiedlicher Hardware, auch VMs unter ESXI.

  22. Dirk sagt:

    Ich hatte exakt das gleiche Fehlerbild, sogar identische Hardware.
    Der entscheidende Tipp war “Schnellstart”.
    Also ein primitiver Selbst-Versuch : Batterie raus, Warten, Batterie rein.
    Erstaunliches Ergebnis! Hilft vielleicht bei anderen Problemen auch.

  23. Gudrun Hoffmann sagt:

    Vielen Dank lieber Günter Born, für die ausführliche Beschreibung des Problems – geholfen hat tatsächlich der ganz einfache Tipp „Neustart“.
    „Borncity.com“ ist für mich stets ein guter Ratgeber.
    Beste Wünsche und alles Gute für das neue Jahr

  24. Manfred Deubel sagt:

    Ich habe Ihren Beitrag mit Interesse gelesen, kann mich Gudrun Hoffmann nur anschließen, besten Dank für Ihre Arbeit. Der Fehler ist bei mir einige Male aufgetreten, konnte ihn jedoch nicht finden, noch mehr Zeit und Nerven verhinderte Ihr Hinweis auf die “Microsoft-Seite -Neustart- ausführen” . Danke!

  25. Sassu sagt:

    Vielen Dank auch von mir für die super Erklärung!
    Ich bin nicht vom Fach, habe aber eine grundsätzliche Frage… mich würde interessieren, ob man denn DHCP zur Vergabe von IP Adressen unbedingt benötigt? Kann die automatische Vergabe nicht auch über IPv6 gelöst werden?

  26. Leon sagt:

    In den vergangenen Wochen hatte ich bei einiger meiner Klienten “keine gültige IP-Konfiguration”.
    Was in allen Fällen ohne Neustart geholfen hat ist eine Eingabeaufforderung (als Administrator) mit:
    ipconfig /renew
    Es wurden zwar vereinzelt Fehler beim Ausführen des Kommandos angezeigt, aber die IP-Konfiguration war danach wieder gültig.

  27. Hermännchen sagt:

    Auch ich bin in die Falle gegangen. Habe alles durchprobiert, aber ohne Ergebnis. Kein Internetzugang. Bis ich auf Deinen Beitrag gestoßen bin. Genial einfach.
    Herzlichen Dank für Deinen Beitrag, er hat mir sehr, sehr viel Arbeit erspart.
    Gruß Hermännchen

    • Hermännchen sagt:

      Nachtrag: Es funktioniert ja mit dem Neustart. Aber wenn ich den PC herunterfahre und dann neu starte habe ich wieder das gleiche Problem.
      Was muß ich tun, daß der PC gleich beim Start Internetverbindung hat?
      Gruß Hermännchen

  28. Birgit Vorländer sagt:

    Vielen Dank für die Tipps. Ich konnte das Internet nur nach Eingabe der “netsh” Kommandos wieder benutzen. Mein Tablet hatte glücklicherweise immer Zugriff zum Internet und so konnte ich den Tipp überhaupt erst finden.

    • Günter Born sagt:

      Alte Indianer-Weisheit, für die ich wieder gesteinigt werde: Für Windows 10 Systeme brauchst Du einfach ein Backup-System zum Recherchieren von Lösungen für Fehler. Am Besten eignet sich ein Android- oder iOS-Smartphone bzw. -Tablet – duck und wech ;-).

  29. Lea sagt:

    Vielen Dank. Ich habe von so etwas überhaupt keine Ahnung und wusste auch nicht was ich machen sollte als mir der Laptop sagte es gäbe keine gültige IP Konfiguration. Habe es dann wie im Beitrag mit ihrer Methode probiert und die administrative Eingabeaufforderung geöffnet und den Befehl netsh int ip reset eingegeben. Seitdem funktioniert das W-LAN an meinem Laptop wieder.

  30. Manfred Burmeister sagt:

    Guten Morgen!

    Auch ich war Leid geplagt. Habe ein Laptop von Lenovo. G780. Als Netzwerkadapter “Qualcomm Atheros AR8162/8166/8168 PCI-E Fast Ethernet Controller (NDIS 6.30” verbaut. Nachdem andere bei mir im Netz sich befindende Geräte weiterhin ohne Probleme im Netz waren hatte ich für mich beschlossen, dass es nur mit meinem System zusammenhängen kann. Ich schloss also Updates aus. Mein Fazit war, dass ich davon ausging, dass es mit dem Netzwerkadapter zusammen hängt.
    Es folgte die Neuanschaffung eines USB Adapters auf RJ45. Ich deaktivierte den Netzwerkadapter von Qualcomm und startete den Rechner neu. Das ist jetzt drei Tage her. Seitdem läuft auf meiner Maschine alles fehlerfrei. Gruß – Manfred.

    • Manfred Burmeister sagt:

      Seit dem neuen USB-Netzwerkadapter habe ich keine Probleme mehr. Kann es sein, dass ein WIN10-Update Probleme mit bestimmten Netzwerkadaptern hat? Das würde vielleicht erklären warum für viele das Problem nach wie vor nicht richtig einzugrenzen ist.

      • Günter Born sagt:

        Kann man nie ausschließen – ich habe es nicht mehr verfolgt, weil Windows 10 hier nur noch auf Testmaschinen läuft und eigentlich ständig irgendwas gepatcht oder als Insider Preview aktualisiert wird.

  31. Senf sagt:

    Hauptsache viel geschrieben und nichts gesagt/gelöst….!

  32. Wolfgang sagt:

    Hallo Zusammen,

    bis eben hatte ich das Problem mit meinem LAN und konnte es wie folgt lösen:
    Da ich im Router für meinen Desktop eine feste IP eingerichtet hatte, habe ich diese nun auch in der Systemsteuerung/ Intertnetoptionen/ Eigenschaften von Internet/ LAN-Einstellungen eingetragen. Somit, denke ich zumindest, entfällt die Suche. Jetzt läuft es wieder.

  33. Chris sagt:

    Danke, da waren eine ganze Menge Informationen beschrieben, mein Internet funktioniert wieder. Ich habe den oben genannten Befehl zum Neustart der IP eingegeben und den Laptop neu gestartet. Fertig.
    Danke!

  34. peter bertram sagt:

    danke fuer die ausfuehrliche diskussion des problems,
    ich selber habe mich diese woche (10/2017) auch damit herumgeplagt.

    meine hardware: thinkpad edge E330 / intel centrino wireless-N 2230

    bei mir hat – nach vielem rumprobieren – diese einfache aenderung
    einer einstellung geholfen:

    systemSteuerung / netzwerk und internet / netzwerkVerb
    rechts-klick aufs aktive WLAN
    klick auf “Eigenschaften”
    klick auf “Konfigurieren”
    klick tab “Erweitert”
    unter “Eigenschaft”
    klick “802.11n Kanalbreite für Band 2.4”
    dann bei “Wert” im pullDown “Auto” auswählen
    (vorher ausgewählt war “20 MHz”)

  35. Bernd Novak sagt:

    Hallo,
    alles sehr gut beschrieben, doch eine Lösung ist es sicher nicht, jedenfalls bei mir. Habe eine HP Pavilion, auf dem ich Win 10 laufen habe. Alles ging mit dem Internet Jahre lang gut ob Wlan oder im Lan, doch wie Ihr ist seit einiger Zeit keine IP, aber das dumme ist es tritt nur bei Lan auf bei Wlan hat es noch nie Probleeme gegeben, auch jetzt nicht.
    Habe alles schon versucht, wirklich alles was so im Internet kursiert, mit netsh… alles mögliche, neue TReiber neuer Router, Umbenenungen, neue REG einträge, Firewall aus an, Virus an aus, Programme gelöscht andere drauf, sogar den Netzwerktreiber von win 7 habe ich bei win 10 zum laufen bekommen, Win zurück gesetzt, alte Sicherrung wieder drauf und und und der witz ist ab und an funktioniert es doch mal so 10 stunden am stück auch bei neustart, aber wenn ich den PC runterfahre wieder hoch, dann gehts entweder gleich nicht, oder nach ner Weile ist Verbindung wieder weg, das geht jetzt schon so ungefähr gefühlt erst seit ca. 3-4 Monaten, vorher war alles wunderbar. Wie gesagt nur über Lan. Kann es sein das Microsoft zugriff auf die PC erlangen will? und deshalb die Verbindungen zusammenbrechen? Weil die dann überfordert werden? Jedenfalls habe ich das Probleem immer noch, oder liegt es an der schlechten Leitung habe Hier nur 2 MB, aber wiederum ist die Verbindung auf den anderen PC stabiel und habe auch auf einem IGEL PC, keine Probleeme.
    Na ich bin mal gespannt ob jemand eine Lösung findet, währe wirklich schön, eine dauerhafte Lösung zu finden.

    • Günter Born sagt:

      Die letzten Sätze zu “MS Kontrolle erlangen will” würde ich nicht unterschreiben – die haben die Kontrolle. Ich tippe schlicht darauf, dass in der Kombination Treiber / Chipsatz ein Problem existiert. Kann man leicht testen: Eine zweite LAN-Karte für 3-5 Euro einbauen und testen – habe hier ein System mit Win7, wo ich so was gezwungen nutzen musste, weil die Verbindung immer wieder einbrach.

  36. Marion Goldschmidt sagt:

    Hallo,
    habe bei Laptop Win 10, 64 bit, einfach in den Freigabeoptionen bei Gast oder Öffentlich die Netzwerkerkennung eingeschaltet, das brachte den Erfolg, die Internetverbindung war sofort da.

  37. Marion Goldschmidt sagt:

    Hallo,
    hatte das Problem auch einem anderen Laptop, obige Lösungsmöglichkeit brachte aber dort keinen Erfolg, erst das Löschen und Neuanlegen der einzelnen
    Profile hatte den positiven Effekt, Internet ging wieder.
    (WIN 10, 64 bit)

  38. Marion Goldschmidt sagt:

    Hallo,
    die gültige und dauerhafte Lösung war letztendlich:
    Es waren zu wenig freie IP-Adressen vergeben, wir haben die Anzahl erhöht und alles ist wieder ok.

  39. Hans Steuernagel sagt:

    Ich bin an einem alten Toshiba, Satellite, 32bit, Windows 10, und hatte heute zum ersten Mal das Problem beim Versenden einer Email. Mehrmals versucht zu versenden, war nicht möglich. Die Überprüfung der Fritz!Box brachte mich nicht weiter. Keine Fehler ersichtlich. Internetverbindung bestens. Direkt über Google in das Internet zu kommen war kein Problem, also noch einmal versucht die Email zu versenden. Das hat wieder funktioniert, ebenso alle Test-Emails an meine zweite Adresse.
    Warum ich mich nicht von AOL trennen kann, fragt mich bitte nicht. Zu faul alle Adressen in ein anderes Programm zu übernehmen, alte Emails…? AOL Desktop Gold ist ein weiterer Rückschritt (Sargnagel).

    • Hans Steuernagel sagt:

      Ein “Npcap Loopback Adapter verfügt über keine gültige IP-Konfiguration”. Mit der Windows-Problembehandlung war keine Lösung möglich. Ich habe diesen Adapter deaktiviert. Seit Tagen keine Probleme mehr.

      • Hans Steuernagel sagt:

        Seit 03.03.18 keine Verbindung über AOL Desktop Gold mehr möglich. Einwahl nur noch über Internet http://www.aol.de und Abruf der aktuellen Emails. Dadurch kein Zugriff auf die gespeicherten Emails. Auswirkung vom deaktivierten Npcap Loopback Adapter? Aber das Einwahlproblem haben noch andere AOL-User.

  40. unoos sagt:

    Hallo zusammen.
    Meine Schwester hatte das gleiche Problem.
    Ich glaube es handelt sich um ein Windows 10 – DHCP – Problem.
    Meine Lösung war eine Statische IP-Adresse zu vergeben.
    zB.
    IP-Adresse: 192.168.2.234
    Subnetmask: 255.255.255.0
    Gateway: 192.168.2.1
    DNS: 192.168.2.1
    Das Netzwerk ist bei uns zwar als öffentliches Netzwerk eingestuft, aber es funktioniert.

  41. Tobias sagt:

    Habe vor drei Tagen neu gebootet (auf Grund eines Gewitters, das mich gewzungen hat, den Rechner mal ganz auszuschalten ;-)), seitdem habe ich das Problem und bin vollkommen ratlos, bei mir hat nichts geholfen. Stehe kurz davor alles platt zu machen und neu aufzusetzen.

    Alle Geräte haben einwandfreies Internet, außer der PC (hier ist der Zugang weder per Kabel noch per WLAN möglich, bekomme immer eine 169er IP per Autokonfig zugewiesen, da der DHCP nicht angefunkt werden). Statische Ip nutzt nichts, ipconfig /release und /renew auch nichts. Treiberupdate halte ich für sinnlos (abgesehen davon, dass ich die aktuellsten habe), die Treiber gingen vorher auch, irgendein böser Windows-Hukuspokus scheint mir am wahrscheinlichsten.

    Windows V1709 (Build 16299.431) Stand 01.06.2018!

    • Uwe sagt:

      Moin Tobias,
      geht mir seit heute genauso. Alles andere funktioniert, nur ein bestimmter nicht. Die grösste Lachnummer war, das in der Problembehandlung stand (so ungefähr): das Problem kann in der Problembehandlung nicht identifiziert werden. …???
      Habe bisher alles mögliche versucht. Es hat sich nichts verändert. Bin jetzt langsam ratlos. Hast Du es gelöst oder hast Du den Rechner platt gemacht und neu aufgesetzt? Freue mich über jede Idee.
      Beste Grüße aus dem Norden

  42. Alexander sagt:

    Vielen Dank für diesen Beitrag. Ich hatte gerade das hier beschriebene Problem. Ich weiß nicht seit wann, da mein PC 2 Zugänge zum Router besitzt: Lan und WLan. Die Lan Schnittstelle war anscheinend betroffen und ich war in letzter Zeit über WLan unterwegs ohne es zu bemerken.

    Nach viel rumgesuche (das hier ist der 4. oder 5. Blog, den ich zu dem Thema besuche) hat deine Lösung bei mir funktioniert. Konsole als Administrator geöffnet und netsh winsock reset
    netsh int ip reset
    eingegeben. Nach dem Neustart funktionieren jetzt wieder beide Schnittstellen.

  43. Pit sagt:

    PROBLEM GELÖST…bei mir hat es funktioniert….
    Fritzbox Sicherung erstellen, Router zurücksetzen auf Werkseinstellungen, Alle W-Lan abhängigen Geräte einschalten auch Drucker, dann Router auf Werkseinstellung zurücksetzen, W-Lan Passwort etc. wie vorher verwenden….und siehe da, alles hat Verbindung zum Router….

  44. FoB sagt:

    Hi,
    danke für die Anregungen. Leider nicht ganz mein Fall, aber vielleicht ein neuen Beitrag damit wert:

    Betrifft auf jeden Fall W10 / 1803

    Der Fall: Die Laptop-WLAN-Karte soll via “Freigabe” geteilt werden. Ein 2. Gerät wird dann an die LAN-Schnittstelle angeschlossen.

    Beim ersten Versuch funktioniert das fehlerfei, das an LAN angeschlossene Gerät erhält eine IP aus dem Bereich 192.168.137.0/24 (wie von MS geplant), im zweiten Schritt dann eine vom Router.

    Bei mir war es dann so, dass wenn der Laptop in Stromsparmodus/Energie sparen ging, oder “nur” neu gestartet wurde, das zweite Gerät an der LAN-Schnittstelle KEINE IP mehr erhielt.
    Ich habe alles ausprobiert, was die netsh-Befehle hergaben: NICHTS!

    Das einzige, was (immer wieder) geholfen hat: Die Netzwerk-Freigabe des WLAN-Adapters DEAKTIVIEREN (und OK) und wieder AKTIVIEREN: Schubs: IP-Adresse ist wieder da.
    Ich hoffe es hilft anderen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.