Windows 10-Fehler: Netzwerkprotokoll fehlt – Teil 2

In Windows 10 haben manche Nutzer ja erhebliche Probleme mit der Netzwerkanbindung und bekommen den Hinweis, dass das Netzwerkprotokoll fehlt. In Teil 1 hatte ich mich ja bereits mit einigen Problemlösungen für den Fehler auseinander gesetzt. In Teil 2 möchte ich noch Ergänzungen nachreichen.


Werbung

Windows-Firewall ist falsch konfiguriert

Normalerweise gebe ich in MS Answers bei Netzwerkproblemen den Tipp, die Firewall-Einstellungen von Fremd-Internet-Security-Lösungen zu überprüfen bzw. diese Lösungen zu deinstallieren und ein Removal Tool des AV-Herstellers auszuführen. Dann kann eine blockierende Firewall ausgeschlossen werden.

Aber bei Systemen, wo nur der Defender und die Windows-Firewall läuft, hätte ich eigentlich keine Probleme erwartet. Blog-Leser Thomas B wies mich in diesem Kommentar darauf hin, dass seit dem Upgrade auf Windows 10 Version 1511 keine Netzwerkgeräte mehr sichtbar waren. Stattdessen wurde ihm der Fehler Netzwerkprotokoll fehlt – Es fehlen die für die Netzwerkkonnektivität erforderlichen Windows-Sockets Registrierungseinträge gemeldet.

Die in Teil 1 beschriebenen Tipps wie das Löschen der Netzwerkadapter halfen nicht wirklich weiter. Der Durchbruch kam, als er die Windows-Firewall-Einstellungen inspizierte. Dort waren die Einträge Netzwerkerkennung und Datei- und Druckerfreigabe  nicht mehr vorhanden.

1. Hierzu gibt man im Suchfeld der Taskleiste “Firewall” ein und und wählt den Treffer Windows-Firewall.

2. In der linken Seitenleiste des Fensters Windows-Firewall wählt man den Eintrag Eine App oder ein Feature durch die Windows-Firewall zulassen.

In der angezeigten Liste sollten die oben genannten Einträge aufgeführt und für Privat auch im Kontrollkästchen markiert sein.

Unter Windows 10 ist diese Liste der zugelassenen Apps und Features ziemlich verludert. Neben den im obigen Screenshot sichtbaren Zusatzprogrammen (auf dem Testrechner vorhanden), tummeln sich noch jede Menge App-Einträge in kryptischer Form der Art @(Microsoft.Bing.Finance….) von Microsoft – so dass man vor lauter Bäumen den Wald nicht mehr sieht.

Bei Problemen kann man auch kontrollieren, ob das Kernnetzwerk dort aufgeführt und zugelassen ist. Klemmt es bei der Heimnetzgruppe, sollte man den Eintrag Heimnetzgruppe kontrollieren.

Einfach mal die Firewall zurücksetzen

Der Durchbruch kam für den Blog-Leser, als er die Windows-Firewall kurz entschlossen zurücksetzte.

Hierzu reicht es, im Fenster Windows-Firewall in der linken Spalte den Befehl Standard wiederherstellen anzuwählen und die Abfrage der Benutzerkontensteuerung zu bestätigen. Im Anschluss ist ein Neustart des Systems auszuführen. Beim Blog-Leser waren dann die Einträge für die benötigten Netzwerkkomponenten wieder vorhanden und das Problem, dass keine Netzwerkteilnehmer angezeigt wurden, war behoben. Bei Recherchen zu diesem Blog-Beitrag habe ich in diesem Thread einen ähnliche Hinweis gefunden.

Netzwerkzuordnung kontrollieren

In diesem Kommentar zu Teil 2 gibt es noch eine Baustelle, die man abprüfen kann (keine Ahnung, was die Leute oder die Windows-Updates so veranstalten): Es geht darum, zu kontrollieren, ob der Rechner noch Bestandteil einer Arbeitsgruppe ist.

1. Wählen Sie das (optional einblendbare) Desktopsymbol Dieser PC mit einem Rechtsklick an und klicken Sie auf den Kontextmenübefehl Eigenschaften.

Falls das Desktopsymbol Dieser PC fehlt, öffnen Sie ein Explorerfenster und öffnen das Kontextmenü des gleichnamigen Eintrags im Navigationsbereich. Man kann auch Windows+Pause drücken, um die Seite Basisinformationen über den Computer anzeigen aufzurufen.

2. Wählen Sie in der Seitenleiste des Fensters System den Befehl Erweiterte Systemeinstellungen und bestätigen Sie die Abfrage der Benutzerkontensteuerung.

3. Gehen Sie unter Systemeigenschaften zur Registerkarte Computername und kontrollieren Sie, ob der Rechner Mitglied einer Arbeitsgruppe ist.

4. Falls der Rechner einer Domäne zugeordnet ist (im verlinkten Kommentar war eine namenlose Domäne zugewiesen), wählen Sie auf der Registerkarte Computername die Schaltfläche Ändern.

5. Im Dialogfeld Ändern des Computernamens bzw. der Domäne ist das Optionsfeld Arbeitsgruppe zu markieren.

Dann alles schließen und Windows neu starten. Im Anschluss probieren, ob das Netzwerk bzw. die Geräte der Arbeitsgruppe erkannt werden und der Netzwerkprotokollfehler behoben ist.


Werbung

Arbeitsstationsdienst kontrollieren

Eine weitere Fehlerursache, die mir unter die Augen gekommen ist: Es kommt wohl auf einigen Maschinen zum Effekt, dass der Arbeitsstationsdienst nicht läuft. Daher Dienste im Suchfeld der Taskleiste eingeben und den Dienstemanager für lokale Dienste wählen. Dort kontrollieren, ob der Arbeitsstationsdienst auf “Automatisch” steht und gestartet werden kann.

Ähnliche Artikel:
Windows 10-Fehler: Netzwerkprotokoll fehlt – Teil 1
Windows 10-Fehler: Netzwerkprotokoll fehlt – Teil 2
Windows 10-Fehler: Netzwerkprotokoll fehlt – Teil 3

Windows 10: Heimnetzgruppe Troubleshooting-FAQ
Windows 10: Netzwerk zeigt Fehler 0x80070035
Windows 10: Anmeldung an FRITZ.NAS geht nicht mehr

Windows 10 Version 1511: 2. November-Update KB3120677


Werbung



Dieser Beitrag wurde unter Netzwerk, Problemlösung, Windows 10 abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

19 Kommentare zu Windows 10-Fehler: Netzwerkprotokoll fehlt – Teil 2

  1. Hans Roitner sagt:

    Nun ja ich habe da ein anderes ziemlich merkwürdiges Win10-Problem:
    Netzwerk (Explorer)
    Unter Computer werden nur 2 (manchmal 3) angezeigt, obwohl 5 in der gleichen Arbeitsgruppe sind.
    Die anderen 3 (2) – darunter der NAS-SERVER lassen sich aber jederzeit über \\Computer öffnen. Sie scheinen dann zwar im Navigationsbereich (als Unterordner von Netzwerk) des Explorer auf, nach wie vor aber nicht im Hauptfenster des Explorers.

    • Günter Born sagt:

      Ich plane da noch Teil 3 …

      • Hans Roitner sagt:

        Die Lösung meines Problems

        Netzwerkcomputer werden (teilweise) nicht angezeigt

        Auf dem Windows 10 Client eine cmd als Administrator starten und folgende Befehle absetzen:

        sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
        sc.exe config mrxsmb20 start= disabled

        Rechner neu starten.
        Das wars

  2. Pingback: Netzwerkprobleme beheben , Internetzugang herstellen und andere Probleme

  3. Thomas Nolte sagt:

    Jetzt habe ich ca 6 Stunden mit dem Ausprobieren sämtlicher Lösungsvorschläge hier verbracht – leider ohne Erfolg.
    Irgendwo fand ich den Tipp: Router ausschalten – 1 Min warten – wieder einschalten.

    Jetzt läuft alles ohne Probleme wie vorher ;-] Oh Mann……

    • hanna sagt:

      .. ging mir genau so 🙂 Auf meinem Pc erschien immer :“ Auf dem PC fehlt mindestens ein Netzwerkprotokoll“ – dann fehlt es trotz Stecker ziehen, immer noch?.
      Schau mal wie es so weiter geht!

  4. Werbung

  5. D4RK00N sagt:

    Nach mehreren Tagen des alleine probierens und testen der oben gennanten Tips, hat bei mir letztendlich folgendes geholfen.
    Da der eine PC ein Lokales- und der andere ein Online-Konto hat, habe ich diesen mit ein Lokales Konto angemeldet und siehe da, es funktioniert.
    Als kein Zugriff vom Lokalen angemeldeten zum Online angemeldeten Pc möglich.
    Warum auch immer…!?

    schönen Abend…

  6. Luccabrasi sagt:

    Hallo, nach stundenlangen probieren mit den Tipps hier, hatte Thomas Nolte die richtige Lösung für mich. Ich habe einfach mal die Fritzbox7360 (Firmware: 6.30) ausgeschaltet, eine Minute gewartet, angeschaltet und schon ist das Problem behoben.

    Ich bin bei Windows seit 3.1.1 aber so viele Probleme mit dem Netzwerk wie bei W10 hatte ich noch bei keiner Windowsversion davor. Schön das es solche Seiten wie Borns IT gibt.

  7. ProjektSwiss sagt:

    Hallo, ich hatte das gleiche Problem wie Hans Roitner.

    Vielen Dank für die Lösung des Problems.
    Nach ausführen der beiden Befehle funktioniert bei mir auch wieder einwandfrei.

    Was mich allerdings noch interessieren würde was diese Befehle genau auslösen?
    Vielleicht kann mir ja der eine oder andere eine Antwort geben.

  8. Werbung

  9. Hänk sagt:

    Ich möchte hier den Beitrag von Thomas Nolte bestätigen. Ich hatte ebenso diesen Fehler und nach vielem Probieren half es, den Router (Fritzbox) vom Strom zu trennen.

    Interessant: Das Wlan der Fitzbox versorgte meine anderen Geräte (auch mit Win 10) anstandslos mit Internet, auch vor dem Neustart. Nur der via Kabel an die Box angeschlossene PC zeigte das hier besprochene Fehlerbild. Daher hatte ich die Box eigentlich auch als Fehler ausgeschlossen, das war am Ende nur ein Verzweiflungsversuch.
    Trotzdem Danke an Born für die stets verständlichen Schritt-für-Schritt-für-Schritt-Aleitungen!!

  10. Hans sagt:

    Hallo,
    Ich hatte auch das Problem, dass mein Pc die Internetverbindung verloren hatte nachdem ich ihn neu gestartet habe. Als Fehler wurde mir ebenfalls angezeigt, dass ein Netzwerk Protokoll fehlt. Mir hat der Tipp von Hans Roitner geholfen die beiden Befehle einzugeben. Vielen Dank dafür!

  11. Stephan Mayer sagt:

    Ich möchte mich herzlichst bei Hans Roitner bedanken, der Tipp brachte mir die Server wieder zurück. Zuvor hatte ich alles an Einstellungen der MS-Firewall ausprobiert – ohne dabei auch nur den Ansatz an Erfolg zu haben – bis hin zum temporären Abschalten von Virenscanner und FW (empfehle ich übrigens nur mit getrennter Internet-Verbindung, was aber für Reparaturen im LAN durchaus mal OK ist). Dann die beiden Zeilen in eine Admin-CMD, reboot. Geht. Merci.

  12. Hans Roitner sagt:

    Nun ja – die Erklärung ist ganz einfach: MICROSOFT HAT MIST GEMACHT – Mit der Version 10586.164 (Windows 10 Version 1511 – 8.3.2016) ist alles, ohne weiteres Herumtun bei mir wieder in Ordnung. Alle Netzwerkgeräte sind sofort da.

  13. Harald sagt:

    Bei mir half der Tipp: Windows-Firewall ist falsch konfiguriert.
    Warum auch immer diese Einstellung geändert wurde (von mir nicht)
    Dankeschön

  14. RebornDarth (Daniel) sagt:

    DANKE DANKE DANKE!!! Seit einigen Wochen -ich denke seit dem letzten kumultativen Update- konnte ich meine NAS nicht mehr über meinen PC erreichen, wohingegen es mit anderen Geräten -auch Win10-Geräte- super funktionierte. Die erste Seite hab ich komplett durch getestet -ohne Erfolg. Ich bin fast verzweifelt und war dabei die Flinte ins Korn zu werfen, als ich dann beschloss die Firewall zurückzusetzen (wie hier beschrieben) und das mit der NAS auf Seite 3 zu versuchen. Ich bin mir nicht sicher welche der Lösungen jetzt den Erfolg gebracht hat, aber es muss eine der beiden letzten Methoden gewesen sein. Mir stellt sich nur die Frage, wieso so ein Aufwand, wenn es ein Bug sein soll, der längst als gefixt gilt -ich denke, ich war mal wieder der „One-in-a-Million“, bei dem er trotzdem wieder auftritt. Wäre nicht das erste Mal. 😉 Naja, mal wieder was dazu gelernt und Spaß am rumstöbern in Windows-Files und Einstellungen gehabt. 😀

  15. Roebi sagt:

    Ich habe alles probiert – von Teil 1 bis Teil 3 und nirgends einen Fehler gefunden. Aber es funktioniert trotzdem nicht. Wobei ich kann vom Compi namens w36 auf die freigebenen Ordners des Compis w500 zugreifen. Aber in umgekehrter Richtung werden mir auf dem w500 wohl w36 und w500 angezeigt, aber wenn ich w36 öffnen will kriege ich die ominöse Message, dass auf \\w36 nicht zugegriffen werden kann. Die Diagnose findet dann nichts und bietet lediglich zusätzliche Optionen an die jedoch auch nicht weiter helfen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.