Windows 8/8.1/10: Backup-Fehler 0x807800C5

In diesem Beitrag möchte ich mich des Fehlers 0x807800C5 annehmen, der bei einer Systemabbildsicherung unter Windows 8/8.1/10 auftreten kann. Der Fehler verhindert, dass Benutzer mit Bordfunktionen Backups anfertigen können.

Die Windows-Backup-Funktion ist zwischenzeitlich von Microsoft wohl abgekündigt und wird aus zukünftigen Windows-Versionen verschwinden. Es gibt mit der Windows-Sicherung auch immer wieder heftig Ärger – im Anhang finden sich nachfolgend einige Blog-Beiträge.


Anzeige

a1: Windows-Backup Fehlerdiagnosen
a2: Windows: Backup-Fehler 0×80042412 beim Zurücklesen
a3: Windows 8.1: Backup-Probleme bei UEFI/GPT-Datenträgern
a4: SystemProfile: Backup-Fehler 0×80070002
a5: Windows 7 Backup-Error 0×81000019
a6: Meldung “Die Wiederherstellung wurde abgeschlossen” kommt immer Teil 1

Das Problem in dürren Worten

Auf den Fehler bin ich hier unter MS-Answers gestoßen – das Problem mäandert aber durchs Web (z.B. hier). Die Fehlermeldung lautet:

Die Sicherung ist fehlgeschlagen. Fehler beim Vorbereiten des Sicherungsabbilds eines Volumes im Sicherungssatz (0x807800C5). Der angegebene Sicherungsdatenträger wurde nicht gefunden (0x80780081).

Das obige Dialogfeld zeigt die betreffende Fehlermeldung, macht aber auch deutlich, dass es multiple Ursachen gehen kann. In der Regel kommen noch zusätzliche Informationen wie Fehlercode 0x80780081 etc., die dann einen Hinweis auf die Ursache liefern.

Zum Fehlercode 0x80780081 habe ich z.B. diesen Answers-Beitrag gefunden, wo das Problem wohl nach mehrfachem Versuch behoben war. Microsoft hat einen Support-Beitrag KB973455 veröffentlicht, der die Fehlercodes 0x80070001, 0x81000037 und  0x80070003 für Windows 7 thematisiert. Nachfolgend noch Ansätze, um Fehlerursachen auszuschließen und ggf. zum Ziel zu gelangen.

Kaputtes Windows oder defektes Dateisystem ausschließen

Als erstes sollte sichergestellt werden, dass kein defektes Dateisystem oder kein beschädigtes Windows die Ursache für den Fehler ist. Hierzu lässt sich eine administrative Eingabeaufforderung öffnen (siehe Windows 8: Administrative Eingabeaufforderung aufrufen). Anschließend ist der Befehl:

sfc /scannow

auszuführen. Der prüft Windows auf beschädigte Systemdateien und solle durchlaufen und keine Fehler melden. Im Nachgang kann man auch noch eine Datenträgerprüfung des zu sichernden Windows ausführen (Windows-Laufwerk per Rechtsklick anwählen, den Kontextmenübefehl Eigenschaften wählen und dann die Datenträgerprüfung auf Fehler über die Registerkarte Tools anstoßen).


Werbung

Prophylaktisch kann man auch die Bibliotheken der Benutzerkonten zurücksetzen (siehe Windows-Bibliotheken reparieren), wenn der Fehlercode auf Probleme beim Lesen der Daten hindeutet.

USB-Probleme ausschließen

Tritt der Fehler beim Sichern auf USB-Festplatten auf, kann ggf. ein fehlerhafter USB-Kommunikationsstrang die Ursache sein (siehe hier). Es ist sicherzustellen, dass die USB-Festplatte an einem eigenen USB-Port hängt und keine anderen Geräte über USB-Hub auf dem gleichen USB-Kanal kommunizieren. Notfalls Windows herunter fahren, die Festplatte abstöpseln und dann Windows starten. Dann die Festplatte anstöpseln und nochmals versuchen.

Ist Sicherheitssoftware installiert, empfiehlt sich die testweise Deinstallation der betreffenden Programme. In diesem MS Answers-Thread empfiehlt ein Forenteilnehmer im konkreten Fall, dass der Sicherungsdatenträger nicht gefunden wurde, die Laufwerksbuchstaben mit dem Tool DriveCleanUp zu bereinigen.

Man kann auch auf dem Sicherungsmedium (wenn dieses angeblich nicht gefunden wird) den Backup-Ordner WindowsImageBackup sowie die versteckte Datei MediaID.bin löschen (siehe auch). Ich hatte auch schon Fälle, wo nur die Neuformatierung des Sicherungsmediums das Backup-Problem behoben hat.


Werbung – meine Windows 8.1 Titel –

Problem beim Sichern auf NAS-Laufwerke

Ein gänzlich anderes Szenario liegt vor, wenn der obige Fehler beim Sichern auf einem NAS-Netzwerkspeicher erfolgt. Es gibt einige Threads in Foren, die dieses Problem unter Windows 8/8.1 thematisieren.

b1: Windows Sicherung in der Systemsteuerung unter Wiederherstellung
b2: Windows Backup failed with error 0x807800C5
b3: Error in backup 0x807800C5
b3: VSS Full Backup Fails on Windows Server 2012 (0x807800C5)

Der Fehler tritt wohl bei Diskstation Manager V 4.2 von Synology aber auch anderen NAS-Anbietern auf (siehe auch hier).

Im Beitrag Windows 8 und die kaputte Shadow Copy berichtet jemand, dass Microsoft etwas am Schattenkopiendienst geändert habe, so dass Windows 8/8.1 nicht mehr auf NAS-Laufwerke sichern könne. In diesem Forenthread hat jemand es mit folgenden Maßnahmen:

– disable SMB2 and large packets in Synology
– edit smb.conf and ADD “strict allocate = yes” to all Shares !!!

zum Laufen gebracht. Und im gleichen Thread hat jemand noch einen Trick benutzt, indem er eine virtuelle Disk (VHD) auf den NAS anlegt, die VHD mountet und die Sicherung dann in die VHD durchführt. Vielleicht helfen die Infos weiter.


Anzeige

Dieser Beitrag wurde unter Backup, Windows 8, Windows 8.1 abgelegt und mit , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

16 Kommentare zu Windows 8/8.1/10: Backup-Fehler 0x807800C5

  1. Pingback: Windows 8/8.1: Backup-Fehler 0x807800C5 - TechBloggers

  2. Paul Kröher sagt:

    >Die Windows-Backup-Funktion ist zwischenzeitlich von Microsoft wohl abgekündigt und wird aus zukünftigen Windows-Versionen verschwinden. Es gibt mit der Windows-Sicherung auch immer wieder heftig Ärger<

    Ich habe dieser Funktion noch nie vertraut und bin mit externer Backupsoftware auch immer problemlos klargekommen.

  3. Günter Born sagt:

    Nachträge: Ich bin in den US Answers-Foren noch auf einige interessante Fundstellen gestoßen, wo MS Support Engineers Informationen gegeben haben.

    Eine Methode, die Prüfung mittels sfc /scannow hatte ich erwähnt. In diesem Forenthread gibt jemand den Hinweis, die folgenden Dateien von alten Backups zu löschen:

    a. Datafile – MediaID.bin
    b. Folder – Windowsimagebackup
    c. Computer-name (file name)

    Und in diesem Forenthread finden sich einige allgemeine Anweisungen von “Sathish S V”, was man tun kann, wenn das obige alles nicht hilft. Dort wird die (versteckte) Datei MediaID.bin ebenfalls erwähnt. Vielleicht hilft es.

  4. Zünd Fabian sagt:

    Dankeschön!

    Bei mir hat das disablen des SMB2 & Large Packet MTU bereits gereicht.

    Freundliche Grüsse
    Fabian Zünd

    • Pascal sagt:

      Hast du eventuell auch einen Link zu einer Anleitung wie und wo man das einstellen kann? Leider wird im verlinkten Thread auch nichts genaueres dazu gesagt.

      Viele Grüße
      Pascal

      • Günter Born sagt:

        Kann leider nicht reagieren -siehe aktueller Blog- Beitrag zu meinem Unfall.

      • Pascal sagt:

        Um auf mich selbst zu antworten:
        Die Option findet man in der Systemsteuerung des NAS unter “Dateidienste”. Der zweite Punkt (Anpassung der der smb.conf) ist etwas komplizierter: Dazu muss zunächst der SSH Zugang aktiviert werden (Systemsteuerung NAS > Terminmal > SSH aktivieren), danach via SSH an der Diskstation anmelden (mache es my cygwin, putty ist aber wohl die verbreitetere Alternative). Die IP der Diskstation findet man via “ping disktation” raus, Nutzername und Passwort sind “admin” + Adminpasswort oder “root” + Adminpasswort.
        Die smb.conf findet man unter /usr/syno/etc/smb.conf
        Nach Änderungen an der Datei muss Samba neu gestartet werden:
        /usr/syno/etc/rc.sysv/S80samba.sh restart
        (früher wohl /usr/syno/etc/rc.d/S80Samba.sh restart)

        Aber: Hat bei mir nicht geholfen.

        Dafür hat es mit der Einrichtung des virtuellen Laufwerks geklappt – habe unter http://lifelunatic.blogspot.de/2013/02/windows-8-und-die-kaputte-shadow-copy.html?google_comment_id=z12yj5kilwbzzpdjd04cirygrvmftx4alak im Kommentar die genauen Schritte beschrieben.

  5. Werbung

  6. Marc Gutt sagt:

    Ich hatte das selbe Problem in Windows 10. Ich habe für den Dateiversionsverlauf das Verzeichnis “w10” auf dem Synology NAS gewählt und für das Image (Windows 7 Sicherung) “w10img”. Das Image ergab die hier genannte Fehlermeldung. Ich wollte dann auch erst ein virtuelles Laufwerk erstellen bis ich auf diesen sehr alten Foren-Eintrag gestoßen bin:
    http://www.synology-forum.de/showthread.html?39802-DS1812-Backup-von-einem-Windows-Server-2012-schl%C3%A4gt-fehl-Error-0x807800C5&p=359302&viewfull=1#post359302
    “This happens after upgrading Windows while still using the same backup target disk.
    The problem is the three old backup files on the target disk that you need to remove.
    Consider the old backup files obsolete and delete them, or move them away into a temporary folder.

    1. Datafile – MediaID.bin
    2. Folder – Windowsimagebackup
    3. Computer-name-file – Zalman (in my case)

    Then restart your backup and find out that now it works.
    Problem Solved …”

    Also habe ich das Verzeichnis auf dem NAS prompt mal gelöscht, es diesmal anders genannt und die Sicherungsregel neu angelegt und gestartet. Und was soll ich sagen. Das Problem ist gelöst.

    Ich kann nicht genau sagen was das Problem verursacht hat. Vielleicht hat schon beim 1. Sicherungsversuch Windows die genannten Dateien falsch angelegt und hat sich daher bei jedem weiteren Versuch daran gestört.

    Übrigens hat es auch eine Weile gedauert bis ich herausgefunden habe, dass mein Login für das NAS nicht mein Username ist, sondern “DISKSTATION/Username”. Jedenfalls viel Glück, dass es bei Euch auch so einfach klappt!

  7. Jan sagt:

    Der folgende Eintrag in der smb.conf des NAS soll helfen.

    [general]

    max protocol = SMB2_02

  8. Werbung

  9. Edo sagt:

    Habe in der Synology das SMB auf 2 gestellt, die alten Sicherungsdaten gelöscht, die Sicherung neu eingerichtet und in der “Erweiterten Datenfreigabe” die Anmeldung auf “Benutzer und Passwort” gestellt. Nun läuft das Backup gerade… hoffentlich auch ganz durch.

  10. Sunny sagt:

    Hallo zusammen,

    ich kämpfe leider immer noch mit diesem Problem.
    Hab schon mit Synology und MS geschrieben und keiner weiß weiter.
    Scheinbar kam das Problem mit dem letzten Windows 10 Update erneut auf.

    Vielleicht stehe ich gerade auf dem Schlauch aber diese Datei kann ich auch nicht im Backup Folder auf dem NAS finden “3. Computer-name-file – Zalman (in my case)”
    1 und 2 wurden gefunden….

    Wäre sehr dankbar falls hier nochmal einer von Euch Pros ein bißchen Ideen liefern könnte.

    Cheers
    Sunny

  11. gh sagt:

    Versuch doch mal folgende Vorgehensweise.
    gefunden bei heise.de
    https://heise.de/-3678852
    für DSM6.2 gibt es ein paar Änderungen.
    der Pfad zu SMB Konfiguration ist nun.
    “/etc/samba/smb.share.conf”
    Unter “Systemsteuerung/Dateidienste/Windows Dateidienst/Erweiterte Einstellungen“ “Max. Protokoll für Windows-Dateidienst“ auf “SMB 3” und min. Protokoll auf “SMB 2 und Large MTU“ einstellen.
    und einen Haken bei “Opportuunistic Locking aktivieren” setzen.
    der Unterpunkt “SMB2 Lease aktivieren” bleibt deaktiviert.

  12. Fabian sagt:

    Ich möchte unbedingt meinen Senf dazugeben. Zudem muss ich mitteilen, dass ich alle empfohlenen Schritte, smb.conf, Protokollversion, etc. ausprobiert habe.
    OHNE ERFOLG.

    Meine Konstellation:
    – HyperV Server 2016 mit 3 VMs (ebenfalls 2016)
    – Server 2016 auf Synologynas (6-1-7-15284 U1) mit wbadmin (cli)

    Mein Problem:
    – 1 der 3 VMs sichert mit meinem wbadmin script seit eh und je bei den anderen 2 klappt es nur wenn ich “-allcritical” weglasse. (was ich aber unbedingt für eine Vollsicherung benötige)
    -So sieht meine Fehlermeldung aus:
    Die Sicherung von Volume “Wiederherstellung (450.00 MB)” konnte nicht abgeschlossen werden. Fehler: Der angegebene Sicherungsdatentr„ger wurde nicht gefunden.

    Error Event Log: 0x807800c5

    HIER MEINE LÖSUNG:
    1) in die VMs eine zusätzliche VHD über den Hypervisor einbinden
    2) diese in der VM initialisieren und formatieren
    3) Reboot
    4) eine Einmalsicherung auf den neu eingebundenen Datenträger machen

    Dannach funktioniert mein WBADMIN Script über die Aufgabenplanung zur NAS wieder wie es soll.
    Bei 2012R2 hatten wir nie Probleme.

    Der Workaround ist für mich nach wie vor nicht logisch.

    Good LUCK!
    Fabian

    • Fabian sagt:

      Ich muss meinen Beitrag noch erweitern:

      zu 4)

      Sofern die Einmalsicherung auf dem zusätzlich eingehangenen VHD Datenträger liegen bleibt, klappt die Sicherung auf die NAS erfolgreich. Löscht man aber die Sicherung auf der VHD, klappt sie wieder nicht. Nun lasse ich einfach eine Sicherung da liegen (frisst ja kein Brot :) ) und habe diese in meine Backupscript auf die NAS einfach nicht mit im INCLUDE befehl drin.

      Dann sieht das Ergebnis so aus:

      Die Sicherung von Volume “(C:)” wurde erfolgreich abgeschlossen.
      Die Sicherung von Volume “Wiederherstellung (450.00 MB)” wurde erfolgreich abgeschlossen.
      Die Sicherung von Volume “EFI (100.00 MB)” wurde erfolgreich abgeschlossen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.